]> git.sesse.net Git - kdenlive/blobdiff - effects/CMakeLists.txt
Add Movit effects.
[kdenlive] / effects / CMakeLists.txt
index 3819765e22b37aedf9949a94a05c22b451141bee..23e6f577cd7d2ac8c013917b0ae2fb7e2b3ae983 100644 (file)
@@ -1,5 +1,6 @@
 INSTALL (FILES 
 
+audiowave.xml
 automask.xml
 boxblur.xml
 brightness.xml
@@ -8,56 +9,121 @@ charcoal.xml
 chroma_hold.xml
 chroma.xml
 crop.xml
+dust.xml
+dynamictext.xml
 freeze.xml
 gamma.xml
+grain.xml
 greyscale.xml
 invert.xml
-ladspa_declipper.xml
-ladspa_equalizer.xml
-ladspa_limiter.xml
-ladspa_phaser.xml
-ladspa_pitch_scale.xml
-ladspa_pitch.xml
-ladspa_rate_scale.xml
-ladspa_reverb.xml
-ladspa_room_reverb.xml
-ladspa_vinyl.xml
 mirror.xml
 mute.xml
 normalise.xml
+oldfilm.xml
 pan_zoom.xml
 obscure.xml
+region.xml
 rotation.xml
+rotation_keyframable.xml
+scratchlines.xml
 sepia.xml
-sox_balance.xml
 sox_bass.xml
 sox_gain.xml
 sox_phaser.xml
 sox_band.xml
 sox_echo.xml
 sox_flanger.xml
-sox_pitch.xml
-sox_reverb.xml
-sox_vibro.xml
 sox_stretch.xml
 threshold.xml
 volume.xml
 wave.xml
 fadein.xml
 fadeout.xml
-frei0r_colordistance.xml
-frei0r_squareblur.xml
-frei0r_distort0r.xml
+frei0r_alpha0ps.xml
+frei0r_alphagrad.xml
+frei0r_alphaspot.xml
 frei0r_balanc0r.xml
-frei0r_scale0tilt.xml
-frei0r_contrast0r.xml
+frei0r_baltan.xml
+frei0r_bezier_curves.xml
 frei0r_brightness.xml
+frei0r_cartoon.xml
+frei0r_cluster.xml
+frei0r_colgate.xml
+frei0r_coloradj_rgb.xml
+frei0r_colordistance.xml
+frei0r_colortap.xml
+frei0r_contrast0r.xml
+frei0r_c0rners.xml
+frei0r_curves.xml
+frei0r_d90stairsteppingfix.xml
+frei0r_defish0r.xml
+frei0r_delay0r.xml
+frei0r_delaygrab.xml
+frei0r_distort0r.xml
+frei0r_edgeglow.xml
+frei0r_equaliz0r.xml
+frei0r_flippo.xml
+frei0r_glow.xml
+frei0r_hqdn3d.xml
+frei0r_hueshift0r.xml
+frei0r_iirblur.xml
+frei0r_keyspillm0pup.xml
 frei0r_lenscorrection.xml
+frei0r_letterb0xed.xml
+frei0r_levels.xml
+frei0r_lightgraffiti.xml
+frei0r_luminance.xml
+frei0r_mask0mate.xml
+frei0r_medians.xml
+frei0r_nervous.xml
+frei0r_nosync0r.xml
+frei0r_pixeliz0r.xml
+frei0r_pr0be.xml
+frei0r_pr0file.xml
+frei0r_primaries.xml
+frei0r_rgbparade.xml
 frei0r_saturat0r.xml
+frei0r_scale0tilt.xml
+frei0r_scanline0r.xml
+frei0r_select0r.xml
+frei0r_sharpness.xml
+frei0r_sobel.xml
+frei0r_sopsat.xml
+frei0r_squareblur.xml
+frei0r_tehroxx0r.xml
+frei0r_three_point_balance.xml
+frei0r_threelay0r.xml
+frei0r_threshold0r.xml
+frei0r_timeout.xml
+frei0r_tint0r.xml
+frei0r_twolay0r.xml
+frei0r_vectorscope.xml
 frei0r_vertigo.xml
+frei0r_vignette.xml
+frei0r_facebl0r.xml
+frei0r_facedetect.xml
 gain.xml
 fade_from_black.xml
 fade_to_black.xml
 speed.xml
+tcolor.xml
+vignette.xml
+swapchannels.xml
+audiobalance.xml
+audiopan.xml
+rotoscoping.xml
+movit_vignette.xml
+movit_white_balance.xml
+movit_blur.xml
+movit_glow.xml
+movit_mirror.xml
+movit_saturation.xml
+movit_unsharp_mask.xml
+movit_deconvolution_sharpen.xml
+movit_opacity.xml
+movit_diffusion.xml
+movit_lift_gamma_gain.xml
 
 DESTINATION ${DATA_INSTALL_DIR}/kdenlive/effects)
+
+add_subdirectory(update)