]> git.sesse.net Git - itkacl/blob - libpam-itkacl-0.4/debian/rules
Make the core library support a configuration file (/etc/itkacl.conf),
[itkacl] / libpam-itkacl-0.4 / debian / rules
1 #!/usr/bin/make -f
2
3 #export DH_VERBOSE=1
4
5 CFLAGS = -Wall -g -fPIC
6
7 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
8         CFLAGS += -O0
9 else
10         CFLAGS += -O2
11 endif
12
13 build:
14         dh_testdir
15         $(MAKE) CFLAGS="$(CFLAGS)"
16
17 clean:
18         dh_testdir
19         dh_testroot
20         $(MAKE) clean
21         dh_clean 
22
23 binary-indep: build
24 binary-arch: build
25         dh_testdir
26         dh_testroot
27         dh_installdirs
28         dh_installdocs
29         
30         $(MAKE) install DESTDIR=debian/libpam-itkacl
31         
32         dh_installchangelogs
33         dh_strip
34         dh_compress
35         dh_fixperms
36         dh_installdeb
37         dh_shlibdeps
38         dh_gencontrol
39         dh_md5sums
40         dh_builddeb
41
42 binary: binary-indep binary-arch
43 .PHONY: build clean binary-indep binary-arch binary