]> git.sesse.net Git - itkacl/blob - php7-itkacl-2.0/debian/rules
Release a new version of the Apache module, with the context support.
[itkacl] / php7-itkacl-2.0 / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3
4 clean:
5         dh_testdir
6         dh_clean
7         $(MAKE) clean
8
9 build:
10         dh_testdir
11         $(MAKE) 
12
13 binary-indep:
14
15 binary-arch:
16         dh_testroot
17         dh_prep
18         dh_installdirs
19         $(MAKE) install DESTDIR=debian/php7-itkacl
20         install -m 0644 -o root -g root debian/itkacl.ini debian/php7-itkacl/etc/php7/conf.d/
21         dh_installdocs
22         dh_installchangelogs
23         dh_compress
24         dh_fixperms
25         dh_strip
26         dh_makeshlibs
27         dh_shlibdeps
28         echo "php:Depends=phpapi-$(shell php-config --phpapi)" >> debian/php7-itkacl.substvars
29         dh_installdeb
30         dh_gencontrol
31         dh_md5sums
32         dh_builddeb
33
34 binary: binary-arch