]> git.sesse.net Git - itkacl/blob - python-itkacl-2.0/debian/rules
Add a Python module.
[itkacl] / python-itkacl-2.0 / debian / rules
1 #!/usr/bin/make -f
2
3 clean:
4         dh_testdir
5         dh_clean
6         python setup.py clean
7         $(RM) -r build/
8         $(RM) itkacl.py itkacl.pyc itkacl_wrap.c
9
10 build:
11         python setup.py build_ext
12
13 binary-indep:
14
15 binary-arch:
16         dh_testroot
17         dh_prep
18         dh_installdirs
19         python setup.py install --root=debian/python-itkacl --install-layout=deb
20         dh_installdocs
21         dh_installchangelogs
22         dh_pysupport
23         dh_compress
24         dh_fixperms
25         dh_strip
26         dh_makeshlibs
27         dh_shlibdeps
28         dh_installdeb
29         dh_gencontrol
30         dh_md5sums
31         dh_builddeb
32
33 binary: binary-arch
34
35 .PHONY: clean build binary-indep binary-arch binary