Give the alpha enums somewhat better/more consistent names, and shuffle them around...
[movit] / gamma_compression_effect.h
1 #ifndef _GAMMA_COMPRESSION_EFFECT_H 
2 #define _GAMMA_COMPRESSION_EFFECT_H 1
3
4 // An effect to convert linear light to the given gamma curve,
5 // typically inserted by the framework automatically at the end
6 // of the processing chain.
7 //
8 // Currently supports sRGB and Rec. 601/709.
9
10 #include "effect.h"
11 #include "effect_chain.h"
12
13 #define COMPRESSION_CURVE_SIZE 4096
14
15 class GammaCompressionEffect : public Effect {
16 private:
17         // Should not be instantiated by end users.
18         GammaCompressionEffect();
19         friend class EffectChain;
20
21 public:
22         virtual std::string effect_type_id() const { return "GammaCompressionEffect"; }
23         std::string output_fragment_shader();
24
25         virtual bool needs_srgb_primaries() const { return false; }
26
27         // Actually needs postmultiplied input as well as outputting it.
28         // EffectChain will take care of that.
29         virtual AlphaHandling alpha_handling() const { return OUTPUT_POSTMULTIPLIED_ALPHA; }
30
31 private:
32         GammaCurve destination_curve;
33         float compression_curve[COMPRESSION_CURVE_SIZE];
34 };
35
36 #endif // !defined(_GAMMA_COMPRESSION_EFFECT_H)