Fix compile error from previous patch