]> git.sesse.net Git - itkacl/blobdiff - python-itkacl-2.0/setup.py
Add a Python module.
[itkacl] / python-itkacl-2.0 / setup.py
diff --git a/python-itkacl-2.0/setup.py b/python-itkacl-2.0/setup.py
new file mode 100644 (file)
index 0000000..ad302dc
--- /dev/null
@@ -0,0 +1,21 @@
+#!/usr/bin/env python
+
+"""
+setup.py file for ITKACL
+"""
+
+from distutils.core import setup, Extension
+
+
+itkacl_module = Extension('_itkacl',
+                           sources=['itkacl.i'],
+                           libraries=['itkacl'],
+                           )
+
+setup (name = 'itkacl',
+       version = '2.0',
+       author      = "Steinar H. Gunderson",
+       description = """Python interface to ITKACL""",
+       ext_modules = [itkacl_module],
+       py_modules = ["itkacl"],
+       )