]> git.sesse.net Git - vlc/blob - vlc.spec
* modules/gui/skins/controls/checkbox.cpp: Fixed a stupid bug (a return
[vlc] / vlc.spec
1 Summary: The VideoLAN client, also a very good standalone video player.
2 Name: vlc
3 Version: 0.5.3
4 Release: 1
5 Group: Applications/Multimedia
6 License: GPL
7 URL: http://www.videolan.org/
8 Source: http://www.videolan.org/pub/videolan/vlc/vlc-%{version}.tar.bz2
9 Buildroot: %{_tmppath}/%{name}-root
10 Packager: Jason Luka <jason@geshp.com>
11 Buildrequires: XFree86-devel, desktop-file-utils
12 %{!?_without_dvd:Buildrequires: libdvdcss-devel}
13 %{!?_without_dvdread:Buildrequires: libdvdread-devel}
14 %{!?_without_dvdplay:Buildrequires: libdvdplay-devel}
15 %{!?_without_dvbpsi:Buildrequires: libdvbpsi-devel}
16 %{!?_without_ogg:Buildrequires: libogg-devel}
17 %{!?_without_mad:Buildrequires: libmad}
18 %{!?_without_ffmpeg:Buildrequires: ffmpeg-devel}
19 %{!?_without_xvid:Buildrequires: xvidcore-devel}
20 %{!?_without_a52:Buildrequires: a52dec-devel}
21 %{?_with_dv:Buildrequires: libdv-devel}
22 %{!?_without_flac:Buildrequires: flac-devel}
23 %{!?_without_vorbis:Buildrequires: libvorbis-devel}
24 %{!?_without_sdl:Buildrequires: SDL-devel}
25 %{!?_without_aa:Buildrequires: aalib-devel}
26 %{!?_without_esd:Buildrequires: esound-devel}
27 %{!?_without_arts:Buildrequires: arts-devel}
28 %{!?_without_alsa:Buildrequires: alsa-lib-devel}
29 %{!?_without_gtk:Buildrequires: gtk+-devel}
30 %{!?_without_gnome:Buildrequires: gnome-libs-devel}
31 %{!?_without_lirc:Buildrequires: lirc}
32 %{?_with_qt:Buildrequires: qt-devel}
33 %{?_with_kde:Buildrequires: kdelibs-devel}
34 %{?_with_ncurses:Buildrequires: ncurses-devel >= 5}
35 %{!?_without_xosd:Buildrequires: xosd-devel}
36 %{!?_without_lirc:Requires: lirc}
37 %{?_with_mozilla:Requires: mozilla-devel}
38
39 Requires: XFree86, desktop-file-utils
40 %{!?_without_dvd:Requires: libdvdcss}
41 %{!?_without_dvdread:Requires: libdvdread}
42 %{!?_without_dvdplay:Requires: libdvdplay}
43 #%%{!?_without_dvbpsi:Requires: libdvbpsi}
44 #%%{!?_without_ogg:Requires: libogg}
45 %{!?_without_mad:Requires: libmad}
46 %{!?_without_ffmpeg:Requires: ffmpeg}
47 #%%{!?_without_xvid:Requires: xvidcore}
48 %{!?_without_a52:Requires: a52dec}
49 #%%{?_with_dv:Requires: libdv}
50 #%%{!?_without_flac:Requires: flac}
51 #%%{!?_without_vorbis:Requires: libvorbis}
52 #%%{!?_without_sdl:Requires: SDL}
53 #%%{!?_without_aa:Requires: aalib}
54 #%%{!?_without_esd:Requires: esound}
55 #%%{!?_without_arts:Requires: arts}
56 #%%{!?_without_alsa:Requires: alsa-lib}
57 #%%{!?_without_gtk:Requires: gtk+}
58 #%%{!?_without_gnome:Requires: gnome-libs}
59 #%%{?_with_qt:Requires: qt}
60 #%%{?_with_kde:Requires: kdelibs}
61 #%%{?_with_ncurses:Requires: ncurses}
62 #%%{!?_without_xosd:Requires: xosd}
63 #%%{!?_without_lirc:Requires: lirc}
64 #%%{?_with_mozilla:Requires: mozilla}
65
66 %description
67 VideoLAN Client (VLC) is a highly portable multimedia player for various
68 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
69 well as DVDs, VCDs, and various streaming protocols.
70
71 Available rpmbuild rebuild options :
72 --with dv mga qt kde ncurses
73 --without dvd dvdread dvdplay dvbpsi v4l avi asf aac ogg rawdv mad ffmpeg xvid
74           mp4 a52 vorbis flac aa esd arts alsa gtk gnome xosd lsp lirc pth
75
76 Options that would need not yet existing add-on packages :
77 --with faad tremor tarkin theora svgalib ggi glide wxwindows
78
79
80 %package devel
81 Summary: Header files and static library from the Videolan Client.
82 Group: Development/Libraries
83 Requires: %{name} = %{version}
84
85 %description devel
86 VideoLAN Client (VLC) is a highly portable multimedia player for various
87 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
88 well as DVDs, VCDs, and various streaming protocols.
89
90 Install this package if you need to build Videolan Client plugins or intend
91 to link statically to it.
92
93
94 %prep
95 %setup -q -n vlc-%{version}
96
97 %build
98 %configure \
99         --enable-release \
100         %{?_without_dvd:--disable-dvd} \
101         %{!?_without_dvdread:--enable-dvdread} \
102         %{!?_without_dvdplay:--enable-dvdplay} \
103         %{!?_without_dvbpsi:--enable-dvbpsi} \
104         %{!?_without_v4l:--enable-v4l} \
105         --enable-vcd \
106         %{?_without_avi:--disable-avi} \
107         %{?_without_asf:--disable-asf} \
108         %{?_without_aac:--disable-aac} \
109         %{?_without_ogg:--disable-ogg} \
110         %{?_without_rawdv:--disable-rawdv} \
111         %{!?_without_mad:--enable-mad} \
112         %{!?_without_ffmpeg:--enable-ffmpeg --with-ffmpeg=%{_prefix}} \
113         %{?_with_faad:--enable-faad} \
114         %{!?_without_xvid:--enable-xvid} \
115         %{?_without_mp4:--disable-mp4} \
116         %{?_without_a52:--disable-a52} \
117         %{?_without_cinepak:--disable-cinepak} \
118         %{?_with_dv:--enable-dv} \
119         %{!?_without_flac:--enable-flac} \
120         %{?_without_vorbis:--disable-vorbis} \
121         %{?_with_tremor:--enable-tremor} \
122         %{?_with_tarkin:--enable-tarkin} \
123         %{?_with_theora:--enable-theora} \
124         --enable-x11 \
125         --enable-xvideo \
126         %{?_without_sdl:--disable-sdl} \
127         --disable-qte \
128         --disable-directx \
129         --enable-fb \
130         %{?_with_mga:--enable-mga} \
131         %{?_with_svgalib:--enable-svgalib} \
132         %{?_with_ggi:--enable-ggi} \
133         %{?_with_glide:--enable-glide} \
134         %{!?_without_aa:--enable-aa} \
135         --without-wingdi \
136         --enable-oss \
137         %{!?_without_esd:--enable-esd} \
138         %{!?_without_arts:--enable-arts} \
139         %{!?_without_alsa:--enable-alsa} \
140         --disable-waveout \
141         %{!?_without_gtk:--enable-gtk} \
142         --disable-familiar \
143         %{!?_without_gnome:--enable-gnome} \
144         %{!?_with_wxwindows:--disable-wxwindows} \
145         %{?_with_qt:--enable-qt} \
146         %{?_with_kde:--enable-kde} \
147         --disable-opie \
148         --disable-macosx \
149         --disable-qnx \
150         --disable-intfwin \
151         %{?_with_ncurses:--enable-ncurses} \
152         %{!?_without_xosd:--enable-xosd} \
153         %{?_without_slp:--disable-slp} \
154         %{!?_without_lirc:--enable-lirc} \
155         %{!?_without_pth:--enable-pth} \
156         --disable-st \
157         %{?_with_mozilla:--enable-mozilla} \
158         --disable-testsuite \
159         --enable-plugins
160 make %{?_smp_mflags}
161
162 %install
163 rm -rf %{buildroot}
164 %makeinstall
165 find  %{buildroot}%{_libdir}/vlc -name "*.so" | xargs strip
166 %find_lang vlc
167
168 cat > %{name}.desktop << EOF
169 [Desktop Entry]
170 Name=VideoLAN Client
171 Comment=%{summary}
172 Icon=%{_datadir}/vlc/vlc48x48.png
173 Exec=vlc
174 Terminal=0
175 Type=Application
176 EOF
177
178 mkdir -p %{buildroot}%{_datadir}/applications
179 desktop-file-install --vendor %{desktop_vendor} --delete-original \
180   --dir %{buildroot}%{_datadir}/applications                      \
181   --add-category X-Red-Hat-Extra                                  \
182   --add-category Application                                      \
183   --add-category AudioVideo                                       \
184   %{name}.desktop
185
186 %post
187 ln /dev/cdrom /dev/dvd -sf
188
189 %postun
190 rm -f /dev/dvd
191
192 %clean
193 rm -rf %{buildroot}
194
195 %files -f vlc.lang
196 %defattr(-, root, root)
197 %doc AUTHORS COPYING ChangeLog MAINTAINERS README THANKS
198 %doc doc/fortunes.txt doc/web-streaming.html
199 %{_bindir}/*vlc
200 %{_libdir}/vlc
201 %{_datadir}/applications/%{desktop_vendor}-%{name}.desktop
202 %{_datadir}/vlc
203
204 %files devel
205 %defattr(-, root, root)
206 %doc HACKING 
207 %{_bindir}/vlc-config
208 %{_includedir}/vlc
209 %{_libdir}/libvlc.a
210
211 %changelog
212 * Mon Apr 7 2003 Jason Luka <jason@geshp.com>
213 - Update to 0.5.3
214
215 * Sat Apr 5 2003 Jason Luka <jason@geshp.com>
216 - Rebuilt for Red Hat 9
217 - Changed dependencies for ffmpeg's new name
218 - Required lirc support at build-time 
219
220 * Sat Mar 25 2003 Jason Luka <jason@geshp.com>
221 - Fixed Buildrequire statements to require all plugins at compile-time
222 - Fixed Require statements so users don't have to install every plugin
223
224 * Thu Mar 23 2003 Jason Luka <jason@geshp.com>
225 - Renamed ffmpeg to libffmpeg
226 - Rebuilt for videolan site
227 - Autolinked /dev/dvd to /dev/cdrom
228
229 * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
230 - Update to 0.5.2.
231 - Fix the dv build dependency, thanks to Alan Hagge.
232 - Added flac support.
233 - Fixed the libdvbpsi requirements.
234
235 * Mon Feb 24 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
236 - Rebuilt against the new xosd lib.
237
238 * Wed Feb 19 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
239 - Update to 0.5.1.
240 - Major spec file update.
241
242 * Fri Nov 15 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
243 - Update to 0.4.6.
244
245 * Tue Oct 22 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
246 - Update to 0.4.5.
247 - Minor --with / --without adjustments.
248
249 * Sun Oct  6 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
250 - Rebuilt for Red Hat Linux 8.0.
251 - New menu entry.
252 - Added all --without options and --with qt.
253
254 * Mon Aug 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
255 - Update to 0.4.4.
256
257 * Fri Jul 26 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
258 - Update to 0.4.3.
259
260 * Fri Jul 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
261 - Update to 0.4.2.
262
263 * Wed Jun  5 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
264 - Update to 0.4.1.
265
266 * Fri May 24 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
267 - Update to 0.4.0.
268 - Disabled qt interface, it's hell to build with qt2/3!
269 - Use %%find_lang and %%{?_smp_mflags}.
270
271 * Fri Apr 19 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
272 - Update to 0.3.1.
273
274 * Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
275 - Update to 0.3.0.
276
277 * Sat Jan 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
278 - Removed the dependency on libdvdcss package, use the built in one instead,
279   because 1.x.x is not as good as 0.0.3.ogle3.
280
281 * Tue Jan  1 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
282 - Update to 0.2.92.
283 - Build fails with libdvdcss < 1.0.1.
284
285 * Tue Nov 13 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
286 - Update to 0.2.91 and now requires libdvdcss 1.0.0.
287
288 * Mon Oct 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
289 - Split libdvdcss into a separate package since it's also needed by the
290   xine menu plugin.
291
292 * Thu Oct 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
293 - Updated to 0.2.90.
294 - Removed ggi, svgalib and aalib since they aren't included in Red Hat 7.2.
295
296 * Mon Aug 27 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
297 - Updated to 0.2.83.
298
299 * Sat Aug 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
300 - Updated to 0.2.82.
301
302 * Mon Jul 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
303 - Updated to 0.2.81.
304 - Added all the new split libdvdcss.* files to the %%files section.
305
306 * Tue Jun  5 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
307 - Updated to the latest release, 0.2.80.
308
309 * Wed May 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
310 - Updated to today's CVS version, works great! :-)
311 - Fixed the desktop menu entry.
312
313 * Tue May 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
314 - Spec file cleanup to make it look more like others do.
315 - Added the use of many macros.
316 - Disabled automatic requires and provides (the package always needed qt,
317   gtk+, gnome etc. otherwise).
318 - Added a system desktop menu entry.
319
320 * Mon Apr 30 2001 Arnaud Gomes-do-Vale <arnaud@glou.org>
321 Added relocation support and compile fixes for Red Hat 7.x.
322
323 * Sat Apr 28 2001 Henri Fallon <henri@videolan.org>
324 New upstream release (0.2.73)
325
326 * Mon Apr 16 2001 Samuel Hocevar <sam@zoy.org>
327 New upstream release (0.2.72)
328
329 * Fri Apr 13 2001 Samuel Hocevar <sam@zoy.org>
330 New upstream release (0.2.71)
331
332 * Sun Apr 8 2001 Christophe Massiot <massiot@via.ecp.fr>
333 New upstream release (0.2.70)
334
335 * Fri Feb 16 2001 Samuel Hocevar <sam@via.ecp.fr>
336 New upstream release
337
338 * Tue Aug  8 2000 Samuel Hocevar <sam@via.ecp.fr>
339 Added framebuffer support
340
341 * Sun Jun 18 2000 Samuel Hocevar <sam@via.ecp.fr>
342 Took over the package
343
344 * Thu Jun 15 2000 Eric Doutreleau <Eric.Doutreleau@int-evry.fr>
345 Initial package
346