]> git.sesse.net Git - vlc/blob - vlc.spec
macosx/vout.m : fixed --macosx-fillscreen
[vlc] / vlc.spec
1 %define mozver 1.4.1
2
3 Summary: VLC media player, a multimedia player and streaming application.
4 Name: vlc
5 Version: 0.7.0
6 Release: 1
7 Group: Applications/Multimedia
8 License: GPL
9 URL: http://www.videolan.org/
10 Source: http://download.videolan.org/pub/videolan/vlc/vlc-%{version}-%{release}.tar.bz2
11 Buildroot: %{_tmppath}/%{name}-root
12 Packager: Jason Luka <jason@geshp.com>
13 Buildrequires: XFree86-devel, desktop-file-utils, libpostproc >= 1.0
14 %{!?_without_dvd:Buildrequires: libdvdcss-devel >= 1.2.8}
15 %{!?_without_dvdread:Buildrequires: libdvdread-devel >= 0.9.4}
16 %{!?_without_dvdplay:Buildrequires: libdvdplay-devel >= 1.0.1}
17 %{!?_without_dvbpsi:Buildrequires: libdvbpsi-devel >= 0.1.3}
18 %{!?_without_ogg:Buildrequires: libogg-devel}
19 %{!?_without_mad:Buildrequires: libmad-devel >= 0.15.0b}
20 %{!?_without_ffmpeg:Buildrequires: ffmpeg-devel}
21 %{!?_without_xvid:Buildrequires: xvidcore-devel >= 0.9.2}
22 %{!?_without_a52:Buildrequires: a52dec-devel}
23 %{!?_without_dv:Buildrequires: libdv-devel >= 0.99}
24 %{!?_without_flac:Buildrequires: flac-devel >= 1.1.0}
25 %{!?_without_vorbis:Buildrequires: libvorbis-devel}
26 %{!?_without_sdl:Buildrequires: SDL-devel}
27 %{!?_without_aa:Buildrequires: aalib-devel}
28 %{!?_without_esd:Buildrequires: esound-devel}
29 %{!?_without_arts:Buildrequires: arts-devel}
30 #%%{!?_without_alsa:Buildrequires: alsa-lib-devel}
31 %{!?_without_gtk:Buildrequires: gtk+-devel}
32 %{!?_without_gnome:Buildrequires: gnome-libs-devel}
33 %{!?_without_lirc:Buildrequires: lirc}
34 %{!?_without_qt:Buildrequires: qt-devel}
35 %{!?_without_kde:Buildrequires: kdelibs-devel}
36 %{!?_without_ncurses:Buildrequires: ncurses-devel >= 5}
37 %{!?_without_xosd:Buildrequires: xosd-devel >= 2.2.5}
38 %{!?_without_id3tag:BuildRequires: libid3tag-devel}
39 %{!?_without_mpeg2dec:BuildRequires: mpeg2dec-devel >= 0.3.2}
40 %{!?_without_wxwindows:BuildRequires: wxGTK-devel >= 2.4.2}
41 %{!?_without_mozilla:BuildRequires: mozilla-devel >= %{mozver}}
42 %{!?_without_mozilla:BuildRequires: mozplugger >= 1.3.2}
43 %{!?_without_speex:BuildRequires: speex-devel >= 1.0.3}
44 %{!?_without_aa:BuildRequires: aalib >= 1.4}
45 %{!?_without_mkv:BuildRequires: matroska}
46 %{!?_without_fribidi:BuildRequires: fribidi-devel}
47
48 Obsoletes: videolan-client
49
50 Requires: XFree86, desktop-file-utils
51 %{!?_without_dvd:Requires: libdvdcss >= 1.2.8}
52 %{!?_without_dvdread:Requires: libdvdread >= 0.9.4}
53 %{!?_without_dvdplay:Requires: libdvdplay >= 1.0.1}
54 %{!?_without_dvbpsi:Requires: libdvbpsi >= 0.1.3}
55 %{!?_without_ogg:Requires: libogg}
56 %{!?_without_mad:Requires: libmad >= 0.15.0b}
57 %{!?_without_ffmpeg:Requires: ffmpeg}
58 %{!?_without_xvid:Requires: xvidcore >= 0.9.2}
59 %{!?_without_a52:Requires: a52dec}
60 %{!?_without_dv:Requires: libdv >= 0.99}
61 %{!?_without_flac:Requires: flac >= 1.1.0}
62 %{!?_without_vorbis:Requires: libvorbis}
63 %{!?_without_sdl:Requires: SDL}
64 %{!?_without_aa:Requires: aalib >= 1.4}
65 %{!?_without_esd:Requires: esound}
66 %{!?_without_arts:Requires: arts}
67 #%%{!?_without_alsa:Requires: alsa-lib}
68 %{!?_without_gtk:Requires: gtk+}
69 %{!?_without_gnome:Requires: gnome-libs}
70 %{?_with_qt:Requires: qt}
71 %{?_with_kde:Requires: kdelibs}
72 %{?_with_ncurses:Requires: ncurses}
73 %{!?_without_xosd:Requires: xosd >= 2.2.5}
74 %{!?_without_lirc:Requires: lirc}
75 %{!?_without_mozilla:Requires: mozilla >= %{mozver}}
76 %{!?_without_speex:Requires: speex >= 1.0.3}
77 %{!?_without_wxwindows:Requires: wxGTK >= 2.4.2}
78 %{!?_without_mkv:Requires: matroska}
79 %{!?_without_fribidi:Requires: fribidi}
80
81 %description
82 VLC media player is a highly portable multimedia player for various audio and 
83 video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as well as DVD's, 
84 VCD's, and various streaming protocols. It can also be used as a server to 
85 stream in unicast or multicast in IPv4 or IPv6 on a high-bandwidth network.
86
87 Available rpmbuild rebuild options :
88 --without dvd dvdread dvdplay dvbpsi dv v4l avi asf aac ogg rawdv mad ffmpeg xvid
89           mp4 a52 vorbis mpeg2dec flac aa esd arts alsa gtk gnome xosd lsp lirc
90           pth id3tag dv qt kde ncurses faad wxwindows mkv fribidi
91
92 Options that would need not yet existing add-on packages :
93 --with tremor tarkin theora ggi glide svgalib mga
94
95
96 %package devel
97 Summary: Header files and static library from VLC media player.
98 Group: Development/Libraries
99 Requires: %{name} = %{version}
100
101 %description devel
102 VLC media player is a highly portable multimedia player for various audio and 
103 video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as well as DVD's, 
104 VCD's, and various streaming protocols. It can also be used as a server to 
105 stream in unicast or multicast in IPv4 or IPv6 on a high-bandwidth network.
106
107 Install this package if you need to build VLC media player plugins or intend
108 to link statically to it.
109
110
111 %prep
112 %setup -q -n vlc-%{version}-%{release}
113
114 %build
115 cp %{_libdir}/mozilla/plugins/mozplugger.so %{_libdir}/mozilla-%{mozver}/plugins/mozplugger.so.bak -f
116 mv %{_libdir}/mozilla-%{mozver}/plugins/mozplugger.so.bak %{_libdir}/mozilla-%{mozver}/plugins/mozplugger.so -f
117 rm %{_libdir}/mozilla -fr
118 ln %{_libdir}/mozilla-%{mozver} %{_libdir}/mozilla -sf
119 ln /usr/share/idl/mozilla-%{mozver} /usr/share/idl/mozilla -sf
120 #ln %{_libdir}/libxvidcore.so.2 %{_libdir}/libxvidcore.so -sf
121
122 %configure \
123         --enable-release \
124         %{?_without_dvd:--disable-dvd} \
125         %{!?_without_dvdread:--enable-dvdread} \
126         %{!?_without_dvdplay:--enable-dvdplay} \
127         %{!?_without_dvbpsi:--enable-dvbpsi} \
128         %{!?_without_v4l:--enable-v4l} \
129         --enable-vcd \
130         %{?_without_avi:--disable-avi} \
131         %{?_without_asf:--disable-asf} \
132         %{?_without_aac:--disable-aac} \
133         %{?_without_ogg:--disable-ogg} \
134         %{?_without_rawdv:--disable-rawdv} \
135         %{!?_without_mad:--enable-mad} \
136         %{!?_without_ffmpeg:--enable-pp --enable-ffmpeg --with-ffmpeg=%{_prefix}} \
137         %{!?_without_faad:--enable-faad} \
138         %{!?_without_xvid:--enable-xvid} \
139         %{?_without_mp4:--disable-mp4} \
140         %{?_without_a52:--disable-a52} \
141         %{?_without_cinepak:--disable-cinepak} \
142         %{!?_without_dv:--enable-dv} \
143         %{!?_without_flac:--enable-flac} \
144         %{?_without_mpeg2dec:--disable-libmpeg2} \
145         %{?_without_vorbis:--disable-vorbis} \
146         %{?_with_tremor:--enable-tremor} \
147         %{?_with_tarkin:--enable-tarkin} \
148         %{!?_without_theora:--enable-theora} \
149         --enable-x11 \
150         --enable-xvideo \
151         %{?_without_sdl:--disable-sdl} \
152         --disable-qte \
153         --disable-directx \
154         --enable-fb \
155         %{?_with_mga:--enable-mga} \
156         %{?_with_svgalib:--enable-svgalib} \
157         %{?_with_ggi:--enable-ggi} \
158         %{?_with_glide:--enable-glide} \
159         %{!?_without_aa:--enable-aa} \
160         --without-wingdi \
161         --enable-oss \
162         %{!?_without_esd:--enable-esd} \
163         %{!?_without_arts:--enable-arts} \
164         %{?_with_alsa:--enable-alsa} \
165         %{!?_without_fribidi:--enable-fribidi} \
166         --disable-waveout \
167         %{!?_without_gtk:--enable-gtk} \
168         --disable-familiar \
169         %{!?_without_gnome:--enable-gnome} \
170         %{?_without_wxwindows:--disable-wxwindows} \
171         %{!?_without_qt:--enable-qt} \
172         %{!?_without_kde:--enable-kde} \
173         --disable-opie \
174         --disable-macosx \
175         --disable-qnx \
176         --disable-intfwin \
177         %{!?_without_ncurses:--enable-ncurses} \
178         %{!?_without_xosd:--enable-xosd} \
179         %{?_without_slp:--disable-slp} \
180         %{!?_without_lirc:--enable-lirc} \
181         %{!?_without_pth:--enable-pth} \
182         --disable-st \
183         %{!?_without_mozilla:--enable-mozilla} \
184         %{?_without_speex:--disable-speex} \
185         --disable-testsuite \
186         --enable-plugins \
187         %{?_without_mkv:--disable-mkv} \
188         %{!?_without_fribidi:--enable-fribidi}
189 make %{?_smp_mflags}
190
191 %install
192 rm -rf %{buildroot}
193 %makeinstall
194 find  %{buildroot}%{_libdir}/vlc -name "*.so" | xargs strip
195 %find_lang vlc
196
197 cat > %{name}.desktop << EOF
198 [Desktop Entry]
199 Name=VLC Media Player
200 Comment=%{summary}
201 Icon=%{_datadir}/vlc/vlc48x48.png
202 Exec=vlc
203 Terminal=0
204 Type=Application
205 EOF
206
207 mv %{buildroot}%{_libdir}/mozilla %{buildroot}%{_libdir}/mozilla-%{mozver} -f
208
209 mkdir -p %{buildroot}%{_datadir}/applications
210 desktop-file-install --vendor gnome --delete-original             \
211   --dir %{buildroot}%{_datadir}/applications                      \
212   --add-category X-Red-Hat-Base                                   \
213   --add-category Application                                      \
214   --add-category AudioVideo                                       \
215   %{name}.desktop
216
217 %post
218 ln /dev/cdrom /dev/dvd -sf
219
220 %postun
221 rm -f /dev/dvd
222 rm /usr/share/idl/mozilla -fr
223
224 %clean
225 rm -rf %{buildroot}
226 rm /usr/share/idl/mozilla -fr
227 rm /usr/lib/mozilla -fr
228 mkdir /usr/lib/mozilla/plugins -p --mode=755
229 mv %{_libdir}/mozilla-%{mozver}/plugins/mozplugger.so %{_libdir}/mozilla/plugins -f
230
231 %files -f vlc.lang
232 %defattr(-, root, root)
233 %doc AUTHORS COPYING ChangeLog MAINTAINERS README THANKS
234 %doc doc/fortunes.txt doc/web-streaming.html doc/intf-vcd.txt doc/vlc-howto.sgml
235 %doc doc/bugreport-howto.txt
236 %exclude %{_datadir}/doc/vlc/*
237 %{_bindir}/*vlc
238 %{_libdir}/vlc
239 %{_libdir}/libvlc_pic.a
240 %{_libdir}/mozilla-%{mozver}/components/vlcintf.xpt
241 %{_libdir}/mozilla-%{mozver}/plugins/libvlcplugin.so
242 %{_datadir}/applications/gnome-%{name}.desktop
243 %{_datadir}/vlc
244
245 %files devel
246 %defattr(-, root, root)
247 %doc HACKING 
248 %{_bindir}/vlc-config
249 %{_includedir}/vlc
250 %{_libdir}/libvlc.a
251
252 %changelog
253 * Tue Dec 2 2003 Jason Luka
254 - Added fribidi support
255 - Added fribidi and mkv options to configure
256
257 * Sat Nov 29 2003 Jason Luka
258 - Fixed Matroska/EBML problem
259 - Updated script for mozilla plugin installation
260
261 * Fri Nov 28 2003 Jason Luka
262 - Update to 0.7.0-test1
263 - Updated version numbers on dependancies
264 - Removed ALSA support until RH/FC turns to kernel 2.6
265 - Added --enable-speex and --enable-pp
266 - Mozilla plugin now built for 1.4.1
267 - Currently broken (Matroska/EBML problems)
268
269 * Mon Aug 25 2003 Jason Luka
270 - Added matroska support
271 - Corrected some symlinking problems with the mozilla plugin
272
273 * Fri Aug 22 2003 Jason Luka <jason@geshp.com>
274 - Update to 0.6.2
275 - Changed menu item name to VideoLAN Media Player
276 - Added openslp support
277 - Added libtar support (needed for skins)
278 - Added symlink to libxvidcore.so, thanks to new version of that software
279
280 * Fri Aug 1 2003 Jason Luka <jason@geshp.com>
281 - Update to 0.6.1
282 - Fixed file structure problems I created to accomodate the mozilla plugin
283 - Changed vendor name for desktop install
284 - Moved vlc to base menu
285 - Moved plugins from /usr/lib/mozilla to /usr/lib/mozilla-x.x.x
286 - Added custom patch to accomodate mozilla plugin
287 - Added execution of bootstrap since Makefile.am was altered
288
289 * Tue Jul 8 2003 Jason Luka <jason@geshp.com>
290 - Update to 0.6.0
291 - Add id3lib, dv, faad, qt, kde, and mozilla plugin support
292 - Added script to symlink mozilla-1.2.1 directories to mozilla so build can complete
293
294 * Sat Apr 5 2003 Jason Luka <jason@geshp.com>
295 - Rebuilt for Red Hat 9
296 - Changed dependencies for ffmpeg's new name
297 - Required lirc support at build-time 
298
299 * Sat Mar 25 2003 Jason Luka <jason@geshp.com>
300 - Fixed Buildrequire statements to require all plugins at compile-time
301 - Fixed Require statements so users don't have to install every plugin
302
303 * Thu Mar 23 2003 Jason Luka <jason@geshp.com>
304 - Renamed ffmpeg to libffmpeg
305 - Rebuilt for videolan site
306 - Autolinked /dev/dvd to /dev/cdrom
307
308 * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
309 - Update to 0.5.2.
310 - Fix the dv build dependency, thanks to Alan Hagge.
311 - Added flac support.
312 - Fixed the libdvbpsi requirements.
313
314 * Mon Feb 24 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
315 - Rebuilt against the new xosd lib.
316
317 * Wed Feb 19 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
318 - Update to 0.5.1.
319 - Major spec file update.
320
321 * Fri Nov 15 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
322 - Update to 0.4.6.
323
324 * Tue Oct 22 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
325 - Update to 0.4.5.
326 - Minor --with / --without adjustments.
327
328 * Sun Oct  6 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
329 - Rebuilt for Red Hat Linux 8.0.
330 - New menu entry.
331 - Added all --without options and --with qt.
332
333 * Mon Aug 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
334 - Update to 0.4.4.
335
336 * Fri Jul 26 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
337 - Update to 0.4.3.
338
339 * Fri Jul 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
340 - Update to 0.4.2.
341
342 * Wed Jun  5 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
343 - Update to 0.4.1.
344
345 * Fri May 24 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
346 - Update to 0.4.0.
347 - Disabled qt interface, it's hell to build with qt2/3!
348 - Use %%find_lang and %%{?_smp_mflags}.
349
350 * Fri Apr 19 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
351 - Update to 0.3.1.
352
353 * Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
354 - Update to 0.3.0.
355
356 * Sat Jan 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
357 - Removed the dependency on libdvdcss package, use the built in one instead,
358   because 1.x.x is not as good as 0.0.3.ogle3.
359
360 * Tue Jan  1 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
361 - Update to 0.2.92.
362 - Build fails with libdvdcss < 1.0.1.
363
364 * Tue Nov 13 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
365 - Update to 0.2.91 and now requires libdvdcss 1.0.0.
366
367 * Mon Oct 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
368 - Split libdvdcss into a separate package since it's also needed by the
369   xine menu plugin.
370
371 * Thu Oct 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
372 - Updated to 0.2.90.
373 - Removed ggi, svgalib and aalib since they aren't included in Red Hat 7.2.
374
375 * Mon Aug 27 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
376 - Updated to 0.2.83.
377
378 * Sat Aug 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
379 - Updated to 0.2.82.
380
381 * Mon Jul 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
382 - Updated to 0.2.81.
383 - Added all the new split libdvdcss.* files to the %%files section.
384
385 * Tue Jun  5 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
386 - Updated to the latest release, 0.2.80.
387
388 * Wed May 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
389 - Updated to today's CVS version, works great! :-)
390 - Fixed the desktop menu entry.
391
392 * Tue May 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
393 - Spec file cleanup to make it look more like others do.
394 - Added the use of many macros.
395 - Disabled automatic requires and provides (the package always needed qt,
396   gtk+, gnome etc. otherwise).
397 - Added a system desktop menu entry.
398
399 * Mon Apr 30 2001 Arnaud Gomes-do-Vale <arnaud@glou.org>
400 Added relocation support and compile fixes for Red Hat 7.x.
401
402 * Sat Apr 28 2001 Henri Fallon <henri@videolan.org>
403 New upstream release (0.2.73)
404
405 * Mon Apr 16 2001 Samuel Hocevar <sam@zoy.org>
406 New upstream release (0.2.72)
407
408 * Fri Apr 13 2001 Samuel Hocevar <sam@zoy.org>
409 New upstream release (0.2.71)
410
411 * Sun Apr 8 2001 Christophe Massiot <massiot@via.ecp.fr>
412 New upstream release (0.2.70)
413
414 * Fri Feb 16 2001 Samuel Hocevar <sam@via.ecp.fr>
415 New upstream release
416
417 * Tue Aug  8 2000 Samuel Hocevar <sam@via.ecp.fr>
418 Added framebuffer support
419
420 * Sun Jun 18 2000 Samuel Hocevar <sam@via.ecp.fr>
421 Took over the package
422
423 * Thu Jun 15 2000 Eric Doutreleau <Eric.Doutreleau@int-evry.fr>
424 Initial package
425