]> git.sesse.net Git - vlc/blob - vlc.spec
Updated description.
[vlc] / vlc.spec
1 %define name            vlc
2 %define vlc_ver         0.4.5
3 %define version         %vlc_ver
4
5 %define cvs             0
6 %if %{cvs}
7 %define cvsdate         20010619
8 %define release         0.%{cvsdate}
9 %define cvs_name        %{name}-snapshot-%{cvsdate}-00
10 %else
11 %define release         1
12 %endif
13
14 # The QT interface is not functional yet
15 %define plugin_qt       0
16 %define plugin_lirc     1
17
18 Summary:        VideoLAN is a free multimedia software solution.
19 Name:           %{name}
20 Version:        %{version}
21 Release:        %{release}
22 Packager:       Yves Duret <yduret@mandrakesoft.com>
23
24 %if %{cvs} 
25 Source0:        http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.bz2
26 %else
27 Source0:        http://www.videolan.org/packages/%{version}/%{name}-%{version}.tar.bz2
28 %endif
29 License:        GPL
30 Group:          Video
31 URL:            http://www.videolan.org/
32 Requires:       vlc-gui
33 # vlc-mad needed by ffmpeg builtin (i want MPEG4 support out of box)
34 Requires:       vlc-mad
35
36 BuildRoot:      %_tmppath/%name-%version-%release-root
37 Buildrequires:  libncurses5-devel
38 #Buildrequires: libqt2-devel
39 Buildrequires:  libgtk+1.2-devel
40 Buildrequires:  gnome-libs-devel
41 Buildrequires:  db1-devel
42 Buildrequires:  alsa-lib-devel
43 Buildrequires:  libarts-devel
44 Buildrequires:  libggi-devel
45 Buildrequires:  aalib-devel
46 Buildrequires:  SDL-devel
47 Buildrequires:  liba52dec-devel
48 Buildrequires:  libmad-devel
49 Buildrequires:  liblirc-devel
50 Buildrequires:  libffmpeg-devel
51
52 %description
53 VideoLAN is an OpenSource streaming solution for every OS developed by
54 students from the Ecole Centrale Paris and developers from all over the
55 World.
56 The VideoLAN Client (vlc) plays MPEG1, MPEG2 and MPEG4 (aka DivX) files,
57 DVDs, VCDs, SVCDs, from a satellite card, from an MPEG2 Transport
58 Streams sent by the VideoLAN Server (vls) or from a Web server (with the
59 HTTP input).
60 You may install vlc-gnome or vlc-gtk to have a nice graphical interface.
61 This package contains no CSS unscrambling functionality for DVDs ;
62 you need the libdvdcss library available from 
63 http://www.videolan.org/libdvdcss/ or http://plf.zarb.org/
64
65 # intf plugins
66 %package gtk
67 Summary: Gtk plugin for the VideoLAN client
68 Group: Video
69 Requires: %{name} = %{version}
70 Provides: vlc-gui
71 %description gtk
72 VideoLAN is a free multimedia software solution.
73
74 This plugin adds a Gtk+ interface to vlc, the VideoLAN Client. To
75 activate it, use the `--intf gtk' flag or run the `gvlc' program.
76
77 %package gnome
78 Summary: Gnome plugin for the VideoLAN client
79 Group: Video
80 Requires: %{name} = %{version}
81 Provides: vlc-gui
82 %description gnome
83 VideoLAN is a free multimedia software solution.
84
85 This plugin adds a Gnome interface to vlc, the VideoLAN Client. To
86 activate it, use the `--intf gnome' flag or run the `gnome-vlc' program.
87
88 %package qt
89 Summary: Qt2 plugin for the VideoLAN client
90 Group: Video
91 Requires: %{name} = %{version}
92 Provides: vlc-gui
93 %description qt
94 VideoLAN is a free multimedia software solution.
95
96 This plugin adds a Qt interface to vlc, the VideoLAN Client. To
97 activate it, use the `--intf qt' flag or run the `qvlc' program.
98
99 %package ncurses
100 Summary: Ncurses console-based plugin for the VideoLAN client
101 Group: Video
102 Requires: %{name} = %{version}
103 %description ncurses
104 VideoLAN is a free multimedia software solution.
105
106 This plugin adds a ncurses interface to vlc, the VideoLAN Client. To
107 activate it, use the `--intf ncurses' flag.
108
109 %package lirc
110 Summary: Lirc plugin for the VideoLAN client
111 Group: Video
112 Requires: %{name} = %{version}
113 %description lirc
114 VideoLAN is a free multimedia software solution.
115
116 This plugin is an infrared lirc interface for vlc, the
117 VideoLAN Client. To activate it, use the `--intf lirc' flag.
118
119
120 # video plugins
121 %package aa
122 Summary: ASCII art video plugin for the VideoLAN client
123 Group: Video
124 Requires: %{name} = %{version}
125 %description aa
126 VideoLAN is a free multimedia software solution.
127
128 This is an ASCII art video output plugin for vlc, the VideoLAN
129 Client. To activate it, use the `--vout aa' flag or select the `aa'
130 vout plugin from the preferences menu.
131
132
133 %package sdl
134 Summary: Simple DirectMedia Layer video plugin for the VideoLAN client
135 Group: Video
136 Requires: %{name} = %{version}
137 %description sdl
138 VideoLAN is a free multimedia software solution.
139
140 This plugin adds support for the Simple DirectMedia Layer library to
141 vlc, the VideoLAN Client. To activate it, use the `--vout sdl' or
142 `--aout sdl' flags or select the `sdl' vout or aout plugin from the
143 preferences menu.
144
145 %package ggi
146 Summary: GGI video plugin for the VideoLAN client
147 Group: Video
148 Requires: %{name} = %{version}
149 %description ggi
150 VideoLAN is a free multimedia software solution.
151
152 This is a GGI plugin for vlc, the VideoLAN Client.  To activate it, use
153 the `--vout ggi' flag or select the `ggi' vout plugin from the preferences
154 menu.
155      
156 # codec plugins
157 %package mad
158 Summary: MAD audio codec plugin for the VideoLAN client
159 Group: Video
160 Requires: %{name} = %{version}
161 %description mad
162 VideoLAN is a free multimedia software solution.
163
164 This plugin adds support for libmad, the MPEG audio decoder library,
165 to the VideoLAN Client. MAD is 100% fixed-point based. To activate
166 this plugin, use the `--mpeg_adec mad' flag or select the `mad' MPEG
167 decoder from the preferences menu.
168
169 # audio plugins
170 %package esd
171 Summary: Enlightened Sound Daemon audio plugin for the VideoLAN client
172 Group: Video
173 Requires: %{name} = %{version}
174 %description esd
175 VideoLAN is a free multimedia software solution.
176
177 This plugin adds support for the Enlightened Sound Daemon to vlc, the
178 VideoLAN Client. To activate it, use the `--aout esd' flag or select
179 the `esd' aout plugin from the preferences menu.
180
181 %package arts
182 Summary: aRts audio plugin for the VideoLAN client
183 Group: Video
184 Requires: %{name} = %{version}
185 %description arts
186 VideoLAN is a free multimedia software solution.
187
188 This plugin adds support for the aRts Sound System to vlc, the
189 VideoLAN Client. To activate it, use the `--aout arts' flag or
190 select the `arts' aout plugin from the preferences menu.
191
192 %package alsa
193 Summary: Advanced Linux Sound Architecture audio plugin for the VideoLAN client
194 Group: Video
195 Requires: %{name} = %{version}
196 %description alsa
197 VideoLAN is a free multimedia software solution.
198
199 This plugin adds support for the Advanced Linux Sound Architecture to
200 vlc, the VideoLAN Client. To activate it, use the `--aout alsa' flag or
201 select the `alsa' aout plugin from the preferences menu.
202
203 %prep
204 %if %{cvs}
205 %setup -q -n %{cvs_name}
206 %else
207 %setup -q
208 %endif
209
210 %build
211 # yves 0.4.0-1mdk
212 # ffmpeg: static linking cause no official ffmpeg release aith a stable ABI
213 # ffmpeg: no plugin posible on ia64 due to the static linking (can not put .a in a .so)
214 %configure  --enable-release \
215             --enable-dvd --without-dvdcss \
216             --enable-gtk --enable-gnome --disable-qt --disable-kde --enable-ncurses --enable-lirc \
217             --enable-x11 --enable-xvideo --enable-ggi --enable-sdl --enable-fb --enable-mga --enable-aa \
218             --enable-esd --enable-alsa --enable-arts \
219             --enable-mad --enable-ffmpeg --with-ffmpeg=/usr
220 export QTDIR=%{_libdir}/qt2 
221 %make
222
223 %install
224 %makeinstall_std
225 install -d %buildroot/%_mandir/man1
226 install doc/vlc.1 %buildroot/%_mandir/man1
227
228 # menu
229 mkdir -p %buildroot/%{_menudir}
230 cat > %buildroot/%{_menudir}/vlc << EOF
231 ?package(vlc): command="%{_bindir}/vlc" hotkey="V" needs="X11" longtitle="VideoLAN is a free multimedia software solution" section="Multimedia/Video" title="VideoLAN Client" icon="vlc.png" hints="Video"
232 EOF
233 cat > %buildroot/%{_menudir}/vlc-gtk << EOF
234 ?package(vlc-gtk): command="%{_bindir}/gvlc" needs="X11" longtitle="VideoLAN is a free multimedia software solution" section="Multimedia/Video" title="Gtk VideoLAN Client" icon="gvlc.png" hints="Video"
235 EOF
236 cat > %buildroot/%{_menudir}/vlc-gnome << EOF
237 ?package(vlc-gnome): command="%{_bindir}/gnome-vlc" needs="X11" longtitle="VideoLAN is a free multimedia software solution" section="Multimedia/Video" title="Gnome VideoLAN Client" icon="gnome-vlc.png" hints="Video"
238 EOF
239 cat > %buildroot/%{_menudir}/vlc-qt << EOF
240 ?package(vlc-gnome): command="%{_bindir}/qvlc" needs="X11" longtitle="VideoLAN is a free multimedia software solution" section="Multimedia/Video" title="Qt VideoLAN Client" icon="qvlc.png" hints="Video"
241 EOF
242
243 # icons
244 mkdir -p %{buildroot}/{%{_miconsdir},%{_liconsdir}}
245 install -m 644 %buildroot/%_datadir/videolan/vlc16x16.png %buildroot/%{_miconsdir}/vlc.png
246 install -m 644 %buildroot/%_datadir/videolan/vlc32x32.png %buildroot/%{_iconsdir}/vlc.png
247 install -m 644 %buildroot/%_datadir/videolan/vlc48x48.png %buildroot/%{_liconsdir}/vlc.png
248 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc16x16.png %buildroot/%{_miconsdir}/gnome-vlc.png
249 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc32x32.png %buildroot/%{_iconsdir}/gnome-vlc.png
250 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc48x48.png %buildroot/%{_liconsdir}/gnome-vlc.png
251 install -m 644 %buildroot/%_datadir/videolan/gvlc16x16.png %buildroot/%{_miconsdir}/gvlc.png
252 install -m 644 %buildroot/%_datadir/videolan/gvlc32x32.png %buildroot/%{_iconsdir}/gvlc.png
253 install -m 644 %buildroot/%_datadir/videolan/gvlc48x48.png %buildroot/%{_liconsdir}/gvlc.png
254 install -m 644 %buildroot/%_datadir/videolan/kvlc16x16.png %buildroot/%{_miconsdir}/kvlc.png
255 install -m 644 %buildroot/%_datadir/videolan/kvlc32x32.png %buildroot/%{_iconsdir}/kvlc.png
256 install -m 644 %buildroot/%_datadir/videolan/kvlc48x48.png %buildroot/%{_liconsdir}/kvlc.png
257 install -m 644 %buildroot/%_datadir/videolan/qvlc16x16.png %buildroot/%{_miconsdir}/qvlc.png
258 install -m 644 %buildroot/%_datadir/videolan/qvlc32x32.png %buildroot/%{_iconsdir}/qvlc.png
259 install -m 644 %buildroot/%_datadir/videolan/qvlc48x48.png %buildroot/%{_liconsdir}/qvlc.png
260
261 %post
262 %update_menus
263 %postun
264 %update_menus
265
266 %clean
267 rm -fr %buildroot
268
269 %files
270 %defattr(-,root,root)
271 %doc README COPYING
272 %{_bindir}/vlc
273
274 %dir %{_libdir}/videolan/vlc
275 %{_libdir}/videolan/vlc/ac3_spdif.so
276 %{_libdir}/videolan/vlc/avi.so
277 %{_libdir}/videolan/vlc/dummy.so
278 %{_libdir}/videolan/vlc/dvd.so
279 %{_libdir}/videolan/vlc/fb.so
280 %{_libdir}/videolan/vlc/file.so
281 %{_libdir}/videolan/vlc/filter_deinterlace.so
282 %{_libdir}/videolan/vlc/filter_distort.so
283 %{_libdir}/videolan/vlc/filter_invert.so
284 %{_libdir}/videolan/vlc/filter_transform.so
285 %{_libdir}/videolan/vlc/filter_wall.so
286 %{_libdir}/videolan/vlc/filter_clone.so
287 %{_libdir}/videolan/vlc/filter_crop.so
288 %{_libdir}/videolan/vlc/fx_scope.so
289 %{_libdir}/videolan/vlc/http.so
290 %{_libdir}/videolan/vlc/ipv4.so
291 %{_libdir}/videolan/vlc/ipv6.so
292 %{_libdir}/videolan/vlc/logger.so
293 %{_libdir}/videolan/vlc/lpcm_adec.so
294 %{_libdir}/videolan/vlc/memcpy.so
295 %{_libdir}/videolan/vlc/mga.so
296 %{_libdir}/videolan/vlc/mpeg_es.so
297 %{_libdir}/videolan/vlc/mpeg_ps.so
298 %{_libdir}/videolan/vlc/mpeg_ts.so
299 %{_libdir}/videolan/vlc/null.so
300 %{_libdir}/videolan/vlc/oss.so
301 %{_libdir}/videolan/vlc/rc.so
302 %{_libdir}/videolan/vlc/spudec.so
303 %{_libdir}/videolan/vlc/udp.so
304 %{_libdir}/videolan/vlc/vcd.so
305 %{_libdir}/videolan/vlc/x11.so
306 #%{_libdir}/videolan/vlc/xmga.so
307
308 %{_mandir}/man1/*
309 %{_menudir}/vlc
310 %{_miconsdir}/vlc.png
311 %{_iconsdir}/vlc.png
312 %{_liconsdir}/vlc.png
313
314
315 # intf plugins
316 %files gtk
317 %defattr(-,root,root)
318 %doc README
319 %{_libdir}/videolan/vlc/gtk.so
320 %{_bindir}/gvlc
321 %{_menudir}/vlc-gtk
322 %{_miconsdir}/gvlc.png
323 %{_iconsdir}/gvlc.png
324 %{_liconsdir}/gvlc.png
325 %post gtk
326 %update_menus
327 %postun gtk
328 %update_menus
329
330 %files gnome
331 %defattr(-,root,root)
332 %doc README
333 %{_libdir}/videolan/vlc/gnome.so
334 %{_bindir}/gnome-vlc
335 %{_menudir}/vlc-gnome
336 %{_miconsdir}/gnome-vlc.png
337 %{_iconsdir}/gnome-vlc.png
338 %{_liconsdir}/gnome-vlc.png
339 %post   gnome
340 %update_menus
341 %postun gnome
342 %update_menus
343
344 %if %{plugin_qt}
345 %files qt
346 %defattr(-,root,root)
347 %doc README
348 %{_libdir}/videolan/vlc/qt.so
349 %{_bindir}/qvlc
350 %{_menudir}/vlc-qt
351 %{_miconsdir}/qvlc.png
352 %{_iconsdir}/qvlc.png
353 %{_liconsdir}/qvlc.png
354 %post   qt
355 %update_menus
356 %postun qt
357 %update_menus
358 %endif
359
360 %files ncurses
361 %defattr(-,root,root)
362 %doc README
363 %{_libdir}/videolan/vlc/ncurses.so
364
365 %if %plugin_lirc
366 %files lirc
367 %defattr(-,root,root)
368 %doc README
369 %{_libdir}/videolan/vlc/lirc.so
370 %endif
371
372 # video plugins
373 %files sdl
374 %defattr(-,root,root)
375 %doc README
376 %{_libdir}/videolan/vlc/sdl.so
377
378 %files ggi
379 %defattr(-,root,root)
380 %doc README
381 %{_libdir}/videolan/vlc/ggi.so
382
383 %files aa
384 %defattr(-,root,root)
385 %doc README
386 %{_libdir}/videolan/vlc/aa.so
387
388 # codec plugin
389 %files mad
390 %defattr(-,root,root)
391 %doc README
392 %{_libdir}/videolan/vlc/mad.so
393
394 #audio plugins
395 %files esd
396 %defattr(-,root,root)
397 %doc README
398 %{_libdir}/videolan/vlc/esd.so
399
400 %files arts
401 %defattr(-,root,root)
402 %doc README
403 %{_libdir}/videolan/vlc/arts.so
404
405 %files alsa
406 %defattr(-,root,root)
407 %doc README
408 %{_libdir}/videolan/vlc/alsa.so
409
410 %changelog
411 * Mon Jun 20 2002 Yves Duret <yduret@mandrakesoft.com> 0.4.2-1mdk
412 - new upstream release
413
414 * Mon Jun 3 2002 Yves Duret <yduret@mandrakesoft.com> 0.4.1-1mdk
415 - new upstream release
416
417 * Thu May 23 2002 Yves Duret <yduret@mandrakesoft.com> 0.4.0-1mdk
418 - version 0.4.0 with MPEG4 (DivX) support thx ffmpeg.
419   thus s/MPEG, MPEG2 and DVD/multimedia/g
420 - sync %%description with debian ones.
421 - vlc now requires a vlc-gui (gtk, gnome or qt).
422 - removed gcc3.1 patches since merged upstream.
423
424 * Mon May 13 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-4mdk
425 - removed xmga plugin (currently broken).
426 - manual rebuild in gcc3.1 environment aka added Patch0 & Patch1
427 - various summary/description changes.
428
429 * Fri May 03 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-3mdk
430 - added vlc-lirc intf plugin rpm.
431
432 * Tue Apr 30 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-2mdk
433 - rebuild against libalsa2 (vlc-sdl)
434
435 * Fri Apr 19 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-1mdk
436 - version 0.3.1.
437 - removed patch0 merged upstream.
438 - removed old %%ifarch ppc
439 - added missing libmad-devel buldrequires
440
441 * Wed Apr 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-4mdk
442 - added liba52 support (buildrequires).
443 - added vlc-alsa audio plugin.
444 - mad is a codec (audio) plugin. corrected description and summary.
445
446 * Wed Apr 10 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-3mdk
447 - added patch0 from CVS: fix crashing GTK popup menus thx Michal Bukovjan <bukovjan@mbox.dkm.cz>
448
449 * Wed Apr 10 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-2mdk
450 - added vlc-arts rpm plugin thx blindauer Emmanuel <manu@agat.net>
451 - better summary for plugin
452 - add packager tag to myself
453
454 * Sun Apr 07 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-1mdk
455 - version 0.3.0
456 - added aa (Asci Art) plugin in vlc-aa rpm
457 - merged with sam's one:
458   * using his plugins list into %%files
459   * removed libdvdcss from the whole tarball.
460   * removed the workaround for vlc's bad /dev/dsp detection.
461 - few spell corrections in all %%description
462 - added buildrequires on SDL-devel
463
464 * Tue Mar 05 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.93-0.1mdk
465 - new cvs snapshot
466 - fix requires
467
468 * Mon Mar 04 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-5mdk
469 - cvs snapshot
470
471 * Sat Jan 26 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-4mdk
472 - mad plugin in vlc-mad rpm
473
474 * Mon Jan 21 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-3mdk
475 - synced with main cvs specfile wich "fixed a few minor inaccuracies"
476
477 * Thu Jan 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-2mdk
478 - readded libdvdcss rpm in specfile. use %%define css 1 with correct sources
479   to build libdvdcss rpm.
480
481 * Wed Jan 09 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-1mdk
482 - version 0.2.92
483 - %%makeinstall_std
484 - splitted again, added vlc-sdl vlc-esd vlc-ggi
485 - bring back some missing plugins
486 - fixed buildrequires
487 - added menu entries and icons (from cvs)
488
489 * Tue Oct 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-2mdk
490 - rebuild against libpng3
491 - added some doc for sir rpmlint
492 - #5583: option -g
493
494 * Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-1mdk
495 - version 0.2.83 : 
496   * Activated subtitles in overlay mode (far from perfect, but this
497     was an often requested feature).
498
499 * Fri Aug 10 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.82-1mdk
500 - version 0.2.82
501
502 * Mon Jul 30 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-1mdk
503 - version 0.2.81
504 - added vlc-ncurses
505
506 * Wed Jun 20 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-0.20010619-1mdk
507 - cvs snapshot
508 - added libdvdcss
509
510 * Wed Jun 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-2mdk
511 - fix build on ppc (c) dadou
512
513 * Mon Jun 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-1mdk
514 - version 0.2.80 : bug fixes and bug fixes and bug fixes and small
515   improvements of the gtk interface.
516 - corrected Summary in vlc-qt
517
518 * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-2mdk
519 - added qt2 plugin (vlc-qt)
520
521 * Wed May 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-1mdk
522 - version 0.2.73
523 - you can now get decss threw a plugin
524 - rewritte srcipt to build vlc (decss plugin)
525 - rebuild with SDL 1.2
526
527 * Thu Apr 26 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-2mdk
528 - true 0.2.72
529
530 * Mon Apr 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-1mdk
531 - version 0.2.72
532 - package split into vlc, vlc-gnome, vlc-gtk
533
534 * Fri Apr 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.71-1mdk
535 - version 0.2.71 :
536   * Fixed segfaults when compiled with gcc 3.0pre and versions of gcc
537     shipped with the latest RedHat distributions.                    
538   * Fixed the BeOS CSS decryption.
539   * Fixed a few issues in IFO parsing.
540   * Fixed XVideo video output.
541   * Updated icons under Linux, BeOS, MacOS X.
542
543 * Wed Apr 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.70-1mdk
544 - version 0.2.70
545
546 * Thu Mar 22 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.63-1mdk
547 - version 0.2.63 : Bugfixes, bugfixes, and bugfixes again, a Gtk+ 
548   interface for the Gnome-impaired, an even better DVD support
549
550 * Fri Feb 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.61-1mdk
551 - new version for all the DVD fans (add MPEG1 support, direct DVD support, 
552   DVD decryption, arbitrary, seeking in the stream, pause, fast forward 
553   and slow motion, hardware YUV acceleration enhanced CSS support and a few 
554   new interface features including drag'n'drop.
555 - first *real* public release (now under the GPL)
556
557 * Sat Jan 06 2001 David BAUDENS <baudens@mandrakesoft.com> 0.1.99i-2mdk
558 - Fix build and use right optimizations on PPC
559 - Enable SDL support
560 - Spec clean up
561
562 * Fri Jan  5 2001 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99i-1mdk
563 - 0.1.99i, rebuild
564
565 * Fri Aug 25 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99h-1mdk
566 - 0.1.99h
567
568 * Mon Jul 10 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99c-1mdk
569 - first Mandrake package with help of Sam