]> git.sesse.net Git - vlc/blob - vlc.spec
* ALL: removed libdvdcss from the vlc tree.
[vlc] / vlc.spec
1 %define name            vlc
2 %define vlc_ver         0.2.92
3 %define version         %vlc_ver
4
5 %define cvs             0
6 %if %{cvs}
7 %define cvsdate         20010619
8 %define release         0.%{cvsdate}mdk
9 %define cvs_name        %{name}-snapshot-%{cvsdate}-00
10 %else
11 %define release         2mdk
12 %endif
13
14 %define plugin_qt       0
15 %define plugin_alsa     0
16
17 Summary:        VideoLAN is a free MPEG, MPEG2 and DVD software solution.
18 Name:           %{name}
19 Version:        %{version}
20 Release:        %{release}
21
22 %if %{cvs} 
23 Source0:        http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.bz2
24 %else
25 Source0:        http://www.videolan.org/packages/%{version}/%{name}-%{version}.tar.bz2
26 %endif
27 License:        GPL
28 Group:          Video
29 URL:            http://videolan.org/
30 BuildRoot:      %_tmppath/%name-%version-%release-root
31 Buildrequires:  libncurses5-devel
32 Buildrequires:  libqt2-devel
33 Buildrequires:  libgtk+1.2-devel
34 Buildrequires:  gnome-libs-devel
35 Buildrequires:  db1-devel
36 Buildrequires:  alsa-lib-devel
37 Buildrequires:  libggi-devel
38
39 %description
40 VideoLAN is a free network-aware MPEG and DVD player.
41 The VideoLAN Client allows to play MPEG2 Transport Streams from the
42 network or from a file, as well as direct DVD playback.
43 VideoLAN is a project of students from the Ecole Centrale Paris.
44 This version add MPEG1 support, direct DVD support, DVD decryption, 
45 arbitrary, seeking in the stream, pause, fast forward and slow motion, 
46 hardware YUV acceleration and a few new interface features 
47 including drag'n'drop.
48 You may install vlc-gnome, vlc-gtk and vlc-qt vlc-gnome vlc-ncurses.
49 This package contains no CSS unscrambling functionality.
50 You need the libdvdcss library available from http://www.videolan.org/libdvdcss/
51
52 %package gtk
53 Summary: Gtk plug-in for VideoLAN, a DVD and MPEG2 player
54 Group: Video
55 Requires: %{name} = %{version}
56 %description gtk
57 The vlc-gtk packages includes the Gtk plug-in for the VideoLAN client.
58 If you are going to watch DVD with the Gtk front-end, you should 
59 install vlc-gtk.
60
61
62 %package gnome
63 Summary: Gnome plug-in for VideoLAN, a DVD and MPEG2 player
64 Group: Video
65 Requires: %{name} = %{version}
66 %description gnome
67 The vlc-gnome packages includes the Gnome plug-in for the VideoLAN client.
68 If you are going to watch DVD with the Gnome front-end, you should 
69 install vlc-gnome.
70
71 %package qt
72 Summary: Qt2 plug-in for VideoLAN, a DVD and MPEG2 player
73 Group: Video
74 Requires: %{name} = %{version}
75 %description qt
76 The vlc-qt packages includes the Qt2 plug-in for the VideoLAN client.
77 If you are going to watch DVD with the Qt2 front-end, you should
78 install vlc-qt
79
80 %package ncurses
81 Summary: Ncurses console-based plug-in for VideoLAN, a DVD and MPEG2 player
82 Group: Video
83 Requires: %{name} = %{version}
84 %description ncurses
85 The vlc-ncurses packages includes the ncurses plug-in for the VideoLAN client.
86 If you are going to watch DVD with the ncurses front-end, you should
87 install vlc-ncurses
88
89 %package sdl
90 Summary: Simple DirectMedia Layer plug-in for VideoLAN, a DVD and MPEG2 player
91 Group: Video
92 Requires: %{name} = %{version}
93 %description sdl
94 The vlc-sdl packages includes the Simple DirectMedia Layer plug-in 
95 for the VideoLAN client.
96 If you are going to watch DVD with the sdl plugin, you should
97 install vlc-sdl
98
99 %package ggi
100 Summary: GGI plug-in for VideoLAN, a DVD and MPEG2 player
101 Group: Video
102 Requires: %{name} = %{version}
103 %description ggi
104 The vlc-ggi packages includes the GGI plug-in for the VideoLAN client.
105 If you are going to watch DVD with the GGI plugin, you should
106 install vlc-ggi
107
108 %package esd
109 Summary: Enlightened Sound Daemon plug-in for VideoLAN, a DVD and MPEG2 player
110 Group: Video
111 Requires: %{name} = %{version}
112 %description esd
113 The vlc-esd packages includes the Enlightened Sound Daemon plug-in 
114 for the VideoLAN client.
115 If you are going to watch DVD with the esd plugin, you should
116 install vlc-esd
117
118 %package alsa
119 Summary: Advanced Linux Sound Architecture plug-in for VideoLAN, a DVD and MPEG2 player
120 Group: Video
121 Requires: %{name} = %{version}
122 %description alsa
123 The vlc-alsa packages includes the Advanced Linux Sound Architecture plug-in for the VideoLAN client.
124 If you are going to watch DVD with the ALSA plugin, you should install vlc-alsa
125
126 %prep
127 %if %{cvs}
128 %setup -q -n %{cvs_name}
129 %else
130 %setup -q -n %{name}-%{vlc_ver}
131 %endif
132
133 %build
134 %ifarch ppc
135 # Dadou - 0.1.99h-mdk - Don't use configure here. It breaks build at present
136 #                       time.
137 ./configure --enable-release \
138             --prefix=%_prefix \
139             --enable-gnome --enable-x11 --enable-gtk --enable-qt \
140             --enable-esd \
141             --enable-fb \
142             --enable-xvideo \
143             --enable-sdl
144 perl -pi -e "s|CFLAGS \+= -mcpu=604e|#CFLAGS \+= -mcpu=604e|" Makefile
145 perl -pi -e "s|#CFLAGS \+= -mcpu=750|CFLAGS \+= -mcpu=750 -mtune=750|" Makefile
146 %else
147 #export CC="gcc-3.0.1" CXX="g++-3.0.1"
148 %configure --enable-release \
149            --enable-gnome --enable-gtk \
150            --enable-x11 --disable-qt --enable-ncurses \
151            --enable-esd --enable-alsa \
152            --enable-fb --enable-mga \
153            --enable-xvideo \
154            --enable-ggi \
155            --enable-sdl 
156 %endif
157 # thier configure check if /dev/dsp exists...
158 perl -pi -e 's#(PLUGINS :=\s)#$1dsp #' Makefile.opts
159 export QTDIR=%{_libdir}/qt2 
160 %make
161
162 %install
163 %makeinstall_std
164 install -d %buildroot/%_mandir/man1
165 install doc/vlc.1 %buildroot/%_mandir/man1
166
167 # menu
168 mkdir -p $RPM_BUILD_ROOT/%{_menudir}
169 cat > $RPM_BUILD_ROOT/%{_menudir}/vlc << EOF
170 ?package(vlc): command="%{_bindir}/vlc" hotkey="V" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="VideoLAN Client" icon="vlc.png" hints="Video"
171 EOF
172 cat > $RPM_BUILD_ROOT/%{_menudir}/vlc-gtk << EOF
173 ?package(vlc-gtk): command="%{_bindir}/gvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gtk VideoLAN Client" icon="gvlc.png" hints="Video"
174 EOF
175 cat > $RPM_BUILD_ROOT/%{_menudir}/vlc-gnome << EOF
176 ?package(vlc-gnome): command="%{_bindir}/gnome-vlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gnome VideoLAN Client" icon="gnome-vlc.png" hints="Video"
177 EOF
178 cat > $RPM_BUILD_ROOT/%{_menudir}/vlc-qt << EOF
179 ?package(vlc-gnome): command="%{_bindir}/qvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Qt VideoLAN Client" icon="qvlc.png" hints="Video"
180 EOF
181
182 # icons
183 mkdir -p %{buildroot}/{%{_miconsdir},%{_liconsdir}}
184 install -m 644 %buildroot/%_datadir/videolan/vlc16x16.png %buildroot/%{_miconsdir}/vlc.png
185 install -m 644 %buildroot/%_datadir/videolan/vlc32x32.png %buildroot/%{_iconsdir}/vlc.png
186 install -m 644 %buildroot/%_datadir/videolan/vlc48x48.png %buildroot/%{_liconsdir}/vlc.png
187 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc16x16.png %buildroot/%{_miconsdir}/gnome-vlc.png
188 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc32x32.png %buildroot/%{_iconsdir}/gnome-vlc.png
189 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc48x48.png %buildroot/%{_liconsdir}/gnome-vlc.png
190 install -m 644 %buildroot/%_datadir/videolan/gvlc16x16.png %buildroot/%{_miconsdir}/gvlc.png
191 install -m 644 %buildroot/%_datadir/videolan/gvlc32x32.png %buildroot/%{_iconsdir}/gvlc.png
192 install -m 644 %buildroot/%_datadir/videolan/gvlc48x48.png %buildroot/%{_liconsdir}/gvlc.png
193 install -m 644 %buildroot/%_datadir/videolan/kvlc16x16.png %buildroot/%{_miconsdir}/kvlc.png
194 install -m 644 %buildroot/%_datadir/videolan/kvlc32x32.png %buildroot/%{_iconsdir}/kvlc.png
195 install -m 644 %buildroot/%_datadir/videolan/kvlc48x48.png %buildroot/%{_liconsdir}/kvlc.png
196 install -m 644 %buildroot/%_datadir/videolan/qvlc16x16.png %buildroot/%{_miconsdir}/qvlc.png
197 install -m 644 %buildroot/%_datadir/videolan/qvlc32x32.png %buildroot/%{_iconsdir}/qvlc.png
198 install -m 644 %buildroot/%_datadir/videolan/qvlc48x48.png %buildroot/%{_liconsdir}/qvlc.png
199
200 %post
201 %update_menus
202 %postun
203 %update_menus
204
205 %clean
206 rm -fr %buildroot
207
208 %files
209 %defattr(-,root,root,-)
210 %doc README COPYING
211 %{_bindir}/vlc
212 %dir %{_libdir}/videolan/vlc
213 %{_libdir}/videolan/vlc/dsp.so
214 %{_libdir}/videolan/vlc/fb.so
215 %{_libdir}/videolan/vlc/x11.so
216 # ac3_spdif: AC3 decoder using SPDIF pass-through.
217 %{_libdir}/videolan/vlc/ac3_spdif.so
218 # spudec: DVD subtitles decoder.
219 %{_libdir}/videolan/vlc/spu_dec.so
220 # nothing useful for the moment.
221 #%dir %{_datadir}/videolan
222 #%{_datadir}/videolan/*
223 %{_mandir}/man1/*
224 %{_menudir}/vlc
225 %{_miconsdir}/vlc.png
226 %{_iconsdir}/vlc.png
227 %{_liconsdir}/vlc.png
228
229 %files gtk
230 %defattr(-,root,root)
231 %doc README
232 %{_libdir}/videolan/vlc/gtk.so
233 %{_bindir}/gvlc
234 %{_menudir}/vlc-gtk
235 %{_miconsdir}/gvlc.png
236 %{_iconsdir}/gvlc.png
237 %{_liconsdir}/gvlc.png
238 %post gtk
239 %update_menus
240 %postun gtk
241 %update_menus
242
243 %files gnome
244 %defattr(-,root,root)
245 %doc README
246 %{_libdir}/videolan/vlc/gnome.so
247 %{_bindir}/gnome-vlc
248 %{_menudir}/vlc-gnome
249 %{_miconsdir}/gnome-vlc.png
250 %{_iconsdir}/gnome-vlc.png
251 %{_liconsdir}/gnome-vlc.png
252 %post   gnome
253 %update_menus
254 %postun gnome
255 %update_menus
256
257 %if %{plugin_qt}
258 %files qt
259 %defattr(-,root,root)
260 %doc README
261 %{_libdir}/videolan/vlc/qt.so
262 %{_bindir}/qvlc
263 %{_menudir}/vlc-qt
264 %{_miconsdir}/qvlc.png
265 %{_iconsdir}/qvlc.png
266 %{_liconsdir}/qvlc.png
267 %post   qt
268 %update_menus
269 %postun qt
270 %update_menus
271 %endif
272
273 %files ncurses
274 %defattr(-,root,root)
275 %doc README
276 %{_libdir}/videolan/vlc/ncurses.so
277
278 %files sdl
279 %defattr(-,root,root)
280 %doc README
281 %{_libdir}/videolan/vlc/sdl.so
282
283 %files ggi
284 %defattr(-,root,root)
285 %doc README
286 %{_libdir}/videolan/vlc/ggi.so
287
288 %files esd
289 %defattr(-,root,root)
290 %doc README
291 %{_libdir}/videolan/vlc/esd.so
292
293 %if %{plugin_alsa}
294 %files alsa
295 %defattr(-,root,root)
296 %doc README
297 %{_libdir}/videolan/vlc/alsa.so
298 %endif
299
300 %changelog
301 * Thu Jan 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-2mdk
302 - readded libdvdcss rpm in specfile. use %%define css 1 with correct sources
303   to build libdvdcss rpm.
304
305 * Wed Jan 09 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-1mdk
306 - version 0.2.92
307 - %%makeinstall_std
308 - splitted again, added vlc-sdl vlc-esd vlc-ggi
309 - bring back some missing plugins
310 - fixed buildrequires
311 - added menu entries and icons (from cvs)
312
313 * Tue Oct 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-2mdk
314 - rebuild against libpng3
315 - added some doc for sir rpmlint
316 - #5583: option -g
317
318 * Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-1mdk
319 - version 0.2.83 : 
320   * Activated subtitles in overlay mode (far from perfect, but this
321     was an often requested feature).
322
323 * Fri Aug 10 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.82-1mdk
324 - version 0.2.82
325
326 * Mon Jul 30 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-1mdk
327 - version 0.2.81
328 - added vlc-ncurses
329
330 * Wed Jun 20 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-0.20010619-1mdk
331 - cvs snapshot
332 - added libdvdcss
333
334 * Wed Jun 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-2mdk
335 - fix build on ppc (c) dadou
336
337 * Mon Jun 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-1mdk
338 - version 0.2.80 : bug fixes and bug fixes and bug fixes and small
339   improvements of the gtk interface.
340 - corrected Summary in vlc-qt
341
342 * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-2mdk
343 - added qt2 plug-in (vlc-qt)
344
345 * Wed May 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-1mdk
346 - version 0.2.73
347 - you can now get decss threw a plug-in
348 - rewritte srcipt to build vlc (decss plugin)
349 - rebuild with SDL 1.2
350
351 * Thu Apr 26 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-2mdk
352 - true 0.2.72
353
354 * Mon Apr 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-1mdk
355 - version 0.2.72
356 - package split into vlc, vlc-gnome, vlc-gtk
357
358 * Fri Apr 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.71-1mdk
359 - version 0.2.71 :
360   * Fixed segfaults when compiled with gcc 3.0pre and versions of gcc
361     shipped with the latest RedHat distributions.                    
362   * Fixed the BeOS CSS decryption.
363   * Fixed a few issues in IFO parsing.
364   * Fixed XVideo video output.
365   * Updated icons under Linux, BeOS, MacOS X.
366
367 * Wed Apr 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.70-1mdk
368 - version 0.2.70
369
370 * Thu Mar 22 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.63-1mdk
371 - version 0.2.63 : Bugfixes, bugfixes, and bugfixes again, a Gtk+ 
372   interface for the Gnome-impaired, an even better DVD support
373
374 * Fri Feb 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.61-1mdk
375 - new version for all the DVD fans (add MPEG1 support, direct DVD support, 
376   DVD decryption, arbitrary, seeking in the stream, pause, fast forward 
377   and slow motion, hardware YUV acceleration enhanced CSS support and a few 
378   new interface features including drag'n'drop.
379 - first *real* public release (now under the GPL)
380
381 * Sat Jan 06 2001 David BAUDENS <baudens@mandrakesoft.com> 0.1.99i-2mdk
382 - Fix build and use right optimizations on PPC
383 - Enable SDL support
384 - Spec clean up
385
386 * Fri Jan  5 2001 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99i-1mdk
387 - 0.1.99i, rebuild
388
389 * Fri Aug 25 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99h-1mdk
390 - 0.1.99h
391
392 * Mon Jul 10 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99c-1mdk
393 - first Mandrake package with help of Sam