]> git.sesse.net Git - vlc/blob - vlc.spec
* ./vlc.spec: imported MandrakeSoft's enhancements.
[vlc] / vlc.spec
1 %define name            vlc
2 %define vlc_ver         0.3.0
3 %define version         %vlc_ver
4
5 %define cvs             0
6 %if %{cvs}
7 %define cvsdate         20010619
8 %define release         0.%{cvsdate}mdk
9 %define cvs_name        %{name}-snapshot-%{cvsdate}-00
10 %else
11 %define release         1mdk
12 %endif
13
14 %define plugin_qt       0
15 %define plugin_alsa     0
16
17 %define configflags     --enable-release \
18                         --enable-dvd --without-dvdcss \
19                         --enable-gtk --enable-gnome --enable-ncurses \
20                         --disable-qt --disable-kde --enable-ncurses \
21                         --enable-x11 --enable-xvideo --enable-sdl --enable-fb \
22                         --enable-ggi --enable-mga --enable-aa \
23                         --enable-esd --enable-alsa --enable-mad 
24
25 Summary:        VideoLAN is a free MPEG, MPEG2 and DVD software solution.
26 Name:           %{name}
27 Version:        %{version}
28 Release:        %{release}
29
30 %if %{cvs} 
31 Source0:        http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.gz
32 %else
33 Source0:        http://www.videolan.org/packages/%{version}/%{name}-%{version}.tar.gz
34 %endif
35 License:        GPL
36 Group:          Video
37 URL:            http://videolan.org/
38 BuildRoot:      %_tmppath/%name-%version-%release-root
39 Buildrequires:  libncurses5-devel
40 Buildrequires:  libqt2-devel
41 Buildrequires:  libgtk+1.2-devel
42 Buildrequires:  gnome-libs-devel
43 Buildrequires:  db1-devel
44 Buildrequires:  alsa-lib-devel
45 Buildrequires:  libggi-devel
46 Buildrequires:  aalib-devel
47 Buildrequires:  SDL-devel
48
49 %description
50 VideoLAN is a free network-aware MPEG and DVD player.
51 The VideoLAN Client allows to play MPEG2 Transport Streams from the
52 network or from a file, as well as direct DVD playback.
53 VideoLAN is a project of students from the Ecole Centrale Paris.
54 This version add MPEG1 support, direct DVD support, DVD decryption, 
55 arbitrary, seeking in the stream, pause, fast forward and slow motion, 
56 hardware YUV acceleration and a few new interface features 
57 including drag'n'drop.
58 You may install vlc-gnome, vlc-gtk and vlc-ncurses.
59 This package contains no CSS unscrambling functionality.
60 You need the libdvdcss library available from 
61 http://www.videolan.org/libdvdcss/ or http://plf.zarb.org/
62
63 # intf plugins
64 %package gtk
65 Summary: Gtk plug-in for VideoLAN, a DVD and MPEG2 player
66 Group: Video
67 Requires: %{name} = %{version}
68 %description gtk
69 The vlc-gtk package includes the Gtk plug-in for the VideoLAN client.
70 If you are going to watch DVD with the Gtk front-end, you should 
71 install vlc-gtk.
72
73 %package gnome
74 Summary: Gnome plug-in for VideoLAN, a DVD and MPEG2 player
75 Group: Video
76 Requires: %{name} = %{version}
77 %description gnome
78 The vlc-gnome package includes the Gnome plug-in for the VideoLAN client.
79 If you are going to watch DVD with the Gnome front-end, you should 
80 install vlc-gnome.
81
82 %package qt
83 Summary: Qt2 plug-in for VideoLAN, a DVD and MPEG2 player
84 Group: Video
85 Requires: %{name} = %{version}
86 %description qt
87 The vlc-qt package includes the Qt2 plug-in for the VideoLAN client.
88 If you are going to watch DVD with the Qt2 front-end, you should
89 install vlc-qt
90
91 %package ncurses
92 Summary: Ncurses console-based plug-in for VideoLAN, a DVD and MPEG2 player
93 Group: Video
94 Requires: %{name} = %{version}
95 %description ncurses
96 The vlc-ncurses package includes the ncurses plug-in for the VideoLAN client.
97 If you are going to watch DVD with the ncurses front-end, you should
98 install vlc-ncurses
99
100 # video plugins
101 %package aa
102 Summary: Ascii Art plug-in for VideoLAN, a DVD and MPEG2 player
103 Group: Video
104 Requires: %{name} = %{version}
105 %description aa
106 The vlc-aa package includes the Simple DirectMedia Layer plug-in 
107 for the VideoLAN client.
108 If you are going to watch DVD with the aa video plugin, you should
109 install vlc-aa
110
111 %package sdl
112 Summary: Simple DirectMedia Layer plug-in for VideoLAN, a DVD and MPEG2 player
113 Group: Video
114 Requires: %{name} = %{version}
115 %description sdl
116 The vlc-sdl package includes the Simple DirectMedia Layer plug-in 
117 for the VideoLAN client.
118 If you are going to watch DVD with the sdl video plugin, you should
119 install vlc-sdl
120
121 %package ggi
122 Summary: GGI plug-in for VideoLAN, a DVD and MPEG2 player
123 Group: Video
124 Requires: %{name} = %{version}
125 %description ggi
126 The vlc-ggi package includes the GGI plug-in for the VideoLAN client.
127 If you are going to watch DVD with the GGI video plugin, you should
128 install vlc-ggi
129
130 # audio plugins
131 %package mad
132 Summary: MAD plug-in for VideoLAN, a DVD and MPEG2 player
133 Group: Video
134 Requires: %{name} = %{version}
135 %description mad
136 The vlc-mad package includes the MAD (MPEG Audio Decoder) plug-in
137 for the VideoLAN client.
138 If you are going to watch DVD with the mad audio plugin, you should
139 install vlc-mad
140
141 %package esd
142 Summary: Enlightened Sound Daemon plug-in for VideoLAN, a DVD and MPEG2 player
143 Group: Video
144 Requires: %{name} = %{version}
145 %description esd
146 The vlc-esd packages includes the Enlightened Sound Daemon plug-in 
147 for the VideoLAN client.
148 If you are going to watch DVD with the esd audio plugin, you should
149 install vlc-esd
150
151 %package alsa
152 Summary: Advanced Linux Sound Architecture plug-in for VideoLAN, a DVD and Mpeg-2 player
153 Group: Video
154 Requires: %{name} = %{version}
155 %description alsa
156 The vlc-alsa packages includes the Advanced Linux Sound Architecture plug-in 
157 for the VideoLAN client.
158 If you are going to watch DVD with the ALSA audio plugin, you should 
159 install vlc-alsa
160
161 %prep
162 %if %{cvs}
163 %setup -q -n %{cvs_name}
164 %else
165 %setup -q -n %{name}-%{vlc_ver}
166 %endif
167
168 %build
169 %ifarch ppc
170 # Dadou - 0.1.99h-mdk - Don't use configure here. It breaks build at present
171 #                       time.
172 ./configure %{configflags}
173 perl -pi -e "s|CFLAGS \+= -mcpu=604e|#CFLAGS \+= -mcpu=604e|" Makefile
174 perl -pi -e "s|#CFLAGS \+= -mcpu=750|CFLAGS \+= -mcpu=750 -mtune=750|" Makefile
175 %else
176 %configure %{configflags}
177 %endif
178 export QTDIR=%{_libdir}/qt2 
179 %make
180
181 %install
182 %makeinstall_std
183 install -d %buildroot/%_mandir/man1
184 install doc/vlc.1 %buildroot/%_mandir/man1
185
186 # menu
187 mkdir -p %buildroot/%{_menudir}
188 cat > %buildroot/%{_menudir}/vlc << EOF
189 ?package(vlc): command="%{_bindir}/vlc" hotkey="V" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="VideoLAN Client" icon="vlc.png" hints="Video"
190 EOF
191 cat > %buildroot/%{_menudir}/vlc-gtk << EOF
192 ?package(vlc-gtk): command="%{_bindir}/gvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gtk VideoLAN Client" icon="gvlc.png" hints="Video"
193 EOF
194 cat > %buildroot/%{_menudir}/vlc-gnome << EOF
195 ?package(vlc-gnome): command="%{_bindir}/gnome-vlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gnome VideoLAN Client" icon="gnome-vlc.png" hints="Video"
196 EOF
197 cat > %buildroot/%{_menudir}/vlc-qt << EOF
198 ?package(vlc-gnome): command="%{_bindir}/qvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Qt VideoLAN Client" icon="qvlc.png" hints="Video"
199 EOF
200
201 # icons
202 mkdir -p %{buildroot}/{%{_miconsdir},%{_liconsdir}}
203 install -m 644 %buildroot/%_datadir/videolan/vlc16x16.png %buildroot/%{_miconsdir}/vlc.png
204 install -m 644 %buildroot/%_datadir/videolan/vlc32x32.png %buildroot/%{_iconsdir}/vlc.png
205 install -m 644 %buildroot/%_datadir/videolan/vlc48x48.png %buildroot/%{_liconsdir}/vlc.png
206 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc16x16.png %buildroot/%{_miconsdir}/gnome-vlc.png
207 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc32x32.png %buildroot/%{_iconsdir}/gnome-vlc.png
208 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc48x48.png %buildroot/%{_liconsdir}/gnome-vlc.png
209 install -m 644 %buildroot/%_datadir/videolan/gvlc16x16.png %buildroot/%{_miconsdir}/gvlc.png
210 install -m 644 %buildroot/%_datadir/videolan/gvlc32x32.png %buildroot/%{_iconsdir}/gvlc.png
211 install -m 644 %buildroot/%_datadir/videolan/gvlc48x48.png %buildroot/%{_liconsdir}/gvlc.png
212 install -m 644 %buildroot/%_datadir/videolan/kvlc16x16.png %buildroot/%{_miconsdir}/kvlc.png
213 install -m 644 %buildroot/%_datadir/videolan/kvlc32x32.png %buildroot/%{_iconsdir}/kvlc.png
214 install -m 644 %buildroot/%_datadir/videolan/kvlc48x48.png %buildroot/%{_liconsdir}/kvlc.png
215 install -m 644 %buildroot/%_datadir/videolan/qvlc16x16.png %buildroot/%{_miconsdir}/qvlc.png
216 install -m 644 %buildroot/%_datadir/videolan/qvlc32x32.png %buildroot/%{_iconsdir}/qvlc.png
217 install -m 644 %buildroot/%_datadir/videolan/qvlc48x48.png %buildroot/%{_liconsdir}/qvlc.png
218
219 %post
220 %update_menus
221 %postun
222 %update_menus
223
224 %clean
225 rm -fr %buildroot
226
227 %files
228 %defattr(-,root,root)
229 %doc README COPYING
230 %{_bindir}/vlc
231
232 %dir %{_libdir}/videolan/vlc
233 %{_libdir}/videolan/vlc/ac3_spdif.so
234 %{_libdir}/videolan/vlc/dsp.so
235 %{_libdir}/videolan/vlc/dummy.so
236 %{_libdir}/videolan/vlc/dvd.so
237 %{_libdir}/videolan/vlc/fb.so
238 %{_libdir}/videolan/vlc/file.so
239 %{_libdir}/videolan/vlc/filter_deinterlace.so
240 %{_libdir}/videolan/vlc/filter_distort.so
241 %{_libdir}/videolan/vlc/filter_invert.so
242 %{_libdir}/videolan/vlc/filter_transform.so
243 %{_libdir}/videolan/vlc/filter_wall.so
244 %{_libdir}/videolan/vlc/fx_scope.so
245 %{_libdir}/videolan/vlc/http.so
246 %{_libdir}/videolan/vlc/ipv4.so
247 %{_libdir}/videolan/vlc/ipv6.so
248 %{_libdir}/videolan/vlc/logger.so
249 %{_libdir}/videolan/vlc/lpcm_adec.so
250 %{_libdir}/videolan/vlc/memcpy.so
251 %{_libdir}/videolan/vlc/mga.so
252 %{_libdir}/videolan/vlc/mpeg_es.so
253 %{_libdir}/videolan/vlc/mpeg_ps.so
254 %{_libdir}/videolan/vlc/mpeg_ts.so
255 %{_libdir}/videolan/vlc/null.so
256 %{_libdir}/videolan/vlc/rc.so
257 %{_libdir}/videolan/vlc/spudec.so
258 %{_libdir}/videolan/vlc/udp.so
259 %{_libdir}/videolan/vlc/vcd.so
260 %{_libdir}/videolan/vlc/x11.so
261 %{_libdir}/videolan/vlc/xmga.so
262
263 %{_mandir}/man1/*
264 %{_menudir}/vlc
265 %{_miconsdir}/vlc.png
266 %{_iconsdir}/vlc.png
267 %{_liconsdir}/vlc.png
268
269
270 # intf plugins
271 %files gtk
272 %defattr(-,root,root)
273 %doc README
274 %{_libdir}/videolan/vlc/gtk.so
275 %{_bindir}/gvlc
276 %{_menudir}/vlc-gtk
277 %{_miconsdir}/gvlc.png
278 %{_iconsdir}/gvlc.png
279 %{_liconsdir}/gvlc.png
280 %post gtk
281 %update_menus
282 %postun gtk
283 %update_menus
284
285 %files gnome
286 %defattr(-,root,root)
287 %doc README
288 %{_libdir}/videolan/vlc/gnome.so
289 %{_bindir}/gnome-vlc
290 %{_menudir}/vlc-gnome
291 %{_miconsdir}/gnome-vlc.png
292 %{_iconsdir}/gnome-vlc.png
293 %{_liconsdir}/gnome-vlc.png
294 %post   gnome
295 %update_menus
296 %postun gnome
297 %update_menus
298
299 %if %{plugin_qt}
300 %files qt
301 %defattr(-,root,root)
302 %doc README
303 %{_libdir}/videolan/vlc/qt.so
304 %{_bindir}/qvlc
305 %{_menudir}/vlc-qt
306 %{_miconsdir}/qvlc.png
307 %{_iconsdir}/qvlc.png
308 %{_liconsdir}/qvlc.png
309 %post   qt
310 %update_menus
311 %postun qt
312 %update_menus
313 %endif
314
315 %files ncurses
316 %defattr(-,root,root)
317 %doc README
318 %{_libdir}/videolan/vlc/ncurses.so
319
320 # video plugins
321 %files sdl
322 %defattr(-,root,root)
323 %doc README
324 %{_libdir}/videolan/vlc/sdl.so
325
326 %files ggi
327 %defattr(-,root,root)
328 %doc README
329 %{_libdir}/videolan/vlc/ggi.so
330
331 %files aa
332 %defattr(-,root,root)
333 %doc README
334 %{_libdir}/videolan/vlc/aa.so
335
336 #audio plugins
337 %files mad
338 %defattr(-,root,root)
339 %doc README
340 %{_libdir}/videolan/vlc/mad.so
341
342 %files esd
343 %defattr(-,root,root)
344 %doc README
345 %{_libdir}/videolan/vlc/esd.so
346
347 %if %{plugin_alsa}
348 %files alsa
349 %defattr(-,root,root)
350 %doc README
351 %{_libdir}/videolan/vlc/alsa.so
352 %endif
353
354 %changelog
355 * Sun Apr 07 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-1mdk
356 - added aa (ASCII Art) plugin in vlc-aa rpm
357 - merged with sam's one:
358   * using his plugins list into %%files
359   * removed libdvdcss from the whole tarball.
360   * removed the workaround for vlc's bad /dev/dsp detection.
361 - few spelling corrections in all %%description
362 - added buildrequires on SDL-devel
363
364 * Thu Apr 06 2002 Samuel Hocevar <sam@zoy.org> 0.3.0
365 - version 0.3.0.
366 - removed libdvdcss from the whole tarball.
367 - removed the workaround for vlc's bad /dev/dsp detection.
368
369 * Tue Mar 05 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.93-0.1mdk
370 - new cvs snapshot
371 - fix requires
372
373 * Mon Mar 04 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-5mdk
374 - cvs snapshot
375
376 * Sat Jan 26 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-4mdk
377 - mad plugin in vlc-mad rpm
378
379 * Mon Jan 21 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-3mdk
380 - synced with main cvs specfile wich "fixed a few minor inaccuracies"
381
382 * Thu Jan 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-2mdk
383 - readded libdvdcss rpm in specfile. use %%define css 1 with correct sources
384   to build libdvdcss rpm.
385
386 * Wed Jan 09 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-1mdk
387 - version 0.2.92
388 - %%makeinstall_std
389 - splitted again, added vlc-sdl vlc-esd vlc-ggi
390 - bring back some missing plugins
391 - fixed buildrequires
392 - added menu entries and icons (from cvs)
393
394 * Tue Oct 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-2mdk
395 - rebuild against libpng3
396 - added some doc for sir rpmlint
397 - #5583: option -g
398
399 * Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-1mdk
400 - version 0.2.83 : 
401   * Activated subtitles in overlay mode (far from perfect, but this
402     was an often requested feature).
403
404 * Fri Aug 10 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.82-1mdk
405 - version 0.2.82
406
407 * Mon Jul 30 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-1mdk
408 - version 0.2.81
409 - added vlc-ncurses
410
411 * Wed Jun 20 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-0.20010619-1mdk
412 - cvs snapshot
413 - added libdvdcss
414
415 * Wed Jun 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-2mdk
416 - fix build on ppc (c) dadou
417
418 * Mon Jun 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-1mdk
419 - version 0.2.80 : bug fixes and bug fixes and bug fixes and small
420   improvements of the gtk interface.
421 - corrected Summary in vlc-qt
422
423 * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-2mdk
424 - added qt2 plug-in (vlc-qt)
425
426 * Wed May 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-1mdk
427 - version 0.2.73
428 - you can now get decss threw a plug-in
429 - rewritte srcipt to build vlc (decss plugin)
430 - rebuild with SDL 1.2
431
432 * Thu Apr 26 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-2mdk
433 - true 0.2.72
434
435 * Mon Apr 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-1mdk
436 - version 0.2.72
437 - package split into vlc, vlc-gnome, vlc-gtk
438
439 * Fri Apr 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.71-1mdk
440 - version 0.2.71 :
441   * Fixed segfaults when compiled with gcc 3.0pre and versions of gcc
442     shipped with the latest RedHat distributions.                    
443   * Fixed the BeOS CSS decryption.
444   * Fixed a few issues in IFO parsing.
445   * Fixed XVideo video output.
446   * Updated icons under Linux, BeOS, MacOS X.
447
448 * Wed Apr 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.70-1mdk
449 - version 0.2.70
450
451 * Thu Mar 22 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.63-1mdk
452 - version 0.2.63 : Bugfixes, bugfixes, and bugfixes again, a Gtk+ 
453   interface for the Gnome-impaired, an even better DVD support
454
455 * Fri Feb 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.61-1mdk
456 - new version for all the DVD fans (add MPEG1 support, direct DVD support, 
457   DVD decryption, arbitrary, seeking in the stream, pause, fast forward 
458   and slow motion, hardware YUV acceleration enhanced CSS support and a few 
459   new interface features including drag'n'drop.
460 - first *real* public release (now under the GPL)
461
462 * Sat Jan 06 2001 David BAUDENS <baudens@mandrakesoft.com> 0.1.99i-2mdk
463 - Fix build and use right optimizations on PPC
464 - Enable SDL support
465 - Spec clean up
466
467 * Fri Jan  5 2001 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99i-1mdk
468 - 0.1.99i, rebuild
469
470 * Fri Aug 25 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99h-1mdk
471 - 0.1.99h
472
473 * Mon Jul 10 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99c-1mdk
474 - first Mandrake package with help of Sam