]> git.sesse.net Git - vlc/blob - vlc.spec
- Update to 0.7.0-test1
[vlc] / vlc.spec
1 %define mozver 1.4.1
2
3 Summary: The VideoLAN client, also a very good standalone video player.
4 Name: vlc
5 Version: 0.7.0
6 Release: test1
7 Group: Applications/Multimedia
8 License: GPL
9 URL: http://www.videolan.org/
10 Source: http://www.videolan.org/pub/videolan/vlc/vlc-%{version}-%{release}.tar.bz2
11 Buildroot: %{_tmppath}/%{name}-root
12 Packager: Jason Luka <jason@geshp.com>
13 Buildrequires: XFree86-devel, desktop-file-utils, libpostproc >= 1.0
14 %{!?_without_dvd:Buildrequires: libdvdcss-devel >= 1.2.8}
15 %{!?_without_dvdread:Buildrequires: libdvdread-devel >= 0.9.4}
16 %{!?_without_dvdplay:Buildrequires: libdvdplay-devel >= 1.0.1}
17 %{!?_without_dvbpsi:Buildrequires: libdvbpsi-devel >= 0.1.3}
18 %{!?_without_ogg:Buildrequires: libogg-devel}
19 %{!?_without_mad:Buildrequires: libmad-devel >= 0.15.0b}
20 %{!?_without_ffmpeg:Buildrequires: ffmpeg-devel}
21 %{!?_without_xvid:Buildrequires: xvidcore-devel >= 0.9.2}
22 %{!?_without_a52:Buildrequires: a52dec-devel}
23 %{!?_without_dv:Buildrequires: libdv-devel >= 0.99}
24 %{!?_without_flac:Buildrequires: flac-devel >= 1.1.0}
25 %{!?_without_vorbis:Buildrequires: libvorbis-devel}
26 %{!?_without_sdl:Buildrequires: SDL-devel}
27 %{!?_without_aa:Buildrequires: aalib-devel}
28 %{!?_without_esd:Buildrequires: esound-devel}
29 %{!?_without_arts:Buildrequires: arts-devel}
30 #%%{!?_without_alsa:Buildrequires: alsa-lib-devel}
31 %{!?_without_gtk:Buildrequires: gtk+-devel}
32 %{!?_without_gnome:Buildrequires: gnome-libs-devel}
33 %{!?_without_lirc:Buildrequires: lirc}
34 %{!?_without_qt:Buildrequires: qt-devel}
35 %{!?_without_kde:Buildrequires: kdelibs-devel}
36 %{!?_without_ncurses:Buildrequires: ncurses-devel >= 5}
37 %{!?_without_xosd:Buildrequires: xosd-devel >= 2.2.5}
38 %{!?_without_id3tag:BuildRequires: libid3tag-devel}
39 %{!?_without_mpeg2dec:BuildRequires: mpeg2dec-devel >= 0.3.2}
40 %{!?_without_wxwindows:BuildRequires: wxGTK-devel >= 2.4.2}
41 %{!?_without_mozilla:BuildRequires: mozilla-devel >= %{mozver}}
42 %{!?_without_speex:BuildRequires: speex-devel >= 1.0.3}
43 %{!?_without_aa:BuildRequires: aalib >= 1.4}
44
45 Obsoletes: videolan-client
46
47 Requires: XFree86, desktop-file-utils
48 %{!?_without_dvd:Requires: libdvdcss >= 1.2.8}
49 %{!?_without_dvdread:Requires: libdvdread >= 0.9.4}
50 %{!?_without_dvdplay:Requires: libdvdplay >= 1.0.1}
51 %{!?_without_dvbpsi:Requires: libdvbpsi >= 0.1.3}
52 %{!?_without_ogg:Requires: libogg}
53 %{!?_without_mad:Requires: libmad >= 0.15.0b}
54 %{!?_without_ffmpeg:Requires: ffmpeg}
55 %{!?_without_xvid:Requires: xvidcore >= 0.9.2}
56 %{!?_without_a52:Requires: a52dec}
57 %{!?_without_dv:Requires: libdv >= 0.99}
58 %{!?_without_flac:Requires: flac >= 1.1.0}
59 %{!?_without_vorbis:Requires: libvorbis}
60 %{!?_without_sdl:Requires: SDL}
61 %{!?_without_aa:Requires: aalib >= 1.4}
62 %{!?_without_esd:Requires: esound}
63 %{!?_without_arts:Requires: arts}
64 #%%{!?_without_alsa:Requires: alsa-lib}
65 %{!?_without_gtk:Requires: gtk+}
66 %{!?_without_gnome:Requires: gnome-libs}
67 %{?_with_qt:Requires: qt}
68 %{?_with_kde:Requires: kdelibs}
69 %{?_with_ncurses:Requires: ncurses}
70 %{!?_without_xosd:Requires: xosd >= 2.2.5}
71 %{!?_without_lirc:Requires: lirc}
72 %{!?_without_mozilla:Requires: mozilla = %{mozver}}
73 %{!?_without_speex:Requires: speex >= 1.0.3}
74 %{!?_without_wxwindows:Requires: wxGTK >= 2.4.2}
75
76 %description
77 VideoLAN Client (VLC) is a highly portable multimedia player for various
78 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
79 well as DVDs, VCDs, and various streaming protocols.
80
81 Available rpmbuild rebuild options :
82 --without dvd dvdread dvdplay dvbpsi dv v4l avi asf aac ogg rawdv mad ffmpeg xvid
83           mp4 a52 vorbis mpeg2dec flac aa esd arts alsa gtk gnome xosd lsp lirc
84           pth id3tag dv qt kde ncurses faad wxwindows
85
86 Options that would need not yet existing add-on packages :
87 --with tremor tarkin theora ggi glide svgalib mga
88
89
90 %package devel
91 Summary: Header files and static library from the Videolan Client.
92 Group: Development/Libraries
93 Requires: %{name} = %{version}
94
95 %description devel
96 VideoLAN Client (VLC) is a highly portable multimedia player for various
97 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
98 well as DVDs, VCDs, and various streaming protocols.
99
100 Install this package if you need to build Videolan Client plugins or intend
101 to link statically to it.
102
103
104 %prep
105 %setup -q -n vlc-%{version}-%{release}
106
107 %build
108 #cp %{_libdir}/mozilla/plugins/plugger.so %{_libdir}/mozilla-%{mozver}/plugins/plugger.so.bak -f
109 #mv %{_libdir}/mozilla-%{mozver}/plugins/plugger.so.bak %{_libdir}/mozilla-%{mozver}/plugins/plugger.so -f
110 #rm %{_libdir}/mozilla -fr
111 #ln %{_libdir}/mozilla-%{mozver} %{_libdir}/mozilla -sf
112 ln /usr/share/idl/mozilla-%{mozver} /usr/share/idl/mozilla -sf
113 #ln %{_libdir}/libxvidcore.so.2 %{_libdir}/libxvidcore.so -sf
114
115 %configure \
116         --enable-release \
117         %{?_without_dvd:--disable-dvd} \
118         %{!?_without_dvdread:--enable-dvdread} \
119         %{!?_without_dvdplay:--enable-dvdplay} \
120         %{!?_without_dvbpsi:--enable-dvbpsi} \
121         %{!?_without_v4l:--enable-v4l} \
122         --enable-vcd \
123         %{?_without_avi:--disable-avi} \
124         %{?_without_asf:--disable-asf} \
125         %{?_without_aac:--disable-aac} \
126         %{?_without_ogg:--disable-ogg} \
127         %{?_without_rawdv:--disable-rawdv} \
128         %{!?_without_mad:--enable-mad} \
129         %{!?_without_ffmpeg:--enable-pp --enable-ffmpeg --with-ffmpeg=%{_prefix}} \
130         %{!?_without_faad:--enable-faad} \
131         %{!?_without_xvid:--enable-xvid} \
132         %{?_without_mp4:--disable-mp4} \
133         %{?_without_a52:--disable-a52} \
134         %{?_without_cinepak:--disable-cinepak} \
135         %{!?_without_dv:--enable-dv} \
136         %{!?_without_flac:--enable-flac} \
137         %{?_without_mpeg2dec:--disable-libmpeg2} \
138         %{?_without_vorbis:--disable-vorbis} \
139         %{?_with_tremor:--enable-tremor} \
140         %{?_with_tarkin:--enable-tarkin} \
141         %{!?_without_theora:--enable-theora} \
142         --enable-x11 \
143         --enable-xvideo \
144         %{?_without_sdl:--disable-sdl} \
145         --disable-qte \
146         --disable-directx \
147         --enable-fb \
148         %{?_with_mga:--enable-mga} \
149         %{?_with_svgalib:--enable-svgalib} \
150         %{?_with_ggi:--enable-ggi} \
151         %{?_with_glide:--enable-glide} \
152         %{!?_without_aa:--enable-aa} \
153         --without-wingdi \
154         --enable-oss \
155         %{!?_without_esd:--enable-esd} \
156         %{!?_without_arts:--enable-arts} \
157         %{?_with_alsa:--enable-alsa} \
158         --disable-waveout \
159         %{!?_without_gtk:--enable-gtk} \
160         --disable-familiar \
161         %{!?_without_gnome:--enable-gnome} \
162         %{?_without_wxwindows:--disable-wxwindows} \
163         %{!?_without_qt:--enable-qt} \
164         %{!?_without_kde:--enable-kde} \
165         --disable-opie \
166         --disable-macosx \
167         --disable-qnx \
168         --disable-intfwin \
169         %{!?_without_ncurses:--enable-ncurses} \
170         %{!?_without_xosd:--enable-xosd} \
171         %{?_without_slp:--disable-slp} \
172         %{!?_without_lirc:--enable-lirc} \
173         %{!?_without_pth:--enable-pth} \
174         --disable-st \
175         %{!?_without_mozilla:--enable-mozilla} \
176         %{?_without_speex:--disable-speex} \
177         --disable-testsuite \
178         --enable-plugins
179 make %{?_smp_mflags}
180
181 %install
182 rm -rf %{buildroot}
183 %makeinstall
184 find  %{buildroot}%{_libdir}/vlc -name "*.so" | xargs strip
185 %find_lang vlc
186
187 cat > %{name}.desktop << EOF
188 [Desktop Entry]
189 Name=VideoLAN Media Player
190 Comment=%{summary}
191 Icon=%{_datadir}/vlc/vlc48x48.png
192 Exec=vlc
193 Terminal=0
194 Type=Application
195 EOF
196
197 mv %{buildroot}%{_libdir}/mozilla %{buildroot}%{_libdir}/mozilla-%{mozver} -f
198
199 mkdir -p %{buildroot}%{_datadir}/applications
200 desktop-file-install --vendor gnome --delete-original             \
201   --dir %{buildroot}%{_datadir}/applications                      \
202   --add-category X-Red-Hat-Base                                   \
203   --add-category Application                                      \
204   --add-category AudioVideo                                       \
205   %{name}.desktop
206
207 %post
208 ln /dev/cdrom /dev/dvd -sf
209 ln %{_libdir}/libxvidcore.so.2 %{_libdir}/libxvidcore.so -sf
210
211 %postun
212 rm -f /dev/dvd
213 rm /usr/share/idl/mozilla -fr
214 rm %{_libdir}/libxvidcore.so -f
215
216 %clean
217 rm -rf %{buildroot}
218 rm /usr/share/idl/mozilla -fr
219 #rm /usr/lib/mozilla -fr
220 #mkdir /usr/lib/mozilla/plugins -p --mode=755
221 #mv %{_libdir}/mozilla-%{mozver}/plugins/plugger.so %{_libdir}/mozilla/plugins -f
222 #rm %{_libdir}/libxvidcore.so -f
223
224 %files -f vlc.lang
225 %defattr(-, root, root)
226 %doc AUTHORS COPYING ChangeLog MAINTAINERS README THANKS
227 %doc doc/fortunes.txt doc/web-streaming.html
228 %{_bindir}/*vlc
229 %{_libdir}/vlc
230 %{_libdir}/libvlc_pic.a
231 %{_libdir}/mozilla-%{mozver}/components/vlcintf.xpt
232 %{_libdir}/mozilla-%{mozver}/plugins/libvlcplugin.so
233 %{_datadir}/applications/gnome-%{name}.desktop
234 %{_datadir}/vlc
235
236 %files devel
237 %defattr(-, root, root)
238 %doc HACKING 
239 %{_bindir}/vlc-config
240 %{_includedir}/vlc
241 %{_libdir}/libvlc.a
242
243 %changelog
244 * Fri Nov 28 2003 Jason Luka
245 - Update to 0.7.0-test1
246 - Updated version numbers on dependancies
247 - Removed ALSA support until RH/FC turns to kernel 2.6
248 - Added --enable-speex and --enable-pp
249 - Mozilla plugin now built for 1.4.1
250 - Currently broken (Matroska/EBML problems)
251
252 * Mon Aug 25 2003 Jason Luka
253 - Added matroska support
254 - Corrected some symlinking problems with the mozilla plugin
255
256 * Fri Aug 22 2003 Jason Luka <jason@geshp.com>
257 - Update to 0.6.2
258 - Changed menu item name to VideoLAN Media Player
259 - Added openslp support
260 - Added libtar support (needed for skins)
261 - Added symlink to libxvidcore.so, thanks to new version of that software
262
263 * Fri Aug 1 2003 Jason Luka <jason@geshp.com>
264 - Update to 0.6.1
265 - Fixed file structure problems I created to accomodate the mozilla plugin
266 - Changed vendor name for desktop install
267 - Moved vlc to base menu
268 - Moved plugins from /usr/lib/mozilla to /usr/lib/mozilla-x.x.x
269 - Added custom patch to accomodate mozilla plugin
270 - Added execution of bootstrap since Makefile.am was altered
271
272 * Tue Jul 8 2003 Jason Luka <jason@geshp.com>
273 - Update to 0.6.0
274 - Add id3lib, dv, faad, qt, kde, and mozilla plugin support
275 - Added script to symlink mozilla-1.2.1 directories to mozilla so build can complete
276
277 * Sat Apr 5 2003 Jason Luka <jason@geshp.com>
278 - Rebuilt for Red Hat 9
279 - Changed dependencies for ffmpeg's new name
280 - Required lirc support at build-time 
281
282 * Sat Mar 25 2003 Jason Luka <jason@geshp.com>
283 - Fixed Buildrequire statements to require all plugins at compile-time
284 - Fixed Require statements so users don't have to install every plugin
285
286 * Thu Mar 23 2003 Jason Luka <jason@geshp.com>
287 - Renamed ffmpeg to libffmpeg
288 - Rebuilt for videolan site
289 - Autolinked /dev/dvd to /dev/cdrom
290
291 * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
292 - Update to 0.5.2.
293 - Fix the dv build dependency, thanks to Alan Hagge.
294 - Added flac support.
295 - Fixed the libdvbpsi requirements.
296
297 * Mon Feb 24 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
298 - Rebuilt against the new xosd lib.
299
300 * Wed Feb 19 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
301 - Update to 0.5.1.
302 - Major spec file update.
303
304 * Fri Nov 15 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
305 - Update to 0.4.6.
306
307 * Tue Oct 22 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
308 - Update to 0.4.5.
309 - Minor --with / --without adjustments.
310
311 * Sun Oct  6 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
312 - Rebuilt for Red Hat Linux 8.0.
313 - New menu entry.
314 - Added all --without options and --with qt.
315
316 * Mon Aug 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
317 - Update to 0.4.4.
318
319 * Fri Jul 26 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
320 - Update to 0.4.3.
321
322 * Fri Jul 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
323 - Update to 0.4.2.
324
325 * Wed Jun  5 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
326 - Update to 0.4.1.
327
328 * Fri May 24 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
329 - Update to 0.4.0.
330 - Disabled qt interface, it's hell to build with qt2/3!
331 - Use %%find_lang and %%{?_smp_mflags}.
332
333 * Fri Apr 19 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
334 - Update to 0.3.1.
335
336 * Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
337 - Update to 0.3.0.
338
339 * Sat Jan 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
340 - Removed the dependency on libdvdcss package, use the built in one instead,
341   because 1.x.x is not as good as 0.0.3.ogle3.
342
343 * Tue Jan  1 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
344 - Update to 0.2.92.
345 - Build fails with libdvdcss < 1.0.1.
346
347 * Tue Nov 13 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
348 - Update to 0.2.91 and now requires libdvdcss 1.0.0.
349
350 * Mon Oct 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
351 - Split libdvdcss into a separate package since it's also needed by the
352   xine menu plugin.
353
354 * Thu Oct 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
355 - Updated to 0.2.90.
356 - Removed ggi, svgalib and aalib since they aren't included in Red Hat 7.2.
357
358 * Mon Aug 27 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
359 - Updated to 0.2.83.
360
361 * Sat Aug 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
362 - Updated to 0.2.82.
363
364 * Mon Jul 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
365 - Updated to 0.2.81.
366 - Added all the new split libdvdcss.* files to the %%files section.
367
368 * Tue Jun  5 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
369 - Updated to the latest release, 0.2.80.
370
371 * Wed May 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
372 - Updated to today's CVS version, works great! :-)
373 - Fixed the desktop menu entry.
374
375 * Tue May 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
376 - Spec file cleanup to make it look more like others do.
377 - Added the use of many macros.
378 - Disabled automatic requires and provides (the package always needed qt,
379   gtk+, gnome etc. otherwise).
380 - Added a system desktop menu entry.
381
382 * Mon Apr 30 2001 Arnaud Gomes-do-Vale <arnaud@glou.org>
383 Added relocation support and compile fixes for Red Hat 7.x.
384
385 * Sat Apr 28 2001 Henri Fallon <henri@videolan.org>
386 New upstream release (0.2.73)
387
388 * Mon Apr 16 2001 Samuel Hocevar <sam@zoy.org>
389 New upstream release (0.2.72)
390
391 * Fri Apr 13 2001 Samuel Hocevar <sam@zoy.org>
392 New upstream release (0.2.71)
393
394 * Sun Apr 8 2001 Christophe Massiot <massiot@via.ecp.fr>
395 New upstream release (0.2.70)
396
397 * Fri Feb 16 2001 Samuel Hocevar <sam@via.ecp.fr>
398 New upstream release
399
400 * Tue Aug  8 2000 Samuel Hocevar <sam@via.ecp.fr>
401 Added framebuffer support
402
403 * Sun Jun 18 2000 Samuel Hocevar <sam@via.ecp.fr>
404 Took over the package
405
406 * Thu Jun 15 2000 Eric Doutreleau <Eric.Doutreleau@int-evry.fr>
407 Initial package
408