]> git.sesse.net Git - vlc/blob - vlc.spec
* ./vlc.spec: fixed build dependencies.
[vlc] / vlc.spec
1 %define name            vlc
2 %define vlc_ver         0.3.1
3 %define version         %vlc_ver
4
5 %define cvs             0
6 %if %{cvs}
7 %define cvsdate         20010619
8 %define release         0.%{cvsdate}mdk
9 %define cvs_name        %{name}-snapshot-%{cvsdate}-00
10 %else
11 %define release         1mdk
12 %endif
13
14 %define plugin_qt       0
15
16 Summary:        VideoLAN is a free MPEG, MPEG2 and DVD software solution.
17 Name:           %{name}
18 Version:        %{version}
19 Release:        %{release}
20 Packager:       Samuel Hocevar <sam@zoy.org>
21
22 %if %{cvs} 
23 Source0:        http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.gz
24 %else
25 Source0:        http://www.videolan.org/packages/%{version}/%{name}-%{version}.tar.gz
26 %endif
27 License:        GPL
28 Group:          Video
29 URL:            http://videolan.org/
30 BuildRoot:      %_tmppath/%name-%version-%release-root
31 Buildrequires:  libncurses5-devel
32 Buildrequires:  libqt2-devel
33 Buildrequires:  libgtk+1.2-devel
34 Buildrequires:  gnome-libs-devel
35 Buildrequires:  db1-devel
36 Buildrequires:  alsa-lib-devel
37 Buildrequires:  libarts-devel
38 Buildrequires:  libggi-devel
39 Buildrequires:  aalib-devel
40 Buildrequires:  SDL-devel
41 Buildrequires:  liba52dec-devel
42 Buildrequires:  libmad-devel
43
44 %description
45 VideoLAN is a free network-aware MPEG and DVD player.
46 The VideoLAN Client allows to play MPEG2 Transport Streams from the
47 network or from a file, as well as direct DVD playback.
48 VideoLAN is a project of students from the Ecole Centrale Paris.
49 This version add MPEG1 support, direct DVD support, DVD decryption, 
50 arbitrary, seeking in the stream, pause, fast forward and slow motion, 
51 hardware YUV acceleration and a few new interface features 
52 including drag'n'drop.
53 You may install vlc-gnome, vlc-gtk and vlc-ncurses.
54 This package contains no CSS unscrambling functionality.
55 You need the libdvdcss library available from 
56 http://www.videolan.org/libdvdcss/ or http://plf.zarb.org/
57
58 # intf plugins
59 %package gtk
60 Summary: Gtk plug-in for VideoLAN, a DVD and MPEG2 player
61 Group: Video
62 Requires: %{name} = %{version}
63 %description gtk
64 The vlc-gtk package includes the Gtk plug-in for the VideoLAN client.
65 If you are going to watch DVD with the Gtk front-end, you should 
66 install vlc-gtk.
67
68 %package gnome
69 Summary: Gnome plug-in for VideoLAN, a DVD and MPEG2 player
70 Group: Video
71 Requires: %{name} = %{version}
72 %description gnome
73 The vlc-gnome package includes the Gnome plug-in for the VideoLAN client.
74 If you are going to watch DVD with the Gnome front-end, you should 
75 install vlc-gnome.
76
77 %package qt
78 Summary: Qt2 plug-in for VideoLAN, a DVD and MPEG2 player
79 Group: Video
80 Requires: %{name} = %{version}
81 %description qt
82 The vlc-qt package includes the Qt2 plug-in for the VideoLAN client.
83 If you are going to watch DVD with the Qt2 front-end, you should
84 install vlc-qt
85
86 %package ncurses
87 Summary: Ncurses console-based plug-in for VideoLAN, a DVD and MPEG2 player
88 Group: Video
89 Requires: %{name} = %{version}
90 %description ncurses
91 The vlc-ncurses package includes the ncurses plug-in for the VideoLAN client.
92 If you are going to watch DVD with the ncurses front-end, you should
93 install vlc-ncurses
94
95 # video plugins
96 %package aa
97 Summary: ASCII art video plug-in for VideoLAN, a DVD and MPEG2 player
98 Group: Video
99 Requires: %{name} = %{version}
100 %description aa
101 The vlc-aa package includes the aalib plug-in for the VideoLAN client.
102 If you are going to watch DVD with the aa video plugin, you should
103 install vlc-aa
104
105 %package sdl
106 Summary: Simple DirectMedia Layer video plug-in for VideoLAN, a DVD and MPEG2 player
107 Group: Video
108 Requires: %{name} = %{version}
109 %description sdl
110 The vlc-sdl package includes the Simple DirectMedia Layer plug-in 
111 for the VideoLAN client.
112 If you are going to watch DVD with the sdl video plugin, you should
113 install vlc-sdl
114
115 %package ggi
116 Summary: GGI video plug-in for VideoLAN, a DVD and MPEG2 player
117 Group: Video
118 Requires: %{name} = %{version}
119 %description ggi
120 The vlc-ggi package includes the GGI plug-in for the VideoLAN client.
121 If you are going to watch DVD with the GGI video plugin, you should
122 install vlc-ggi
123
124 # codec plugins
125 %package mad
126 Summary: MAD audio codec plug-in for VideoLAN, a DVD and MPEG2 player
127 Group: Video
128 Requires: %{name} = %{version}
129 %description mad
130 The vlc-mad package includes the MAD (MPEG Audio Decoder) plug-in
131 for the VideoLAN client.
132 If you are going to watch DVD with the mad codec plugin, you should
133 install vlc-mad
134
135 # audio plugins
136 %package esd
137 Summary: Enlightened Sound Daemon audio plug-in for VideoLAN, a DVD and MPEG2 player
138 Group: Video
139 Requires: %{name} = %{version}
140 %description esd
141 The vlc-esd package includes the Enlightened Sound Daemon plug-in 
142 for the VideoLAN client.
143 If you are going to watch DVD with the esd audio plugin, you should
144 install vlc-esd
145
146 %package arts
147 Summary: aRts audio plug-in for VideoLAN, a DVD and MPEG2 player
148 Group: Video
149 Requires: %{name} = %{version}
150 %description arts
151 The vlc-arts package includes the aRts audio plug-in
152 for the VideoLAN client.
153 If you are going to watch DVD with the aRts audio plugin, you should
154 install vlc-arts
155
156 %package alsa
157 Summary: Advanced Linux Sound Architecture audio plug-in for VideoLAN, a DVD and MPGE2 player
158 Group: Video
159 Requires: %{name} = %{version}
160 %description alsa
161 The vlc-alsa packages includes the Advanced Linux Sound Architecture plug-in 
162 for the VideoLAN client.
163 If you are going to watch DVD with the ALSA audio plugin, you should 
164 install vlc-alsa
165
166 %prep
167 %if %{cvs}
168 %setup -q -n %{cvs_name}
169 %else
170 %setup -q -n %{name}-%{vlc_ver}
171 %endif
172
173 %build
174 %configure  --enable-release \
175             --enable-dvd --without-dvdcss \
176             --enable-gtk --enable-gnome --disable-qt --disable-kde --enable-ncurses \
177             --enable-x11 --enable-xvideo --enable-ggi --enable-sdl --enable-fb --enable-mga --enable-aa \
178             --enable-esd --enable-alsa --enable-arts \
179             --enable-mad
180 export QTDIR=%{_libdir}/qt2 
181 %make
182
183 %install
184 %makeinstall_std
185 install -d %buildroot/%_mandir/man1
186 install doc/vlc.1 %buildroot/%_mandir/man1
187
188 # menu
189 mkdir -p %buildroot/%{_menudir}
190 cat > %buildroot/%{_menudir}/vlc << EOF
191 ?package(vlc): command="%{_bindir}/vlc" hotkey="V" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="VideoLAN Client" icon="vlc.png" hints="Video"
192 EOF
193 cat > %buildroot/%{_menudir}/vlc-gtk << EOF
194 ?package(vlc-gtk): command="%{_bindir}/gvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gtk VideoLAN Client" icon="gvlc.png" hints="Video"
195 EOF
196 cat > %buildroot/%{_menudir}/vlc-gnome << EOF
197 ?package(vlc-gnome): command="%{_bindir}/gnome-vlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gnome VideoLAN Client" icon="gnome-vlc.png" hints="Video"
198 EOF
199 cat > %buildroot/%{_menudir}/vlc-qt << EOF
200 ?package(vlc-gnome): command="%{_bindir}/qvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Qt VideoLAN Client" icon="qvlc.png" hints="Video"
201 EOF
202
203 # icons
204 mkdir -p %{buildroot}/{%{_miconsdir},%{_liconsdir}}
205 install -m 644 %buildroot/%_datadir/videolan/vlc16x16.png %buildroot/%{_miconsdir}/vlc.png
206 install -m 644 %buildroot/%_datadir/videolan/vlc32x32.png %buildroot/%{_iconsdir}/vlc.png
207 install -m 644 %buildroot/%_datadir/videolan/vlc48x48.png %buildroot/%{_liconsdir}/vlc.png
208 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc16x16.png %buildroot/%{_miconsdir}/gnome-vlc.png
209 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc32x32.png %buildroot/%{_iconsdir}/gnome-vlc.png
210 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc48x48.png %buildroot/%{_liconsdir}/gnome-vlc.png
211 install -m 644 %buildroot/%_datadir/videolan/gvlc16x16.png %buildroot/%{_miconsdir}/gvlc.png
212 install -m 644 %buildroot/%_datadir/videolan/gvlc32x32.png %buildroot/%{_iconsdir}/gvlc.png
213 install -m 644 %buildroot/%_datadir/videolan/gvlc48x48.png %buildroot/%{_liconsdir}/gvlc.png
214 install -m 644 %buildroot/%_datadir/videolan/kvlc16x16.png %buildroot/%{_miconsdir}/kvlc.png
215 install -m 644 %buildroot/%_datadir/videolan/kvlc32x32.png %buildroot/%{_iconsdir}/kvlc.png
216 install -m 644 %buildroot/%_datadir/videolan/kvlc48x48.png %buildroot/%{_liconsdir}/kvlc.png
217 install -m 644 %buildroot/%_datadir/videolan/qvlc16x16.png %buildroot/%{_miconsdir}/qvlc.png
218 install -m 644 %buildroot/%_datadir/videolan/qvlc32x32.png %buildroot/%{_iconsdir}/qvlc.png
219 install -m 644 %buildroot/%_datadir/videolan/qvlc48x48.png %buildroot/%{_liconsdir}/qvlc.png
220
221 %post
222 %update_menus
223 %postun
224 %update_menus
225
226 %clean
227 rm -fr %buildroot
228
229 %files
230 %defattr(-,root,root)
231 %doc README COPYING
232 %{_bindir}/vlc
233
234 %dir %{_libdir}/videolan/vlc
235 %{_libdir}/videolan/vlc/ac3_spdif.so
236 %{_libdir}/videolan/vlc/dsp.so
237 %{_libdir}/videolan/vlc/dummy.so
238 %{_libdir}/videolan/vlc/dvd.so
239 %{_libdir}/videolan/vlc/fb.so
240 %{_libdir}/videolan/vlc/file.so
241 %{_libdir}/videolan/vlc/filter_deinterlace.so
242 %{_libdir}/videolan/vlc/filter_distort.so
243 %{_libdir}/videolan/vlc/filter_invert.so
244 %{_libdir}/videolan/vlc/filter_transform.so
245 %{_libdir}/videolan/vlc/filter_wall.so
246 %{_libdir}/videolan/vlc/fx_scope.so
247 %{_libdir}/videolan/vlc/http.so
248 %{_libdir}/videolan/vlc/ipv4.so
249 %{_libdir}/videolan/vlc/ipv6.so
250 %{_libdir}/videolan/vlc/logger.so
251 %{_libdir}/videolan/vlc/lpcm_adec.so
252 %{_libdir}/videolan/vlc/memcpy.so
253 %{_libdir}/videolan/vlc/mga.so
254 %{_libdir}/videolan/vlc/mpeg_es.so
255 %{_libdir}/videolan/vlc/mpeg_ps.so
256 %{_libdir}/videolan/vlc/mpeg_ts.so
257 %{_libdir}/videolan/vlc/null.so
258 %{_libdir}/videolan/vlc/rc.so
259 %{_libdir}/videolan/vlc/spudec.so
260 %{_libdir}/videolan/vlc/udp.so
261 %{_libdir}/videolan/vlc/vcd.so
262 %{_libdir}/videolan/vlc/x11.so
263 %{_libdir}/videolan/vlc/xmga.so
264
265 %{_mandir}/man1/*
266 %{_menudir}/vlc
267 %{_miconsdir}/vlc.png
268 %{_iconsdir}/vlc.png
269 %{_liconsdir}/vlc.png
270
271
272 # intf plugins
273 %files gtk
274 %defattr(-,root,root)
275 %doc README
276 %{_libdir}/videolan/vlc/gtk.so
277 %{_bindir}/gvlc
278 %{_menudir}/vlc-gtk
279 %{_miconsdir}/gvlc.png
280 %{_iconsdir}/gvlc.png
281 %{_liconsdir}/gvlc.png
282 %post gtk
283 %update_menus
284 %postun gtk
285 %update_menus
286
287 %files gnome
288 %defattr(-,root,root)
289 %doc README
290 %{_libdir}/videolan/vlc/gnome.so
291 %{_bindir}/gnome-vlc
292 %{_menudir}/vlc-gnome
293 %{_miconsdir}/gnome-vlc.png
294 %{_iconsdir}/gnome-vlc.png
295 %{_liconsdir}/gnome-vlc.png
296 %post   gnome
297 %update_menus
298 %postun gnome
299 %update_menus
300
301 %if %{plugin_qt}
302 %files qt
303 %defattr(-,root,root)
304 %doc README
305 %{_libdir}/videolan/vlc/qt.so
306 %{_bindir}/qvlc
307 %{_menudir}/vlc-qt
308 %{_miconsdir}/qvlc.png
309 %{_iconsdir}/qvlc.png
310 %{_liconsdir}/qvlc.png
311 %post   qt
312 %update_menus
313 %postun qt
314 %update_menus
315 %endif
316
317 %files ncurses
318 %defattr(-,root,root)
319 %doc README
320 %{_libdir}/videolan/vlc/ncurses.so
321
322 # video plugins
323 %files sdl
324 %defattr(-,root,root)
325 %doc README
326 %{_libdir}/videolan/vlc/sdl.so
327
328 %files ggi
329 %defattr(-,root,root)
330 %doc README
331 %{_libdir}/videolan/vlc/ggi.so
332
333 %files aa
334 %defattr(-,root,root)
335 %doc README
336 %{_libdir}/videolan/vlc/aa.so
337
338 # codec plugin
339 %files mad
340 %defattr(-,root,root)
341 %doc README
342 %{_libdir}/videolan/vlc/mad.so
343
344 #audio plugins
345 %files esd
346 %defattr(-,root,root)
347 %doc README
348 %{_libdir}/videolan/vlc/esd.so
349
350 %files arts
351 %defattr(-,root,root)
352 %doc README
353 %{_libdir}/videolan/vlc/arts.so
354
355 %files alsa
356 %defattr(-,root,root)
357 %doc README
358 %{_libdir}/videolan/vlc/alsa.so
359
360 %changelog
361 * Thu Apr 18 2002 Samuel Hocevar <sam@zoy.org> 0.3.1
362 - version 0.3.1.
363 - patch0 is no longer needed.
364
365 * Wed Apr 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-1mdk
366 - version 0.3.1 (hum soon)
367 - removed old %%ifarch ppc
368
369 * Wed Apr 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-4mdk
370 - added liba52 support (buildrequires).
371 - added vlc-alsa audio plugin.
372 - mad is a codec (audio) plugin. corrected description and summary.
373
374 * Wed Apr 10 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-3mdk
375 - added patch0 from CVS: fix crashing GTK popup menus thx Michal Bukovjan <bukovjan@mbox.dkm.cz>
376
377 * Wed Apr 10 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-2mdk
378 - added vlc-arts rpm plugin thx blindauer Emmanuel <manu@agat.net>
379 - better summary for plug-in
380 - add packager tag to myself
381
382 * Sun Apr 07 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-1mdk
383 - added aa (Asci Art) plugin in vlc-aa rpm
384 - merged with sam's one:
385   * using his plugins list into %%files
386   * removed libdvdcss from the whole tarball.
387   * removed the workaround for vlc's bad /dev/dsp detection.
388 - few spelling corrections in all %%description
389 - added buildrequires on SDL-devel
390
391 * Thu Apr 06 2002 Samuel Hocevar <sam@zoy.org> 0.3.0
392 - version 0.3.0.
393 - removed libdvdcss from the whole tarball.
394 - removed the workaround for vlc's bad /dev/dsp detection.
395
396 * Tue Mar 05 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.93-0.1mdk
397 - new cvs snapshot
398 - fix requires
399
400 * Mon Mar 04 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-5mdk
401 - cvs snapshot
402
403 * Sat Jan 26 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-4mdk
404 - mad plugin in vlc-mad rpm
405
406 * Mon Jan 21 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-3mdk
407 - synced with main cvs specfile wich "fixed a few minor inaccuracies"
408
409 * Thu Jan 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-2mdk
410 - readded libdvdcss rpm in specfile. use %%define css 1 with correct sources
411   to build libdvdcss rpm.
412
413 * Wed Jan 09 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-1mdk
414 - version 0.2.92
415 - %%makeinstall_std
416 - splitted again, added vlc-sdl vlc-esd vlc-ggi
417 - bring back some missing plugins
418 - fixed buildrequires
419 - added menu entries and icons (from cvs)
420
421 * Tue Oct 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-2mdk
422 - rebuild against libpng3
423 - added some doc for sir rpmlint
424 - #5583: option -g
425
426 * Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-1mdk
427 - version 0.2.83 : 
428   * Activated subtitles in overlay mode (far from perfect, but this
429     was an often requested feature).
430
431 * Fri Aug 10 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.82-1mdk
432 - version 0.2.82
433
434 * Mon Jul 30 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-1mdk
435 - version 0.2.81
436 - added vlc-ncurses
437
438 * Wed Jun 20 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-0.20010619-1mdk
439 - cvs snapshot
440 - added libdvdcss
441
442 * Wed Jun 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-2mdk
443 - fix build on ppc (c) dadou
444
445 * Mon Jun 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-1mdk
446 - version 0.2.80 : bug fixes and bug fixes and bug fixes and small
447   improvements of the gtk interface.
448 - corrected Summary in vlc-qt
449
450 * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-2mdk
451 - added qt2 plug-in (vlc-qt)
452
453 * Wed May 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-1mdk
454 - version 0.2.73
455 - you can now get decss threw a plug-in
456 - rewritte srcipt to build vlc (decss plugin)
457 - rebuild with SDL 1.2
458
459 * Thu Apr 26 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-2mdk
460 - true 0.2.72
461
462 * Mon Apr 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-1mdk
463 - version 0.2.72
464 - package split into vlc, vlc-gnome, vlc-gtk
465
466 * Fri Apr 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.71-1mdk
467 - version 0.2.71 :
468   * Fixed segfaults when compiled with gcc 3.0pre and versions of gcc
469     shipped with the latest RedHat distributions.                    
470   * Fixed the BeOS CSS decryption.
471   * Fixed a few issues in IFO parsing.
472   * Fixed XVideo video output.
473   * Updated icons under Linux, BeOS, MacOS X.
474
475 * Wed Apr 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.70-1mdk
476 - version 0.2.70
477
478 * Thu Mar 22 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.63-1mdk
479 - version 0.2.63 : Bugfixes, bugfixes, and bugfixes again, a Gtk+ 
480   interface for the Gnome-impaired, an even better DVD support
481
482 * Fri Feb 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.61-1mdk
483 - new version for all the DVD fans (add MPEG1 support, direct DVD support, 
484   DVD decryption, arbitrary, seeking in the stream, pause, fast forward 
485   and slow motion, hardware YUV acceleration enhanced CSS support and a few 
486   new interface features including drag'n'drop.
487 - first *real* public release (now under the GPL)
488
489 * Sat Jan 06 2001 David BAUDENS <baudens@mandrakesoft.com> 0.1.99i-2mdk
490 - Fix build and use right optimizations on PPC
491 - Enable SDL support
492 - Spec clean up
493
494 * Fri Jan  5 2001 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99i-1mdk
495 - 0.1.99i, rebuild
496
497 * Fri Aug 25 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99h-1mdk
498 - 0.1.99h
499
500 * Mon Jul 10 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99c-1mdk
501 - first Mandrake package with help of Sam