]> git.sesse.net Git - vlc/blob - vlc.spec
Changes to Red Hat spec file:
[vlc] / vlc.spec
1 %define mozver 1.2.1
2
3 Summary: The VideoLAN client, also a very good standalone video player.
4 Name: vlc
5 Version: 0.6.3
6 Release: 1
7 Group: Applications/Multimedia
8 License: GPL
9 URL: http://www.videolan.org/
10 Source: http://www.videolan.org/pub/videolan/vlc/vlc-%{version}.tar.bz2
11 Buildroot: %{_tmppath}/%{name}-root
12 Packager: Jason Luka <jason@geshp.com>
13 Buildrequires: XFree86-devel, desktop-file-utils, libpostproc
14 %{!?_without_dvd:Buildrequires: libdvdcss-devel}
15 %{!?_without_dvdread:Buildrequires: libdvdread-devel}
16 %{!?_without_dvdplay:Buildrequires: libdvdplay-devel}
17 %{!?_without_dvbpsi:Buildrequires: libdvbpsi-devel}
18 %{!?_without_ogg:Buildrequires: libogg-devel}
19 %{!?_without_mad:Buildrequires: libmad}
20 %{!?_without_ffmpeg:Buildrequires: ffmpeg-devel}
21 %{!?_without_xvid:Buildrequires: xvidcore-devel}
22 %{!?_without_a52:Buildrequires: a52dec-devel}
23 %{!?_without_dv:Buildrequires: libdv-devel}
24 %{!?_without_flac:Buildrequires: flac-devel}
25 %{!?_without_vorbis:Buildrequires: libvorbis-devel}
26 %{!?_without_sdl:Buildrequires: SDL-devel}
27 %{!?_without_aa:Buildrequires: aalib-devel}
28 %{!?_without_esd:Buildrequires: esound-devel}
29 %{!?_without_arts:Buildrequires: arts-devel}
30 %{!?_without_alsa:Buildrequires: alsa-lib-devel}
31 %{!?_without_gtk:Buildrequires: gtk+-devel}
32 %{!?_without_gnome:Buildrequires: gnome-libs-devel}
33 %{!?_without_lirc:Buildrequires: lirc}
34 %{!?_without_qt:Buildrequires: qt-devel}
35 %{!?_without_kde:Buildrequires: kdelibs-devel}
36 %{!?_without_ncurses:Buildrequires: ncurses-devel >= 5}
37 %{!?_without_xosd:Buildrequires: xosd-devel}
38 %{!?_without_mozilla:BuildRequires: mozilla-devel}
39 %{!?_without_id3tag:BuildRequires: libid3tag-devel}
40 %{!?_without_mpeg2dec:BuildRequires: mpeg2dec-devel >= 0.3.2}
41 %{!?_without_wxwindows:BuildRequires: wxGTK-devel >= 2.4.1}
42 %{!?_without_mozilla:BuildRequires: mozilla-devel = %{mozver}}
43 Obsoletes: videolan-client
44
45 Requires: XFree86, desktop-file-utils
46 %{!?_without_dvd:Requires: libdvdcss}
47 %{!?_without_dvdread:Requires: libdvdread}
48 %{!?_without_dvdplay:Requires: libdvdplay}
49 %{!?_without_dvbpsi:Requires: libdvbpsi}
50 %{!?_without_ogg:Requires: libogg}
51 %{!?_without_mad:Requires: libmad}
52 %{!?_without_ffmpeg:Requires: ffmpeg}
53 %{!?_without_xvid:Requires: xvidcore >= 0.9.2}
54 %{!?_without_a52:Requires: a52dec}
55 %{!?_without_dv:Requires: libdv}
56 %{!?_without_flac:Requires: flac}
57 %{!?_without_vorbis:Requires: libvorbis}
58 %{!?_without_sdl:Requires: SDL}
59 %{!?_without_aa:Requires: aalib}
60 %{!?_without_esd:Requires: esound}
61 %{!?_without_arts:Requires: arts}
62 %{!?_without_alsa:Requires: alsa-lib}
63 %{!?_without_gtk:Requires: gtk+}
64 %{!?_without_gnome:Requires: gnome-libs}
65 %{?_with_qt:Requires: qt}
66 %{?_with_kde:Requires: kdelibs}
67 %{?_with_ncurses:Requires: ncurses}
68 %{!?_without_xosd:Requires: xosd}
69 %{!?_without_lirc:Requires: lirc}
70 %{?_with_mozilla:Requires: mozilla = %{mozver}}
71 %{!?_without_wxwindows:Requires: wxGTK >= 2.4.1}
72
73 %description
74 VideoLAN Client (VLC) is a highly portable multimedia player for various
75 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
76 well as DVDs, VCDs, and various streaming protocols.
77
78 Available rpmbuild rebuild options :
79 --without dvd dvdread dvdplay dvbpsi dv v4l avi asf aac ogg rawdv mad ffmpeg xvid
80           mp4 a52 vorbis mpeg2dec flac aa esd arts gtk gnome xosd lsp lirc
81           pth id3tag dv qt kde ncurses faad alsa wxwindows skins
82
83 Options that would need not yet existing add-on packages :
84 --with tremor tarkin theora ggi glide svgalib mga
85
86 %package devel
87 Summary: Header files and static library from the Videolan Client.
88 Group: Development/Libraries
89 Requires: %{name} = %{version}
90
91 %description devel
92 VideoLAN Client (VLC) is a highly portable multimedia player for various
93 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
94 well as DVDs, VCDs, and various streaming protocols.
95
96 Install this package if you need to build Videolan Client plugins or intend
97 to link statically to it.
98
99
100 %prep
101 %setup -q -n vlc-%{version}
102
103 %build
104 cp %{_libdir}/mozilla/plugins/plugger.so %{_libdir}/mozilla-%{mozver}/plugins/plugger.so.bak -f
105 mv %{_libdir}/mozilla-%{mozver}/plugins/plugger.so.bak %{_libdir}/mozilla-%{mozver}/plugins/plugger.so -f
106 rm %{_libdir}/mozilla -fr
107 ln %{_libdir}/mozilla-%{mozver} %{_libdir}/mozilla -sf
108 ln /usr/share/idl/mozilla-%{mozver} /usr/share/idl/mozilla -sf
109 ln %{_libdir}/libxvidcore.so.2 %{_libdir}/libxvidcore.so -sf
110
111 %configure \
112         --enable-release \
113         %{?_without_dvd:--disable-dvd} \
114         %{!?_without_dvdread:--enable-dvdread} \
115         %{!?_without_dvdplay:--enable-dvdplay} \
116         %{!?_without_dvbpsi:--enable-dvbpsi} \
117         %{!?_without_v4l:--enable-v4l} \
118         --enable-vcd \
119         %{?_without_avi:--disable-avi} \
120         %{?_without_asf:--disable-asf} \
121         %{?_without_aac:--disable-aac} \
122         %{?_without_ogg:--disable-ogg} \
123         %{?_without_rawdv:--disable-rawdv} \
124         %{!?_without_mad:--enable-mad} \
125         %{!?_without_ffmpeg:--enable-ffmpeg --with-ffmpeg=%{_prefix}} \
126         %{!?_without_faad:--enable-faad} \
127         %{!?_without_xvid:--enable-xvid} \
128         %{?_without_mp4:--disable-mp4} \
129         %{?_without_a52:--disable-a52} \
130         %{?_without_cinepak:--disable-cinepak} \
131         %{!?_without_dv:--enable-dv} \
132         %{!?_without_flac:--enable-flac} \
133         %{?_without_mpeg2dec:--disable-libmpeg2} \
134         %{?_without_vorbis:--disable-vorbis} \
135         %{?_with_tremor:--enable-tremor} \
136         %{?_with_tarkin:--enable-tarkin} \
137         %{!?_without_theora:--enable-theora} \
138         --enable-x11 \
139         --enable-xvideo \
140         %{?_without_sdl:--disable-sdl} \
141         --disable-qte \
142         --disable-directx \
143         --enable-fb \
144         %{?_with_mga:--enable-mga} \
145         %{?_with_svgalib:--enable-svgalib} \
146         %{?_with_ggi:--enable-ggi} \
147         %{?_with_glide:--enable-glide} \
148         %{!?_without_aa:--enable-aa} \
149         --without-wingdi \
150         --enable-oss \
151         %{!?_without_esd:--enable-esd} \
152         %{!?_without_arts:--enable-arts} \
153         %{?_with_alsa:--enable-alsa} \
154         --disable-waveout \
155         %{!?_without_gtk:--enable-gtk} \
156         --disable-familiar \
157         %{!?_without_gnome:--enable-gnome} \
158         %{?_without_wxwindows:--disable-wxwindows} \
159         %{!?_without_wxwindows:--enable-skins} \
160         %{!?_without_qt:--enable-qt} \
161         %{!?_without_kde:--enable-kde} \
162         --disable-opie \
163         --disable-macosx \
164         --disable-qnx \
165         --disable-intfwin \
166         %{!?_without_ncurses:--enable-ncurses} \
167         %{!?_without_xosd:--enable-xosd} \
168         %{?_without_slp:--disable-slp} \
169         %{!?_without_lirc:--enable-lirc} \
170         %{!?_without_pth:--enable-pth} \
171         --disable-st \
172         %{!?_without_mozilla:--enable-mozilla} \
173         --disable-testsuite \
174         --enable-plugins
175 make %{?_smp_mflags}
176
177 %install
178 rm -rf %{buildroot}
179 %makeinstall
180 find  %{buildroot}%{_libdir}/vlc -name "*.so" | xargs strip
181 %find_lang vlc
182
183 cat > %{name}.desktop << EOF
184 [Desktop Entry]
185 Name=VideoLAN Media Player
186 Comment=%{summary}
187 Icon=%{_datadir}/vlc/vlc48x48.png
188 Exec=vlc
189 Terminal=0
190 Type=Application
191 EOF
192
193 mv %{buildroot}%{_libdir}/mozilla %{buildroot}%{_libdir}/mozilla-%{mozver} -f
194
195 mkdir -p %{buildroot}%{_datadir}/applications
196 desktop-file-install --vendor gnome --delete-original             \
197   --dir %{buildroot}%{_datadir}/applications                      \
198   --add-category X-Red-Hat-Base                                   \
199   --add-category Application                                      \
200   --add-category AudioVideo                                       \
201   %{name}.desktop
202
203 %post
204 ln /dev/cdrom /dev/dvd -sf
205 ln %{_libdir}/libxvidcore.so.2 %{_libdir}/libxvidcore.so -sf
206
207 %postun
208 rm -f /dev/dvd
209 rm /usr/share/idl/mozilla -fr
210 rm %{_libdir}/libxvidcore.so -f
211
212 %clean
213 rm -rf %{buildroot}
214 rm /usr/share/idl/mozilla -fr
215 rm /usr/lib/mozilla -fr
216 mkdir /usr/lib/mozilla/plugins -p --mode=755
217 mv %{_libdir}/mozilla-%{mozver}/plugins/plugger.so %{_libdir}/mozilla/plugins -f
218 rm %{_libdir}/libxvidcore.so -f
219
220 %files -f vlc.lang
221 %defattr(-, root, root)
222 %doc AUTHORS COPYING ChangeLog MAINTAINERS README THANKS
223 %doc doc/fortunes.txt doc/web-streaming.html
224 %{_bindir}/*vlc
225 %{_libdir}/vlc
226 %{_libdir}/libvlc_pic.a
227 %{_libdir}/mozilla-%{mozver}/components/vlcintf.xpt
228 %{_libdir}/mozilla-%{mozver}/plugins/libvlcplugin.so
229 %{_datadir}/applications/gnome-%{name}.desktop
230 %{_datadir}/vlc
231
232 %files devel
233 %defattr(-, root, root)
234 %doc HACKING 
235 %{_bindir}/vlc-config
236 %{_includedir}/vlc
237 %{_libdir}/libvlc.a
238
239 %changelog
240 * Sat Sep 22 2003 Jason Luka
241 - Added wxwindows, alsa, and skin support
242 - Fixed dependancies, specifically a version conflict of xvidcore
243
244 * Thu Sep 20 2003 Jason Luka
245 - Removed wxinterface because it's redundant
246 - Removed alsa support because it's not needed in Red Hat
247
248 * Mon Aug 25 2003 Jason Luka
249 - Added matroska support
250 - Corrected some symlinking problems with the mozilla plugin
251
252 * Fri Aug 22 2003 Jason Luka <jason@geshp.com>
253 - Update to 0.6.2
254 - Changed menu item name to VideoLAN Media Player
255 - Added openslp support
256 - Added libtar support (needed for skins)
257 - Added symlink to libxvidcore.so, thanks to new version of that software
258
259 * Fri Aug 1 2003 Jason Luka <jason@geshp.com>
260 - Update to 0.6.1
261 - Fixed file structure problems I created to accomodate the mozilla plugin
262 - Changed vendor name for desktop install
263 - Moved vlc to base menu
264 - Moved plugins from /usr/lib/mozilla to /usr/lib/mozilla-x.x.x
265 - Added custom patch to accomodate mozilla plugin
266 - Added execution of bootstrap since Makefile.am was altered
267
268 * Tue Jul 8 2003 Jason Luka <jason@geshp.com>
269 - Update to 0.6.0
270 - Add id3lib, dv, faad, qt, kde, and mozilla plugin support
271 - Added script to symlink mozilla-1.2.1 directories to mozilla so build can complete
272
273 * Sat Apr 5 2003 Jason Luka <jason@geshp.com>
274 - Rebuilt for Red Hat 9
275 - Changed dependencies for ffmpeg's new name
276 - Required lirc support at build-time 
277
278 * Sat Mar 25 2003 Jason Luka <jason@geshp.com>
279 - Fixed Buildrequire statements to require all plugins at compile-time
280 - Fixed Require statements so users don't have to install every plugin
281
282 * Thu Mar 23 2003 Jason Luka <jason@geshp.com>
283 - Renamed ffmpeg to libffmpeg
284 - Rebuilt for videolan site
285 - Autolinked /dev/dvd to /dev/cdrom
286
287 * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
288 - Update to 0.5.2.
289 - Fix the dv build dependency, thanks to Alan Hagge.
290 - Added flac support.
291 - Fixed the libdvbpsi requirements.
292
293 * Mon Feb 24 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
294 - Rebuilt against the new xosd lib.
295
296 * Wed Feb 19 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
297 - Update to 0.5.1.
298 - Major spec file update.
299
300 * Fri Nov 15 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
301 - Update to 0.4.6.
302
303 * Tue Oct 22 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
304 - Update to 0.4.5.
305 - Minor --with / --without adjustments.
306
307 * Sun Oct  6 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
308 - Rebuilt for Red Hat Linux 8.0.
309 - New menu entry.
310 - Added all --without options and --with qt.
311
312 * Mon Aug 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
313 - Update to 0.4.4.
314
315 * Fri Jul 26 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
316 - Update to 0.4.3.
317
318 * Fri Jul 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
319 - Update to 0.4.2.
320
321 * Wed Jun  5 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
322 - Update to 0.4.1.
323
324 * Fri May 24 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
325 - Update to 0.4.0.
326 - Disabled qt interface, it's hell to build with qt2/3!
327 - Use %%find_lang and %%{?_smp_mflags}.
328
329 * Fri Apr 19 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
330 - Update to 0.3.1.
331
332 * Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
333 - Update to 0.3.0.
334
335 * Sat Jan 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
336 - Removed the dependency on libdvdcss package, use the built in one instead,
337   because 1.x.x is not as good as 0.0.3.ogle3.
338
339 * Tue Jan  1 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
340 - Update to 0.2.92.
341 - Build fails with libdvdcss < 1.0.1.
342
343 * Tue Nov 13 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
344 - Update to 0.2.91 and now requires libdvdcss 1.0.0.
345
346 * Mon Oct 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
347 - Split libdvdcss into a separate package since it's also needed by the
348   xine menu plugin.
349
350 * Thu Oct 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
351 - Updated to 0.2.90.
352 - Removed ggi, svgalib and aalib since they aren't included in Red Hat 7.2.
353
354 * Mon Aug 27 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
355 - Updated to 0.2.83.
356
357 * Sat Aug 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
358 - Updated to 0.2.82.
359
360 * Mon Jul 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
361 - Updated to 0.2.81.
362 - Added all the new split libdvdcss.* files to the %%files section.
363
364 * Tue Jun  5 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
365 - Updated to the latest release, 0.2.80.
366
367 * Wed May 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
368 - Updated to today's CVS version, works great! :-)
369 - Fixed the desktop menu entry.
370
371 * Tue May 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
372 - Spec file cleanup to make it look more like others do.
373 - Added the use of many macros.
374 - Disabled automatic requires and provides (the package always needed qt,
375   gtk+, gnome etc. otherwise).
376 - Added a system desktop menu entry.
377
378 * Mon Apr 30 2001 Arnaud Gomes-do-Vale <arnaud@glou.org>
379 Added relocation support and compile fixes for Red Hat 7.x.
380
381 * Sat Apr 28 2001 Henri Fallon <henri@videolan.org>
382 New upstream release (0.2.73)
383
384 * Mon Apr 16 2001 Samuel Hocevar <sam@zoy.org>
385 New upstream release (0.2.72)
386
387 * Fri Apr 13 2001 Samuel Hocevar <sam@zoy.org>
388 New upstream release (0.2.71)
389
390 * Sun Apr 8 2001 Christophe Massiot <massiot@via.ecp.fr>
391 New upstream release (0.2.70)
392
393 * Fri Feb 16 2001 Samuel Hocevar <sam@via.ecp.fr>
394 New upstream release
395
396 * Tue Aug  8 2000 Samuel Hocevar <sam@via.ecp.fr>
397 Added framebuffer support
398
399 * Sun Jun 18 2000 Samuel Hocevar <sam@via.ecp.fr>
400 Took over the package
401
402 * Thu Jun 15 2000 Eric Doutreleau <Eric.Doutreleau@int-evry.fr>
403 Initial package
404