]> git.sesse.net Git - vlc/blob - vlc.spec
* ./doc/release-howto.txt: updated documentation.
[vlc] / vlc.spec
1 %define name            vlc
2 %define vlc_ver         0.3.0
3 %define version         %vlc_ver
4
5 %define cvs             0
6 %if %{cvs}
7 %define cvsdate         20010619
8 %define release         0.%{cvsdate}mdk
9 %define cvs_name        %{name}-snapshot-%{cvsdate}-00
10 %else
11 %define release         2mdk
12 %endif
13
14 %define plugin_qt       0
15 %define plugin_alsa     0
16
17 Summary:        VideoLAN is a free MPEG, MPEG2 and DVD software solution.
18 Name:           %{name}
19 Version:        %{version}
20 Release:        %{release}
21
22 %if %{cvs} 
23 Source0:        http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.gz
24 %else
25 Source0:        http://www.videolan.org/packages/%{version}/%{name}-%{version}.tar.gz
26 %endif
27 License:        GPL
28 Group:          Video
29 URL:            http://videolan.org/
30 BuildRoot:      %_tmppath/%name-%version-%release-root
31 Buildrequires:  libncurses5-devel
32 Buildrequires:  libqt2-devel
33 Buildrequires:  libgtk+1.2-devel
34 Buildrequires:  gnome-libs-devel
35 Buildrequires:  db1-devel
36 Buildrequires:  alsa-lib-devel
37 Buildrequires:  libggi-devel
38
39 %description
40 VideoLAN is a free network-aware MPEG and DVD player.
41 The VideoLAN Client allows to play MPEG2 Transport Streams from the
42 network or from a file, as well as direct DVD playback.
43 VideoLAN is a project of students from the Ecole Centrale Paris.
44 This version add MPEG1 support, direct DVD support, DVD decryption, 
45 arbitrary, seeking in the stream, pause, fast forward and slow motion, 
46 hardware YUV acceleration and a few new interface features 
47 including drag'n'drop.
48 You may install vlc-gnome, vlc-gtk and vlc-qt vlc-gnome vlc-ncurses.
49 This package contains no CSS unscrambling functionality.
50 You need the libdvdcss library available from http://www.videolan.org/libdvdcss/
51
52 %package gtk
53 Summary: Gtk plug-in for VideoLAN, a DVD and MPEG2 player
54 Group: Video
55 Requires: %{name} = %{version}
56 %description gtk
57 The vlc-gtk packages includes the Gtk plug-in for the VideoLAN client.
58 If you are going to watch DVD with the Gtk front-end, you should 
59 install vlc-gtk.
60
61
62 %package gnome
63 Summary: Gnome plug-in for VideoLAN, a DVD and MPEG2 player
64 Group: Video
65 Requires: %{name} = %{version}
66 %description gnome
67 The vlc-gnome packages includes the Gnome plug-in for the VideoLAN client.
68 If you are going to watch DVD with the Gnome front-end, you should 
69 install vlc-gnome.
70
71 %package qt
72 Summary: Qt2 plug-in for VideoLAN, a DVD and MPEG2 player
73 Group: Video
74 Requires: %{name} = %{version}
75 %description qt
76 The vlc-qt packages includes the Qt2 plug-in for the VideoLAN client.
77 If you are going to watch DVD with the Qt2 front-end, you should
78 install vlc-qt
79
80 %package ncurses
81 Summary: Ncurses console-based plug-in for VideoLAN, a DVD and MPEG2 player
82 Group: Video
83 Requires: %{name} = %{version}
84 %description ncurses
85 The vlc-ncurses packages includes the ncurses plug-in for the VideoLAN client.
86 If you are going to watch DVD with the ncurses front-end, you should
87 install vlc-ncurses
88
89 %package sdl
90 Summary: Simple DirectMedia Layer plug-in for VideoLAN, a DVD and MPEG2 player
91 Group: Video
92 Requires: %{name} = %{version}
93 %description sdl
94 The vlc-sdl packages includes the Simple DirectMedia Layer plug-in 
95 for the VideoLAN client.
96 If you are going to watch DVD with the sdl plugin, you should
97 install vlc-sdl
98
99 %package ggi
100 Summary: GGI plug-in for VideoLAN, a DVD and MPEG2 player
101 Group: Video
102 Requires: %{name} = %{version}
103 %description ggi
104 The vlc-ggi packages includes the GGI plug-in for the VideoLAN client.
105 If you are going to watch DVD with the GGI plugin, you should
106 install vlc-ggi
107
108 %package esd
109 Summary: Enlightened Sound Daemon plug-in for VideoLAN, a DVD and MPEG2 player
110 Group: Video
111 Requires: %{name} = %{version}
112 %description esd
113 The vlc-esd packages includes the Enlightened Sound Daemon plug-in 
114 for the VideoLAN client.
115 If you are going to watch DVD with the esd plugin, you should
116 install vlc-esd
117
118 %package alsa
119 Summary: Advanced Linux Sound Architecture plug-in for VideoLAN, a DVD and MPEG2 player
120 Group: Video
121 Requires: %{name} = %{version}
122 %description alsa
123 The vlc-alsa packages includes the Advanced Linux Sound Architecture plug-in for the VideoLAN client.
124 If you are going to watch DVD with the ALSA plugin, you should install vlc-alsa
125
126 %prep
127 %if %{cvs}
128 %setup -q -n %{cvs_name}
129 %else
130 %setup -q -n %{name}-%{vlc_ver}
131 %endif
132
133 %build
134 %ifarch ppc
135 # Dadou - 0.1.99h-mdk - Don't use configure here. It breaks build at present
136 #                       time.
137 ./configure --enable-release --enable-dvd --without-dvdcss \
138             --prefix=%_prefix \
139             --enable-gnome --enable-x11 --enable-gtk --enable-qt \
140             --enable-esd \
141             --enable-fb \
142             --enable-xvideo \
143             --enable-sdl
144 perl -pi -e "s|CFLAGS \+= -mcpu=604e|#CFLAGS \+= -mcpu=604e|" Makefile
145 perl -pi -e "s|#CFLAGS \+= -mcpu=750|CFLAGS \+= -mcpu=750 -mtune=750|" Makefile
146 %else
147 #export CC="gcc-3.0.1" CXX="g++-3.0.1"
148 %configure --enable-release --enable-dvd --without-dvdcss \
149            --enable-gnome --enable-gtk \
150            --enable-x11 --disable-qt --enable-ncurses \
151            --enable-esd --enable-alsa \
152            --enable-fb --enable-mga \
153            --enable-xvideo \
154            --enable-ggi \
155            --enable-sdl 
156 %endif
157 export QTDIR=%{_libdir}/qt2 
158 %make
159
160 %install
161 %makeinstall_std
162 install -d %buildroot/%_mandir/man1
163 install doc/vlc.1 %buildroot/%_mandir/man1
164
165 # menu
166 mkdir -p $RPM_BUILD_ROOT/%{_menudir}
167 cat > $RPM_BUILD_ROOT/%{_menudir}/vlc << EOF
168 ?package(vlc): command="%{_bindir}/vlc" hotkey="V" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="VideoLAN Client" icon="vlc.png" hints="Video"
169 EOF
170 cat > $RPM_BUILD_ROOT/%{_menudir}/vlc-gtk << EOF
171 ?package(vlc-gtk): command="%{_bindir}/gvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gtk VideoLAN Client" icon="gvlc.png" hints="Video"
172 EOF
173 cat > $RPM_BUILD_ROOT/%{_menudir}/vlc-gnome << EOF
174 ?package(vlc-gnome): command="%{_bindir}/gnome-vlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gnome VideoLAN Client" icon="gnome-vlc.png" hints="Video"
175 EOF
176 cat > $RPM_BUILD_ROOT/%{_menudir}/vlc-qt << EOF
177 ?package(vlc-gnome): command="%{_bindir}/qvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Qt VideoLAN Client" icon="qvlc.png" hints="Video"
178 EOF
179
180 # icons
181 mkdir -p %{buildroot}/{%{_miconsdir},%{_liconsdir}}
182 install -m 644 %buildroot/%_datadir/videolan/vlc16x16.png %buildroot/%{_miconsdir}/vlc.png
183 install -m 644 %buildroot/%_datadir/videolan/vlc32x32.png %buildroot/%{_iconsdir}/vlc.png
184 install -m 644 %buildroot/%_datadir/videolan/vlc48x48.png %buildroot/%{_liconsdir}/vlc.png
185 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc16x16.png %buildroot/%{_miconsdir}/gnome-vlc.png
186 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc32x32.png %buildroot/%{_iconsdir}/gnome-vlc.png
187 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc48x48.png %buildroot/%{_liconsdir}/gnome-vlc.png
188 install -m 644 %buildroot/%_datadir/videolan/gvlc16x16.png %buildroot/%{_miconsdir}/gvlc.png
189 install -m 644 %buildroot/%_datadir/videolan/gvlc32x32.png %buildroot/%{_iconsdir}/gvlc.png
190 install -m 644 %buildroot/%_datadir/videolan/gvlc48x48.png %buildroot/%{_liconsdir}/gvlc.png
191 install -m 644 %buildroot/%_datadir/videolan/kvlc16x16.png %buildroot/%{_miconsdir}/kvlc.png
192 install -m 644 %buildroot/%_datadir/videolan/kvlc32x32.png %buildroot/%{_iconsdir}/kvlc.png
193 install -m 644 %buildroot/%_datadir/videolan/kvlc48x48.png %buildroot/%{_liconsdir}/kvlc.png
194 install -m 644 %buildroot/%_datadir/videolan/qvlc16x16.png %buildroot/%{_miconsdir}/qvlc.png
195 install -m 644 %buildroot/%_datadir/videolan/qvlc32x32.png %buildroot/%{_iconsdir}/qvlc.png
196 install -m 644 %buildroot/%_datadir/videolan/qvlc48x48.png %buildroot/%{_liconsdir}/qvlc.png
197
198 %post
199 %update_menus
200 %postun
201 %update_menus
202
203 %clean
204 rm -fr %buildroot
205
206 %files
207 %defattr(-,root,root,-)
208 %doc README COPYING
209 %{_bindir}/vlc
210 %dir %{_libdir}/videolan/vlc
211 %{_libdir}/videolan/vlc/ac3_spdif.so
212 %{_libdir}/videolan/vlc/dsp.so
213 %{_libdir}/videolan/vlc/dummy.so
214 %{_libdir}/videolan/vlc/dvd.so
215 %{_libdir}/videolan/vlc/fb.so
216 %{_libdir}/videolan/vlc/file.so
217 %{_libdir}/videolan/vlc/filter_deinterlace.so
218 %{_libdir}/videolan/vlc/filter_distort.so
219 %{_libdir}/videolan/vlc/filter_invert.so
220 %{_libdir}/videolan/vlc/filter_transform.so
221 %{_libdir}/videolan/vlc/filter_wall.so
222 %{_libdir}/videolan/vlc/fx_scope.so
223 %{_libdir}/videolan/vlc/http.so
224 %{_libdir}/videolan/vlc/ipv4.so
225 %{_libdir}/videolan/vlc/ipv6.so
226 %{_libdir}/videolan/vlc/logger.so
227 %{_libdir}/videolan/vlc/lpcm_adec.so
228 %{_libdir}/videolan/vlc/memcpy.so
229 %{_libdir}/videolan/vlc/mga.so
230 %{_libdir}/videolan/vlc/mpeg_es.so
231 %{_libdir}/videolan/vlc/mpeg_ps.so
232 %{_libdir}/videolan/vlc/mpeg_ts.so
233 %{_libdir}/videolan/vlc/null.so
234 %{_libdir}/videolan/vlc/rc.so
235 %{_libdir}/videolan/vlc/spudec.so
236 %{_libdir}/videolan/vlc/udp.so
237 %{_libdir}/videolan/vlc/vcd.so
238 %{_libdir}/videolan/vlc/x11.so
239 %{_libdir}/videolan/vlc/xmga.so
240 # nothing useful for the moment.
241 #%dir %{_datadir}/videolan
242 #%{_datadir}/videolan/*
243 %{_mandir}/man1/*
244 %{_menudir}/vlc
245 %{_miconsdir}/vlc.png
246 %{_iconsdir}/vlc.png
247 %{_liconsdir}/vlc.png
248
249 %files gtk
250 %defattr(-,root,root)
251 %doc README
252 %{_libdir}/videolan/vlc/gtk.so
253 %{_bindir}/gvlc
254 %{_menudir}/vlc-gtk
255 %{_miconsdir}/gvlc.png
256 %{_iconsdir}/gvlc.png
257 %{_liconsdir}/gvlc.png
258 %post gtk
259 %update_menus
260 %postun gtk
261 %update_menus
262
263 %files gnome
264 %defattr(-,root,root)
265 %doc README
266 %{_libdir}/videolan/vlc/gnome.so
267 %{_bindir}/gnome-vlc
268 %{_menudir}/vlc-gnome
269 %{_miconsdir}/gnome-vlc.png
270 %{_iconsdir}/gnome-vlc.png
271 %{_liconsdir}/gnome-vlc.png
272 %post   gnome
273 %update_menus
274 %postun gnome
275 %update_menus
276
277 %if %{plugin_qt}
278 %files qt
279 %defattr(-,root,root)
280 %doc README
281 %{_libdir}/videolan/vlc/qt.so
282 %{_bindir}/qvlc
283 %{_menudir}/vlc-qt
284 %{_miconsdir}/qvlc.png
285 %{_iconsdir}/qvlc.png
286 %{_liconsdir}/qvlc.png
287 %post   qt
288 %update_menus
289 %postun qt
290 %update_menus
291 %endif
292
293 %files ncurses
294 %defattr(-,root,root)
295 %doc README
296 %{_libdir}/videolan/vlc/ncurses.so
297
298 %files sdl
299 %defattr(-,root,root)
300 %doc README
301 %{_libdir}/videolan/vlc/sdl.so
302
303 %files ggi
304 %defattr(-,root,root)
305 %doc README
306 %{_libdir}/videolan/vlc/ggi.so
307
308 %files esd
309 %defattr(-,root,root)
310 %doc README
311 %{_libdir}/videolan/vlc/esd.so
312
313 %if %{plugin_alsa}
314 %files alsa
315 %defattr(-,root,root)
316 %doc README
317 %{_libdir}/videolan/vlc/alsa.so
318 %endif
319
320 %changelog
321 * Thu Apr 06 2002 Samuel Hocevar <sam@zoy.org> 0.3.0
322 - version 0.3.0.
323 - removed libdvdcss from the whole tarball.
324 - removed the workaround for vlc's bad /dev/dsp detection.
325
326 * Thu Jan 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-2mdk
327 - readded libdvdcss rpm in specfile. use %%define css 1 with correct sources
328   to build libdvdcss rpm.
329
330 * Wed Jan 09 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-1mdk
331 - version 0.2.92
332 - %%makeinstall_std
333 - splitted again, added vlc-sdl vlc-esd vlc-ggi
334 - bring back some missing plugins
335 - fixed buildrequires
336 - added menu entries and icons (from cvs)
337
338 * Tue Oct 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-2mdk
339 - rebuild against libpng3
340 - added some doc for sir rpmlint
341 - #5583: option -g
342
343 * Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-1mdk
344 - version 0.2.83 : 
345   * Activated subtitles in overlay mode (far from perfect, but this
346     was an often requested feature).
347
348 * Fri Aug 10 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.82-1mdk
349 - version 0.2.82
350
351 * Mon Jul 30 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-1mdk
352 - version 0.2.81
353 - added vlc-ncurses
354
355 * Wed Jun 20 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-0.20010619-1mdk
356 - cvs snapshot
357 - added libdvdcss
358
359 * Wed Jun 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-2mdk
360 - fix build on ppc (c) dadou
361
362 * Mon Jun 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-1mdk
363 - version 0.2.80 : bug fixes and bug fixes and bug fixes and small
364   improvements of the gtk interface.
365 - corrected Summary in vlc-qt
366
367 * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-2mdk
368 - added qt2 plug-in (vlc-qt)
369
370 * Wed May 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-1mdk
371 - version 0.2.73
372 - you can now get decss threw a plug-in
373 - rewritte srcipt to build vlc (decss plugin)
374 - rebuild with SDL 1.2
375
376 * Thu Apr 26 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-2mdk
377 - true 0.2.72
378
379 * Mon Apr 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-1mdk
380 - version 0.2.72
381 - package split into vlc, vlc-gnome, vlc-gtk
382
383 * Fri Apr 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.71-1mdk
384 - version 0.2.71 :
385   * Fixed segfaults when compiled with gcc 3.0pre and versions of gcc
386     shipped with the latest RedHat distributions.                    
387   * Fixed the BeOS CSS decryption.
388   * Fixed a few issues in IFO parsing.
389   * Fixed XVideo video output.
390   * Updated icons under Linux, BeOS, MacOS X.
391
392 * Wed Apr 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.70-1mdk
393 - version 0.2.70
394
395 * Thu Mar 22 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.63-1mdk
396 - version 0.2.63 : Bugfixes, bugfixes, and bugfixes again, a Gtk+ 
397   interface for the Gnome-impaired, an even better DVD support
398
399 * Fri Feb 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.61-1mdk
400 - new version for all the DVD fans (add MPEG1 support, direct DVD support, 
401   DVD decryption, arbitrary, seeking in the stream, pause, fast forward 
402   and slow motion, hardware YUV acceleration enhanced CSS support and a few 
403   new interface features including drag'n'drop.
404 - first *real* public release (now under the GPL)
405
406 * Sat Jan 06 2001 David BAUDENS <baudens@mandrakesoft.com> 0.1.99i-2mdk
407 - Fix build and use right optimizations on PPC
408 - Enable SDL support
409 - Spec clean up
410
411 * Fri Jan  5 2001 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99i-1mdk
412 - 0.1.99i, rebuild
413
414 * Fri Aug 25 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99h-1mdk
415 - 0.1.99h
416
417 * Mon Jul 10 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99c-1mdk
418 - first Mandrake package with help of Sam