]> git.sesse.net Git - vlc/blob - vlc.spec
Updated for tentative 0.6.3 release.
[vlc] / vlc.spec
1 %define mozver 1.2,1
2
3 Summary: The VideoLAN client, also a very good standalone video player.
4 Name: vlc
5 Version: 0.6.3
6 Release: 1
7 Group: Applications/Multimedia
8 License: GPL
9 URL: http://www.videolan.org/
10 Source: http://www.videolan.org/pub/videolan/vlc/vlc-%{version}.tar.bz2
11 Buildroot: %{_tmppath}/%{name}-root
12 Packager: Jason Luka <jason@geshp.com>
13 Buildrequires: XFree86-devel, desktop-file-utils, libpostproc
14 %{!?_without_dvd:Buildrequires: libdvdcss-devel}
15 %{!?_without_dvdread:Buildrequires: libdvdread-devel}
16 %{!?_without_dvdplay:Buildrequires: libdvdplay-devel}
17 %{!?_without_dvbpsi:Buildrequires: libdvbpsi-devel}
18 %{!?_without_ogg:Buildrequires: libogg-devel}
19 %{!?_without_mad:Buildrequires: libmad}
20 %{!?_without_ffmpeg:Buildrequires: ffmpeg-devel}
21 %{!?_without_xvid:Buildrequires: xvidcore-devel}
22 %{!?_without_a52:Buildrequires: a52dec-devel}
23 %{!?_without_dv:Buildrequires: libdv-devel}
24 %{!?_without_flac:Buildrequires: flac-devel}
25 %{!?_without_vorbis:Buildrequires: libvorbis-devel}
26 %{!?_without_sdl:Buildrequires: SDL-devel}
27 %{!?_without_aa:Buildrequires: aalib-devel}
28 %{!?_without_esd:Buildrequires: esound-devel}
29 %{!?_without_arts:Buildrequires: arts-devel}
30 %{!?_without_alsa:Buildrequires: alsa-lib-devel}
31 %{!?_without_gtk:Buildrequires: gtk+-devel}
32 %{!?_without_gnome:Buildrequires: gnome-libs-devel}
33 %{!?_without_lirc:Buildrequires: lirc}
34 %{!?_without_qt:Buildrequires: qt-devel}
35 %{!?_without_kde:Buildrequires: kdelibs-devel}
36 %{!?_without_ncurses:Buildrequires: ncurses-devel >= 5}
37 %{!?_without_xosd:Buildrequires: xosd-devel}
38 %{!?_without_mozilla:BuildRequires: mozilla-devel}
39 %{!?_without_id3tag:BuildRequires: libid3tag-devel}
40 %{!?_without_mpeg2dec:BuildRequires: mpeg2dec-devel >= 0.3.2}
41 %{?_with_wxwindows:BuildRequires: wxGTK-devel >= 2.4.1}
42 %{!?_without_mozilla:BuildRequires: mozilla-devel = %{mozver}}
43 Obsoletes: videolan-client
44
45 Requires: XFree86, desktop-file-utils
46 %{!?_without_dvd:Requires: libdvdcss}
47 %{!?_without_dvdread:Requires: libdvdread}
48 %{!?_without_dvdplay:Requires: libdvdplay}
49 %{!?_without_dvbpsi:Requires: libdvbpsi}
50 #%%{!?_without_ogg:Requires: libogg}
51 %{!?_without_mad:Requires: libmad}
52 %{!?_without_ffmpeg:Requires: ffmpeg}
53 #%%{!?_without_xvid:Requires: xvidcore}
54 %{!?_without_a52:Requires: a52dec}
55 #%%{!?_without_dv:Requires: libdv}
56 #%%{!?_without_flac:Requires: flac}
57 #%%{!?_without_vorbis:Requires: libvorbis}
58 #%%{!?_without_sdl:Requires: SDL}
59 #%%{!?_without_aa:Requires: aalib}
60 #%%{!?_without_esd:Requires: esound}
61 #%%{!?_without_arts:Requires: arts}
62 #%%{!?_without_alsa:Requires: alsa-lib}
63 #%%{!?_without_gtk:Requires: gtk+}
64 #%%{!?_without_gnome:Requires: gnome-libs}
65 #%%{?_with_qt:Requires: qt}
66 #%%{?_with_kde:Requires: kdelibs}
67 #%%{?_with_ncurses:Requires: ncurses}
68 #%%{!?_without_xosd:Requires: xosd}
69 #%%{!?_without_lirc:Requires: lirc}
70 %{?_with_mozilla:Requires: mozilla = %{mozver}}
71
72 %description
73 VideoLAN Client (VLC) is a highly portable multimedia player for various
74 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
75 well as DVDs, VCDs, and various streaming protocols.
76
77 Available rpmbuild rebuild options :
78 --without dvd dvdread dvdplay dvbpsi dv v4l avi asf aac ogg rawdv mad ffmpeg xvid
79           mp4 a52 vorbis mpeg2dec flac aa esd arts gtk gnome xosd lsp lirc
80           pth id3tag dv qt kde ncurses faad
81
82 Options that would need not yet existing add-on packages :
83 --with tremor tarkin theora ggi glide svgalib mga
84
85 Options removed for better Red Hat compatibility
86 --with alsa wxwindows
87
88
89 %package devel
90 Summary: Header files and static library from the Videolan Client.
91 Group: Development/Libraries
92 Requires: %{name} = %{version}
93
94 %description devel
95 VideoLAN Client (VLC) is a highly portable multimedia player for various
96 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
97 well as DVDs, VCDs, and various streaming protocols.
98
99 Install this package if you need to build Videolan Client plugins or intend
100 to link statically to it.
101
102
103 %prep
104 %setup -q -n vlc-%{version}
105
106 %build
107 cp %{_libdir}/mozilla/plugins/plugger.so %{_libdir}/mozilla-%{mozver}/plugins/plugger.so.bak -f
108 mv %{_libdir}/mozilla-%{mozver}/plugins/plugger.so.bak %{_libdir}/mozilla-%{mozver}/plugins/plugger.so -f
109 rm %{_libdir}/mozilla -fr
110 ln %{_libdir}/mozilla-%{mozver} %{_libdir}/mozilla -sf
111 ln /usr/share/idl/mozilla-%{mozver} /usr/share/idl/mozilla -sf
112 ln %{_libdir}/libxvidcore.so.2 %{_libdir}/libxvidcore.so -sf
113
114 %configure \
115         --enable-release \
116         %{?_without_dvd:--disable-dvd} \
117         %{!?_without_dvdread:--enable-dvdread} \
118         %{!?_without_dvdplay:--enable-dvdplay} \
119         %{!?_without_dvbpsi:--enable-dvbpsi} \
120         %{!?_without_v4l:--enable-v4l} \
121         --enable-vcd \
122         %{?_without_avi:--disable-avi} \
123         %{?_without_asf:--disable-asf} \
124         %{?_without_aac:--disable-aac} \
125         %{?_without_ogg:--disable-ogg} \
126         %{?_without_rawdv:--disable-rawdv} \
127         %{!?_without_mad:--enable-mad} \
128         %{!?_without_ffmpeg:--enable-ffmpeg --with-ffmpeg=%{_prefix}} \
129         %{!?_without_faad:--enable-faad} \
130         %{!?_without_xvid:--enable-xvid} \
131         %{?_without_mp4:--disable-mp4} \
132         %{?_without_a52:--disable-a52} \
133         %{?_without_cinepak:--disable-cinepak} \
134         %{!?_without_dv:--enable-dv} \
135         %{!?_without_flac:--enable-flac} \
136         %{?_without_mpeg2dec:--disable-libmpeg2} \
137         %{?_without_vorbis:--disable-vorbis} \
138         %{?_with_tremor:--enable-tremor} \
139         %{?_with_tarkin:--enable-tarkin} \
140         %{!?_without_theora:--enable-theora} \
141         --enable-x11 \
142         --enable-xvideo \
143         %{?_without_sdl:--disable-sdl} \
144         --disable-qte \
145         --disable-directx \
146         --enable-fb \
147         %{?_with_mga:--enable-mga} \
148         %{?_with_svgalib:--enable-svgalib} \
149         %{?_with_ggi:--enable-ggi} \
150         %{?_with_glide:--enable-glide} \
151         %{!?_without_aa:--enable-aa} \
152         --without-wingdi \
153         --enable-oss \
154         %{!?_without_esd:--enable-esd} \
155         %{!?_without_arts:--enable-arts} \
156         %{?_with_alsa:--enable-alsa} \
157         --disable-waveout \
158         %{!?_without_gtk:--enable-gtk} \
159         --disable-familiar \
160         %{!?_without_gnome:--enable-gnome} \
161         %{!?_with_wxwindows:--disable-wxwindows} \
162         %{!?_without_qt:--enable-qt} \
163         %{!?_without_kde:--enable-kde} \
164         --disable-opie \
165         --disable-macosx \
166         --disable-qnx \
167         --disable-intfwin \
168         %{!?_without_ncurses:--enable-ncurses} \
169         %{!?_without_xosd:--enable-xosd} \
170         %{?_without_slp:--disable-slp} \
171         %{!?_without_lirc:--enable-lirc} \
172         %{!?_without_pth:--enable-pth} \
173         --disable-st \
174         %{!?_without_mozilla:--enable-mozilla} \
175         --disable-testsuite \
176         --enable-plugins
177 make %{?_smp_mflags}
178
179 %install
180 rm -rf %{buildroot}
181 %makeinstall
182 find  %{buildroot}%{_libdir}/vlc -name "*.so" | xargs strip
183 %find_lang vlc
184
185 cat > %{name}.desktop << EOF
186 [Desktop Entry]
187 Name=VideoLAN Media Player
188 Comment=%{summary}
189 Icon=%{_datadir}/vlc/vlc48x48.png
190 Exec=vlc
191 Terminal=0
192 Type=Application
193 EOF
194
195 mv %{buildroot}%{_libdir}/mozilla %{buildroot}%{_libdir}/mozilla-%{mozver} -f
196
197 mkdir -p %{buildroot}%{_datadir}/applications
198 desktop-file-install --vendor gnome --delete-original             \
199   --dir %{buildroot}%{_datadir}/applications                      \
200   --add-category X-Red-Hat-Base                                   \
201   --add-category Application                                      \
202   --add-category AudioVideo                                       \
203   %{name}.desktop
204
205 %post
206 ln /dev/cdrom /dev/dvd -sf
207 ln %{_libdir}/libxvidcore.so.2 %{_libdir}/libxvidcore.so -sf
208
209 %postun
210 rm -f /dev/dvd
211 rm /usr/share/idl/mozilla -fr
212 rm %{_libdir}/libxvidcore.so -f
213
214 %clean
215 rm -rf %{buildroot}
216 rm /usr/share/idl/mozilla -fr
217 rm /usr/lib/mozilla -fr
218 mkdir /usr/lib/mozilla/plugins -p --mode=755
219 mv %{_libdir}/mozilla-%{mozver}/plugins/plugger.so %{_libdir}/mozilla/plugins -f
220 rm %{_libdir}/libxvidcore.so -f
221
222 %files -f vlc.lang
223 %defattr(-, root, root)
224 %doc AUTHORS COPYING ChangeLog MAINTAINERS README THANKS
225 %doc doc/fortunes.txt doc/web-streaming.html
226 %{_bindir}/*vlc
227 %{_libdir}/vlc
228 %{_libdir}/libvlc_pic.a
229 %{_libdir}/mozilla-%{mozver}/components/vlcintf.xpt
230 %{_libdir}/mozilla-%{mozver}/plugins/libvlcplugin.so
231 %{_datadir}/applications/gnome-%{name}.desktop
232 %{_datadir}/vlc
233
234 %files devel
235 %defattr(-, root, root)
236 %doc HACKING 
237 %{_bindir}/vlc-config
238 %{_includedir}/vlc
239 %{_libdir}/libvlc.a
240
241 %changelog
242 * Thu Sep 20 2003 Jason Luka
243 - Removed wxinterface because it's redundant
244 - Removed alsa support because it's not needed in Red Hat
245
246 * Mon Aug 25 2003 Jason Luka
247 - Added matroska support
248 - Corrected some symlinking problems with the mozilla plugin
249
250 * Fri Aug 22 2003 Jason Luka <jason@geshp.com>
251 - Update to 0.6.2
252 - Changed menu item name to VideoLAN Media Player
253 - Added openslp support
254 - Added libtar support (needed for skins)
255 - Added symlink to libxvidcore.so, thanks to new version of that software
256
257 * Fri Aug 1 2003 Jason Luka <jason@geshp.com>
258 - Update to 0.6.1
259 - Fixed file structure problems I created to accomodate the mozilla plugin
260 - Changed vendor name for desktop install
261 - Moved vlc to base menu
262 - Moved plugins from /usr/lib/mozilla to /usr/lib/mozilla-x.x.x
263 - Added custom patch to accomodate mozilla plugin
264 - Added execution of bootstrap since Makefile.am was altered
265
266 * Tue Jul 8 2003 Jason Luka <jason@geshp.com>
267 - Update to 0.6.0
268 - Add id3lib, dv, faad, qt, kde, and mozilla plugin support
269 - Added script to symlink mozilla-1.2.1 directories to mozilla so build can complete
270
271 * Sat Apr 5 2003 Jason Luka <jason@geshp.com>
272 - Rebuilt for Red Hat 9
273 - Changed dependencies for ffmpeg's new name
274 - Required lirc support at build-time 
275
276 * Sat Mar 25 2003 Jason Luka <jason@geshp.com>
277 - Fixed Buildrequire statements to require all plugins at compile-time
278 - Fixed Require statements so users don't have to install every plugin
279
280 * Thu Mar 23 2003 Jason Luka <jason@geshp.com>
281 - Renamed ffmpeg to libffmpeg
282 - Rebuilt for videolan site
283 - Autolinked /dev/dvd to /dev/cdrom
284
285 * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
286 - Update to 0.5.2.
287 - Fix the dv build dependency, thanks to Alan Hagge.
288 - Added flac support.
289 - Fixed the libdvbpsi requirements.
290
291 * Mon Feb 24 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
292 - Rebuilt against the new xosd lib.
293
294 * Wed Feb 19 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
295 - Update to 0.5.1.
296 - Major spec file update.
297
298 * Fri Nov 15 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
299 - Update to 0.4.6.
300
301 * Tue Oct 22 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
302 - Update to 0.4.5.
303 - Minor --with / --without adjustments.
304
305 * Sun Oct  6 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
306 - Rebuilt for Red Hat Linux 8.0.
307 - New menu entry.
308 - Added all --without options and --with qt.
309
310 * Mon Aug 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
311 - Update to 0.4.4.
312
313 * Fri Jul 26 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
314 - Update to 0.4.3.
315
316 * Fri Jul 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
317 - Update to 0.4.2.
318
319 * Wed Jun  5 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
320 - Update to 0.4.1.
321
322 * Fri May 24 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
323 - Update to 0.4.0.
324 - Disabled qt interface, it's hell to build with qt2/3!
325 - Use %%find_lang and %%{?_smp_mflags}.
326
327 * Fri Apr 19 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
328 - Update to 0.3.1.
329
330 * Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
331 - Update to 0.3.0.
332
333 * Sat Jan 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
334 - Removed the dependency on libdvdcss package, use the built in one instead,
335   because 1.x.x is not as good as 0.0.3.ogle3.
336
337 * Tue Jan  1 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
338 - Update to 0.2.92.
339 - Build fails with libdvdcss < 1.0.1.
340
341 * Tue Nov 13 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
342 - Update to 0.2.91 and now requires libdvdcss 1.0.0.
343
344 * Mon Oct 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
345 - Split libdvdcss into a separate package since it's also needed by the
346   xine menu plugin.
347
348 * Thu Oct 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
349 - Updated to 0.2.90.
350 - Removed ggi, svgalib and aalib since they aren't included in Red Hat 7.2.
351
352 * Mon Aug 27 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
353 - Updated to 0.2.83.
354
355 * Sat Aug 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
356 - Updated to 0.2.82.
357
358 * Mon Jul 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
359 - Updated to 0.2.81.
360 - Added all the new split libdvdcss.* files to the %%files section.
361
362 * Tue Jun  5 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
363 - Updated to the latest release, 0.2.80.
364
365 * Wed May 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
366 - Updated to today's CVS version, works great! :-)
367 - Fixed the desktop menu entry.
368
369 * Tue May 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
370 - Spec file cleanup to make it look more like others do.
371 - Added the use of many macros.
372 - Disabled automatic requires and provides (the package always needed qt,
373   gtk+, gnome etc. otherwise).
374 - Added a system desktop menu entry.
375
376 * Mon Apr 30 2001 Arnaud Gomes-do-Vale <arnaud@glou.org>
377 Added relocation support and compile fixes for Red Hat 7.x.
378
379 * Sat Apr 28 2001 Henri Fallon <henri@videolan.org>
380 New upstream release (0.2.73)
381
382 * Mon Apr 16 2001 Samuel Hocevar <sam@zoy.org>
383 New upstream release (0.2.72)
384
385 * Fri Apr 13 2001 Samuel Hocevar <sam@zoy.org>
386 New upstream release (0.2.71)
387
388 * Sun Apr 8 2001 Christophe Massiot <massiot@via.ecp.fr>
389 New upstream release (0.2.70)
390
391 * Fri Feb 16 2001 Samuel Hocevar <sam@via.ecp.fr>
392 New upstream release
393
394 * Tue Aug  8 2000 Samuel Hocevar <sam@via.ecp.fr>
395 Added framebuffer support
396
397 * Sun Jun 18 2000 Samuel Hocevar <sam@via.ecp.fr>
398 Took over the package
399
400 * Thu Jun 15 2000 Eric Doutreleau <Eric.Doutreleau@int-evry.fr>
401 Initial package
402