]> git.sesse.net Git - vlc/blob - vlc.spec
Bumped up revision number to 0.2.92-dev and 1.0.1-dev.
[vlc] / vlc.spec
1 # This is borrowed and adapted from Mandrake's Cooker
2 %define name    vlc
3 %define vlc_ver 0.2.92-dev
4 %define version %vlc_ver
5
6 # libdvdcss
7 %define major   0
8 %define lib_ver 1.0.1-dev
9 %define lib_name libdvdcss%{major}
10
11 %define cvs     0
12
13 %if %{cvs}
14 %define cvsdate 20011002
15 %define release 0.%{cvsdate}
16 %define cvs_name %{name}-snapshot-%{cvsdate}-00
17 %else
18 %define release 1
19 %endif
20
21 Summary:        VideoLAN is a free MPEG, MPEG-2 and DVD software solution.
22 Name:           %{name}
23 Version:        %{version}
24 Release:        %{release}
25
26 %if %{cvs} 
27 Source0:        http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.bz2
28 %else
29 Source0:        http://www.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
30 %endif
31 License:        GPL
32 Group:          Video
33 URL:            http://videolan.org/
34 BuildRoot:      %_tmppath/%name-%version-%release-root
35 #This is for Mandrake :
36 #Buildrequires: libncurses5-devel
37 #Buildrequires: libqt2-devel
38 #Buildrequires: libgtk+1.2-devel
39 #Buildrequires: gnome-libs-devel
40 #Buildrequires: db1-devel
41 #This is for RedHat :
42 Buildrequires: ncurses-devel
43 Buildrequires: qt-devel
44 Buildrequires: gtk+-devel
45 Buildrequires: gnome-libs-devel
46 Buildrequires: SDL-devel
47 Buildrequires: db1
48
49 %description
50 VideoLAN is a free network-aware MPEG and DVD player.
51 The VideoLAN Client allows to play MPEG-2 Transport Streams from the
52 network or from a file, as well as direct DVD playback.
53 VideoLAN is a project of students from the Ecole Centrale Paris.
54 This version add MPEG-1 support, direct DVD support, DVD decryption, 
55 arbitrary, seeking in the stream, pause, fast forward and slow motion, 
56 hardware YUV acceleration and a few new interface features 
57 including drag'n'drop.
58 You may install vlc-gnome, vlc-gtk and vlc-qt vlc-gnome vlc-ncurses.
59
60 %package gtk
61 Summary: Gtk plug-in for VideoLAN, a DVD and MPEG-2 player
62 Group: Video
63 Requires: %{name} = %{version}
64 %description gtk
65 The vlc-gtk packages includes the Gtk plug-in for the VideoLAN client.
66 If you are going to watch DVD with the Gtk front-end, you should 
67 install vlc-gtk.
68
69
70 %package gnome
71 Summary: Gnome plug-in for VideoLAN, a DVD and MPEG-2 player
72 Group: Video
73 Requires: %{name} = %{version}
74 %description gnome
75 The vlc-gnome packages includes the Gnome plug-in for the VideoLAN client.
76 If you are going to watch DVD with the Gnome front-end, you should 
77 install vlc-gnome.
78
79 %package qt
80 Summary: Qt2 plug-in for VideoLAN, a DVD and MPEG-2 player
81 Group: Video
82 Requires: %{name} = %{version}
83 %description qt
84 The vlc-qt packages includes the Qt2 plug-in for the VideoLAN client.
85 If you are going to watch DVD with the Qt2 front-end, you should
86 install vlc-qt
87
88 %package ncurses
89 Summary: Ncurses console-based plug-in for VideoLAN, a DVD and MPEG-2 player
90 Group: Video
91 Requires: %{name} = %{version}
92 %description ncurses
93 The vlc-ncurses packages includes the ncurses plug-in for the VideoLAN client.
94 If you are going to watch DVD with the ncurses front-end, you should
95 install vlc-ncurses
96
97
98 %prep
99 %if %{cvs}
100 %setup -q -n %{cvs_name}
101 %else
102 %setup -q -n %{name}-%{vlc_ver}
103 %endif
104
105 %build
106 export QTDIR=%{_libdir}/qt-2.3.0/
107 %configure --enable-release --with-dvdcss=local-shared \
108            --enable-gnome --enable-gtk \
109            --enable-x11 --enable-qt --enable-ncurses \
110            --enable-esd --disable-alsa \
111            --enable-fb \
112            --enable-xvideo \
113            --enable-sdl 
114 make
115
116 %install
117 %makeinstall
118 install -d %buildroot/%_mandir/man1
119 install doc/vlc.1 %buildroot/%_mandir/man1
120
121 %clean
122 rm -fr %buildroot
123
124 %files
125 %defattr(-,root,root,-)
126 %doc README COPYING FAQ AUTHORS
127 %{_bindir}/vlc
128
129 %{_libdir}/videolan/vlc/dsp.so
130 %{_libdir}/videolan/vlc/esd.so
131 %{_libdir}/videolan/vlc/fb.so
132 %{_libdir}/videolan/vlc/sdl.so
133 %{_libdir}/videolan/vlc/x*.so
134
135 %dir %{_datadir}/videolan
136 %{_datadir}/videolan/*
137 %{_mandir}/man1/*
138
139 %files gtk
140 %defattr(-,root,root)
141 %{_libdir}/videolan/vlc/gtk.so
142 %{_bindir}/gvlc
143
144 %files gnome
145 %defattr(-,root,root)
146 %{_libdir}/videolan/vlc/gnome.so
147 %{_bindir}/gnome-vlc
148
149 %files qt
150 %defattr(-,root,root)
151 %{_libdir}/videolan/vlc/qt.so
152 %{_bindir}/qvlc
153
154 %files ncurses
155 %defattr(-,root,root)
156 %{_libdir}/videolan/vlc/ncurses.so
157
158
159 %changelog
160 * Mon Nov 12 2001 Christophe Massiot <massiot@via.ecp.fr> 0.2.91-1
161 - version 0.2.91
162
163 * Wed Oct 10 2001 Christophe Massiot <massiot@via.ecp.fr> 0.2.90-1
164 - version 0.2.90
165
166 * Tue Oct 02 2001 Christophe Massiot <massiot@via.ecp.fr>
167 - Imported Mandrake's vlc.spec into the CVS
168
169 * Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-1mdk
170 - version 0.2.83 : 
171   * Activated subtitles in overlay mode (far from perfect, but this
172     was an often requested feature).
173
174 * Fri Aug 10 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.82-1mdk
175 - version 0.2.82
176
177 * Mon Jul 30 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-1mdk
178 - version 0.2.81
179 - added vlc-ncurses
180
181 * Wed Jun 20 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-0.20010619-1mdk
182 - cvs snapshot
183 - added libdvdcss
184
185 * Wed Jun 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-2mdk
186 - fix build on ppc (c) dadou
187
188 * Mon Jun 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-1mdk
189 - version 0.2.80 : bug fixes and bug fixes and bug fixes and small
190   improvements of the gtk interface.
191 - corrected Summary in vlc-qt
192
193 * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-2mdk
194 - added qt2 plug-in (vlc-qt)
195
196 * Wed May 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-1mdk
197 - version 0.2.73
198 - you can now get decss threw a plug-in
199 - rewritte srcipt to build vlc (decss plugin)
200 - rebuild with SDL 1.2
201
202 * Thu Apr 26 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-2mdk
203 - true 0.2.72
204
205 * Mon Apr 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-1mdk
206 - version 0.2.72
207 - package split into vlc, vlc-gnome, vlc-gtk
208
209 * Fri Apr 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.71-1mdk
210 - version 0.2.71 :
211   * Fixed segfaults when compiled with gcc 3.0pre and versions of gcc
212     shipped with the latest RedHat distributions.                    
213   * Fixed the BeOS CSS decryption.
214   * Fixed a few issues in IFO parsing.
215   * Fixed XVideo video output.
216   * Updated icons under Linux, BeOS, MacOS X.
217
218 * Wed Apr 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.70-1mdk
219 - version 0.2.70
220
221 * Thu Mar 22 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.63-1mdk
222 - version 0.2.63 : Bugfixes, bugfixes, and bugfixes again, a Gtk+ 
223   interface for the Gnome-impaired, an even better DVD support
224
225 * Fri Feb 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.61-1mdk
226 - new version for all the DVD fans (add MPEG1 support, direct DVD support, 
227   DVD decryption, arbitrary, seeking in the stream, pause, fast forward 
228   and slow motion, hardware YUV acceleration enhanced CSS support and a few 
229   new interface features including drag'n'drop.
230 - first *real* public release (now under the GPL)
231
232 * Sat Jan 06 2001 David BAUDENS <baudens@mandrakesoft.com> 0.1.99i-2mdk
233 - Fix build and use right optimizations on PPC
234 - Enable SDL support
235 - Spec clean up
236
237 * Fri Jan  5 2001 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99i-1mdk
238 - 0.1.99i, rebuild
239
240 * Fri Aug 25 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99h-1mdk
241 - 0.1.99h
242
243 * Mon Jul 10 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99c-1mdk
244 - first Mandrake package with help of Sam