]> git.sesse.net Git - vlc/blob - vlc.spec
- Updated matroska/ebml fix
[vlc] / vlc.spec
1 %define mozver 1.4.1
2
3 Summary: The VideoLAN client, also a very good standalone video player.
4 Name: vlc
5 Version: 0.7.0
6 Release: test1
7 Group: Applications/Multimedia
8 License: GPL
9 URL: http://www.videolan.org/
10 Source: http://www.videolan.org/pub/videolan/vlc/vlc-%{version}-%{release}.tar.bz2
11 Buildroot: %{_tmppath}/%{name}-root
12 Packager: Jason Luka <jason@geshp.com>
13 Buildrequires: XFree86-devel, desktop-file-utils, libpostproc >= 1.0
14 %{!?_without_dvd:Buildrequires: libdvdcss-devel >= 1.2.8}
15 %{!?_without_dvdread:Buildrequires: libdvdread-devel >= 0.9.4}
16 %{!?_without_dvdplay:Buildrequires: libdvdplay-devel >= 1.0.1}
17 %{!?_without_dvbpsi:Buildrequires: libdvbpsi-devel >= 0.1.3}
18 %{!?_without_ogg:Buildrequires: libogg-devel}
19 %{!?_without_mad:Buildrequires: libmad-devel >= 0.15.0b}
20 %{!?_without_ffmpeg:Buildrequires: ffmpeg-devel}
21 %{!?_without_xvid:Buildrequires: xvidcore-devel >= 0.9.2}
22 %{!?_without_a52:Buildrequires: a52dec-devel}
23 %{!?_without_dv:Buildrequires: libdv-devel >= 0.99}
24 %{!?_without_flac:Buildrequires: flac-devel >= 1.1.0}
25 %{!?_without_vorbis:Buildrequires: libvorbis-devel}
26 %{!?_without_sdl:Buildrequires: SDL-devel}
27 %{!?_without_aa:Buildrequires: aalib-devel}
28 %{!?_without_esd:Buildrequires: esound-devel}
29 %{!?_without_arts:Buildrequires: arts-devel}
30 #%%{!?_without_alsa:Buildrequires: alsa-lib-devel}
31 %{!?_without_gtk:Buildrequires: gtk+-devel}
32 %{!?_without_gnome:Buildrequires: gnome-libs-devel}
33 %{!?_without_lirc:Buildrequires: lirc}
34 %{!?_without_qt:Buildrequires: qt-devel}
35 %{!?_without_kde:Buildrequires: kdelibs-devel}
36 %{!?_without_ncurses:Buildrequires: ncurses-devel >= 5}
37 %{!?_without_xosd:Buildrequires: xosd-devel >= 2.2.5}
38 %{!?_without_id3tag:BuildRequires: libid3tag-devel}
39 %{!?_without_mpeg2dec:BuildRequires: mpeg2dec-devel >= 0.3.2}
40 %{!?_without_wxwindows:BuildRequires: wxGTK-devel >= 2.4.2}
41 %{!?_without_mozilla:BuildRequires: mozilla-devel >= %{mozver}}
42 %{!?_without_mozilla:BuildRequires: mozplugger >= 1.3.2}
43 %{!?_without_speex:BuildRequires: speex-devel >= 1.0.3}
44 %{!?_without_aa:BuildRequires: aalib >= 1.4}
45
46 Obsoletes: videolan-client
47
48 Requires: XFree86, desktop-file-utils
49 %{!?_without_dvd:Requires: libdvdcss >= 1.2.8}
50 %{!?_without_dvdread:Requires: libdvdread >= 0.9.4}
51 %{!?_without_dvdplay:Requires: libdvdplay >= 1.0.1}
52 %{!?_without_dvbpsi:Requires: libdvbpsi >= 0.1.3}
53 %{!?_without_ogg:Requires: libogg}
54 %{!?_without_mad:Requires: libmad >= 0.15.0b}
55 %{!?_without_ffmpeg:Requires: ffmpeg}
56 %{!?_without_xvid:Requires: xvidcore >= 0.9.2}
57 %{!?_without_a52:Requires: a52dec}
58 %{!?_without_dv:Requires: libdv >= 0.99}
59 %{!?_without_flac:Requires: flac >= 1.1.0}
60 %{!?_without_vorbis:Requires: libvorbis}
61 %{!?_without_sdl:Requires: SDL}
62 %{!?_without_aa:Requires: aalib >= 1.4}
63 %{!?_without_esd:Requires: esound}
64 %{!?_without_arts:Requires: arts}
65 #%%{!?_without_alsa:Requires: alsa-lib}
66 %{!?_without_gtk:Requires: gtk+}
67 %{!?_without_gnome:Requires: gnome-libs}
68 %{?_with_qt:Requires: qt}
69 %{?_with_kde:Requires: kdelibs}
70 %{?_with_ncurses:Requires: ncurses}
71 %{!?_without_xosd:Requires: xosd >= 2.2.5}
72 %{!?_without_lirc:Requires: lirc}
73 %{!?_without_mozilla:Requires: mozilla >= %{mozver}}
74 %{!?_without_speex:Requires: speex >= 1.0.3}
75 %{!?_without_wxwindows:Requires: wxGTK >= 2.4.2}
76
77 %description
78 VideoLAN Client (VLC) is a highly portable multimedia player for various
79 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
80 well as DVDs, VCDs, and various streaming protocols.
81
82 Available rpmbuild rebuild options :
83 --without dvd dvdread dvdplay dvbpsi dv v4l avi asf aac ogg rawdv mad ffmpeg xvid
84           mp4 a52 vorbis mpeg2dec flac aa esd arts alsa gtk gnome xosd lsp lirc
85           pth id3tag dv qt kde ncurses faad wxwindows
86
87 Options that would need not yet existing add-on packages :
88 --with tremor tarkin theora ggi glide svgalib mga
89
90
91 %package devel
92 Summary: Header files and static library from the Videolan Client.
93 Group: Development/Libraries
94 Requires: %{name} = %{version}
95
96 %description devel
97 VideoLAN Client (VLC) is a highly portable multimedia player for various
98 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...) as
99 well as DVDs, VCDs, and various streaming protocols.
100
101 Install this package if you need to build Videolan Client plugins or intend
102 to link statically to it.
103
104
105 %prep
106 %setup -q -n vlc-%{version}-%{release}
107
108 %build
109 cp %{_libdir}/mozilla/plugins/mozplugger.so %{_libdir}/mozilla-%{mozver}/plugins/mozplugger.so.bak -f
110 mv %{_libdir}/mozilla-%{mozver}/plugins/mozplugger.so.bak %{_libdir}/mozilla-%{mozver}/plugins/mozplugger.so -f
111 rm %{_libdir}/mozilla -fr
112 ln %{_libdir}/mozilla-%{mozver} %{_libdir}/mozilla -sf
113 ln /usr/share/idl/mozilla-%{mozver} /usr/share/idl/mozilla -sf
114 #ln %{_libdir}/libxvidcore.so.2 %{_libdir}/libxvidcore.so -sf
115
116 %configure \
117         --enable-release \
118         %{?_without_dvd:--disable-dvd} \
119         %{!?_without_dvdread:--enable-dvdread} \
120         %{!?_without_dvdplay:--enable-dvdplay} \
121         %{!?_without_dvbpsi:--enable-dvbpsi} \
122         %{!?_without_v4l:--enable-v4l} \
123         --enable-vcd \
124         %{?_without_avi:--disable-avi} \
125         %{?_without_asf:--disable-asf} \
126         %{?_without_aac:--disable-aac} \
127         %{?_without_ogg:--disable-ogg} \
128         %{?_without_rawdv:--disable-rawdv} \
129         %{!?_without_mad:--enable-mad} \
130         %{!?_without_ffmpeg:--enable-pp --enable-ffmpeg --with-ffmpeg=%{_prefix}} \
131         %{!?_without_faad:--enable-faad} \
132         %{!?_without_xvid:--enable-xvid} \
133         %{?_without_mp4:--disable-mp4} \
134         %{?_without_a52:--disable-a52} \
135         %{?_without_cinepak:--disable-cinepak} \
136         %{!?_without_dv:--enable-dv} \
137         %{!?_without_flac:--enable-flac} \
138         %{?_without_mpeg2dec:--disable-libmpeg2} \
139         %{?_without_vorbis:--disable-vorbis} \
140         %{?_with_tremor:--enable-tremor} \
141         %{?_with_tarkin:--enable-tarkin} \
142         %{!?_without_theora:--enable-theora} \
143         --enable-x11 \
144         --enable-xvideo \
145         %{?_without_sdl:--disable-sdl} \
146         --disable-qte \
147         --disable-directx \
148         --enable-fb \
149         %{?_with_mga:--enable-mga} \
150         %{?_with_svgalib:--enable-svgalib} \
151         %{?_with_ggi:--enable-ggi} \
152         %{?_with_glide:--enable-glide} \
153         %{!?_without_aa:--enable-aa} \
154         --without-wingdi \
155         --enable-oss \
156         %{!?_without_esd:--enable-esd} \
157         %{!?_without_arts:--enable-arts} \
158         %{?_with_alsa:--enable-alsa} \
159         --disable-waveout \
160         %{!?_without_gtk:--enable-gtk} \
161         --disable-familiar \
162         %{!?_without_gnome:--enable-gnome} \
163         %{?_without_wxwindows:--disable-wxwindows} \
164         %{!?_without_qt:--enable-qt} \
165         %{!?_without_kde:--enable-kde} \
166         --disable-opie \
167         --disable-macosx \
168         --disable-qnx \
169         --disable-intfwin \
170         %{!?_without_ncurses:--enable-ncurses} \
171         %{!?_without_xosd:--enable-xosd} \
172         %{?_without_slp:--disable-slp} \
173         %{!?_without_lirc:--enable-lirc} \
174         %{!?_without_pth:--enable-pth} \
175         --disable-st \
176         %{!?_without_mozilla:--enable-mozilla} \
177         %{?_without_speex:--disable-speex} \
178         --disable-testsuite \
179         --enable-plugins
180 make %{?_smp_mflags}
181
182 %install
183 rm -rf %{buildroot}
184 %makeinstall
185 find  %{buildroot}%{_libdir}/vlc -name "*.so" | xargs strip
186 %find_lang vlc
187
188 cat > %{name}.desktop << EOF
189 [Desktop Entry]
190 Name=VideoLAN Media Player
191 Comment=%{summary}
192 Icon=%{_datadir}/vlc/vlc48x48.png
193 Exec=vlc
194 Terminal=0
195 Type=Application
196 EOF
197
198 mv %{buildroot}%{_libdir}/mozilla %{buildroot}%{_libdir}/mozilla-%{mozver} -f
199
200 mkdir -p %{buildroot}%{_datadir}/applications
201 desktop-file-install --vendor gnome --delete-original             \
202   --dir %{buildroot}%{_datadir}/applications                      \
203   --add-category X-Red-Hat-Base                                   \
204   --add-category Application                                      \
205   --add-category AudioVideo                                       \
206   %{name}.desktop
207
208 %post
209 ln /dev/cdrom /dev/dvd -sf
210
211 %postun
212 rm -f /dev/dvd
213 rm /usr/share/idl/mozilla -fr
214
215 %clean
216 rm -rf %{buildroot}
217 rm /usr/share/idl/mozilla -fr
218 rm /usr/lib/mozilla -fr
219 mkdir /usr/lib/mozilla/plugins -p --mode=755
220 mv %{_libdir}/mozilla-%{mozver}/plugins/mozplugger.so %{_libdir}/mozilla/plugins -f
221
222 %files -f vlc.lang
223 %defattr(-, root, root)
224 %doc AUTHORS COPYING ChangeLog MAINTAINERS README THANKS
225 %doc doc/fortunes.txt doc/web-streaming.html doc/intf-vcd.txt doc/vlc-howto.sgml
226 %doc doc/bugreport-howto.txt
227 %exclude %{_datadir}/doc/vlc/*
228 %{_bindir}/*vlc
229 %{_libdir}/vlc
230 %{_libdir}/libvlc_pic.a
231 %{_libdir}/mozilla-%{mozver}/components/vlcintf.xpt
232 %{_libdir}/mozilla-%{mozver}/plugins/libvlcplugin.so
233 %{_datadir}/applications/gnome-%{name}.desktop
234 %{_datadir}/vlc
235
236 %files devel
237 %defattr(-, root, root)
238 %doc HACKING 
239 %{_bindir}/vlc-config
240 %{_includedir}/vlc
241 %{_libdir}/libvlc.a
242
243 %changelog
244 * Sat Nov 29 2003 Jason Luka
245 - Fixed Matroska/EBML problem
246 - Updated script for mozilla plugin installation
247
248 * Fri Nov 28 2003 Jason Luka
249 - Update to 0.7.0-test1
250 - Updated version numbers on dependancies
251 - Removed ALSA support until RH/FC turns to kernel 2.6
252 - Added --enable-speex and --enable-pp
253 - Mozilla plugin now built for 1.4.1
254 - Currently broken (Matroska/EBML problems)
255
256 * Mon Aug 25 2003 Jason Luka
257 - Added matroska support
258 - Corrected some symlinking problems with the mozilla plugin
259
260 * Fri Aug 22 2003 Jason Luka <jason@geshp.com>
261 - Update to 0.6.2
262 - Changed menu item name to VideoLAN Media Player
263 - Added openslp support
264 - Added libtar support (needed for skins)
265 - Added symlink to libxvidcore.so, thanks to new version of that software
266
267 * Fri Aug 1 2003 Jason Luka <jason@geshp.com>
268 - Update to 0.6.1
269 - Fixed file structure problems I created to accomodate the mozilla plugin
270 - Changed vendor name for desktop install
271 - Moved vlc to base menu
272 - Moved plugins from /usr/lib/mozilla to /usr/lib/mozilla-x.x.x
273 - Added custom patch to accomodate mozilla plugin
274 - Added execution of bootstrap since Makefile.am was altered
275
276 * Tue Jul 8 2003 Jason Luka <jason@geshp.com>
277 - Update to 0.6.0
278 - Add id3lib, dv, faad, qt, kde, and mozilla plugin support
279 - Added script to symlink mozilla-1.2.1 directories to mozilla so build can complete
280
281 * Sat Apr 5 2003 Jason Luka <jason@geshp.com>
282 - Rebuilt for Red Hat 9
283 - Changed dependencies for ffmpeg's new name
284 - Required lirc support at build-time 
285
286 * Sat Mar 25 2003 Jason Luka <jason@geshp.com>
287 - Fixed Buildrequire statements to require all plugins at compile-time
288 - Fixed Require statements so users don't have to install every plugin
289
290 * Thu Mar 23 2003 Jason Luka <jason@geshp.com>
291 - Renamed ffmpeg to libffmpeg
292 - Rebuilt for videolan site
293 - Autolinked /dev/dvd to /dev/cdrom
294
295 * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
296 - Update to 0.5.2.
297 - Fix the dv build dependency, thanks to Alan Hagge.
298 - Added flac support.
299 - Fixed the libdvbpsi requirements.
300
301 * Mon Feb 24 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
302 - Rebuilt against the new xosd lib.
303
304 * Wed Feb 19 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
305 - Update to 0.5.1.
306 - Major spec file update.
307
308 * Fri Nov 15 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
309 - Update to 0.4.6.
310
311 * Tue Oct 22 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
312 - Update to 0.4.5.
313 - Minor --with / --without adjustments.
314
315 * Sun Oct  6 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
316 - Rebuilt for Red Hat Linux 8.0.
317 - New menu entry.
318 - Added all --without options and --with qt.
319
320 * Mon Aug 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
321 - Update to 0.4.4.
322
323 * Fri Jul 26 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
324 - Update to 0.4.3.
325
326 * Fri Jul 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
327 - Update to 0.4.2.
328
329 * Wed Jun  5 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
330 - Update to 0.4.1.
331
332 * Fri May 24 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
333 - Update to 0.4.0.
334 - Disabled qt interface, it's hell to build with qt2/3!
335 - Use %%find_lang and %%{?_smp_mflags}.
336
337 * Fri Apr 19 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
338 - Update to 0.3.1.
339
340 * Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
341 - Update to 0.3.0.
342
343 * Sat Jan 12 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
344 - Removed the dependency on libdvdcss package, use the built in one instead,
345   because 1.x.x is not as good as 0.0.3.ogle3.
346
347 * Tue Jan  1 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
348 - Update to 0.2.92.
349 - Build fails with libdvdcss < 1.0.1.
350
351 * Tue Nov 13 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
352 - Update to 0.2.91 and now requires libdvdcss 1.0.0.
353
354 * Mon Oct 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
355 - Split libdvdcss into a separate package since it's also needed by the
356   xine menu plugin.
357
358 * Thu Oct 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
359 - Updated to 0.2.90.
360 - Removed ggi, svgalib and aalib since they aren't included in Red Hat 7.2.
361
362 * Mon Aug 27 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
363 - Updated to 0.2.83.
364
365 * Sat Aug 11 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
366 - Updated to 0.2.82.
367
368 * Mon Jul 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
369 - Updated to 0.2.81.
370 - Added all the new split libdvdcss.* files to the %%files section.
371
372 * Tue Jun  5 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
373 - Updated to the latest release, 0.2.80.
374
375 * Wed May 30 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
376 - Updated to today's CVS version, works great! :-)
377 - Fixed the desktop menu entry.
378
379 * Tue May 22 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
380 - Spec file cleanup to make it look more like others do.
381 - Added the use of many macros.
382 - Disabled automatic requires and provides (the package always needed qt,
383   gtk+, gnome etc. otherwise).
384 - Added a system desktop menu entry.
385
386 * Mon Apr 30 2001 Arnaud Gomes-do-Vale <arnaud@glou.org>
387 Added relocation support and compile fixes for Red Hat 7.x.
388
389 * Sat Apr 28 2001 Henri Fallon <henri@videolan.org>
390 New upstream release (0.2.73)
391
392 * Mon Apr 16 2001 Samuel Hocevar <sam@zoy.org>
393 New upstream release (0.2.72)
394
395 * Fri Apr 13 2001 Samuel Hocevar <sam@zoy.org>
396 New upstream release (0.2.71)
397
398 * Sun Apr 8 2001 Christophe Massiot <massiot@via.ecp.fr>
399 New upstream release (0.2.70)
400
401 * Fri Feb 16 2001 Samuel Hocevar <sam@via.ecp.fr>
402 New upstream release
403
404 * Tue Aug  8 2000 Samuel Hocevar <sam@via.ecp.fr>
405 Added framebuffer support
406
407 * Sun Jun 18 2000 Samuel Hocevar <sam@via.ecp.fr>
408 Took over the package
409
410 * Thu Jun 15 2000 Eric Doutreleau <Eric.Doutreleau@int-evry.fr>
411 Initial package
412