]> git.sesse.net Git - vlc/blob - vlc.spec
* 0.2.90 release.
[vlc] / vlc.spec
1 # This is borrowed and adapted from Mandrake's Cooker
2 %define name    vlc
3 %define vlc_ver 0.2.90
4 %define version %vlc_ver
5
6 # libdvdcss
7 %define major   0
8 %define lib_ver 0.0.3
9 %define lib_name libdvdcss%{major}
10
11 %define cvs     0
12
13 %if %{cvs}
14 %define cvsdate 20011002
15 %define release 0.%{cvsdate}
16 %define cvs_name %{name}-snapshot-%{cvsdate}-00
17 %else
18 %define release 1
19 %endif
20
21 Summary:        VideoLAN is a free MPEG, MPEG-2 and DVD software solution.
22 Name:           %{name}
23 Version:        %{version}
24 Release:        %{release}
25
26 %if %{cvs} 
27 Source0:        http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.bz2
28 %else
29 Source0:        http://www.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
30 %endif
31 License:        GPL
32 Group:          Video
33 URL:            http://videolan.org/
34 BuildRoot:      %_tmppath/%name-%version-%release-root
35 #This is for Mandrake :
36 #Buildrequires: libncurses5-devel
37 #Buildrequires: libqt2-devel
38 #Buildrequires: libgtk+1.2-devel
39 #Buildrequires: gnome-libs-devel
40 #Buildrequires: db1-devel
41 #This is for RedHat :
42 Buildrequires: ncurses-devel
43 Buildrequires: qt2-devel
44 Buildrequires: gtk+-devel
45 Buildrequires:  gnome-libs-devel
46 Buildrequires: db1
47
48 %description
49 VideoLAN is a free network-aware MPEG and DVD player.
50 The VideoLAN Client allows to play MPEG-2 Transport Streams from the
51 network or from a file, as well as direct DVD playback.
52 VideoLAN is a project of students from the Ecole Centrale Paris.
53 This version add MPEG-1 support, direct DVD support, DVD decryption, 
54 arbitrary, seeking in the stream, pause, fast forward and slow motion, 
55 hardware YUV acceleration and a few new interface features 
56 including drag'n'drop.
57 You may install vlc-gnome, vlc-gtk and vlc-qt vlc-gnome vlc-ncurses.
58
59 %package gtk
60 Summary: Gtk plug-in for VideoLAN, a DVD and MPEG-2 player
61 Group: Video
62 Requires: %{name} = %{version}
63 %description gtk
64 The vlc-gtk packages includes the Gtk plug-in for the VideoLAN client.
65 If you are going to watch DVD with the Gtk front-end, you should 
66 install vlc-gtk.
67
68
69 %package gnome
70 Summary: Gnome plug-in for VideoLAN, a DVD and MPEG-2 player
71 Group: Video
72 Requires: %{name} = %{version}
73 %description gnome
74 The vlc-gnome packages includes the Gnome plug-in for the VideoLAN client.
75 If you are going to watch DVD with the Gnome front-end, you should 
76 install vlc-gnome.
77
78 %package qt
79 Summary: Qt2 plug-in for VideoLAN, a DVD and MPEG-2 player
80 Group: Video
81 Requires: %{name} = %{version}
82 %description qt
83 The vlc-qt packages includes the Qt2 plug-in for the VideoLAN client.
84 If you are going to watch DVD with the Qt2 front-end, you should
85 install vlc-qt
86
87 %package ncurses
88 Summary: Ncurses console-based plug-in for VideoLAN, a DVD and MPEG-2 player
89 Group: Video
90 Requires: %{name} = %{version}
91 %description ncurses
92 The vlc-ncurses packages includes the ncurses plug-in for the VideoLAN client.
93 If you are going to watch DVD with the ncurses front-end, you should
94 install vlc-ncurses
95
96
97 %prep
98 %if %{cvs}
99 %setup -q -n %{cvs_name}
100 %else
101 %setup -q -n %{name}-%{vlc_ver}
102 %endif
103
104 %build
105 %configure --with-dvdcss=local-shared \
106            --enable-gnome --enable-gtk \
107            --enable-x11 --enable-qt --enable-ncurses \
108            --enable-esd --disable-alsa \
109            --enable-fb \
110            --enable-xvideo \
111            --enable-sdl 
112 export QTDIR=%{_libdir}/qt2 
113 %make
114
115 %install
116 %makeinstall
117 install -d %buildroot/%_mandir/man1
118 install doc/vlc.1 %buildroot/%_mandir/man1
119
120 %clean
121 rm -fr %buildroot
122
123 %files
124 %defattr(-,root,root,-)
125 %doc README COPYING
126 %{_bindir}/vlc
127
128 %{_libdir}/videolan/vlc/dsp.so
129 %{_libdir}/videolan/vlc/esd.so
130 %{_libdir}/videolan/vlc/fb.so
131 %{_libdir}/videolan/vlc/sdl.so
132 %{_libdir}/videolan/vlc/x*.so
133
134 %dir %{_datadir}/videolan
135 %{_datadir}/videolan/*
136 %{_mandir}/man1/*
137
138 %files gtk
139 %defattr(-,root,root)
140 %{_libdir}/videolan/vlc/gtk.so
141 %{_bindir}/gvlc
142
143 %files gnome
144 %defattr(-,root,root)
145 %{_libdir}/videolan/vlc/gnome.so
146 %{_bindir}/gnome-vlc
147
148 %files qt
149 %defattr(-,root,root)
150 %{_libdir}/videolan/vlc/qt.so
151 %{_bindir}/qvlc
152
153 %files ncurses
154 %defattr(-,root,root)
155 %{_libdir}/videolan/vlc/ncurses.so
156
157
158 %changelog
159 * Wed Oct 10 2001 Christophe Massiot <massiot@via.ecp.fr> 0.2.90-1
160 - version 0.2.90
161
162 * Tue Oct 02 2001 Christophe Massiot <massiot@via.ecp.fr>
163 - Imported Mandrake's vlc.spec into the CVS
164
165 * Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-1mdk
166 - version 0.2.83 : 
167   * Activated subtitles in overlay mode (far from perfect, but this
168     was an often requested feature).
169
170 * Fri Aug 10 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.82-1mdk
171 - version 0.2.82
172
173 * Mon Jul 30 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-1mdk
174 - version 0.2.81
175 - added vlc-ncurses
176
177 * Wed Jun 20 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-0.20010619-1mdk
178 - cvs snapshot
179 - added libdvdcss
180
181 * Wed Jun 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-2mdk
182 - fix build on ppc (c) dadou
183
184 * Mon Jun 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-1mdk
185 - version 0.2.80 : bug fixes and bug fixes and bug fixes and small
186   improvements of the gtk interface.
187 - corrected Summary in vlc-qt
188
189 * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-2mdk
190 - added qt2 plug-in (vlc-qt)
191
192 * Wed May 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-1mdk
193 - version 0.2.73
194 - you can now get decss threw a plug-in
195 - rewritte srcipt to build vlc (decss plugin)
196 - rebuild with SDL 1.2
197
198 * Thu Apr 26 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-2mdk
199 - true 0.2.72
200
201 * Mon Apr 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-1mdk
202 - version 0.2.72
203 - package split into vlc, vlc-gnome, vlc-gtk
204
205 * Fri Apr 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.71-1mdk
206 - version 0.2.71 :
207   * Fixed segfaults when compiled with gcc 3.0pre and versions of gcc
208     shipped with the latest RedHat distributions.                    
209   * Fixed the BeOS CSS decryption.
210   * Fixed a few issues in IFO parsing.
211   * Fixed XVideo video output.
212   * Updated icons under Linux, BeOS, MacOS X.
213
214 * Wed Apr 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.70-1mdk
215 - version 0.2.70
216
217 * Thu Mar 22 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.63-1mdk
218 - version 0.2.63 : Bugfixes, bugfixes, and bugfixes again, a Gtk+ 
219   interface for the Gnome-impaired, an even better DVD support
220
221 * Fri Feb 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.61-1mdk
222 - new version for all the DVD fans (add MPEG1 support, direct DVD support, 
223   DVD decryption, arbitrary, seeking in the stream, pause, fast forward 
224   and slow motion, hardware YUV acceleration enhanced CSS support and a few 
225   new interface features including drag'n'drop.
226 - first *real* public release (now under the GPL)
227
228 * Sat Jan 06 2001 David BAUDENS <baudens@mandrakesoft.com> 0.1.99i-2mdk
229 - Fix build and use right optimizations on PPC
230 - Enable SDL support
231 - Spec clean up
232
233 * Fri Jan  5 2001 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99i-1mdk
234 - 0.1.99i, rebuild
235
236 * Fri Aug 25 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99h-1mdk
237 - 0.1.99h
238
239 * Mon Jul 10 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99c-1mdk
240 - first Mandrake package with help of Sam