]> git.sesse.net Git - casparcg/blobdiff - core/CMakeLists.txt
Created a consumer that provides sync to a channel based on the pace of another chann...
[casparcg] / core / CMakeLists.txt
index aaa67b0e12840c54bfe2d058643630402722564c..21ef8a9bdef15a137c68de1968d2efff4c524801 100644 (file)
@@ -2,6 +2,8 @@ cmake_minimum_required (VERSION 2.6)
 project (core)
 
 set(SOURCES
+               consumer/syncto/syncto_consumer.cpp
+
                consumer/frame_consumer.cpp
                consumer/output.cpp
                consumer/port.cpp
@@ -58,6 +60,8 @@ set(SOURCES
                video_format.cpp
 )
 set(HEADERS
+               consumer/syncto/syncto_consumer.h
+
                consumer/frame_consumer.h
                consumer/output.h
                consumer/port.h
@@ -149,6 +153,7 @@ include_directories(${GLEW_INCLUDE_PATH})
 
 source_group(sources ./*)
 source_group(sources\\consumer consumer/*)
+source_group(sources\\consumer\\syncto consumer/syncto/*)
 source_group(sources\\diagnostics diagnostics/*)
 source_group(sources\\producer producer/*)
 source_group(sources\\producer\\framerate producer/framerate/*)