]> git.sesse.net Git - vlc/blobdiff - libs/srtp/Makefile.am
Fix initialization
[vlc] / libs / srtp / Makefile.am
index 74c4bafe049598c0a67ab9f6dd09f6ff661a426b..7c95859eb507608e7e6377f90e6972c12e43cef4 100644 (file)
@@ -36,3 +36,17 @@ test_aes_SOURCES = test-aes.c
 srtp_SOURCES = recv.c
 srtp_LDADD = libvlc_srtp.la
 
+lcov-run:
+       rm -f *.gcda lcov
+       $(MAKE) $(AM_MAKEFLAGS) check
+
+lcov-pre.out:
+       lcov -c -d . -o lcov.tmp
+
+lcov.out: lcov-pre.out
+       lcov -r lcov.tmp '*test*' > lcov.out
+
+lcov: lcov.out
+       genhtml lcov.out -o lcov
+
+.PHONY: lcov-run