]> git.sesse.net Git - vlc/blobdiff - modules/gui/qt4/Makefile.am
input: drop ITEM_TYPE_CDDA
[vlc] / modules / gui / qt4 / Makefile.am
index 5dc1f40c6589ba7126d58219b25224a24126d700..0fe434836314e4a9d2bf12be57801c9d03a2f5fe 100644 (file)
@@ -14,13 +14,13 @@ guidir = $(pluginsdir)/gui
 
 SUFFIXES += .ui .h .hpp .moc.cpp
 
-libqt4_plugin_la_CXXFLAGS = $(AM_CXXFLAGS) $(QT_CFLAGS)
-libqt4_plugin_la_LIBADD = $(QT_LIBS)
+libqt4_plugin_la_CXXFLAGS = $(AM_CXXFLAGS) $(QT_CFLAGS) $(CXXFLAGS_qt4)
+libqt4_plugin_la_LIBADD = $(QT_LIBS) $(LIBS_qt4) $(LIBM)
 libqt4_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(guidir)'
 if HAVE_OS2
 else
 if HAVE_WIN32
-libqt4_plugin_la_LIBADD += -lole32
+libqt4_plugin_la_LIBADD += -lole32 -lcomctl32 -luuid
 else
 libqt4_plugin_la_LIBADD += $(X_LIBS) $(X_PRE_LIB) -lX11
 endif
@@ -40,7 +40,7 @@ libqt4_plugin_la_SOURCES = \
        input_manager.cpp input_manager.hpp \
        actions_manager.cpp actions_manager.hpp \
        extensions_manager.cpp extensions_manager.hpp \
-        managers/addons_manager.cpp managers/addons_manager.hpp \
+       managers/addons_manager.cpp managers/addons_manager.hpp \
        recents.cpp recents.hpp \
        adapters/seekpoints.cpp adapters/seekpoints.hpp \
        adapters/chromaprint.cpp adapters/chromaprint.hpp \
@@ -49,7 +49,6 @@ libqt4_plugin_la_SOURCES = \
        dialogs/bookmarks.cpp dialogs/bookmarks.hpp \
        dialogs/preferences.cpp dialogs/preferences.hpp \
        dialogs/mediainfo.cpp dialogs/mediainfo.hpp \
-       dialogs/ml_configuration.cpp dialogs/ml_configuration.hpp \
        dialogs/epg.cpp dialogs/epg.hpp \
        dialogs/extended.cpp dialogs/extended.hpp \
        dialogs/messages.cpp dialogs/messages.hpp \
@@ -73,7 +72,7 @@ libqt4_plugin_la_SOURCES = \
        components/info_widgets.cpp components/info_widgets.hpp \
        components/preferences_widgets.cpp components/preferences_widgets.hpp \
        components/complete_preferences.cpp \
-               components/complete_preferences.hpp \
+       components/complete_preferences.hpp \
        components/simple_preferences.cpp components/simple_preferences.hpp \
        components/open_panels.cpp components/open_panels.hpp \
        components/interface_widgets.cpp components/interface_widgets.hpp \
@@ -85,22 +84,20 @@ libqt4_plugin_la_SOURCES = \
        components/epg/EPGView.cpp components/epg/EPGView.hpp \
        components/epg/EPGWidget.cpp components/epg/EPGWidget.hpp \
        components/playlist/views.cpp components/playlist/views.hpp \
-       components/playlist/ml_item.cpp components/playlist/ml_item.hpp \
-       components/playlist/ml_model.cpp components/playlist/ml_model.hpp \
        components/playlist/vlc_model.cpp components/playlist/vlc_model.hpp \
        components/playlist/playlist_model.cpp \
-               components/playlist/playlist_model.hpp \
+       components/playlist/playlist_model.hpp \
        components/playlist/playlist_item.cpp \
-               components/playlist/playlist_item.hpp \
+       components/playlist/playlist_item.hpp \
        components/playlist/standardpanel.cpp \
-               components/playlist/standardpanel.hpp \
+       components/playlist/standardpanel.hpp \
        components/playlist/playlist.cpp components/playlist/playlist.hpp \
        components/playlist/selector.cpp components/playlist/selector.hpp \
-               components/playlist/sorting.h \
+       components/playlist/sorting.h \
        components/sout/profile_selector.cpp \
-               components/sout/profile_selector.hpp \
+       components/sout/profile_selector.hpp \
        components/sout/sout_widgets.cpp components/sout/sout_widgets.hpp \
-               components/sout/profiles.hpp \
+       components/sout/profiles.hpp \
        util/animators.cpp util/animators.hpp \
        util/input_slider.cpp util/input_slider.hpp \
        util/timetooltip.cpp util/timetooltip.hpp \
@@ -114,9 +111,9 @@ libqt4_plugin_la_SOURCES = \
        util/buttons/BrowseButton.cpp util/buttons/BrowseButton.hpp \
        util/buttons/DeckButtonsLayout.cpp util/buttons/DeckButtonsLayout.hpp \
        util/buttons/RoundButton.cpp util/buttons/RoundButton.hpp \
-               util/qvlcframe.hpp \
-               util/qvlcapp.hpp \
-               util/singleton.hpp \
+       util/qvlcframe.hpp \
+       util/qvlcapp.hpp \
+       util/singleton.hpp \
        styles/seekstyle.cpp styles/seekstyle.hpp
 if HAVE_WIN32
 libqt4_plugin_la_SOURCES += main_interface_win32.cpp
@@ -142,7 +139,7 @@ nodist_libqt4_plugin_la_SOURCES = \
        input_manager.moc.cpp \
        actions_manager.moc.cpp \
        extensions_manager.moc.cpp \
-        managers/addons_manager.moc.cpp \
+       managers/addons_manager.moc.cpp \
        recents.moc.cpp \
        adapters/seekpoints.moc.cpp \
        adapters/chromaprint.moc.cpp \
@@ -169,7 +166,6 @@ nodist_libqt4_plugin_la_SOURCES = \
        dialogs/firstrun.moc.cpp \
        dialogs/extensions.moc.cpp \
        dialogs/fingerprintdialog.moc.cpp \
-       dialogs/ml_configuration.moc.cpp \
        components/extended_panels.moc.cpp \
        components/info_panels.moc.cpp \
        components/info_widgets.moc.cpp \
@@ -190,7 +186,6 @@ nodist_libqt4_plugin_la_SOURCES = \
        components/playlist/playlist.moc.cpp \
        components/playlist/standardpanel.moc.cpp \
        components/playlist/selector.moc.cpp \
-       components/playlist/ml_model.moc.cpp \
        components/sout/profile_selector.moc.cpp \
        components/sout/sout_widgets.moc.cpp \
        util/animators.moc.cpp \
@@ -288,6 +283,9 @@ DEPS_res = \
        pixmaps/faster.png \
        pixmaps/faster2.png \
        pixmaps/go-next.png \
+       pixmaps/addons/addon.png \
+       pixmaps/addons/addon_broken.png \
+       pixmaps/addons/score.png \
        pixmaps/menus/exit_16px.png \
        pixmaps/menus/help_16px.png \
        pixmaps/menus/info_16px.png \
@@ -386,7 +384,6 @@ DEPS_res = \
        pixmaps/toolbar/volume-slider-inside.png \
        pixmaps/toolbar/volume-slider-outside.png \
        pixmaps/types/capture-card_16px.png \
-       pixmaps/types/cdda_16px.png \
        pixmaps/types/disc_16px.png \
        pixmaps/types/file-asym_16px.png \
        pixmaps/types/file-wide_16px.png \
@@ -397,7 +394,7 @@ DEPS_res = \
        pixmaps/types/tape_16px.png \
        pixmaps/types/type_directory.png \
        pixmaps/types/type_file.png \
-       pixmaps/types/type_net.png \
+       pixmaps/types/type_stream.png \
        pixmaps/types/type_node.png \
        pixmaps/types/type_playlist.png \
        pixmaps/types/type_unknown.xpm \