]> git.sesse.net Git - vlc/blobdiff - src/Makefile.am
vlc shall be installable - fix #1735
[vlc] / src / Makefile.am
index ee08cd60cb1fa489e6dc2ab05b79ee59b9c37c92..fd718cad437ffcf90719b84449624c0f31f8eac5 100644 (file)
@@ -162,7 +162,7 @@ nice:
 
 lib_LTLIBRARIES = libvlccore.la libvlc.la
 
-AM_LDFLAGS = -no-undefined -no-install
+AM_LDFLAGS = -no-undefined
 if HAVE_WIN32
 AM_LDFLAGS += -avoid-version
 endif
@@ -492,29 +492,36 @@ dist_check_SCRIPTS = check_symbols check_headers
 TESTS = $(check_PROGRAMS) check_symbols
 
 CFLAGS_tests = `$(VLC_CONFIG) --cflags libvlc`
+LDFLAGS_tests = $(AM_LDFLAGS) -no-install
 
 test_block_SOURCES = test/block.c
 test_block_LDADD = libvlccore.la
 test_block_CFLAGS = $(CFLAGS_tests)
+test_block_LDFLAGS = $(LDFLAGS_tests)
 
 test_dictionary_SOURCES = test/dictionary.c
 test_dictionary_LDADD = libvlccore.la
 test_dictionary_CFLAGS = $(CFLAGS_tests)
+test_dictionary_LDFLAGS = $(LDFLAGS_tests)
 
 test_i18n_atof_SOURCES = test/i18n_atof.c text/charset.c
 test_i18n_atof_LDADD = libvlccore.la
 test_i18n_atof_CFLAGS = $(CFLAGS_tests)
+test_i18n_atof_LDFLAGS = $(LDFLAGS_tests)
 
 test_url_SOURCES = test/url.c
 test_url_LDADD = libvlccore.la
 test_url_CFLAGS = $(CFLAGS_tests)
+test_url_LDFLAGS = $(LDFLAGS_tests)
 
 test_utf8_SOURCES = test/utf8.c
 test_utf8_LDADD = libvlccore.la
 test_utf8_CFLAGS = $(CFLAGS_tests)
+test_utf8_LDFLAGS = $(LDFLAGS_tests)
 
 test_headers_SOURCES = test/headers.c
 test_headers_CFLAGS = $(CFLAGS_tests)
+test_headers_LDFLAGS = $(LDFLAGS_tests)
 
 check-local:
        for h in `echo $(pkginclude_HEADERS) | sed -e s,\.\./include/,,g`; \