]> git.sesse.net Git - vlc/blobdiff - test/Makefile.am
Add a test about chain escaping escaping.
[vlc] / test / Makefile.am
index 0b11a9bbac6de4948bd2e217b4af1bea4f9f39b3..e88f78c35ea11c4e565fb8c1f0cb6fa32f421e47 100644 (file)
@@ -18,6 +18,7 @@ check_PROGRAMS = \
        test_libvlc_media \
        test_libvlc_media_list \
        test_libvlc_media_player \
+       test_src_config_chain \
        test_src_misc_variables \
         $(NULL)
 
@@ -91,6 +92,11 @@ test_src_misc_variables_LDADD = $(top_builddir)/src/libvlc.la
 test_src_misc_variables_CFLAGS = $(CFLAGS_tests)
 test_src_misc_variables_LDFLAGS = $(LDFLAGS_tests)
 
+test_src_config_chain_SOURCES = src/config/chain.c
+test_src_config_chain_LDADD = $(top_builddir)/src/libvlc.la
+test_src_config_chain_CFLAGS = $(CFLAGS_tests)
+test_src_config_chain_LDFLAGS = $(LDFLAGS_tests)
+
 checkall:
        $(MAKE) check_PROGRAMS="$(check_PROGRAMS) $(EXTRA_PROGRAMS)" check