]> git.sesse.net Git - bcachefs-tools-debian/blob - default.nix
Add upstream files
[bcachefs-tools-debian] / default.nix
1 { nixpkgs ? (import ./nix/nixpkgs.nix)
2 }:
3
4 with nixpkgs;
5
6 stdenv.mkDerivation rec {
7   name = "bcachefs-tools-${version}";
8   version = "git";
9
10   src = lib.cleanSource ./.; # NOTE: ignore .git, otherwise things get weird!
11
12   nativeBuildInputs = [ git pkgconfig ];
13   buildInputs =
14     [ liburcu libuuid libaio zlib attr keyutils
15       libsodium libscrypt
16     ];
17
18   enableParallelBuilding = true;
19   makeFlags =
20     [ "PREFIX=$(out)"
21     ];
22
23   meta = with stdenv.lib; {
24     description = "Userspace tools for bcachefs";
25     homepage    = http://bcachefs.org;
26     license     = licenses.gpl2;
27     platforms   = platforms.linux;
28     maintainers =
29       [ "Kent Overstreet <kent.overstreet@gmail.com>"
30       ];
31   };
32 }