]> git.sesse.net Git - vlc/blob - extras/libdvdcss/libdvdcss.spec
* Fixed bugs in RPM spec files ;
[vlc] / extras / libdvdcss / libdvdcss.spec
1 # This is borrowed and adapted from Mandrake's Cooker
2 %define name    libdvdcss
3 %define version 0.0.3
4 %define release 1
5 %define major   0
6 %define lib_name %{name}%{major}
7
8 Summary:        A library for accessing DVDs like block device, deciphering CSS encryption if needed.
9 Name:           %{name}
10 Version:        %{version}
11 Release:        %{release}
12
13 Source0:        http://www.videolan.org/pub/videolan/libdvcss/%{version}/%{name}-%{version}.tar.bz2
14 License:        GPL
15 Group:          System/Libraries
16 URL:            http://videolan.org/
17 BuildRoot:      %_tmppath/%name-%version-%release-root
18
19 %description
20 libdvdcss is a simple library designed for accessing DVDs like a block device
21 without having to bother about the decryption. The important features are:
22  * Portability. Currently supported platforms are GNU/Linux, FreeBSD, BeOS
23    and Windows. The MacOS X version is being worked on as well.
24  * Simplicity. There are currently 7 functions in the API, and we intend to
25    keep this number low.
26  * Freedom. libdvdcss is released under the General Public License, ensuring
27    it will stay free, and used only for free software products.
28  * Just better. Unlike most similar projects, libdvdcss doesn't require the
29    region of your drive to be set.
30
31 %package -n %{lib_name}
32 Summary:        A library for accessing DVDs like block device, deciphering CSS encryption if needed.
33 Group:          System/Libraries
34 Provides:       %name
35
36 %description -n %{lib_name}
37 libdvdcss is a simple library designed for accessing DVDs like a block device 
38 without having to bother about the decryption. The important features are:
39  * Portability. Currently supported platforms are GNU/Linux, FreeBSD, BeOS
40    and Windows. The MacOS X version is being worked on as well.
41  * Simplicity. There are currently 7 functions in the API, and we intend to 
42    keep this number low.
43  * Freedom. libdvdcss is released under the General Public License, ensuring
44    it will stay free, and used only for free software products.
45  * Just better. Unlike most similar projects, libdvdcss doesn't require the 
46    region of your drive to be set.
47
48 %package -n %{lib_name}-devel
49 Summary:        Development tools for programs which will use the libdvdcss library.
50 Group:          Development/C
51 Provides:       %name-devel
52 Requires:       %{lib_name} = %{version}
53  
54 %description -n %{lib_name}-devel
55 The %{name}-devel package includes the header files and static libraries
56 necessary for developing programs which will manipulate DVDs files using
57 the %{name} library.
58  
59  If you are going to develop programs which will manipulate DVDs,
60  you should install %{name}-devel.  You'll also need to have the %name
61  package installed.
62  
63
64 %prep
65 %setup -q
66
67 %build
68 %configure
69 make libdvdcss
70
71 %install
72 %makeinstall
73
74 %clean
75 rm -fr %buildroot
76
77 %post -n %{lib_name} -p /sbin/ldconfig
78  
79 %postun -n %{lib_name} -p /sbin/ldconfig
80
81 %files -n %{lib_name}
82 %defattr(-,root,root,-)
83 %doc COPYING AUTHORS
84 %{_libdir}/*.so.*
85
86 %files -n %{lib_name}-devel
87 %defattr(-,root,root)
88 %doc COPYING
89 %{_libdir}/*.a
90 %{_libdir}/*.so
91 %{_includedir}/*
92
93 %changelog
94 * Tue Oct 02 2001 Christophe Massiot <massiot@via.ecp.fr>
95 - Imported Mandrake's vlc.spec into the CVS
96
97 * Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.0.3-1mdk
98 - version 0.0.3
99
100 * Mon Aug 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.0.2-1mdk
101 - version 0.0.2
102
103 * Tue Jun 19 2001 Yves Duret <yduret@mandrakesoft.com> 0.0.1-1mdk
104 - first release and first mdk release
105
106 #EOF