]> git.sesse.net Git - vlc/blob - extras/package/rpm/vlc.fedora.spec
Typos
[vlc] / extras / package / rpm / vlc.fedora.spec
1 # TODO: daap, goom, libdc1394, libggi, java-vlc.
2 #
3 %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
4
5
6 %define with_static_ffmpeg              1
7 %define ffmpeg_date     20070503
8 %define with_static_live555             0
9 %define live555_date    2007.04.24a
10 %define vlc_svn                         0
11 %define vlc_date    20070514
12 %define with_dirac                      1
13 %define with_mozilla                    1
14 %define with_java_vlc                   0
15 %define rpmfusion                       0
16
17
18 Summary:        Multi-platform MPEG, DVD, and DivX player
19 Name:           vlc
20 %if %vlc_svn
21 %define release_tag   0.1
22 %define _version %{version}-svn
23 Version:        0.9.0
24 Release:        %{release_tag}.%{vlc_date}svn%{?dist}
25 %else
26 Version:        0.8.6b
27 %define release_tag   5
28 %define _version %{version}
29 Release:        %{release_tag}%{?dist}.2
30 %endif
31 License:        GPL
32 Group:          Applications/Multimedia
33 URL:            http://www.videolan.org/
34 %if %vlc_svn    
35 Source0:        http://nightlies.videolan.org/build/source/vlc-snapshot-%{vlc_date}.tar.bz2
36 %else
37 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/vlc-%{version}.tar.bz2
38 ## Bugfix sources...
39 #Source0:       http://nightlies.videolan.org/build/source/vlc-snapshot-branch-0.8.6-bugfix-%{vlc_date}.tar.gz
40 %endif
41 %if %with_static_ffmpeg
42 Source1:        http://rpm.greysector.net/livna/ffmpeg-%{ffmpeg_date}.tar.bz2
43 %endif
44 %if %with_static_live555
45 Source2:        http://www.live555.com/liveMedia/public/live.%{live555_date}.tar.gz
46 %endif
47 Patch0:         vlc-0.8.6-ffmpegX11.patch
48 Patch1:         vlc-0.8.6-wx28.patch
49 Patch2:         vlc-0.8.6a-faad2.patch
50 Patch3:         vlc-0.8.6a-automake110.patch
51 Patch4:         vlc-0.8.6-FLAC_api_change.patch
52 Patch6:         vlc-trunk-dirac_0_6_0-api.patch
53 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
54
55 Requires(post): /sbin/ldconfig
56 Requires(postun): /sbin/ldconfig
57
58 BuildRequires:  automake
59 BuildRequires:  gettext-devel
60 BuildRequires:  desktop-file-utils
61 BuildRequires:  libtool
62
63 BuildRequires:  a52dec-devel
64 BuildRequires:  aalib-devel
65 BuildRequires:  alsa-lib-devel
66 BuildRequires:  arts-devel
67 BuildRequires:  avahi-devel
68 BuildRequires:  cdparanoia-devel
69 # Don't work now wip
70 #BuildRequires:  directfb-devel
71 BuildRequires:  esound-devel
72 BuildRequires:  faac-devel
73 BuildRequires:  faad2-devel < 2.5
74 BuildRequires:  flac-devel
75 BuildRequires:  fribidi-devel
76 # wip -  glide.h usability... no
77 #BuildRequires:  Glide3-devel
78 #BuildRequires:  Glide3-libGL
79 BuildRequires:  gnome-vfs2-devel
80 BuildRequires:  gnutls-devel >= 1.0.17
81 BuildRequires:  gsm-devel
82 BuildRequires:  gtk2-devel
83 BuildRequires:  hal-devel
84 BuildRequires:  jack-audio-connection-kit-devel
85 BuildRequires:  lame-devel
86 BuildRequires:  libavc1394-devel
87 BuildRequires:  libcaca-devel
88 BuildRequires:  libcddb-devel
89 BuildRequires:  libcdio-devel >= 0.77-3
90 # kwizart this is the same issue with cdio and cddax svcdx configure options.
91 # http://bugzilla.livna.org/show_bug.cgi?id=1342 or see
92 # http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=221359
93 BuildConflicts: libcdio-devel = 0.78.2  
94 BuildRequires:  libdca-devel
95 BuildRequires:  libdv-devel
96 BuildRequires:  libdvbpsi-devel
97 BuildRequires:  libdvdnav-devel
98 BuildRequires:  libebml-devel
99 BuildRequires:  libid3tag-devel
100 BuildRequires:  libGLU-devel
101 BuildRequires:  libmad-devel
102 BuildRequires:  libmatroska-devel >= 0.7.6
103 BuildRequires:  libmodplug-devel
104 BuildRequires:  libmpcdec-devel
105 BuildRequires:  libnotify-devel
106 BuildRequires:  libpng-devel
107 BuildRequires:  libraw1394-devel
108 BuildRequires:  librsvg2-devel >= 2.5.0
109 BuildRequires:  libsysfs-devel
110 BuildRequires:  libshout-devel
111 BuildRequires:  libtar-devel
112 BuildRequires:  libtheora-devel
113 BuildRequires:  libtiff-devel
114 BuildRequires:  libupnp-devel
115 BuildRequires:  libvorbis-devel
116 BuildRequires:  libxml2-devel
117 BuildRequires:  lirc-devel
118 %if %with_static_live555 
119 BuildConflicts: live-devel
120 %else
121 BuildRequires:  live-devel >= 0-0.11.2006.08.07
122 %endif
123 BuildRequires:  mpeg2dec-devel >= 0.3.2
124 BuildRequires:  ncurses-devel
125 BuildRequires:  openslp-devel
126 BuildRequires:  ORBit2-devel
127 # This Seem Broken
128 #BuildRequires: portaudio
129 BuildRequires:  pth-devel
130 BuildRequires:  python-devel
131 BuildRequires:  pyorbit-devel
132 BuildRequires:  SDL_image-devel
133 BuildRequires:  speex-devel >= 1.1.5
134 %ifarch %{ix86} x86_64
135 BuildRequires:  svgalib-devel
136 %endif
137 BuildRequires:  twolame-devel
138 BuildRequires:  vcdimager-devel >= 0.7.21
139 BuildRequires:  wxGTK-devel >= 2.6
140 BuildRequires:  x264-devel >= 0-0.8.20061028
141 BuildRequires:  xosd-devel
142 BuildRequires:  xvidcore-devel
143 BuildRequires:  zlib-devel
144
145 # X-libs
146 BuildRequires:  libXt-devel
147 BuildRequires:  libXv-devel
148 BuildRequires:  libXxf86vm-devel
149
150 %if "%fedora" > "6"
151 BuildRequires: libsmbclient-devel
152 %else 
153 BuildRequires: samba-common
154 %endif
155
156 %if %with_mozilla
157 BuildRequires:  firefox-devel >= 1.5.0.0
158 ## Will be later replaced by 
159 #BuildRequires:  xulrunner-devel
160 ##
161 BuildRequires:  nspr-devel
162 BuildRequires:  nss-devel
163 BuildRequires:  js-devel
164 %endif
165
166 %if %with_static_ffmpeg
167 ## Static version already bundle it
168 BuildConflicts: ffmpeg-devel
169 %else
170 BuildRequires:  ffmpeg-devel >= 0.4.9-0
171 %endif
172
173 %if %with_dirac
174 # Diract is still experimental in vlc - 0.6.0 is now in Fedora
175 # Review http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=221405
176 BuildRequires:  dirac-devel >= 0.6.0
177 %endif
178
179 %if %with_java_vlc
180 BuildRequires:  libgcj-devel
181 %endif
182
183 %if %vlc_svn
184 BuildRequires:  opencv-devel
185 BuildRequires:  qt4-devel
186 BuildRequires:  dbus-devel
187 BuildRequires:  xorg-x11-proto-devel
188 #BuildRequires:  lua-devel
189 %endif
190
191 %if %rpmfusion
192 BuildRequires:  libopendaap-devel
193 BuildRequires:  libgoom2-devel
194 BuildRequires:  libdc1394-devel
195 BuildRequires:  libggi-devel
196 %endif
197
198
199 Provides:       videolan-client = %{version}-%{release}
200 Provides:       videolan-client-wx = %{version}-%{release}
201 Provides:       videolan-client-ncurses = %{version}-%{release}
202 Obsoletes:      videolan-client < 0.8.1
203 #Obsoletes:     videolan-client-gnome < 0.8.1
204 #Obsoletes:     videolan-client-kde < 0.8.1
205 Obsoletes:      videolan-client-ncurses < 0.8.1
206 Obsoletes:      videolan-client-wx < 0.8.1
207
208 %package devel
209 Summary:        Development package for %{name}
210 Group:          Development/Libraries
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       %{name} = %{version}-%{release}
213 Provides:       videolan-client-devel = %{version}-%{release}
214 Obsoletes:      videolan-client-devel < 0.8.1
215
216 %description
217 VLC (initially VideoLAN Client) is a highly portable multimedia player
218 for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
219 mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
220 It can also be used as a server to stream in unicast or multicast in
221 IPv4 or IPv6 on a high-bandwidth network.
222
223 %description devel
224 This package contains development files for VLC Media Player.
225
226 VLC (initially VideoLAN Client) is a highly portable multimedia player
227 for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
228 mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
229 It can also be used as a server to stream in unicast or multicast in
230 IPv4 or IPv6 on a high-bandwidth network.
231
232
233 %package -n python-vlc
234 Summary:        VLC Media Player binding for Python
235 Group:          Applications/Multimedia 
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       pyorbit
238
239 %description -n python-vlc
240 VLC Media Player binding for Python 
241
242
243 %if %with_mozilla
244 %package -n mozilla-vlc
245 Summary:        VLC Media Player plugin for Mozilla compatible web browsers
246 Group:          Applications/Multimedia 
247 Requires:       %{name} = %{version}-%{release}
248 Requires:       %{_libdir}/mozilla/plugins
249 Provides:       videolan-client-mozilla = %{version}-%{release}
250 Obsoletes:      videolan-client-mozilla < 0.8.1
251
252 %description -n mozilla-vlc
253 This package contains a VLC Media Player plugin for Mozilla compatible
254 web browsers.
255
256 VLC (initially VideoLAN Client) is a highly portable multimedia player
257 for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
258 mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
259 It can also be used as a server to stream in unicast or multicast in
260 IPv4 or IPv6 on a high-bandwidth network.
261 %endif
262
263 %if %with_java_vlc
264 %package -n java-vlc
265 Summary:        VLC Media Player binding for Java
266 Group:          Applications/Multimedia 
267 Requires:       %{name} = %{version}-%{release}
268
269 %description -n java-vlc
270 VLC Media Player binding for Java
271 %endif
272
273
274 %prep
275 %setup -q -n %{name}-%{_version}
276 %if %with_static_ffmpeg
277 %setup -q -D -T -a 1 -n %{name}-%{_version}
278 %endif
279 %if %with_static_live555
280 %setup -q -D -T -a 2 -n %{name}-%{_version}
281 %endif
282
283 %patch0 -p1 -b .ffmpegX11
284 %patch1 -p1 -b .wx28
285 %if %vlc_svn
286 #Xvmc quick fix on svn and AMD64
287 sed -i 's|pop |popl |g' modules/codec/xvmc/*
288 sed -i 's|push |pushl |g' modules/codec/xvmc/*
289 %else
290 %patch2 -p1 -b .faad2
291 %patch3 -p0 -b .automake110
292 %patch4 -p1 -b .FLAC_api
293 %patch6 -p0 -b .dirac6
294 %endif
295
296 %{__perl} -pi -e \
297 's|/usr/share/fonts/truetype/freefont/FreeSerifBold\.ttf|%{_datadir}/fonts/bitstream-vera/VeraSeBd.ttf|' \
298 modules/misc/freetype.c
299 # Fix PLUGIN_PATH path for lib64
300 %{__perl} -pi -e 's|/lib/vlc|/%{_lib}/vlc|g' vlc-config.in.in configure*
301 # Fix perms issues
302 chmod 644 mozilla/control/*
303 chmod 644 src/control/log.c
304 sed -i 's/\r//'  mozilla/control/* 
305
306 sh bootstrap
307
308
309
310 %build
311 %if %with_static_ffmpeg
312 export CFLAGS="%{optflags}"
313 # Build bundeled ffmpeg first
314 pushd ffmpeg-%{ffmpeg_date}
315 ./configure \
316         --extra-cflags="-fPIC -DPIC" \
317         --enable-static \
318         --disable-shared \
319         --enable-libmp3lame \
320         --enable-libfaac \
321         --enable-pp \
322         --enable-gpl \
323 %if %vlc_svn
324         --enable-swscaler \
325 %endif
326 # Watch http://trac.videolan.org/vlc/ticket/865
327 # Planned to be enabled for 0.9.x
328
329         make %{?_smp_mflags}
330 popd
331 %endif
332
333 %if %with_static_live555
334 # Then bundled live555 - not needed
335 pushd live
336 # Force the use of our CFLAGS
337 %{__perl} -pi -e 's|-O2|%{optflags} -fPIC -DPIC|g' config.linux
338 # Configure and build
339 ./genMakefiles linux && make
340 popd
341 %endif
342
343
344 %if %with_mozilla
345 # fix mozilla plugin
346 export XPIDL="$(rpm -ql firefox-devel.%{_target_cpu}|grep '/xpidl$')"
347 export MOZVER="$(rpm -q --qf=%{VERSION} firefox-devel.%{_target_cpu})"
348 %endif
349 export CFLAGS="%{optflags} -fPIC"
350 export CXXFLAGS="%{optflags} -fPIC"
351
352
353 # Altivec compiler flags aren't set properly (0.8.2)
354 %ifarch ppc ppc64
355 export CFLAGS="$CFLAGS -maltivec -mabi=altivec"
356 %endif
357
358 # java-vlc
359 %if %with_java_vlc
360 export JAVA_HOME=%{_prefix}/lib/jvm/java
361 %endif
362
363 # cddax & vcdx : doesn't build, at least on fc6 x86_64
364 # with libcdio > 0.77-3
365 %configure \
366         --disable-dependency-tracking           \
367         --disable-rpath                         \
368         --enable-shout                          \
369         --enable-release                        \
370         --enable-live555                        \
371 %if %with_static_live555 
372         --with-live555-tree=live                \
373 %endif
374 %if %rpmfusion
375         --enable-dc1394                         \
376         --enable-dv                             \
377 %endif
378         --enable-ffmpeg --with-ffmpeg-mp3lame --with-ffmpeg-faac \
379 %if %with_static_ffmpeg 
380         --with-ffmpeg-tree=ffmpeg-%{ffmpeg_date} \
381 %endif
382         --disable-libtool                       \
383         --with-gnu-ld                           \
384         --disable-static                        \
385         --enable-shared                         \
386         --disable-pth                           \
387         --enable-dvdread                        \
388         --enable-v4l                            \
389         --enable-pvr                            \
390         --enable-libcdio                        \
391 %ifarch x86_64
392         --enable-cddax                          \
393 %endif
394         --enable-vcdx                           \
395         --enable-dvb                            \
396         --enable-faad                           \
397         --enable-twolame                        \
398         --enable-real                           \
399         --enable-realrtsp                       \
400         --enable-flac                           \
401         --enable-tremor                         \
402         --enable-speex                          \
403         --enable-tarkin                         \
404         --enable-theora                         \
405 %if %with_dirac 
406         --enable-dirac                          \
407 %endif 
408         --enable-svg                            \
409         --enable-snapshot                       \
410 %ifarch %{ix86} x86_64
411         --enable-svgalib                        \
412 %endif
413         --enable-aa                             \
414         --enable-caca                           \
415         --enable-esd                            \
416         --enable-arts                           \
417         --enable-jack                           \
418         --enable-ncurses                        \
419         --enable-xosd                           \
420 %if %rpmfusion
421         --enable-goom                           \
422         --enable-ggi                            \
423 %endif
424         --enable-slp                            \
425         --enable-lirc                           \
426         --enable-corba                          \
427         --with-x                                \
428         --enable-mediacontrol-python-bindings   \
429 %if %with_java_vlc
430         --enable-java-bindings                  \
431 %endif
432 %ifarch %{ix86}
433         --enable-loader                         \
434 %endif
435         --without-contrib                       \
436 %if %with_mozilla 
437         --enable-mozilla                        \
438 %endif
439         --with-x264-tree=%{_includedir}         \
440 %if %vlc_svn
441         --enable-libtool                        \
442         --enable-shared                         \
443         --disable-static                        \
444         --enable-opencv                         \
445         --enable-python-bindings                \
446         --disable-switcher                      \
447         --disable-libcdio                       \
448         --disable-cddax                         \
449         --disable-vcdx                          \
450         --disable-audioscrobbler                \
451         --disable-musicbrainz                   \
452         --enable-taglib                         \
453         --enable-dbus-control                   \
454         --enable-qt4                            \
455         --disable-xvmc                          \
456 %endif
457
458
459 ## temp disabled
460 # --enable-cyberlink                            \
461 # --enable-qte                                  \
462 # --enable-ggi                                  \
463 # --enable-quicktime                            \
464 # --with-wine-sdk-path=%{_includedir}/wine/windows      \
465 #       --enable-directfb                       \
466 #       --with-directfb="no"                    \
467 #       --enable-glide                          \
468 #       --with-glide=%{_includedir}/glide3      \
469
470
471 %if %vlc_svn
472 sed -i -e 's|python $(srcdir)/setup.py install|python $(srcdir)/setup.py install --root $(DESTDIR)|' bindings/python/Makefile
473 %else
474 sed -i -e 's|python $(srcdir)/setup.py install|python $(srcdir)/setup.py install --root $(DESTDIR)|' bindings/mediacontrol-python/Makefile
475 %endif
476 sed -i -e 's|cflags="${cflags} -I/usr/include/ffmpeg"|cflags="${cflags} -I%{_includedir}/ffmpeg -I%{_includedir}/postproc/"|' vlc-config
477
478 %if %with_mozilla
479         make %{?_smp_mflags} XPIDL_INCL="-I%{_datadir}/idl/firefox-$MOZVER/" 
480 %else
481         make %{?_smp_mflags}
482 %endif
483
484 %install
485 rm -rf $RPM_BUILD_ROOT __doc
486
487 make install DESTDIR=$RPM_BUILD_ROOT
488 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
489 mv $RPM_BUILD_ROOT%{_datadir}/doc/vlc __doc
490
491 %if %with_mozilla 
492 chmod +x $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/libvlcplugin.so
493 %endif
494
495 install -dm 755 $RPM_BUILD_ROOT%{_mandir}/man1
496 install -pm 644 doc/vlc*.1 $RPM_BUILD_ROOT%{_mandir}/man1
497
498 install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
499 ln -s ../../../../vlc/vlc48x48.png \
500         $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/vlc.png
501
502 sed -i -e 's|Version=|Version=%{version}\n#Version=|' $RPM_BUILD_ROOT%{_datadir}/applications/vlc.desktop
503 desktop-file-install --vendor livna                     \
504         --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
505         --delete-original                               \
506         --mode 644                                      \
507         $RPM_BUILD_ROOT%{_datadir}/applications/vlc.desktop
508
509 %if %vlc_svn
510 %else
511 # Fix perms of python things
512 chmod 755 $RPM_BUILD_ROOT%{_bindir}/vlcwrapper.py
513 chmod 755 $RPM_BUILD_ROOT%{_libdir}/advene/MediaControl.so
514 # Fix python shebang
515 sed -i -e 's|"""Wrapper|#!/usr/bin/python\n"""Wrapper|' $RPM_BUILD_ROOT%{_bindir}/vlcwrapper.py
516 %endif
517
518 %find_lang %{name}
519
520
521 %clean
522 rm -rf $RPM_BUILD_ROOT __doc
523
524
525 %post
526 %{_bindir}/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor &>/dev/null
527 %{_bindir}/update-desktop-database %{_datadir}/applications > /dev/null 2>&1
528 /sbin/ldconfig || :
529
530
531 %postun
532 %{_bindir}/update-desktop-database %{_datadir}/applications > /dev/null 2>&1
533 %{_bindir}/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor &>/dev/null
534 /sbin/ldconfig || :
535
536
537 %files -f %{name}.lang
538 %defattr(-,root,root,-)
539 %doc AUTHORS COPYING ChangeLog NEWS README THANKS __doc/*
540 %{_bindir}/vlc
541 %{_bindir}/svlc
542 %{_datadir}/vlc/
543 %{_mandir}/man1/vlc.1*
544 %{_datadir}/applications/*%{name}.desktop
545 %{_datadir}/icons/hicolor/*/apps/vlc.png
546 %if %vlc_svn
547 %{_bindir}/qvlc
548 #{_datadir}/applications/gnome-vlc-default.sh
549 %{_libdir}/*.so.*
550 %dir %{_libdir}/vlc
551 %{_libdir}/vlc/*
552 %else
553 %{_bindir}/wxvlc
554 %exclude %{_libdir}/vlc/*.a
555 %exclude %{_libdir}/lib*.a
556 # Corba plugin is unmaintained and broken in vlc
557 %exclude %{_libdir}/vlc/control/libcorba_plugin.so
558 %dir %{_libdir}/vlc
559 %{_libdir}/vlc/*
560 %endif
561
562 %files devel
563 %defattr(-,root,root,-)
564 %doc HACKING
565 %{_bindir}/vlc-config
566 %dir %{_includedir}/vlc
567 %{_includedir}/vlc/*
568 %{_mandir}/man1/vlc-config.1*
569 %if %vlc_svn
570 %{_libdir}/*.so
571 %else
572 %{_libdir}/vlc/*.a
573 %{_libdir}/libvlc.a
574 %endif
575
576 %if %with_mozilla
577 %files -n mozilla-vlc
578 %defattr(-,root,root,-)
579 %{_libdir}/mozilla/plugins/libvlcplugin.so
580 %endif
581
582
583 %files -n python-vlc
584 %defattr(-,root,root,-)
585 %{python_sitearch}/*
586 %if %vlc_svn
587 %else
588 %{_bindir}/vlcwrapper.py
589 %exclude %{_bindir}/vlcwrapper.py?
590 %dir %{_libdir}/advene
591 %{_libdir}/advene/MediaControl.so
592 %{_datadir}/idl/MediaControl.idl
593 %endif
594
595 %if %with_java_vlc
596 %files -n java-vlc
597 %defattr(-,root,root,-)
598 %endif
599
600
601 %changelog
602 * Sat May 19 2007 kwizart < kwizart at gmail.com > - 0.8.6b-5
603 - Removed no more needed Selinux Context:
604   fixed in http://bugzilla.redhat.com/237473
605
606 * Sun May 13 2007 kwizart < kwizart at gmail.com > - 0.8.6b-4
607 - Disabled pth (broken) and...
608 - Build ffmpeg static (since shared ffmpeg is pth enabled).
609 - Add post & postun update-desktop-database
610 - Update static ffmpeg to 20070503 (same as shared version)
611
612 * Sun May 13 2007 kwizart < kwizart at gmail.com > - 0.8.6b-3.3
613 - Test static updated live555
614
615 * Sat May 12 2007 kwizart < kwizart at gmail.com > - 0.8.6b-3.2
616 - Update to the new ffmpeg with pth (testing - wip )
617
618 * Fri May  4 2007 kwizart < kwizart at gmail.com > - 0.8.6b-3.1
619 - Add BR libebml-devel
620 - Add BR Glide3-devel
621 - Add BR gnome-vfs2-devel
622 - Add BR libxml2-devel
623 - Fix BR faad2-devel < 2.5
624 - Add rpmfusion BR libopendaap-devel
625 - Add rpmfusion BR libgoom2-devel
626 - Add rpmfusion BR libdc1394-devel
627 - Exclude corba plugin (broken)
628 - Add relatives %%configure options
629 - Comment Glide3 (don't work now - wip)
630
631 * Thu May  3 2007 kwizart < kwizart at gmail.com > - 0.8.6b-3
632 - Enable --enable-pth with ffmpeg
633   bump release in case testing take much time.
634
635 * Thu May  3 2007 kwizart < kwizart at gmail.com > - 0.8.6b-1.3
636 - Fix Selinux remain quiet with semanage
637
638 * Tue May  1 2007 kwizart < kwizart at gmail.com > - 0.8.6b-1.2
639 - Few improvements for svn version
640 - Add missing BR ORBit2-devel and pyorbit-devel
641 - Improved post preun postun section with help from Anvil.
642
643 * Mon Apr 30 2007 kwizart < kwizart at gmail.com > - 0.8.6b-1.1
644 - Add missing BR libtiff-devel
645 - Fix Selinux buglet when Selinux is not activated
646   was https://bugzilla.livna.org/show_bug.cgi?id=1484
647
648 * Sat Apr 21 2007 kwizart < kwizart at gmail.com > - 0.8.6b-1
649 - Update to Final 8.6b
650 - Enable Dirac codec
651 - Fix mozilla-vlc libXt.so loading 
652   (removing mozilla-sdk since using firefox sdk >= 1.5)
653 - Fix SeLinux context for dmo plugin. Was:
654   https://bugzilla.livna.org/show_bug.cgi?id=1404
655 - Enabled cddax only for x86_64 (broken type).
656
657 * Wed Apr 18 2007 kwizart < kwizart at gmail.com > - 0.8.6b-0.3
658 - Fix BR for libsmbclient-devel for Fedora 7
659 - Update to 0.8.6-bugfix-20070418
660 - Add BR libraw1394-devel
661 - Add BR libavc1394-devel
662
663 * Mon Apr 16 2007 kwizart < kwizart at gmail.com > - 0.8.6b-0.2
664 - Fix svgalib-devel only for x86 x86_64
665 - Fix firefox-devel headers presence/usability. This remains:
666  npapi.h: accepted by the compiler, rejected by the preprocessor!
667  npapi.h: proceeding with the compiler's result
668
669 * Sat Apr 14 2007 kwizart < kwizart at gmail.com > - 0.8.6b-0.1
670 - Update to rc 0.8.6b (bugfix)
671 - Hack configure.ac script (it didn't detect firefox headers)
672 - Add BR libshout-devel
673 - Add BR svgalib-devel
674 - Add BR gtk2-devel
675 - Add BR directfb-devel (wip)
676 - Add BR libnotify-devel
677 - Enabled --enable-speex
678 - Testing --enable-portaudio not useful (oss is deprecated)
679 - Enabled --enable-pda
680 - Testing --enable-directfb (wip)
681 - Removed patch5 (was format.c)
682
683 * Thu Apr  5 2007 kwizart < kwizart at gmail.com > - 0.8.6a-5
684 - Use system ffmpeg lib (pth and libtool seems to be incompatible with it)
685 - Dirac seem to compile fine but testing usability for now.
686 - Cache isn't useful for now (and won't be since using system libs)
687 - Exclude %%{_bindir}/vlcwrapper.py? since this is the guideline about python for now.
688
689 * Mon Apr  2 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.6
690 - Fix %%{_libdir}/advene directory ownership from: #1458
691 - Fix .py? presence and perm (644)
692 - Remove .la after make install
693 - Add --disable-pth (broken for release and svn)
694   
695 * Sat Mar 24 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.5
696 - Test dirac (disabled mozilla )
697 - Test Updated static live555 to 2007.02.22
698 - Clean up svn to release changes
699
700 * Tue Mar 22 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.4
701 - WIP changes - ld.conf is unuseful...
702
703 * Wed Mar 21 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.3
704 - Revert back to the static vlc version 
705  ( will explore this with ld.conf later )
706
707 * Wed Mar 21 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.2
708 - Fix .desktop file
709 - Disable broken libtool 
710 - Quick fixes for svn/cache prepare
711 - Patch format_c
712 - Fix rpmlint error with python-vlc
713
714 * Tue Mar 20 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.1
715 - Enable cache for static compilation - wip
716
717 * Fri Mar  9 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4
718 - Enable conditionnal build for
719         * mozilla-vlc, java-vlc, dirac
720         * ffmpeg and live static
721 - Enable pth
722 - Enable gnu_ld
723
724 * Thu Mar  8 2007 kwizart < kwizart at gmail.com > - 0.8.6a-3.1
725 - Fix firefox-devel detection when avaible both i386 and x86_64
726   http://bugzilla.livna.org/show_bug.cgi?id=1442
727
728 * Thu Mar  8 2007 kwizart < kwizart at gmail.com > - 0.8.6a-3
729 - Recover patch3 from Ville Skyttä
730 - Fix FLAC api change see
731  http://bugzilla.livna.org/show_bug.cgi?id=1433
732
733 * Thu Mar  8 2007 kwizart < kwizart at gmail.com > - 0.8.6a-2
734 - Update ffmpeg to 20070308
735 - Enabled static build for internal ffmpeg (x264 vlc modules)
736 - Fixed: some configure options has changed for ffmpeg
737
738 * Sat Mar  3 2007 Thorsten Leemhuis <fedora at leemhuis dot info> - 0.8.6a-1.2
739 - Rebuild
740
741 * Sun Feb  4 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.8.6a-1.1
742 - Fix aclocal/automake fix for automake 1.10 without breaking it for earlier.
743
744 * Sun Feb  4 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.8.6a-1
745 - Build internal copy of ffmpeg with $RPM_OPT_FLAGS.
746 - Don't hardcode path to firefox headers.
747 - Drop Application and X-Livna categories from desktop entry.
748 - Clean up some unneeded cruft from specfile.
749 - Fix aclocal/automake calls during bootstrap.
750 - Let rpmbuild strip MediaControl.so.
751
752 * Sat Feb  3 2007 kwizart < kwizart at gmail.com > - 0.8.6a-0.4.static
753 - Internal static build of ffmpeg from Matthias version.
754
755 * Fri Jan 19 2007 kwizart < kwizart at gmail.com > - 0.8.6a-0.3
756 - Re-enabled mozilla-vlc
757 - use ifarch ix86
758
759 * Sat Jan 13 2007 kwizart < kwizart at gmail.com > - 0.8.6a-0.2
760 - Import patches from Matthias version
761 - try to fix firefox includes for mozilla-vlc -> disabled
762
763 * Wed Jan 10 2007 kwizart < kwizart at gmail.com > - 0.8.6a-0.1
764 - Try to Fix run with libavformat.so.51
765 - disabled
766
767 * Mon Jan  8 2007 kwizart < kwizart at gmail.com > - 0.8.6-5
768 - Update to BR bugzilla infos.
769 - Fix perms with python and debug headers.
770 - Cleaned obsolete-not-provided
771
772 * Fri Jan  5 2007 kwizart < kwizart at gmail.com > - 0.8.6-4
773 - Use BuildConflics with libcdio
774 - Enabled --enable-cddax
775 - Enabled --enable-vcdx
776 -  waiting --enable-quicktime (build fails)
777
778 * Fri Jan  5 2007 kwizart < kwizart at gmail.com > - 0.8.6-3
779   with help from Rathan
780 - Update to 0.8.6a (security update!)
781   from http://www.videolan.org/sa0701.html - #1342
782 - Add version to desktop file
783 - Fix dual shortcuts / Add MimeType
784
785 * Wed Jan  3 2007 kwizart < kwizart at gmail.com > - 0.8.6-2
786  with help from Rathan
787 - Enabled --enable-shout
788 - Enabled --enable-quicktime (x86 only !) 
789 - Enabled --enable-loader (x86 only !)
790 - Enabled --with-wine-sdk-path (x86 only !)
791 - Enabled --enable-corba
792 -  testing --enable-dirac (libdirac-devel reviewing in extra)
793    http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=221405
794 - Enabled --enable-mediacontrol-python-bindings
795 - Cosmetic changes in BR
796
797 * Mon Dec 11 2006 kwizart < kwizart at gmail.com > - 0.8.6-1.fc6
798 - Update to 8.6 final
799 - Change deprecated livdotcom to live555
800 - build shared librairies is default since 8.6
801 - Enabled --enable-dvdread
802 - Enabled --enable-faad
803 - Enabled --enable-twolame
804 -   waiting --enable-quicktime (problem finding xqtsdk )
805 - Enabled --enable-real
806 - Enabled --enable-realrtsp
807 - Enabled --enable-tremor
808 - Enabled --enable-tarkin
809 -   waiting --enable-dirac (TODO libdirac-devel )
810 - Enabled --enable-snapshot
811 - Enabled --enable-portaudio
812 - Enabled --enable-jack
813 -   waiting --enable-mediacontrol-python-bindings (default install error)
814 -   waiting --enable-cddax (new version of libcdio 0.78.2)
815 -   waiting --enable-vcdx (new version of libcdio 0.78.2)
816
817 * Mon Dec 04 2006 kwizart < kwizart at gmail.com > - 0.8.6-rc1.1.fc6
818 - Update to 8.6rc1
819 - disable components in mozilla-vlc
820 - disable libvlc_pic.a in devel
821 - Enable x264-devel for static linking.
822
823 * Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 0.8.5-6
824 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
825
826 * Mon Sep 25 2006 Dams <anvil[AT]livna.org> - 0.8.5-5
827 - BuildReq:libtool
828
829 * Sun Sep 24 2006 Dams <anvil[AT]livna.org> - 0.8.5-4
830 - Fixed the mozilla plugin damn build 
831
832 * Sat Sep  9 2006 Dams <anvil[AT]livna.org> - 0.8.5-3
833 - sysfsutils-devel -> libsysfs-devel
834
835 * Sat Sep  9 2006 Dams <anvil[AT]livna.org> - 0.8.5-1
836 - Updated to 0.8.5
837 - Fixed MOZVER value in case more than one mozilla is installed.
838 - Dropped patches 1, 2 and 3
839
840 * Wed Aug 16 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.8.4a-2
841 - Adjust for new live package, enable it on all archs.
842
843 * Fri Apr 14 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.8.4a-1
844 - Apply upstream patch to fix linking with newer ffmpeg/postproc.
845 - Drop no longer needed build conditionals and build dependencies.
846 - Enable Avahi, Musepack, SLP and sysfs support, fix SDL and Xv.
847 - Install icon to %%{_datadir}/icons/hicolor.
848 - Drop zero Epoch remainders.
849 - Fix -devel obsoletes.
850 - Specfile cleanups.
851
852 * Fri Mar 24 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.8.4-9.a
853 - rebuild 
854
855 * Tue Mar 21 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
856 0.8.4-8.a
857 - fix #775
858
859 * Mon Mar 20 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
860 0.8.4-7.a
861 - add -fPIC for all arches
862
863 * Mon Mar 20 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
864 0.8.4-6.a
865 - fix build on ppc/i386
866
867 * Thu Mar 16 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
868 0.8.4-5.a
869 - fix BR
870
871 * Wed Mar 15 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
872 0.8.4-4.a
873 - make vlc build again
874
875 * Tue Mar 14 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.8.4-3.a
876 - drop "0.lvn" from release
877
878 * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
879 - add dist
880
881 * Mon Jan 09 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 0.8.4-0.lvn.3.a
882 - add all BRs the new ffmpeg needs
883
884 * Fri Jan 06 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 0.8.4-0.lvn.2.a
885 - add buildoption "--without mkv" -- ebml in FC3 is to old
886 - add buildoption "--without svg" -- does not build with svg on FC3-x86-64
887
888 * Thu Jan 05 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 0.8.4-0.lvn.1.a
889 - Update to 0.8.4a [with help from che (Rudolf Kastl)]
890 - Fix x64
891 - drop Epoch
892 - drop vlc-0.8.2-test2-altivec.patch, seems they worked on this
893 - use " --disable-libcdio" until we update to wxGTK2 2.6
894 - use "--disable-livedotcom" on x86_64 (does not build)
895
896 * Sat Aug  6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.8.2-0.lvn.4
897 - Fix "--without cddb" build when libcddb-devel is installed.
898 - BuildRequire live-devel instead of live.
899
900 * Wed Aug  3 2005 Dams <anvil[AT]livna.org> - 0:0.8.2-0.lvn.3
901 - Rebuilt *without* libcddb
902 - Rebuilt against new libdvbpsi
903
904 * Thu Jul 28 2005 Dams <anvil[AT]livna.org> - 0:0.8.2-0.lvn.2
905 - Rebuilt against new libcddb/libcdio
906
907 * Sat Jul  9 2005 Dams <anvil[AT]livna.org> - 0:0.8.2-0.lvn.1
908 - Updated to final 0.8.2
909
910 * Mon Jun  6 2005 Ville Skyttä <ville.skytta at iki.fi> 0:0.8.2-0.lvn.0.1.test2
911 - Update to 0.8.2-test2, rename to vlc, improve summaries and descriptions.
912 - Enable many more modules, many small improvements and cleanups here and there
913 - Use unversioned install dir for the Mozilla plugin, rename to mozilla-vlc.
914 - Drop < FC3 compatiblity due to unavailability of required lib versions.
915 - Fold wx and ncurses to the main package (upstream has retired the
916   VLC Gnome and KDE UI's, so separate UI packages don't have a purpose
917   any more).
918
919 * Sat Sep 11 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.2-0.lvn.7
920 - Remove dependency on libpostproc-devel, it's now in ffmpeg-devel (bug 255).
921
922 * Thu Sep  2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.2-0.lvn.6
923 - BuildRequire alsa-lib-devel, was lost in previous update (bug 258).
924 - Add libcdio and libmodplug build dependencies.
925 - Tweak descriptions, remove unnecessary conditional sections.
926 - Disable dependency tracking to speed up the build.
927
928 * Sun Aug 29 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.2-0.lvn.5
929 - Use system ffmpeg (>= 0.4.9), and make it, ALSA, and fribidi unconditional.
930 - Build with theora by default.
931 - Change default font to Vera serif bold.
932 - Enable pvr support for Hauppauge card users (thanks to Gabriel L. Somlo).
933
934 * Mon Jul  5 2004 Dams <anvil[AT]livna.org> 0:0.7.2-0.lvn.4
935 - Enabled libcddb support
936
937 * Wed Jun 30 2004 Dams <anvil[AT]livna.org> 0:0.7.2-0.lvn.3
938 - speex now conditional and default disabled since vlc requires
939   development version. 
940
941 * Wed Jun 30 2004 Dams <anvil[AT]livna.org> 0:0.7.2-0.lvn.2
942 - Optional Fribidi and libtheora support (default disabled)
943
944 * Tue May 25 2004 Dams <anvil[AT]livna.org> 0:0.7.2-0.lvn.1
945 - Updated to 0.7.2
946
947 * Fri May  7 2004 Dams <anvil[AT]livna.org> 0:0.7.1-0.lvn.1
948 - BuildConflicts:ffmpeg
949 - Build against private ffmpeg snapshot
950
951 * Tue Mar  9 2004 Dams <anvil[AT]livna.org> 0:0.7.1-0.lvn.1
952 - Updated to 0.7.1
953 - Added live.com libraries support
954 - Added matroska support
955
956 * Sun Jan  4 2004 Dams <anvil[AT]livna.org> 0:0.7.0-0.lvn.1
957 - Updated to 0.7.0
958 - s/fdr/lvn
959
960 * Wed Dec 10 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.7
961 - Conditional ffmpeg build option (default enabled)
962
963 * Fri Sep  5 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.6
964 - pth support now default disabled 
965
966 * Fri Sep  5 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.5
967 - slp support can now be not-build with '--without slp'
968
969 * Thu Sep  4 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.4
970 - Added missing defattr for subpackages
971 - Fixed permissions on mozilla plugin
972 - fixed build failure due to typos in ncurses changes
973 - Removed useless explicit 'Requires:' in subpackages declarations
974
975 * Tue Sep  2 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.3
976 - Added builddep for libpng-devel and openslp-devel 
977 - Added gnome (default:enabled) and ncurses (default:disabled)
978   subpackages
979 - Removed macros (mkdir/install/perl)
980 - Modified descriptions
981 - Removed gtk/gnome2 build deps
982 - Added conditionnal (default-disabled) build option for alsa
983 - Added conditionnal builddep for pth-devel
984
985 * Fri Aug 22 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.2
986 - Added missing BuildRequires for gtk+-devel
987
988 * Thu Aug 14 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.1
989 - Updated to 0.6.2
990 - Hopefully fixed 'if' conditions for optional buildrequires
991
992 * Tue Jul  8 2003 Dams <anvil[AT]livna.org> 0:0.6.0-0.fdr.3
993 - Providing vlc 
994
995 * Tue Jul  8 2003 Dams <anvil[AT]livna.org> 0:0.6.0-0.fdr.2
996 - Moved desktop entry from devel to main package (stupid me)
997
998 * Mon Apr 28 2003 Dams <anvil[AT]livna.org> 
999 - Initial build.