]> git.sesse.net Git - bcachefs-tools-debian/blob - packaging/bcachefs-tools.spec
7a9e7f1636eedeaeb4d9c759819159ec826beeb8
[bcachefs-tools-debian] / packaging / bcachefs-tools.spec
1 Name:           bcachefs-tools
2 # define with i.e. --define '_version 1.0'
3 Version:        %{_version}
4 Release:        1%{?dist}
5 Summary:        Userspace tools for bcachefs
6
7 License:        GPLv2
8 URL:            https://github.com/koverstreet/bcachefs-tools
9
10 BuildRequires:  gcc
11 BuildRequires:  make
12 BuildRequires:  cargo
13 BuildRequires:  clang-devel
14 BuildRequires:  keyutils-libs-devel
15 BuildRequires:  libaio-devel
16 BuildRequires:  libattr-devel
17 BuildRequires:  libblkid-devel
18 BuildRequires:  libsodium-devel
19 BuildRequires:  libuuid-devel
20 BuildRequires:  libzstd-devel
21 BuildRequires:  lz4-devel
22 BuildRequires:  systemd-devel
23 BuildRequires:  udev
24 BuildRequires:  userspace-rcu-devel
25 BuildRequires:  zlib-devel
26
27 %description
28 The bcachefs tool, which has a number of subcommands for formatting and managing bcachefs filesystems. Run bcachefs --help for full list of commands.
29
30 %prep
31 %setup -q
32
33 %build
34 %make_build V=0 --no-print-directory
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 mkdir -p $RPM_BUILD_ROOT%{_sbindir}
39 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man8
40 %make_install PREFIX=%{_exec_prefix} ROOT_SBINDIR=%{_sbindir}
41
42 # These may be debian-specific, and for unlocking encrypted root fs
43 rm -f %{buildroot}/%{_datadir}/initramfs-tools/hooks/bcachefs
44 rm -f %{buildroot}/%{_datadir}/initramfs-tools/scripts/local-premount/bcachefs
45 # The library is not needed by userspace
46 rm -f %{buildroot}/usr/lib/libbcachefs.so
47
48 %files
49 %{_sbindir}/bcachefs
50 %{_sbindir}/mount.bcachefs
51 %{_sbindir}/fsck.bcachefs
52 %{_sbindir}/mkfs.bcachefs
53 %{_sbindir}/mount.fuse.bcachefs
54 %{_sbindir}/fsck.fuse.bcachefs
55 %{_sbindir}/mkfs.fuse.bcachefs
56 %{_mandir}/man8/bcachefs.8.gz
57 %{_udevrulesdir}/64-bcachefs.rules
58
59 %changelog
60 * Tue Nov 15 2022 Eric Sandeen <sandeen@sandeen.net> - 2022.11.15-1
61 - NOTE: This binary RPM has been built directly from the bcachefs-tools
62   git tree with "make rpm" from the git hash indicated in the package version.
63 - Update spec file to allow in-tree rpm builds
64 - Remove maually added Requires: and unneeded build-requires
65
66 * Tue Jan 21 2020 Michael Adams <unquietwiki@gmail.com> - 2020.01.21-1
67 - Updated RPM package definition to reflect that changes in codebase have occurred.
68
69 * Tue Jan 07 2020 Michael Adams <unquietwiki@gmail.com> - 2020.01.07-1
70 - Initial RPM package definition
71 - Makefile needs further work to accomodate RPM macros.