]> git.sesse.net Git - bcachefs-tools-debian/blob - packaging/bcachefs-tools.spec
Update bcachefs sources to cbb2e45634dd bcachefs: fix simulateously upgrading & downg...
[bcachefs-tools-debian] / packaging / bcachefs-tools.spec
1 Name:           bcachefs-tools
2 # define with i.e. --define '_version 1.0'
3 Version:        %{_version}
4 Release:        1%{?dist}
5 Summary:        Userspace tools for bcachefs
6
7 License:        GPLv2
8 URL:            https://github.com/koverstreet/bcachefs-tools
9
10 BuildRequires:  gcc
11 BuildRequires:  make
12 BuildRequires:  cargo
13 BuildRequires:  clang-devel
14 BuildRequires:  keyutils-libs-devel
15 BuildRequires:  libaio-devel
16 BuildRequires:  libattr-devel
17 BuildRequires:  libblkid-devel
18 BuildRequires:  libsodium-devel
19 BuildRequires:  libuuid-devel
20 BuildRequires:  libzstd-devel
21 BuildRequires:  lz4-devel
22 BuildRequires:  systemd-devel
23 BuildRequires:  systemd-rpm-macros
24 BuildRequires:  udev
25 BuildRequires:  userspace-rcu-devel
26 BuildRequires:  zlib-devel
27
28 %description
29 The bcachefs tool, which has a number of subcommands for formatting and managing bcachefs filesystems. Run bcachefs --help for full list of commands.
30
31 %prep
32 %setup -q
33
34 %build
35 %make_build V=0 --no-print-directory
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 mkdir -p $RPM_BUILD_ROOT%{_sbindir}
40 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man8
41 %make_install PREFIX=%{_exec_prefix} ROOT_SBINDIR=%{_sbindir}
42
43 # These may be debian-specific, and for unlocking encrypted root fs
44 rm -f %{buildroot}/%{_datadir}/initramfs-tools/hooks/bcachefs
45 rm -f %{buildroot}/%{_datadir}/initramfs-tools/scripts/local-premount/bcachefs
46 # The library is not needed by userspace
47 rm -f %{buildroot}/usr/lib/libbcachefs.so
48
49 %files
50 %{_sbindir}/bcachefs
51 %{_sbindir}/mount.bcachefs
52 %{_sbindir}/fsck.bcachefs
53 %{_sbindir}/mkfs.bcachefs
54 %{_sbindir}/mount.fuse.bcachefs
55 %{_sbindir}/fsck.fuse.bcachefs
56 %{_sbindir}/mkfs.fuse.bcachefs
57 %{_mandir}/man8/bcachefs.8.gz
58 %{_udevrulesdir}/64-bcachefs.rules
59 %{_unitdir}/bcachefsck*
60 %{_unitdir}/system-bcachefsck.slice
61 %{_libexecdir}/bcachefsck*
62
63 %changelog
64 * Tue Nov 15 2022 Eric Sandeen <sandeen@sandeen.net> - 2022.11.15-1
65 - NOTE: This binary RPM has been built directly from the bcachefs-tools
66   git tree with "make rpm" from the git hash indicated in the package version.
67 - Update spec file to allow in-tree rpm builds
68 - Remove maually added Requires: and unneeded build-requires
69
70 * Tue Jan 21 2020 Michael Adams <unquietwiki@gmail.com> - 2020.01.21-1
71 - Updated RPM package definition to reflect that changes in codebase have occurred.
72
73 * Tue Jan 07 2020 Michael Adams <unquietwiki@gmail.com> - 2020.01.07-1
74 - Initial RPM package definition
75 - Makefile needs further work to accomodate RPM macros.