1 # TODO: daap, goom, libdc1394, libggi, java-vlc.
3 %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6 %define with_static_ffmpeg 1
7 %define ffmpeg_date 20070503
8 %define with_static_live555 0
9 %define live555_date 2007.04.24a
11 %define vlc_date 20070514
13 %define with_mozilla 1
14 %define with_java_vlc 0
18 Summary: Multi-platform MPEG, DVD, and DivX player
21 %define release_tag 0.1
22 %define _version %{version}-svn
24 Release: %{release_tag}.%{vlc_date}svn%{?dist}
28 %define _version %{version}
29 Release: %{release_tag}%{?dist}.2
32 Group: Applications/Multimedia
33 URL: http://www.videolan.org/
35 Source0: http://nightlies.videolan.org/build/source/vlc-snapshot-%{vlc_date}.tar.bz2
37 Source0: http://download.videolan.org/pub/videolan/vlc/%{version}/vlc-%{version}.tar.bz2
39 #Source0: http://nightlies.videolan.org/build/source/vlc-snapshot-branch-0.8.6-bugfix-%{vlc_date}.tar.gz
41 %if %with_static_ffmpeg
42 Source1: http://rpm.greysector.net/livna/ffmpeg-%{ffmpeg_date}.tar.bz2
44 %if %with_static_live555
45 Source2: http://www.live555.com/liveMedia/public/live.%{live555_date}.tar.gz
47 Patch0: vlc-0.8.6-ffmpegX11.patch
48 Patch1: vlc-0.8.6-wx28.patch
49 Patch2: vlc-0.8.6a-faad2.patch
50 Patch3: vlc-0.8.6a-automake110.patch
51 Patch4: vlc-0.8.6-FLAC_api_change.patch
52 Patch6: vlc-trunk-dirac_0_6_0-api.patch
53 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
55 Requires(post): /sbin/ldconfig
56 Requires(postun): /sbin/ldconfig
58 BuildRequires: automake
59 BuildRequires: gettext-devel
60 BuildRequires: desktop-file-utils
61 BuildRequires: libtool
63 BuildRequires: a52dec-devel
64 BuildRequires: aalib-devel
65 BuildRequires: alsa-lib-devel
66 BuildRequires: arts-devel
67 BuildRequires: avahi-devel
68 BuildRequires: cdparanoia-devel
70 #BuildRequires: directfb-devel
71 BuildRequires: esound-devel
72 BuildRequires: faac-devel
73 BuildRequires: faad2-devel < 2.5
74 BuildRequires: flac-devel
75 BuildRequires: fribidi-devel
76 # wip - glide.h usability... no
77 #BuildRequires: Glide3-devel
78 #BuildRequires: Glide3-libGL
79 BuildRequires: gnome-vfs2-devel
80 BuildRequires: gnutls-devel >= 1.0.17
81 BuildRequires: gsm-devel
82 BuildRequires: gtk2-devel
83 BuildRequires: hal-devel
84 BuildRequires: jack-audio-connection-kit-devel
85 BuildRequires: lame-devel
86 BuildRequires: libavc1394-devel
87 BuildRequires: libcaca-devel
88 BuildRequires: libcddb-devel
89 BuildRequires: libcdio-devel >= 0.77-3
90 # kwizart this is the same issue with cdio and cddax svcdx configure options.
91 # http://bugzilla.livna.org/show_bug.cgi?id=1342 or see
92 # http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=221359
93 BuildConflicts: libcdio-devel = 0.78.2
94 BuildRequires: libdca-devel
95 BuildRequires: libdv-devel
96 BuildRequires: libdvbpsi-devel
97 BuildRequires: libdvdnav-devel
98 BuildRequires: libebml-devel
99 BuildRequires: libid3tag-devel
100 BuildRequires: libGLU-devel
101 BuildRequires: libmad-devel
102 BuildRequires: libmatroska-devel >= 0.7.6
103 BuildRequires: libmodplug-devel
104 BuildRequires: libmpcdec-devel
105 BuildRequires: libnotify-devel
106 BuildRequires: libpng-devel
107 BuildRequires: libraw1394-devel
108 BuildRequires: librsvg2-devel >= 2.5.0
109 BuildRequires: libsysfs-devel
110 BuildRequires: libshout-devel
111 BuildRequires: libtar-devel
112 BuildRequires: libtheora-devel
113 BuildRequires: libtiff-devel
114 BuildRequires: libupnp-devel
115 BuildRequires: libvorbis-devel
116 BuildRequires: libxml2-devel
117 BuildRequires: lirc-devel
118 %if %with_static_live555
119 BuildConflicts: live-devel
121 BuildRequires: live-devel >= 0-0.11.2006.08.07
123 BuildRequires: mpeg2dec-devel >= 0.3.2
124 BuildRequires: ncurses-devel
125 BuildRequires: openslp-devel
126 BuildRequires: ORBit2-devel
128 #BuildRequires: portaudio
129 BuildRequires: pth-devel
130 BuildRequires: python-devel
131 BuildRequires: pyorbit-devel
132 BuildRequires: SDL_image-devel
133 BuildRequires: speex-devel >= 1.1.5
134 %ifarch %{ix86} x86_64
135 BuildRequires: svgalib-devel
137 BuildRequires: twolame-devel
138 BuildRequires: vcdimager-devel >= 0.7.21
139 BuildRequires: wxGTK-devel >= 2.6
140 BuildRequires: x264-devel >= 0-0.8.20061028
141 BuildRequires: xosd-devel
142 BuildRequires: xvidcore-devel
143 BuildRequires: zlib-devel
146 BuildRequires: libXt-devel
147 BuildRequires: libXv-devel
148 BuildRequires: libXxf86vm-devel
151 BuildRequires: libsmbclient-devel
153 BuildRequires: samba-common
157 BuildRequires: firefox-devel >= 1.5.0.0
158 ## Will be later replaced by
159 #BuildRequires: xulrunner-devel
161 BuildRequires: nspr-devel
162 BuildRequires: nss-devel
163 BuildRequires: js-devel
166 %if %with_static_ffmpeg
167 ## Static version already bundle it
168 BuildConflicts: ffmpeg-devel
170 BuildRequires: ffmpeg-devel >= 0.4.9-0
174 # Diract is still experimental in vlc - 0.6.0 is now in Fedora
175 # Review http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=221405
176 BuildRequires: dirac-devel >= 0.6.0
180 BuildRequires: libgcj-devel
184 BuildRequires: opencv-devel
185 BuildRequires: qt4-devel
186 BuildRequires: dbus-devel
187 BuildRequires: xorg-x11-proto-devel
188 #BuildRequires: lua-devel
192 BuildRequires: libopendaap-devel
193 BuildRequires: libgoom2-devel
194 BuildRequires: libdc1394-devel
195 BuildRequires: libggi-devel
199 Provides: videolan-client = %{version}-%{release}
200 Provides: videolan-client-wx = %{version}-%{release}
201 Provides: videolan-client-ncurses = %{version}-%{release}
202 Obsoletes: videolan-client < 0.8.1
203 #Obsoletes: videolan-client-gnome < 0.8.1
204 #Obsoletes: videolan-client-kde < 0.8.1
205 Obsoletes: videolan-client-ncurses < 0.8.1
206 Obsoletes: videolan-client-wx < 0.8.1
209 Summary: Development package for %{name}
210 Group: Development/Libraries
211 Requires: %{name} = %{version}-%{release}
212 Requires: %{name} = %{version}-%{release}
213 Provides: videolan-client-devel = %{version}-%{release}
214 Obsoletes: videolan-client-devel < 0.8.1
217 VLC (initially VideoLAN Client) is a highly portable multimedia player
218 for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
219 mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
220 It can also be used as a server to stream in unicast or multicast in
221 IPv4 or IPv6 on a high-bandwidth network.
224 This package contains development files for VLC Media Player.
226 VLC (initially VideoLAN Client) is a highly portable multimedia player
227 for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
228 mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
229 It can also be used as a server to stream in unicast or multicast in
230 IPv4 or IPv6 on a high-bandwidth network.
233 %package -n python-vlc
234 Summary: VLC Media Player binding for Python
235 Group: Applications/Multimedia
236 Requires: %{name} = %{version}-%{release}
239 %description -n python-vlc
240 VLC Media Player binding for Python
244 %package -n mozilla-vlc
245 Summary: VLC Media Player plugin for Mozilla compatible web browsers
246 Group: Applications/Multimedia
247 Requires: %{name} = %{version}-%{release}
248 Requires: %{_libdir}/mozilla/plugins
249 Provides: videolan-client-mozilla = %{version}-%{release}
250 Obsoletes: videolan-client-mozilla < 0.8.1
252 %description -n mozilla-vlc
253 This package contains a VLC Media Player plugin for Mozilla compatible
256 VLC (initially VideoLAN Client) is a highly portable multimedia player
257 for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
258 mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
259 It can also be used as a server to stream in unicast or multicast in
260 IPv4 or IPv6 on a high-bandwidth network.
265 Summary: VLC Media Player binding for Java
266 Group: Applications/Multimedia
267 Requires: %{name} = %{version}-%{release}
269 %description -n java-vlc
270 VLC Media Player binding for Java
275 %setup -q -n %{name}-%{_version}
276 %if %with_static_ffmpeg
277 %setup -q -D -T -a 1 -n %{name}-%{_version}
279 %if %with_static_live555
280 %setup -q -D -T -a 2 -n %{name}-%{_version}
283 %patch0 -p1 -b .ffmpegX11
286 #Xvmc quick fix on svn and AMD64
287 sed -i 's|pop |popl |g' modules/codec/xvmc/*
288 sed -i 's|push |pushl |g' modules/codec/xvmc/*
290 %patch2 -p1 -b .faad2
291 %patch3 -p0 -b .automake110
292 %patch4 -p1 -b .FLAC_api
293 %patch6 -p0 -b .dirac6
297 's|/usr/share/fonts/truetype/freefont/FreeSerifBold\.ttf|%{_datadir}/fonts/bitstream-vera/VeraSeBd.ttf|' \
298 modules/misc/freetype.c
299 # Fix PLUGIN_PATH path for lib64
300 %{__perl} -pi -e 's|/lib/vlc|/%{_lib}/vlc|g' vlc-config.in.in configure*
302 chmod 644 mozilla/control/*
303 chmod 644 src/control/log.c
304 sed -i 's/\r//' mozilla/control/*
311 %if %with_static_ffmpeg
312 export CFLAGS="%{optflags}"
313 # Build bundeled ffmpeg first
314 pushd ffmpeg-%{ffmpeg_date}
316 --extra-cflags="-fPIC -DPIC" \
319 --enable-libmp3lame \
326 # Watch http://trac.videolan.org/vlc/ticket/865
327 # Planned to be enabled for 0.9.x
333 %if %with_static_live555
334 # Then bundled live555 - not needed
336 # Force the use of our CFLAGS
337 %{__perl} -pi -e 's|-O2|%{optflags} -fPIC -DPIC|g' config.linux
338 # Configure and build
339 ./genMakefiles linux && make
346 export XPIDL="$(rpm -ql firefox-devel.%{_target_cpu}|grep '/xpidl$')"
347 export MOZVER="$(rpm -q --qf=%{VERSION} firefox-devel.%{_target_cpu})"
349 export CFLAGS="%{optflags} -fPIC"
350 export CXXFLAGS="%{optflags} -fPIC"
353 # Altivec compiler flags aren't set properly (0.8.2)
355 export CFLAGS="$CFLAGS -maltivec -mabi=altivec"
360 export JAVA_HOME=%{_prefix}/lib/jvm/java
363 # cddax & vcdx : doesn't build, at least on fc6 x86_64
364 # with libcdio > 0.77-3
366 --disable-dependency-tracking \
371 %if %with_static_live555
372 --with-live555-tree=live \
378 --enable-ffmpeg --with-ffmpeg-mp3lame --with-ffmpeg-faac \
379 %if %with_static_ffmpeg
380 --with-ffmpeg-tree=ffmpeg-%{ffmpeg_date} \
410 %ifarch %{ix86} x86_64
429 --enable-mediacontrol-python-bindings \
431 --enable-java-bindings \
440 --with-x264-tree=%{_includedir} \
446 --enable-python-bindings \
451 --disable-audioscrobbler \
452 --disable-musicbrainz \
454 --enable-dbus-control \
461 # --enable-cyberlink \
464 # --enable-quicktime \
465 # --with-wine-sdk-path=%{_includedir}/wine/windows \
466 # --enable-directfb \
467 # --with-directfb="no" \
469 # --with-glide=%{_includedir}/glide3 \
473 sed -i -e 's|python $(srcdir)/setup.py install|python $(srcdir)/setup.py install --root $(DESTDIR)|' bindings/python/Makefile
475 sed -i -e 's|python $(srcdir)/setup.py install|python $(srcdir)/setup.py install --root $(DESTDIR)|' bindings/mediacontrol-python/Makefile
477 sed -i -e 's|cflags="${cflags} -I/usr/include/ffmpeg"|cflags="${cflags} -I%{_includedir}/ffmpeg -I%{_includedir}/postproc/"|' vlc-config
480 make %{?_smp_mflags} XPIDL_INCL="-I%{_datadir}/idl/firefox-$MOZVER/"
486 rm -rf $RPM_BUILD_ROOT __doc
488 make install DESTDIR=$RPM_BUILD_ROOT
489 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
490 mv $RPM_BUILD_ROOT%{_datadir}/doc/vlc __doc
493 chmod +x $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/libvlcplugin.so
496 install -dm 755 $RPM_BUILD_ROOT%{_mandir}/man1
497 install -pm 644 doc/vlc*.1 $RPM_BUILD_ROOT%{_mandir}/man1
499 install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
500 ln -s ../../../../vlc/vlc48x48.png \
501 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/vlc.png
503 sed -i -e 's|Version=|Version=%{version}\n#Version=|' $RPM_BUILD_ROOT%{_datadir}/applications/vlc.desktop
504 desktop-file-install --vendor livna \
505 --dir $RPM_BUILD_ROOT%{_datadir}/applications \
508 $RPM_BUILD_ROOT%{_datadir}/applications/vlc.desktop
512 # Fix perms of python things
513 chmod 755 $RPM_BUILD_ROOT%{_bindir}/vlcwrapper.py
514 chmod 755 $RPM_BUILD_ROOT%{_libdir}/advene/MediaControl.so
516 sed -i -e 's|"""Wrapper|#!/usr/bin/python\n"""Wrapper|' $RPM_BUILD_ROOT%{_bindir}/vlcwrapper.py
523 rm -rf $RPM_BUILD_ROOT __doc
527 %{_bindir}/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor &>/dev/null
528 %{_bindir}/update-desktop-database %{_datadir}/applications > /dev/null 2>&1
533 %{_bindir}/update-desktop-database %{_datadir}/applications > /dev/null 2>&1
534 %{_bindir}/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor &>/dev/null
538 %files -f %{name}.lang
539 %defattr(-,root,root,-)
540 %doc AUTHORS COPYING ChangeLog MAINTAINERS NEWS README THANKS __doc/*
544 %{_mandir}/man1/vlc.1*
545 %{_datadir}/applications/*%{name}.desktop
546 %{_datadir}/icons/hicolor/*/apps/vlc.png
549 #{_datadir}/applications/gnome-vlc-default.sh
555 %exclude %{_libdir}/vlc/*.a
556 %exclude %{_libdir}/lib*.a
557 # Corba plugin is unmaintained and broken in vlc
558 %exclude %{_libdir}/vlc/control/libcorba_plugin.so
564 %defattr(-,root,root,-)
566 %{_bindir}/vlc-config
567 %dir %{_includedir}/vlc
569 %{_mandir}/man1/vlc-config.1*
578 %files -n mozilla-vlc
579 %defattr(-,root,root,-)
580 %{_libdir}/mozilla/plugins/libvlcplugin.so
585 %defattr(-,root,root,-)
589 %{_bindir}/vlcwrapper.py
590 %exclude %{_bindir}/vlcwrapper.py?
591 %dir %{_libdir}/advene
592 %{_libdir}/advene/MediaControl.so
593 %{_datadir}/idl/MediaControl.idl
598 %defattr(-,root,root,-)
603 * Sat May 19 2007 kwizart < kwizart at gmail.com > - 0.8.6b-5
604 - Removed no more needed Selinux Context:
605 fixed in http://bugzilla.redhat.com/237473
607 * Sun May 13 2007 kwizart < kwizart at gmail.com > - 0.8.6b-4
608 - Disabled pth (broken) and...
609 - Build ffmpeg static (since shared ffmpeg is pth enabled).
610 - Add post & postun update-desktop-database
611 - Update static ffmpeg to 20070503 (same as shared version)
613 * Sun May 13 2007 kwizart < kwizart at gmail.com > - 0.8.6b-3.3
614 - Test static updated live555
616 * Sat May 12 2007 kwizart < kwizart at gmail.com > - 0.8.6b-3.2
617 - Update to the new ffmpeg with pth (testing - wip )
619 * Fri May 4 2007 kwizart < kwizart at gmail.com > - 0.8.6b-3.1
620 - Add BR libebml-devel
621 - Add BR Glide3-devel
622 - Add BR gnome-vfs2-devel
623 - Add BR libxml2-devel
624 - Fix BR faad2-devel < 2.5
625 - Add rpmfusion BR libopendaap-devel
626 - Add rpmfusion BR libgoom2-devel
627 - Add rpmfusion BR libdc1394-devel
628 - Exclude corba plugin (broken)
629 - Add relatives %%configure options
630 - Comment Glide3 (don't work now - wip)
632 * Thu May 3 2007 kwizart < kwizart at gmail.com > - 0.8.6b-3
633 - Enable --enable-pth with ffmpeg
634 bump release in case testing take much time.
636 * Thu May 3 2007 kwizart < kwizart at gmail.com > - 0.8.6b-1.3
637 - Fix Selinux remain quiet with semanage
639 * Tue May 1 2007 kwizart < kwizart at gmail.com > - 0.8.6b-1.2
640 - Few improvements for svn version
641 - Add missing BR ORBit2-devel and pyorbit-devel
642 - Improved post preun postun section with help from Anvil.
644 * Mon Apr 30 2007 kwizart < kwizart at gmail.com > - 0.8.6b-1.1
645 - Add missing BR libtiff-devel
646 - Fix Selinux buglet when Selinux is not activated
647 was https://bugzilla.livna.org/show_bug.cgi?id=1484
649 * Sat Apr 21 2007 kwizart < kwizart at gmail.com > - 0.8.6b-1
650 - Update to Final 8.6b
652 - Fix mozilla-vlc libXt.so loading
653 (removing mozilla-sdk since using firefox sdk >= 1.5)
654 - Fix SeLinux context for dmo plugin. Was:
655 https://bugzilla.livna.org/show_bug.cgi?id=1404
656 - Enabled cddax only for x86_64 (broken type).
658 * Wed Apr 18 2007 kwizart < kwizart at gmail.com > - 0.8.6b-0.3
659 - Fix BR for libsmbclient-devel for Fedora 7
660 - Update to 0.8.6-bugfix-20070418
661 - Add BR libraw1394-devel
662 - Add BR libavc1394-devel
664 * Mon Apr 16 2007 kwizart < kwizart at gmail.com > - 0.8.6b-0.2
665 - Fix svgalib-devel only for x86 x86_64
666 - Fix firefox-devel headers presence/usability. This remains:
667 npapi.h: accepted by the compiler, rejected by the preprocessor!
668 npapi.h: proceeding with the compiler's result
670 * Sat Apr 14 2007 kwizart < kwizart at gmail.com > - 0.8.6b-0.1
671 - Update to rc 0.8.6b (bugfix)
672 - Hack configure.ac script (it didn't detect firefox headers)
673 - Add BR libshout-devel
674 - Add BR svgalib-devel
676 - Add BR directfb-devel (wip)
677 - Add BR libnotify-devel
678 - Enabled --enable-speex
679 - Testing --enable-portaudio not usefull (oss is deprecated)
680 - Enabled --enable-pda
681 - Testing --enable-directfb (wip)
682 - Removed patch5 (was format.c)
684 * Thu Apr 5 2007 kwizart < kwizart at gmail.com > - 0.8.6a-5
685 - Use system ffmpeg lib (pth and libtool seems to be incompatible with it)
686 - Dirac seem to compile fine but testing usability for now.
687 - Cache isn't usefull for now (and won't be since using system libs)
688 - Exclude %%{_bindir}/vlcwrapper.py? since this is the guideline about python for now.
690 * Mon Apr 2 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.6
691 - Fix %%{_libdir}/advene directory ownership from: #1458
692 - Fix .py? presence and perm (644)
693 - Remove .la after make install
694 - Add --disable-pth (broken for release and svn)
696 * Sat Mar 24 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.5
697 - Test dirac (disabled mozilla )
698 - Test Updated static live555 to 2007.02.22
699 - Clean up svn to release changes
701 * Tue Mar 22 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.4
702 - WIP changes - ld.conf is unusefull...
704 * Wed Mar 21 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.3
705 - Revert back to the static vlc version
706 ( will explore this with ld.conf later )
708 * Wed Mar 21 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.2
710 - Disable broken libtool
711 - Quick fixes for svn/cache prepare
713 - Fix rpmlint error with python-vlc
715 * Tue Mar 20 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4.1
716 - Enable cache for static compilation - wip
718 * Fri Mar 9 2007 kwizart < kwizart at gmail.com > - 0.8.6a-4
719 - Enable conditionnal build for
720 * mozilla-vlc, java-vlc, dirac
721 * ffmpeg and live static
725 * Thu Mar 8 2007 kwizart < kwizart at gmail.com > - 0.8.6a-3.1
726 - Fix firefox-devel detection when avaible both i386 and x86_64
727 http://bugzilla.livna.org/show_bug.cgi?id=1442
729 * Thu Mar 8 2007 kwizart < kwizart at gmail.com > - 0.8.6a-3
730 - Recover patch3 from Ville Skyttä
731 - Fix FLAC api change see
732 http://bugzilla.livna.org/show_bug.cgi?id=1433
734 * Thu Mar 8 2007 kwizart < kwizart at gmail.com > - 0.8.6a-2
735 - Update ffmpeg to 20070308
736 - Enabled static build for internal ffmpeg (x264 vlc modules)
737 - Fixed: some configure options has changed for ffmpeg
739 * Sat Mar 3 2007 Thorsten Leemhuis <fedora at leemhuis dot info> - 0.8.6a-1.2
742 * Sun Feb 4 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.8.6a-1.1
743 - Fix aclocal/automake fix for automake 1.10 without breaking it for earlier.
745 * Sun Feb 4 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.8.6a-1
746 - Build internal copy of ffmpeg with $RPM_OPT_FLAGS.
747 - Don't hardcode path to firefox headers.
748 - Drop Application and X-Livna categories from desktop entry.
749 - Clean up some unneeded cruft from specfile.
750 - Fix aclocal/automake calls during bootstrap.
751 - Let rpmbuild strip MediaControl.so.
753 * Sat Feb 3 2007 kwizart < kwizart at gmail.com > - 0.8.6a-0.4.static
754 - Internal static build of ffmpeg from Matthias version.
756 * Fri Jan 19 2007 kwizart < kwizart at gmail.com > - 0.8.6a-0.3
757 - Re-enabled mozilla-vlc
760 * Sat Jan 13 2007 kwizart < kwizart at gmail.com > - 0.8.6a-0.2
761 - Import patches from Matthias version
762 - try to fix firefox includes for mozilla-vlc -> disabled
764 * Wed Jan 10 2007 kwizart < kwizart at gmail.com > - 0.8.6a-0.1
765 - Try to Fix run with libavformat.so.51
768 * Mon Jan 8 2007 kwizart < kwizart at gmail.com > - 0.8.6-5
769 - Update to BR bugzilla infos.
770 - Fix perms with python and debug headers.
771 - Cleaned obsolete-not-provided
773 * Fri Jan 5 2007 kwizart < kwizart at gmail.com > - 0.8.6-4
774 - Use BuildConflics with libcdio
775 - Enabled --enable-cddax
776 - Enabled --enable-vcdx
777 - waiting --enable-quicktime (build fails)
779 * Fri Jan 5 2007 kwizart < kwizart at gmail.com > - 0.8.6-3
780 with help from Rathan
781 - Update to 0.8.6a (security update!)
782 from http://www.videolan.org/sa0701.html - #1342
783 - Add version to desktop file
784 - Fix dual shortcuts / Add MimeType
786 * Wed Jan 3 2007 kwizart < kwizart at gmail.com > - 0.8.6-2
787 with help from Rathan
788 - Enabled --enable-shout
789 - Enabled --enable-quicktime (x86 only !)
790 - Enabled --enable-loader (x86 only !)
791 - Enabled --with-wine-sdk-path (x86 only !)
792 - Enabled --enable-corba
793 - testing --enable-dirac (libdirac-devel reviewing in extra)
794 http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=221405
795 - Enabled --enable-mediacontrol-python-bindings
796 - Cosmetic changes in BR
798 * Mon Dec 11 2006 kwizart < kwizart at gmail.com > - 0.8.6-1.fc6
799 - Update to 8.6 final
800 - Change deprecated livdotcom to live555
801 - build shared librairies is default since 8.6
802 - Enabled --enable-dvdread
803 - Enabled --enable-faad
804 - Enabled --enable-twolame
805 - waiting --enable-quicktime (problem finding xqtsdk )
806 - Enabled --enable-real
807 - Enabled --enable-realrtsp
808 - Enabled --enable-tremor
809 - Enabled --enable-tarkin
810 - waiting --enable-dirac (TODO libdirac-devel )
811 - Enabled --enable-snapshot
812 - Enabled --enable-portaudio
813 - Enabled --enable-jack
814 - Enabled --enable-galaktos
815 - waiting --enable-mediacontrol-python-bindings (default install error)
816 - waiting --enable-cddax (new version of libcdio 0.78.2)
817 - waiting --enable-vcdx (new version of libcdio 0.78.2)
819 * Mon Dec 04 2006 kwizart < kwizart at gmail.com > - 0.8.6-rc1.1.fc6
821 - disable components in mozilla-vlc
822 - disable libvlc_pic.a in devel
823 - Enable x264-devel for static linking.
825 * Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 0.8.5-6
826 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
828 * Mon Sep 25 2006 Dams <anvil[AT]livna.org> - 0.8.5-5
831 * Sun Sep 24 2006 Dams <anvil[AT]livna.org> - 0.8.5-4
832 - Fixed the mozilla plugin damn build
834 * Sat Sep 9 2006 Dams <anvil[AT]livna.org> - 0.8.5-3
835 - sysfsutils-devel -> libsysfs-devel
837 * Sat Sep 9 2006 Dams <anvil[AT]livna.org> - 0.8.5-1
839 - Fixed MOZVER value in case more than one mozilla is installed.
840 - Dropped patches 1, 2 and 3
842 * Wed Aug 16 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.8.4a-2
843 - Adjust for new live package, enable it on all archs.
845 * Fri Apr 14 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.8.4a-1
846 - Apply upstream patch to fix linking with newer ffmpeg/postproc.
847 - Drop no longer needed build conditionals and build dependencies.
848 - Enable Avahi, Musepack, SLP and sysfs support, fix SDL and Xv.
849 - Install icon to %%{_datadir}/icons/hicolor.
850 - Drop zero Epoch remainders.
851 - Fix -devel obsoletes.
854 * Fri Mar 24 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.8.4-9.a
857 * Tue Mar 21 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
861 * Mon Mar 20 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
863 - add -fPIC for all arches
865 * Mon Mar 20 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
867 - fix build on ppc/i386
869 * Thu Mar 16 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
873 * Wed Mar 15 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
875 - make vlc build again
877 * Tue Mar 14 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.8.4-3.a
878 - drop "0.lvn" from release
880 * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
883 * Mon Jan 09 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 0.8.4-0.lvn.3.a
884 - add all BRs the new ffmpeg needs
886 * Fri Jan 06 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 0.8.4-0.lvn.2.a
887 - add buildoption "--without mkv" -- ebml in FC3 is to old
888 - add buildoption "--without svg" -- does not build with svg on FC3-x86-64
890 * Thu Jan 05 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 0.8.4-0.lvn.1.a
891 - Update to 0.8.4a [with help from che (Rudolf Kastl)]
894 - drop vlc-0.8.2-test2-altivec.patch, seems they worked on this
895 - use " --disable-libcdio" until we update to wxGTK2 2.6
896 - use "--disable-livedotcom" on x86_64 (does not build)
898 * Sat Aug 6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.8.2-0.lvn.4
899 - Fix "--without cddb" build when libcddb-devel is installed.
900 - BuildRequire live-devel instead of live.
902 * Wed Aug 3 2005 Dams <anvil[AT]livna.org> - 0:0.8.2-0.lvn.3
903 - Rebuilt *without* libcddb
904 - Rebuilt against new libdvbpsi
906 * Thu Jul 28 2005 Dams <anvil[AT]livna.org> - 0:0.8.2-0.lvn.2
907 - Rebuilt against new libcddb/libcdio
909 * Sat Jul 9 2005 Dams <anvil[AT]livna.org> - 0:0.8.2-0.lvn.1
910 - Updated to final 0.8.2
912 * Mon Jun 6 2005 Ville Skyttä <ville.skytta at iki.fi> 0:0.8.2-0.lvn.0.1.test2
913 - Update to 0.8.2-test2, rename to vlc, improve summaries and descriptions.
914 - Enable many more modules, many small improvements and cleanups here and there
915 - Use unversioned install dir for the Mozilla plugin, rename to mozilla-vlc.
916 - Drop < FC3 compatiblity due to unavailability of required lib versions.
917 - Fold wx and ncurses to the main package (upstream has retired the
918 VLC Gnome and KDE UI's, so separate UI packages don't have a purpose
921 * Sat Sep 11 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.2-0.lvn.7
922 - Remove dependency on libpostproc-devel, it's now in ffmpeg-devel (bug 255).
924 * Thu Sep 2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.2-0.lvn.6
925 - BuildRequire alsa-lib-devel, was lost in previous update (bug 258).
926 - Add libcdio and libmodplug build dependencies.
927 - Tweak descriptions, remove unnecessary conditional sections.
928 - Disable dependency tracking to speed up the build.
930 * Sun Aug 29 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.2-0.lvn.5
931 - Use system ffmpeg (>= 0.4.9), and make it, ALSA, and fribidi unconditional.
932 - Build with theora by default.
933 - Change default font to Vera serif bold.
934 - Enable pvr support for Hauppauge card users (thanks to Gabriel L. Somlo).
936 * Mon Jul 5 2004 Dams <anvil[AT]livna.org> 0:0.7.2-0.lvn.4
937 - Enabled libcddb support
939 * Wed Jun 30 2004 Dams <anvil[AT]livna.org> 0:0.7.2-0.lvn.3
940 - speex now conditional and default disabled since vlc requires
943 * Wed Jun 30 2004 Dams <anvil[AT]livna.org> 0:0.7.2-0.lvn.2
944 - Optional Fribidi and libtheora support (default disabled)
946 * Tue May 25 2004 Dams <anvil[AT]livna.org> 0:0.7.2-0.lvn.1
949 * Fri May 7 2004 Dams <anvil[AT]livna.org> 0:0.7.1-0.lvn.1
950 - BuildConflicts:ffmpeg
951 - Build against private ffmpeg snapshot
953 * Tue Mar 9 2004 Dams <anvil[AT]livna.org> 0:0.7.1-0.lvn.1
955 - Added live.com libraries support
956 - Added matroska support
958 * Sun Jan 4 2004 Dams <anvil[AT]livna.org> 0:0.7.0-0.lvn.1
962 * Wed Dec 10 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.7
963 - Conditional ffmpeg build option (default enabled)
965 * Fri Sep 5 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.6
966 - pth support now default disabled
968 * Fri Sep 5 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.5
969 - slp support can now be not-build with '--without slp'
971 * Thu Sep 4 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.4
972 - Added missing defattr for subpackages
973 - Fixed permissions on mozilla plugin
974 - fixed build failure due to typos in ncurses changes
975 - Removed useless explicit 'Requires:' in subpackages declarations
977 * Tue Sep 2 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.3
978 - Added builddep for libpng-devel and openslp-devel
979 - Added gnome (default:enabled) and ncurses (default:disabled)
981 - Removed macros (mkdir/install/perl)
982 - Modified descriptions
983 - Removed gtk/gnome2 build deps
984 - Added conditionnal (default-disabled) build option for alsa
985 - Added conditionnal builddep for pth-devel
987 * Fri Aug 22 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.2
988 - Added missing BuildRequires for gtk+-devel
990 * Thu Aug 14 2003 Dams <anvil[AT]livna.org> 0:0.6.2-0.fdr.1
992 - Hopefully fixed 'if' conditions for optional buildrequires
994 * Tue Jul 8 2003 Dams <anvil[AT]livna.org> 0:0.6.0-0.fdr.3
997 * Tue Jul 8 2003 Dams <anvil[AT]livna.org> 0:0.6.0-0.fdr.2
998 - Moved desktop entry from devel to main package (stupid me)
1000 * Mon Apr 28 2003 Dams <anvil[AT]livna.org>