]> git.sesse.net Git - vlc/blob - vlc.spec
* ./configure.in: switched version to 0.3.1.
[vlc] / vlc.spec
1 %define name            vlc
2 %define vlc_ver         0.3.1
3 %define version         %vlc_ver
4
5 %define cvs             0
6 %if %{cvs}
7 %define cvsdate         20010619
8 %define release         0.%{cvsdate}mdk
9 %define cvs_name        %{name}-snapshot-%{cvsdate}-00
10 %else
11 %define release         1mdk
12 %endif
13
14 %define plugin_qt       0
15
16 Summary:        VideoLAN is a free MPEG, MPEG2 and DVD software solution.
17 Name:           %{name}
18 Version:        %{version}
19 Release:        %{release}
20 Packager:       Samuel Hocevar <sam@zoy.org>
21
22 %if %{cvs} 
23 Source0:        http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.gz
24 %else
25 Source0:        http://www.videolan.org/packages/%{version}/%{name}-%{version}.tar.gz
26 %endif
27 License:        GPL
28 Group:          Video
29 URL:            http://videolan.org/
30 BuildRoot:      %_tmppath/%name-%version-%release-root
31 Buildrequires:  libncurses5-devel
32 Buildrequires:  libqt2-devel
33 Buildrequires:  libgtk+1.2-devel
34 Buildrequires:  gnome-libs-devel
35 Buildrequires:  db1-devel
36 Buildrequires:  alsa-lib-devel
37 Buildrequires:  libarts-devel
38 Buildrequires:  libggi-devel
39 Buildrequires:  aalib-devel
40 Buildrequires:  SDL-devel
41 Buildrequires:  liba52-devel
42
43 %description
44 VideoLAN is a free network-aware MPEG and DVD player.
45 The VideoLAN Client allows to play MPEG2 Transport Streams from the
46 network or from a file, as well as direct DVD playback.
47 VideoLAN is a project of students from the Ecole Centrale Paris.
48 This version add MPEG1 support, direct DVD support, DVD decryption, 
49 arbitrary, seeking in the stream, pause, fast forward and slow motion, 
50 hardware YUV acceleration and a few new interface features 
51 including drag'n'drop.
52 You may install vlc-gnome, vlc-gtk and vlc-ncurses.
53 This package contains no CSS unscrambling functionality.
54 You need the libdvdcss library available from 
55 http://www.videolan.org/libdvdcss/ or http://plf.zarb.org/
56
57 # intf plugins
58 %package gtk
59 Summary: Gtk plug-in for VideoLAN, a DVD and MPEG2 player
60 Group: Video
61 Requires: %{name} = %{version}
62 %description gtk
63 The vlc-gtk package includes the Gtk plug-in for the VideoLAN client.
64 If you are going to watch DVD with the Gtk front-end, you should 
65 install vlc-gtk.
66
67 %package gnome
68 Summary: Gnome plug-in for VideoLAN, a DVD and MPEG2 player
69 Group: Video
70 Requires: %{name} = %{version}
71 %description gnome
72 The vlc-gnome package includes the Gnome plug-in for the VideoLAN client.
73 If you are going to watch DVD with the Gnome front-end, you should 
74 install vlc-gnome.
75
76 %package qt
77 Summary: Qt2 plug-in for VideoLAN, a DVD and MPEG2 player
78 Group: Video
79 Requires: %{name} = %{version}
80 %description qt
81 The vlc-qt package includes the Qt2 plug-in for the VideoLAN client.
82 If you are going to watch DVD with the Qt2 front-end, you should
83 install vlc-qt
84
85 %package ncurses
86 Summary: Ncurses console-based plug-in for VideoLAN, a DVD and MPEG2 player
87 Group: Video
88 Requires: %{name} = %{version}
89 %description ncurses
90 The vlc-ncurses package includes the ncurses plug-in for the VideoLAN client.
91 If you are going to watch DVD with the ncurses front-end, you should
92 install vlc-ncurses
93
94 # video plugins
95 %package aa
96 Summary: ASCII art video plug-in for VideoLAN, a DVD and MPEG2 player
97 Group: Video
98 Requires: %{name} = %{version}
99 %description aa
100 The vlc-aa package includes the aalib plug-in for the VideoLAN client.
101 If you are going to watch DVD with the aa video plugin, you should
102 install vlc-aa
103
104 %package sdl
105 Summary: Simple DirectMedia Layer video plug-in for VideoLAN, a DVD and MPEG2 player
106 Group: Video
107 Requires: %{name} = %{version}
108 %description sdl
109 The vlc-sdl package includes the Simple DirectMedia Layer plug-in 
110 for the VideoLAN client.
111 If you are going to watch DVD with the sdl video plugin, you should
112 install vlc-sdl
113
114 %package ggi
115 Summary: GGI video plug-in for VideoLAN, a DVD and MPEG2 player
116 Group: Video
117 Requires: %{name} = %{version}
118 %description ggi
119 The vlc-ggi package includes the GGI plug-in for the VideoLAN client.
120 If you are going to watch DVD with the GGI video plugin, you should
121 install vlc-ggi
122
123 # codec plugins
124 %package mad
125 Summary: MAD audio codec plug-in for VideoLAN, a DVD and MPEG2 player
126 Group: Video
127 Requires: %{name} = %{version}
128 %description mad
129 The vlc-mad package includes the MAD (MPEG Audio Decoder) plug-in
130 for the VideoLAN client.
131 If you are going to watch DVD with the mad codec plugin, you should
132 install vlc-mad
133
134 # audio plugins
135 %package esd
136 Summary: Enlightened Sound Daemon audio plug-in for VideoLAN, a DVD and MPEG2 player
137 Group: Video
138 Requires: %{name} = %{version}
139 %description esd
140 The vlc-esd package includes the Enlightened Sound Daemon plug-in 
141 for the VideoLAN client.
142 If you are going to watch DVD with the esd audio plugin, you should
143 install vlc-esd
144
145 %package arts
146 Summary: aRts audio plug-in for VideoLAN, a DVD and MPEG2 player
147 Group: Video
148 Requires: %{name} = %{version}
149 %description arts
150 The vlc-arts package includes the aRts audio plug-in
151 for the VideoLAN client.
152 If you are going to watch DVD with the aRts audio plugin, you should
153 install vlc-arts
154
155 %package alsa
156 Summary: Advanced Linux Sound Architecture audio plug-in for VideoLAN, a DVD and MPGE2 player
157 Group: Video
158 Requires: %{name} = %{version}
159 %description alsa
160 The vlc-alsa packages includes the Advanced Linux Sound Architecture plug-in 
161 for the VideoLAN client.
162 If you are going to watch DVD with the ALSA audio plugin, you should 
163 install vlc-alsa
164
165 %prep
166 %if %{cvs}
167 %setup -q -n %{cvs_name}
168 %else
169 %setup -q -n %{name}-%{vlc_ver}
170 %endif
171
172 %build
173 %configure  --enable-release \
174             --enable-dvd --without-dvdcss \
175             --enable-gtk --enable-gnome --disable-qt --disable-kde --enable-ncurses \
176             --enable-x11 --enable-xvideo --enable-ggi --enable-sdl --enable-fb --enable-mga --enable-aa \
177             --enable-esd --enable-alsa --enable-arts \
178             --enable-mad
179 export QTDIR=%{_libdir}/qt2 
180 %make
181
182 %install
183 %makeinstall_std
184 install -d %buildroot/%_mandir/man1
185 install doc/vlc.1 %buildroot/%_mandir/man1
186
187 # menu
188 mkdir -p %buildroot/%{_menudir}
189 cat > %buildroot/%{_menudir}/vlc << EOF
190 ?package(vlc): command="%{_bindir}/vlc" hotkey="V" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="VideoLAN Client" icon="vlc.png" hints="Video"
191 EOF
192 cat > %buildroot/%{_menudir}/vlc-gtk << EOF
193 ?package(vlc-gtk): command="%{_bindir}/gvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gtk VideoLAN Client" icon="gvlc.png" hints="Video"
194 EOF
195 cat > %buildroot/%{_menudir}/vlc-gnome << EOF
196 ?package(vlc-gnome): command="%{_bindir}/gnome-vlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Gnome VideoLAN Client" icon="gnome-vlc.png" hints="Video"
197 EOF
198 cat > %buildroot/%{_menudir}/vlc-qt << EOF
199 ?package(vlc-gnome): command="%{_bindir}/qvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2 and DVD software solution" section="Multimedia/Video" title="Qt VideoLAN Client" icon="qvlc.png" hints="Video"
200 EOF
201
202 # icons
203 mkdir -p %{buildroot}/{%{_miconsdir},%{_liconsdir}}
204 install -m 644 %buildroot/%_datadir/videolan/vlc16x16.png %buildroot/%{_miconsdir}/vlc.png
205 install -m 644 %buildroot/%_datadir/videolan/vlc32x32.png %buildroot/%{_iconsdir}/vlc.png
206 install -m 644 %buildroot/%_datadir/videolan/vlc48x48.png %buildroot/%{_liconsdir}/vlc.png
207 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc16x16.png %buildroot/%{_miconsdir}/gnome-vlc.png
208 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc32x32.png %buildroot/%{_iconsdir}/gnome-vlc.png
209 install -m 644 %buildroot/%_datadir/videolan/gnome-vlc48x48.png %buildroot/%{_liconsdir}/gnome-vlc.png
210 install -m 644 %buildroot/%_datadir/videolan/gvlc16x16.png %buildroot/%{_miconsdir}/gvlc.png
211 install -m 644 %buildroot/%_datadir/videolan/gvlc32x32.png %buildroot/%{_iconsdir}/gvlc.png
212 install -m 644 %buildroot/%_datadir/videolan/gvlc48x48.png %buildroot/%{_liconsdir}/gvlc.png
213 install -m 644 %buildroot/%_datadir/videolan/kvlc16x16.png %buildroot/%{_miconsdir}/kvlc.png
214 install -m 644 %buildroot/%_datadir/videolan/kvlc32x32.png %buildroot/%{_iconsdir}/kvlc.png
215 install -m 644 %buildroot/%_datadir/videolan/kvlc48x48.png %buildroot/%{_liconsdir}/kvlc.png
216 install -m 644 %buildroot/%_datadir/videolan/qvlc16x16.png %buildroot/%{_miconsdir}/qvlc.png
217 install -m 644 %buildroot/%_datadir/videolan/qvlc32x32.png %buildroot/%{_iconsdir}/qvlc.png
218 install -m 644 %buildroot/%_datadir/videolan/qvlc48x48.png %buildroot/%{_liconsdir}/qvlc.png
219
220 %post
221 %update_menus
222 %postun
223 %update_menus
224
225 %clean
226 rm -fr %buildroot
227
228 %files
229 %defattr(-,root,root)
230 %doc README COPYING
231 %{_bindir}/vlc
232
233 %dir %{_libdir}/videolan/vlc
234 %{_libdir}/videolan/vlc/ac3_spdif.so
235 %{_libdir}/videolan/vlc/dsp.so
236 %{_libdir}/videolan/vlc/dummy.so
237 %{_libdir}/videolan/vlc/dvd.so
238 %{_libdir}/videolan/vlc/fb.so
239 %{_libdir}/videolan/vlc/file.so
240 %{_libdir}/videolan/vlc/filter_deinterlace.so
241 %{_libdir}/videolan/vlc/filter_distort.so
242 %{_libdir}/videolan/vlc/filter_invert.so
243 %{_libdir}/videolan/vlc/filter_transform.so
244 %{_libdir}/videolan/vlc/filter_wall.so
245 %{_libdir}/videolan/vlc/fx_scope.so
246 %{_libdir}/videolan/vlc/http.so
247 %{_libdir}/videolan/vlc/ipv4.so
248 %{_libdir}/videolan/vlc/ipv6.so
249 %{_libdir}/videolan/vlc/logger.so
250 %{_libdir}/videolan/vlc/lpcm_adec.so
251 %{_libdir}/videolan/vlc/memcpy.so
252 %{_libdir}/videolan/vlc/mga.so
253 %{_libdir}/videolan/vlc/mpeg_es.so
254 %{_libdir}/videolan/vlc/mpeg_ps.so
255 %{_libdir}/videolan/vlc/mpeg_ts.so
256 %{_libdir}/videolan/vlc/null.so
257 %{_libdir}/videolan/vlc/rc.so
258 %{_libdir}/videolan/vlc/spudec.so
259 %{_libdir}/videolan/vlc/udp.so
260 %{_libdir}/videolan/vlc/vcd.so
261 %{_libdir}/videolan/vlc/x11.so
262 %{_libdir}/videolan/vlc/xmga.so
263
264 %{_mandir}/man1/*
265 %{_menudir}/vlc
266 %{_miconsdir}/vlc.png
267 %{_iconsdir}/vlc.png
268 %{_liconsdir}/vlc.png
269
270
271 # intf plugins
272 %files gtk
273 %defattr(-,root,root)
274 %doc README
275 %{_libdir}/videolan/vlc/gtk.so
276 %{_bindir}/gvlc
277 %{_menudir}/vlc-gtk
278 %{_miconsdir}/gvlc.png
279 %{_iconsdir}/gvlc.png
280 %{_liconsdir}/gvlc.png
281 %post gtk
282 %update_menus
283 %postun gtk
284 %update_menus
285
286 %files gnome
287 %defattr(-,root,root)
288 %doc README
289 %{_libdir}/videolan/vlc/gnome.so
290 %{_bindir}/gnome-vlc
291 %{_menudir}/vlc-gnome
292 %{_miconsdir}/gnome-vlc.png
293 %{_iconsdir}/gnome-vlc.png
294 %{_liconsdir}/gnome-vlc.png
295 %post   gnome
296 %update_menus
297 %postun gnome
298 %update_menus
299
300 %if %{plugin_qt}
301 %files qt
302 %defattr(-,root,root)
303 %doc README
304 %{_libdir}/videolan/vlc/qt.so
305 %{_bindir}/qvlc
306 %{_menudir}/vlc-qt
307 %{_miconsdir}/qvlc.png
308 %{_iconsdir}/qvlc.png
309 %{_liconsdir}/qvlc.png
310 %post   qt
311 %update_menus
312 %postun qt
313 %update_menus
314 %endif
315
316 %files ncurses
317 %defattr(-,root,root)
318 %doc README
319 %{_libdir}/videolan/vlc/ncurses.so
320
321 # video plugins
322 %files sdl
323 %defattr(-,root,root)
324 %doc README
325 %{_libdir}/videolan/vlc/sdl.so
326
327 %files ggi
328 %defattr(-,root,root)
329 %doc README
330 %{_libdir}/videolan/vlc/ggi.so
331
332 %files aa
333 %defattr(-,root,root)
334 %doc README
335 %{_libdir}/videolan/vlc/aa.so
336
337 # codec plugin
338 %files mad
339 %defattr(-,root,root)
340 %doc README
341 %{_libdir}/videolan/vlc/mad.so
342
343 #audio plugins
344 %files esd
345 %defattr(-,root,root)
346 %doc README
347 %{_libdir}/videolan/vlc/esd.so
348
349 %files arts
350 %defattr(-,root,root)
351 %doc README
352 %{_libdir}/videolan/vlc/arts.so
353
354 %files alsa
355 %defattr(-,root,root)
356 %doc README
357 %{_libdir}/videolan/vlc/alsa.so
358
359 %changelog
360 * Thu Apr 18 2002 Samuel Hocevar <sam@zoy.org> 0.3.1
361 - version 0.3.1.
362 - patch0 is no longer needed.
363
364 * Wed Apr 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-1mdk
365 - version 0.3.1 (hum soon)
366 - removed old %%ifarch ppc
367
368 * Wed Apr 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-4mdk
369 - added liba52 support (buildrequires).
370 - added vlc-alsa audio plugin.
371 - mad is a codec (audio) plugin. corrected description and summary.
372
373 * Wed Apr 10 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-3mdk
374 - added patch0 from CVS: fix crashing GTK popup menus thx Michal Bukovjan <bukovjan@mbox.dkm.cz>
375
376 * Wed Apr 10 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-2mdk
377 - added vlc-arts rpm plugin thx blindauer Emmanuel <manu@agat.net>
378 - better summary for plug-in
379 - add packager tag to myself
380
381 * Sun Apr 07 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-1mdk
382 - added aa (Asci Art) plugin in vlc-aa rpm
383 - merged with sam's one:
384   * using his plugins list into %%files
385   * removed libdvdcss from the whole tarball.
386   * removed the workaround for vlc's bad /dev/dsp detection.
387 - few spelling corrections in all %%description
388 - added buildrequires on SDL-devel
389
390 * Thu Apr 06 2002 Samuel Hocevar <sam@zoy.org> 0.3.0
391 - version 0.3.0.
392 - removed libdvdcss from the whole tarball.
393 - removed the workaround for vlc's bad /dev/dsp detection.
394
395 * Tue Mar 05 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.93-0.1mdk
396 - new cvs snapshot
397 - fix requires
398
399 * Mon Mar 04 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-5mdk
400 - cvs snapshot
401
402 * Sat Jan 26 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-4mdk
403 - mad plugin in vlc-mad rpm
404
405 * Mon Jan 21 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-3mdk
406 - synced with main cvs specfile wich "fixed a few minor inaccuracies"
407
408 * Thu Jan 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-2mdk
409 - readded libdvdcss rpm in specfile. use %%define css 1 with correct sources
410   to build libdvdcss rpm.
411
412 * Wed Jan 09 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-1mdk
413 - version 0.2.92
414 - %%makeinstall_std
415 - splitted again, added vlc-sdl vlc-esd vlc-ggi
416 - bring back some missing plugins
417 - fixed buildrequires
418 - added menu entries and icons (from cvs)
419
420 * Tue Oct 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-2mdk
421 - rebuild against libpng3
422 - added some doc for sir rpmlint
423 - #5583: option -g
424
425 * Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-1mdk
426 - version 0.2.83 : 
427   * Activated subtitles in overlay mode (far from perfect, but this
428     was an often requested feature).
429
430 * Fri Aug 10 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.82-1mdk
431 - version 0.2.82
432
433 * Mon Jul 30 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-1mdk
434 - version 0.2.81
435 - added vlc-ncurses
436
437 * Wed Jun 20 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-0.20010619-1mdk
438 - cvs snapshot
439 - added libdvdcss
440
441 * Wed Jun 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-2mdk
442 - fix build on ppc (c) dadou
443
444 * Mon Jun 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-1mdk
445 - version 0.2.80 : bug fixes and bug fixes and bug fixes and small
446   improvements of the gtk interface.
447 - corrected Summary in vlc-qt
448
449 * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-2mdk
450 - added qt2 plug-in (vlc-qt)
451
452 * Wed May 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-1mdk
453 - version 0.2.73
454 - you can now get decss threw a plug-in
455 - rewritte srcipt to build vlc (decss plugin)
456 - rebuild with SDL 1.2
457
458 * Thu Apr 26 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-2mdk
459 - true 0.2.72
460
461 * Mon Apr 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-1mdk
462 - version 0.2.72
463 - package split into vlc, vlc-gnome, vlc-gtk
464
465 * Fri Apr 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.71-1mdk
466 - version 0.2.71 :
467   * Fixed segfaults when compiled with gcc 3.0pre and versions of gcc
468     shipped with the latest RedHat distributions.                    
469   * Fixed the BeOS CSS decryption.
470   * Fixed a few issues in IFO parsing.
471   * Fixed XVideo video output.
472   * Updated icons under Linux, BeOS, MacOS X.
473
474 * Wed Apr 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.70-1mdk
475 - version 0.2.70
476
477 * Thu Mar 22 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.63-1mdk
478 - version 0.2.63 : Bugfixes, bugfixes, and bugfixes again, a Gtk+ 
479   interface for the Gnome-impaired, an even better DVD support
480
481 * Fri Feb 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.61-1mdk
482 - new version for all the DVD fans (add MPEG1 support, direct DVD support, 
483   DVD decryption, arbitrary, seeking in the stream, pause, fast forward 
484   and slow motion, hardware YUV acceleration enhanced CSS support and a few 
485   new interface features including drag'n'drop.
486 - first *real* public release (now under the GPL)
487
488 * Sat Jan 06 2001 David BAUDENS <baudens@mandrakesoft.com> 0.1.99i-2mdk
489 - Fix build and use right optimizations on PPC
490 - Enable SDL support
491 - Spec clean up
492
493 * Fri Jan  5 2001 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99i-1mdk
494 - 0.1.99i, rebuild
495
496 * Fri Aug 25 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99h-1mdk
497 - 0.1.99h
498
499 * Mon Jul 10 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99c-1mdk
500 - first Mandrake package with help of Sam