]> git.sesse.net Git - vlc/blob - vlc.spec
adaptation for 0.5 branch. almost working :)
[vlc] / vlc.spec
1 %define name            vlc
2 %define vlc_ver         0.5.0
3 %define version         %vlc_ver
4 %define libmajor        0
5 %define libname         lib%name%libmajor
6
7 %define cvs             0
8 %if %{cvs}
9 %define cvsdate         20021213
10 %define release         0.%{cvsdate}
11 %define cvs_name        %{name}-%version-cvs
12 %else
13 %define release         0.1mdk
14 %endif
15
16 # The QT interface is not functional yet
17 %define plugin_qt       0
18 %define plugin_lirc     1
19 %define plugin_svgalib  0
20
21 Summary:        VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
22 Name:           %{name}
23 Version:        %{version}
24 Release:        %{release}
25 Packager:       Yves Duret <yves@zarb.org>
26
27 %if %{cvs} 
28 Source0:        http://www.videolan.org/pub/videolan/vlc/snapshots/%{cvs_name}.tar.bz2
29 %else
30 Source0:        http://www.videolan.org/packages/%{version}/%{name}-%{version}.tar.bz2
31 %endif
32 License:        GPL
33 Group:          Video
34 URL:            http://www.videolan.org/
35 Requires:       vlc-gui
36 # vlc-mad needed by ffmpeg builtin (i want MPEG4 support out of box)
37 Requires:       vlc-mad
38
39 BuildRoot:      %_tmppath/%name-%version-%release-root
40 #Buildrequires: libncurses5-devel
41 #Buildrequires: libqt2-devel
42 #Buildrequires: libgtk+1.2-devel
43 #Buildrequires: gnome-libs-devel
44 #Buildrequires: db1-devel
45 Buildrequires:  libalsa2-devel
46 Buildrequires:  libesound0-devel
47 #Buildrequires: libarts-devel
48 #Buildrequires: libggi-devel
49 #Buildrequires: aalib-devel
50 #Buildrequires: SDL-devel
51 #Buildrequires: liba52dec-devel
52 #Buildrequires: libmad-devel
53 #Buildrequires: liblirc-devel
54 #Buildrequires: libffmpeg-devel
55 #Buildrequires: libvorbis-devel
56 #Buildrequires: libogg-devel
57 #Buildrequires: mozilla-devel
58 #Buildrequires: libdev2-devel
59 #Buildrequires: libxosd2-devel
60
61 %description
62 VideoLAN is an OpenSource streaming solution for every OS developed by
63 students from the Ecole Centrale Paris and developers from all over the
64 World.
65 The VideoLAN Client (vlc) plays MPEG1, MPEG2 and MPEG4 (aka DivX) files,
66 DVDs, VCDs, SVCDs, from a satellite card, from an MPEG2 Transport
67 Streams sent by the VideoLAN Server (vls) or from a Web server (with the
68 HTTP input).
69 You may install vlc-gnome or vlc-gtk to have a nice graphical interface.
70 This package contains no CSS unscrambling functionality for DVDs ;
71 you need the libdvdcss library available from 
72 http://www.videolan.org/libdvdcss/ or http://plf.zarb.org/
73
74 #general packages
75 %package -n %libname-devel
76 Summary: Development files for the VideoLAN Client
77 Group: Development/C
78 Requires: %name = %version-%release
79 Provides: %{name}-devel = %version-%release
80 %description -n %libname-devel
81 Development files for the VideoLAN Client
82 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
83
84 This package contains headers and a static library required to build plugins
85 for the VideoLAN Client, or standalone applications using VideoLAN Client.
86
87 %package -n mozilla-plugin-vlc
88 Summary: A multimedia plugin for Mozilla, based on vlc
89 group: Video
90 Requires: %name = %version-%release
91 %description -n mozilla-plugin-vlc
92 This plugin adds support for MPEG, MPEG2, DVD and DivX to your Mozilla
93 browser. The decoding process is done by vlc and the output window is
94 embedded in a webpage or directly in the browser window. There is also
95 support for fullscreen display.
96
97
98 # intf plugins
99 %package -n gvlc
100 Summary: Gtk plugin for the VideoLAN client
101 Group: Video
102 Requires: %{name} = %{version}
103 Provides: vlc-gui
104 %description -n gvlc
105 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
106
107 This plugin adds a Gtk+ interface to vlc, the VideoLAN Client. To
108 activate it, use the `--intf gtk' flag or run the `gvlc' program.
109
110 %package -n gnome-vlc
111 Summary: Gnome plugin for the VideoLAN client
112 Group: Video
113 Requires: %{name} = %{version}
114 Provides: vlc-gui, vlc-gnome
115 Obsoletes: vlc-gnome
116 %description -n gnome-vlc
117 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
118
119 This plugin adds a Gnome interface to vlc, the VideoLAN Client. To
120 activate it, use the `--intf gnome' flag or run the `gnome-vlc' program.
121
122 %package -n qvlc
123 Summary: Qt2 plugin for the VideoLAN client
124 Group: Video
125 Requires: %{name} = %{version}
126 Provides: vlc-gui, vlc-qt
127 Obsoletes: vlc-qt
128 %description -n qvlc
129 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
130
131 This plugin adds a Qt interface to vlc, the VideoLAN Client. To
132 activate it, use the `--intf qt' flag or run the `qvlc' program.
133
134 %package -n kvlc
135 Summary: KDE frontend for the VideoLAN client
136 Group: Video
137 Requires: %{name} = %{version}
138 Provides: vlc-gui
139 %description -n kvlc
140 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
141
142 This plugin adds a KDE interface to vlc, the VideoLAN Client. To
143 activate it, use the `--intf kde' flag or run the `kvlc' program.
144
145
146 %package plugin-ncurses
147 Summary: Ncurses console-based plugin for the VideoLAN client
148 Group: Video
149 Requires: %{name} = %{version}
150 %description plugin-ncurses
151 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
152
153 This plugin adds a ncurses interface to vlc, the VideoLAN Client. To
154 activate it, use the `--intf ncurses' flag.
155
156 %package plugin-lirc
157 Summary: Lirc plugin for the VideoLAN client
158 Group: Video
159 Requires: %{name} = %{version}
160 Obsoletes: vlc-lirc
161 Provides: vlc-lirc
162 %description plugin-lirc
163 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
164
165 This plugin is an infrared lirc interface for vlc, the
166 VideoLAN Client. To activate it, use the `--intf lirc' flag.
167
168 #
169 # video plugins
170 %package plugin-aa
171 Summary: ASCII art video plugin for the VideoLAN client
172 Group: Video
173 Requires: %{name} = %{version}
174 Obsoletes: vlc-aa
175 Provides: vlc-aa
176 %description plugin-aa
177 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
178
179 This is an ASCII art video output plugin for vlc, the VideoLAN
180 Client. To activate it, use the `--vout aa' flag or select the `aa'
181 vout plugin from the preferences menu.
182
183
184 %package plugin-sdl
185 Summary: Simple DirectMedia Layer video plugin for the VideoLAN client
186 Group: Video
187 Requires: %{name} = %{version}
188 Obsoletes: vlc-sdl
189 Provides: vlc-sdl
190 %description plugin-sdl
191 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
192
193 This plugin adds support for the Simple DirectMedia Layer library to
194 vlc, the VideoLAN Client. To activate it, use the `--vout sdl' or
195 `--aout sdl' flags or select the `sdl' vout or aout plugin from the
196 preferences menu.
197
198 %package plugin-ggi
199 Summary: GGI video plugin for the VideoLAN client
200 Group: Video
201 Requires: %{name} = %{version}
202 Obsoletes: vlc-ggi
203 Provides: vlc-ggi
204 %description plugin-ggi
205 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
206
207 This is a GGI plugin for vlc, the VideoLAN Client.  To activate it, use
208 the `--vout ggi' flag or select the `ggi' vout plugin from the preferences
209 menu.
210
211 %package plugin-svgalib
212 Summary: SVGAlib video plugin for the VideoLAN client
213 Group: Video
214 Requires: %{name} = %{version}
215 %description plugin-svgalib
216 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
217
218 This plugin adds support for SVGAlib to vlc, the VideoLAN Client. To
219 activate it, use the `--vout svgalib' flag or select the `svgalib' video
220 output plugin from the preferences menu. Note that you will need root
221 permissions to use SVGAlib.
222
223
224 #
225 # visualization plugins
226 %package plugin-xosd
227 Summary: X On-Screen Display plugin for the VideoLAN client
228 Group: Video
229 Requires: %{name} = %{version}
230 %description plugin-xosd
231 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
232
233 This is an On-Screen Display plugin for vlc, the VideoLAN Client. To
234 activate it, use the `--intf xosd' flag or select the `xosd' interface
235 plugin from the preferences menu.
236
237 # codec plugins
238 %package plugin-mad
239 Summary: MAD audio codec plugin for the VideoLAN client
240 Group: Video
241 Requires: %{name} = %{version}
242 Obsoletes: vlc-mad
243 Provides: vlc-mad
244 %description plugin-mad
245 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
246
247 This plugin adds support for libmad, the MPEG audio decoder library,
248 to the VideoLAN Client. MAD is 100% fixed-point based. To activate
249 this plugin, use the `--mpeg_adec mad' flag or select the `mad' MPEG
250 decoder from the preferences menu.
251
252 %package plugin-ogg
253 Summary: Ogg demuxer and Vorbis codec plugin for the VideoLAN client
254 Group: Video
255 Requires: %{name} = %{version}
256 %description plugin-ogg
257 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
258
259 These plugins add support for the Ogg bitstream format and the Ogg Vorbis
260 compressed audio format to vlc, the VideoLAN Client. They are autodetected.
261
262 %package plugin-a52
263 Summary: A-52 (AC-3) codec plugin for the VideoLAN client
264 Group: Video
265 Requires: %{name} = %{version}
266 %description plugin-a52
267 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
268
269 This plugin adds support for the ATSC A-52 (aka. AC-3) audio format to
270 vlc, the VideoLAN Client. The plugin is autodetected.
271
272 %package plugin-dv
273 Summary: DV codec plugin for the VideoLAN client
274 Group: Video
275 Requires: %{name} = %{version}
276 %description plugin-dv
277 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
278
279 This plugin adds support for the DV video format to vlc, the VideoLAN
280 Client. The plugin is autodetected.
281
282 #
283 # input plugins
284 %package plugin-dvb
285 Summary: DVB input plugin for the VideoLAN client
286 Group: Video
287 Requires: %{name} = %{version}
288 %description plugin-dvb
289 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
290
291 This plugin adds support for DVB cards to vlc, the VideoLAN Client. Note
292 that your card needs to be supported by your kernel before vlc can use it.
293
294 #
295 # audio plugins
296 %package plugin-esd
297 Summary: Enlightened Sound Daemon audio plugin for the VideoLAN client
298 Group: Video
299 Requires: %{name} = %{version}
300 Obsoletes: vlc-esd
301 Provides: vlc-esd
302 %description plugin-esd
303 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
304
305 This plugin adds support for the Enlightened Sound Daemon to vlc, the
306 VideoLAN Client. To activate it, use the `--aout esd' flag or select
307 the `esd' aout plugin from the preferences menu.
308
309 %package plugin-arts
310 Summary: aRts audio plugin for the VideoLAN client
311 Group: Video
312 Requires: %{name} = %{version}
313 Obsoletes: vlc-arts
314 Provides: vlc-arts
315 %description plugin-arts
316 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
317
318 This plugin adds support for the aRts Sound System to vlc, the
319 VideoLAN Client. To activate it, use the `--aout arts' flag or
320 select the `arts' aout plugin from the preferences menu.
321
322 %package plugin-alsa
323 Summary: Advanced Linux Sound Architecture audio plugin for the VideoLAN client
324 Group: Video
325 Requires: %{name} = %{version}
326 Obsoletes: vlc-alsa
327 Provides: vlc-alsa
328 %description plugin-alsa
329 VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution.
330
331 This plugin adds support for the Advanced Linux Sound Architecture to
332 vlc, the VideoLAN Client. To activate it, use the `--aout alsa' flag or
333 select the `alsa' aout plugin from the preferences menu.
334
335 %prep
336 %if %{cvs}
337 %setup -q -n %{cvs_name}
338 %else
339 %setup -q 
340 #-n %name-%version-cvs
341 %endif
342
343 %build
344 # yves 0.4.0-1mdk
345 # ffmpeg: static linking cause no official ffmpeg release aith a stable ABI
346 # ffmpeg: no plugin posible on ia64 due to the static linking (can not put .a in a .so)
347 %configure  --enable-release \
348             --enable-dvd --without-dvdcss --enable-dvdplay \
349 #            --enable-gtk --enable-gnome --disable-qt --disable-kde --enable-ncurses --enable-lirc \
350             --enable-x11 --enable-xvideo \
351             #--enable-ggi --enable-sdl --enable-fb --enable-mga --enable-aa \
352             --enable-esd --enable-alsa \
353 #--enable-arts \
354 #           --enable-mad --enable-ffmpeg --with-ffmpeg=/usr
355             
356 # --enable-a52 --enable-aa --enable-dvbpsi --enable-xosd --enable-mozilla --enable-kde --enable-mp4 --enable-dvb --enable-dv --enable-svgalib --enable-satellite --enable-ogg --enable-vorbis
357
358 export QTDIR=%{_libdir}/qt3 
359 %make
360
361 %install
362 %makeinstall_std
363 %find_lang %name
364 #install -d %buildroot/%_mandir/man1
365 #install doc/vlc.1 %buildroot/%_mandir/man1
366
367 # menu
368 mkdir -p %buildroot/%{_menudir}
369 cat > %buildroot/%{_menudir}/vlc << EOF
370 ?package(vlc): command="%{_bindir}/vlc" hotkey="V" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution" section="Multimedia/Video" title="VideoLAN Client" icon="vlc.png" hints="Video"
371 EOF
372 cat > %buildroot/%{_menudir}/gvlc << EOF
373 ?package(gvlc): command="%{_bindir}/gvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution" section="Multimedia/Video" title="Gtk VideoLAN Client" icon="gvlc.png" hints="Video"
374 EOF
375 cat > %buildroot/%{_menudir}/gnome-vlc << EOF
376 ?package(gnome-vlc): command="%{_bindir}/gnome-vlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution" section="Multimedia/Video" title="Gnome VideoLAN Client" icon="gnome-vlc.png" hints="Video"
377 EOF
378 %if %{plugin_qt}
379 cat > %buildroot/%{_menudir}/qvlc << EOF
380 ?package(qvlc): command="%{_bindir}/qvlc" needs="X11" longtitle="VideoLAN is a free MPEG, MPEG2, DVD and DivX software solution" section="Multimedia/Video" title="Qt VideoLAN Client" icon="qvlc.png" hints="Video"
381 EOF
382 %endif
383
384 # icons
385 mkdir -p %{buildroot}/{%{_miconsdir},%{_liconsdir}}
386 install -m 644 %buildroot/%_datadir/vlc/vlc16x16.png %buildroot/%_miconsdir/vlc.png
387 install -m 644 %buildroot/%_datadir/vlc/vlc32x32.png %buildroot/%_iconsdir/vlc.png
388 install -m 644 %buildroot/%_datadir/vlc/vlc48x48.png %buildroot/%_liconsdir/vlc.png
389 install -m 644 %buildroot/%_datadir/vlc/gnome-vlc16x16.png %buildroot/%_miconsdir/gnome-vlc.png
390 install -m 644 %buildroot/%_datadir/vlc/gnome-vlc32x32.png %buildroot/%_iconsdir/gnome-vlc.png
391 install -m 644 %buildroot/%_datadir/vlc/gnome-vlc48x48.png %buildroot/%_liconsdir/gnome-vlc.png
392 install -m 644 %buildroot/%_datadir/vlc/gvlc16x16.png %buildroot/%_miconsdir/gvlc.png
393 install -m 644 %buildroot/%_datadir/vlc/gvlc32x32.png %buildroot/%_iconsdir/gvlc.png
394 install -m 644 %buildroot/%_datadir/vlc/gvlc48x48.png %buildroot/%_liconsdir/gvlc.png
395 install -m 644 %buildroot/%_datadir/vlc/kvlc16x16.png %buildroot/%_miconsdir/kvlc.png
396 install -m 644 %buildroot/%_datadir/vlc/kvlc32x32.png %buildroot/%_iconsdir/kvlc.png
397 install -m 644 %buildroot/%_datadir/vlc/kvlc48x48.png %buildroot/%_liconsdir/kvlc.png
398 %if %{plugin_qt}
399 install -m 644 %buildroot/%_datadir/vlc/qvlc16x16.png %buildroot/%_miconsdir/qvlc.png
400 install -m 644 %buildroot/%_datadir/vlc/qvlc32x32.png %buildroot/%_iconsdir/qvlc.png
401 install -m 644 %buildroot/%_datadir/vlc/qvlc48x48.png %buildroot/%_liconsdir/qvlc.png
402 %endif
403
404 %post
405 %update_menus
406 %postun
407 %update_menus
408
409 %clean
410 rm -fr %buildroot
411
412 %files -f %name.lang
413 %defattr(-,root,root)
414 %doc README COPYING
415 %_bindir/vlc
416
417 %dir %_libdir/vlc
418
419 %dir %_libdir/vlc/access
420 %_libdir/vlc/access/libaccess_file_plugin.so
421 %_libdir/vlc/access/libaccess_http_plugin.so
422 %_libdir/vlc/access/libaccess_mms_plugin.so
423 %_libdir/vlc/access/libaccess_rtp_plugin.so
424 %_libdir/vlc/access/libaccess_udp_plugin.so
425 %_libdir/vlc/access/libdvdplay_plugin.so
426 %_libdir/vlc/access/libdvd_plugin.so
427 %_libdir/vlc/access/libdvdread_plugin.so
428 %_libdir/vlc/access/libvcd_plugin.so
429
430 %dir %_libdir/vlc/audio_filter
431 %_libdir/vlc/audio_filter/liba52tospdif_plugin.so
432 %_libdir/vlc/audio_filter/libfixed32tofloat32_plugin.so
433 %_libdir/vlc/audio_filter/libfixed32tos16_plugin.so
434 %_libdir/vlc/audio_filter/libfloat32tos16_plugin.so
435 %_libdir/vlc/audio_filter/libfloat32tos8_plugin.so
436 %_libdir/vlc/audio_filter/libfloat32tou16_plugin.so
437 %_libdir/vlc/audio_filter/libfloat32tou8_plugin.so
438 %_libdir/vlc/audio_filter/libheadphone_channel_mixer_plugin.so
439 %_libdir/vlc/audio_filter/liblinear_resampler_plugin.so
440 %_libdir/vlc/audio_filter/libs16tofloat32_plugin.so
441 %_libdir/vlc/audio_filter/libs16tofloat32swab_plugin.so
442 %_libdir/vlc/audio_filter/libs8tofloat32_plugin.so
443 %_libdir/vlc/audio_filter/libtrivial_channel_mixer_plugin.so
444 %_libdir/vlc/audio_filter/libtrivial_resampler_plugin.so
445 %_libdir/vlc/audio_filter/libu8tofixed32_plugin.so
446 %_libdir/vlc/audio_filter/libu8tofloat32_plugin.so
447 %_libdir/vlc/audio_filter/libugly_resampler_plugin.so
448
449 %dir %_libdir/vlc/audio_mixer
450 %_libdir/vlc/audio_mixer/libfloat32_mixer_plugin.so
451 %_libdir/vlc/audio_mixer/libspdif_mixer_plugin.so
452 %_libdir/vlc/audio_mixer/libtrivial_mixer_plugin.so
453
454 %dir %_libdir/vlc/audio_output
455 %_libdir/vlc/audio_output/libaout_file_plugin.so
456 %_libdir/vlc/audio_output/liboss_plugin.so
457
458
459 %dir %_libdir/vlc/codec
460 %_libdir/vlc/codec/liba52_plugin.so
461 %_libdir/vlc/codec/libadpcm_plugin.so
462 %_libdir/vlc/codec/libaraw_plugin.so
463 %_libdir/vlc/codec/libcinepak_plugin.so
464 %_libdir/vlc/codec/libdownmix3dn_plugin.so
465 %_libdir/vlc/codec/libdownmixsse_plugin.so
466 %_libdir/vlc/codec/libidctclassic_plugin.so
467 %_libdir/vlc/codec/libidctmmxext_plugin.so
468 %_libdir/vlc/codec/libidctmmx_plugin.so
469 %_libdir/vlc/codec/libidct_plugin.so
470 %_libdir/vlc/codec/libimdct3dn_plugin.so
471 %_libdir/vlc/codec/libimdctsse_plugin.so
472 %_libdir/vlc/codec/liblpcm_plugin.so
473 %_libdir/vlc/codec/libmotionmmxext_plugin.so
474 %_libdir/vlc/codec/libmotionmmx_plugin.so
475 %_libdir/vlc/codec/libmotion_plugin.so
476 %_libdir/vlc/codec/libmpeg_audio_plugin.so
477 %_libdir/vlc/codec/libmpeg_video_plugin.so
478 %_libdir/vlc/codec/libspudec_plugin.so
479
480 %dir %_libdir/vlc/control
481
482 %dir %_libdir/vlc/demux
483 %_libdir/vlc/demux/libaac_plugin.so
484 %_libdir/vlc/demux/libasf_plugin.so
485 %_libdir/vlc/demux/libaudio_plugin.so
486 %_libdir/vlc/demux/libavi_plugin.so
487 %_libdir/vlc/demux/libdemuxdump_plugin.so
488 %_libdir/vlc/demux/libdemuxsub_plugin.so
489 %_libdir/vlc/demux/libes_plugin.so
490 %_libdir/vlc/demux/libid3_plugin.so
491 %_libdir/vlc/demux/libm3u_plugin.so
492 %_libdir/vlc/demux/libmp4_plugin.so
493 %_libdir/vlc/demux/libmpeg_system_plugin.so
494 %_libdir/vlc/demux/libps_plugin.so
495 %_libdir/vlc/demux/libts_plugin.so
496 %_libdir/vlc/demux/libwav_plugin.so
497
498 %dir %_libdir/vlc/misc
499 %_libdir/vlc/misc/libdummy_plugin.so
500 %_libdir/vlc/misc/libipv4_plugin.so
501 %_libdir/vlc/misc/libipv6_plugin.so
502 %_libdir/vlc/misc/liblogger_plugin.so
503 %_libdir/vlc/misc/libmemcpy3dn_plugin.so
504 %_libdir/vlc/misc/libmemcpymmxext_plugin.so
505 %_libdir/vlc/misc/libmemcpymmx_plugin.so
506 %_libdir/vlc/misc/libmemcpy_plugin.so
507 %_libdir/vlc/misc/libsap_plugin.so
508
509 %dir %_libdir/vlc/video_chroma
510 %_libdir/vlc/video_chroma/libi420_rgb_mmx_plugin.so
511 %_libdir/vlc/video_chroma/libi420_rgb_plugin.so
512 %_libdir/vlc/video_chroma/libi420_ymga_mmx_plugin.so
513 %_libdir/vlc/video_chroma/libi420_ymga_plugin.so
514 %_libdir/vlc/video_chroma/libi420_yuy2_mmx_plugin.so
515 %_libdir/vlc/video_chroma/libi420_yuy2_plugin.so
516 %_libdir/vlc/video_chroma/libi422_yuy2_mmx_plugin.so
517 %_libdir/vlc/video_chroma/libi422_yuy2_plugin.so
518
519 %dir %_libdir/vlc/video_filter
520 %_libdir/vlc/video_filter/libadjust_plugin.so
521 %_libdir/vlc/video_filter/libclone_plugin.so
522 %_libdir/vlc/video_filter/libcrop_plugin.so
523 %_libdir/vlc/video_filter/libdeinterlace_plugin.so
524 %_libdir/vlc/video_filter/libdistort_plugin.so
525 %_libdir/vlc/video_filter/libinvert_plugin.so
526 %_libdir/vlc/video_filter/libmotionblur_plugin.so
527 %_libdir/vlc/video_filter/libtransform_plugin.so
528 %_libdir/vlc/video_filter/libwall_plugin.so
529
530 %dir %_libdir/vlc/video_output
531 %_libdir/vlc/video_output/libfb_plugin.so
532 %_libdir/vlc/video_output/libx11_plugin.so
533 %_libdir/vlc/video_output/libxvideo_plugin.so
534
535 %dir %_libdir/vlc/visualization
536
537 %_mandir/man1/*
538 %_menudir/vlc
539 %_miconsdir/vlc.png
540 %_iconsdir/vlc.png
541 %_liconsdir/vlc.png
542
543 %files -n %libname-devel
544 %defattr(-,root,root)
545 %doc README
546 %dir %_includedir/vlc
547 %_includedir/vlc/*
548 %_libdir/*a
549 %_libdir/vlc/*a
550 %_bindir/vlc-config
551
552 %files -n mozilla-plugin-vlc
553 %defattr(-,root,root)
554 %doc README
555 # FIXME: seems to be mozilla-version/plugin on Mandrake
556 #%dir %_libdir/mozilla
557 %_libdir/mozilla/*
558
559 # intf plugins
560 %files -n gvlc
561 %defattr(-,root,root)
562 %doc README
563 %_libdir/vlc/misc/libgtk_main_plugin.so
564 %_libdir/vlc/gui/libgtk_plugin.so
565 %_bindir/gvlc
566 %_menudir/gvlc
567 %_miconsdir/gvlc.png
568 %_iconsdir/gvlc.png
569 %_liconsdir/gvlc.png
570 %post -n gvlc
571 %update_menus
572 %postun -n gvlc
573 %update_menus
574
575 %files -n gnome-vlc
576 %defattr(-,root,root)
577 %doc README
578 %_libdir/vlc/misc/libgnome_main_plugin.so
579 %_libdir/vlc/gui/libgnome_plugin.so
580 %_bindir/gnome-vlc
581 %_menudir/gnome-vlc
582 %_miconsdir/gnome-vlc.png
583 %_iconsdir/gnome-vlc.png
584 %_liconsdir/gnome-vlc.png
585 %post   -n gnome-vlc
586 %update_menus
587 %postun -n gnome-vlc
588 %update_menus
589
590 %if %{plugin_qt}
591 %files -n qvlc
592 %defattr(-,root,root)
593 %doc README
594 %_libdir/vlc/gui/libqt_plugin.so
595 %_bindir/qvlc
596 %_menudir/qvlc
597 %_miconsdir/qvlc.png
598 %_iconsdir/qvlc.png
599 %_liconsdir/qvlc.png
600 %post   -n qvlc
601 %update_menus
602 %postun -n qvlc
603 %update_menus
604 %endif
605
606 %files -n kvlc
607 %doc README
608 %_libdir/vlc/gui/libkde_plugin.so
609 %_bindir/kvlc
610 %_menudir/kvlc
611 %_miconsdir/kvlc.png
612 %_iconsdir/kvlc.png
613 %_liconsdir/kvlc.png
614 %post   -n kvlc
615 %update_menus
616 %postun -n kvlc
617 %update_menus
618
619
620 %files plugin-ncurses
621 %defattr(-,root,root)
622 %doc README
623 %_libdir/vlc/gui/libncurses_plugin.so
624
625 %if %plugin_lirc
626 %files plugin-lirc
627 %defattr(-,root,root)
628 %doc README
629 %_libdir/vlc/control/liblirc_plugin.so
630 %endif
631
632 # video plugins
633 %files plugin-sdl
634 %defattr(-,root,root)
635 %doc README
636 %_libdir/vlc/audio_output/libaout_sdl_plugin.so
637 %_libdir/vlc/video_output/libvout_sdl_plugin.so
638
639 %files plugin-ggi
640 %defattr(-,root,root)
641 %doc README
642 %{_libdir}/vlc/video_output/libggi_plugin.so
643
644 %files plugin-aa
645 %defattr(-,root,root)
646 %doc README
647 %{_libdir}/vlc/video_output/libaa_plugin.so
648
649 %if %plugin_svgalib
650 %files plugin-svgalib
651 %defattr(-,root,root)
652 %doc README
653 %_libdir/vlc/video_output/libsvgalib_plugin.so
654 %endif
655
656 # visualization plugin
657 %files plugin-xosd
658 %defattr(-,root,root)
659 %doc README
660 %_libdir/vlc/visualization/libxosd_plugin.so
661
662 # codec plugin
663 %files plugin-mad
664 %defattr(-,root,root)
665 %doc README
666 %{_libdir}/vlc/codec/libmad_plugin.so
667
668 %files plugin-ogg
669 %defattr(-,root,root)
670 %doc README
671 %{_libdir}/vlc/demux/libogg_plugin.so
672 %{_libdir}/vlc/vlc/codec/libvorbis_plugin.so
673
674 %files plugin-dv
675 %defattr(-,root,root)
676 %doc README
677 %_libdir/vlc/codec/libdv_plugin.so
678
679 %files plugin-a52
680 %defattr(-,root,root)
681 %doc README
682 %_libdir/vlc/codec/liba52_plugin.so
683
684 # input plugin
685 %files plugin-dvb
686 %defattr(-,root,root)
687 %doc README
688 %_libdir/vlc/access/libsatellite_plugin.so
689
690 #audio plugins
691 %files plugin-esd
692 %defattr(-,root,root)
693 %doc README
694 %_libdir/vlc/audio_output/libesd_plugin.so
695
696 %files plugin-arts
697 %defattr(-,root,root)
698 %doc README
699 %_libdir/vlc/audio_output/libarts_plugin.so
700
701 %files plugin-alsa
702 %defattr(-,root,root)
703 %doc README
704 %_libdir/vlc/audio_output/libalsa_plugin.so
705
706 %changelog
707 * Mon Jun 20 2002 Yves Duret <yduret@mandrakesoft.com> 0.4.2-1mdk
708 - new upstream release
709
710 * Mon Jun 3 2002 Yves Duret <yduret@mandrakesoft.com> 0.4.1-1mdk
711 - new upstream release
712
713 * Thu May 23 2002 Yves Duret <yduret@mandrakesoft.com> 0.4.0-1mdk
714 - version 0.4.0 with MPEG4 (DivX) support thx ffmpeg.
715   thus s/MPEG, MPEG2 and DVD/multimedia/g
716 - sync %%description with debian ones.
717 - vlc now requires a vlc-gui (gtk, gnome or qt).
718 - removed gcc3.1 patches since merged upstream.
719
720 * Mon May 13 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-4mdk
721 - removed xmga plugin (currently broken).
722 - manual rebuild in gcc3.1 environment aka added Patch0 & Patch1
723 - various summary/description changes.
724
725 * Fri May 03 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-3mdk
726 - added vlc-lirc intf plugin rpm.
727
728 * Tue Apr 30 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-2mdk
729 - rebuild against libalsa2 (vlc-sdl)
730
731 * Fri Apr 19 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.1-1mdk
732 - version 0.3.1.
733 - removed patch0 merged upstream.
734 - removed old %%ifarch ppc
735 - added missing libmad-devel buldrequires
736
737 * Wed Apr 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-4mdk
738 - added liba52 support (buildrequires).
739 - added vlc-alsa audio plugin.
740 - mad is a codec (audio) plugin. corrected description and summary.
741
742 * Wed Apr 10 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-3mdk
743 - added patch0 from CVS: fix crashing GTK popup menus thx Michal Bukovjan <bukovjan@mbox.dkm.cz>
744
745 * Wed Apr 10 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-2mdk
746 - added vlc-arts rpm plugin thx blindauer Emmanuel <manu@agat.net>
747 - better summary for plugin
748 - add packager tag to myself
749
750 * Sun Apr 07 2002 Yves Duret <yduret@mandrakesoft.com> 0.3.0-1mdk
751 - version 0.3.0
752 - added aa (Asci Art) plugin in vlc-aa rpm
753 - merged with sam's one:
754   * using his plugins list into %%files
755   * removed libdvdcss from the whole tarball.
756   * removed the workaround for vlc's bad /dev/dsp detection.
757 - few spell corrections in all %%description
758 - added buildrequires on SDL-devel
759
760 * Tue Mar 05 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.93-0.1mdk
761 - new cvs snapshot
762 - fix requires
763
764 * Mon Mar 04 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-5mdk
765 - cvs snapshot
766
767 * Sat Jan 26 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-4mdk
768 - mad plugin in vlc-mad rpm
769
770 * Mon Jan 21 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-3mdk
771 - synced with main cvs specfile wich "fixed a few minor inaccuracies"
772
773 * Thu Jan 17 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-2mdk
774 - readded libdvdcss rpm in specfile. use %%define css 1 with correct sources
775   to build libdvdcss rpm.
776
777 * Wed Jan 09 2002 Yves Duret <yduret@mandrakesoft.com> 0.2.92-1mdk
778 - version 0.2.92
779 - %%makeinstall_std
780 - splitted again, added vlc-sdl vlc-esd vlc-ggi
781 - bring back some missing plugins
782 - fixed buildrequires
783 - added menu entries and icons (from cvs)
784
785 * Tue Oct 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-2mdk
786 - rebuild against libpng3
787 - added some doc for sir rpmlint
788 - #5583: option -g
789
790 * Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.83-1mdk
791 - version 0.2.83 : 
792   * Activated subtitles in overlay mode (far from perfect, but this
793     was an often requested feature).
794
795 * Fri Aug 10 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.82-1mdk
796 - version 0.2.82
797
798 * Mon Jul 30 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-1mdk
799 - version 0.2.81
800 - added vlc-ncurses
801
802 * Wed Jun 20 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.81-0.20010619-1mdk
803 - cvs snapshot
804 - added libdvdcss
805
806 * Wed Jun 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-2mdk
807 - fix build on ppc (c) dadou
808
809 * Mon Jun 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.80-1mdk
810 - version 0.2.80 : bug fixes and bug fixes and bug fixes and small
811   improvements of the gtk interface.
812 - corrected Summary in vlc-qt
813
814 * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-2mdk
815 - added qt2 plugin (vlc-qt)
816
817 * Wed May 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.73-1mdk
818 - version 0.2.73
819 - you can now get decss threw a plugin
820 - rewritte srcipt to build vlc (decss plugin)
821 - rebuild with SDL 1.2
822
823 * Thu Apr 26 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-2mdk
824 - true 0.2.72
825
826 * Mon Apr 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.72-1mdk
827 - version 0.2.72
828 - package split into vlc, vlc-gnome, vlc-gtk
829
830 * Fri Apr 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.71-1mdk
831 - version 0.2.71 :
832   * Fixed segfaults when compiled with gcc 3.0pre and versions of gcc
833     shipped with the latest RedHat distributions.                    
834   * Fixed the BeOS CSS decryption.
835   * Fixed a few issues in IFO parsing.
836   * Fixed XVideo video output.
837   * Updated icons under Linux, BeOS, MacOS X.
838
839 * Wed Apr 11 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.70-1mdk
840 - version 0.2.70
841
842 * Thu Mar 22 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.63-1mdk
843 - version 0.2.63 : Bugfixes, bugfixes, and bugfixes again, a Gtk+ 
844   interface for the Gnome-impaired, an even better DVD support
845
846 * Fri Feb 16 2001 Yves Duret <yduret@mandrakesoft.com> 0.2.61-1mdk
847 - new version for all the DVD fans (add MPEG1 support, direct DVD support, 
848   DVD decryption, arbitrary, seeking in the stream, pause, fast forward 
849   and slow motion, hardware YUV acceleration enhanced CSS support and a few 
850   new interface features including drag'n'drop.
851 - first *real* public release (now under the GPL)
852
853 * Sat Jan 06 2001 David BAUDENS <baudens@mandrakesoft.com> 0.1.99i-2mdk
854 - Fix build and use right optimizations on PPC
855 - Enable SDL support
856 - Spec clean up
857
858 * Fri Jan  5 2001 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99i-1mdk
859 - 0.1.99i, rebuild
860
861 * Fri Aug 25 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99h-1mdk
862 - 0.1.99h
863
864 * Mon Jul 10 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.1.99c-1mdk
865 - first Mandrake package with help of Sam