]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - Cargo.toml
move Rust sources to top level, C sources into c_src
[bcachefs-tools-debian] / Cargo.toml
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644 (file)
index 0000000..66d7bc6
--- /dev/null
@@ -0,0 +1,27 @@
+[package]
+name = "bcachefs-tools"
+version = "0.3.1"
+authors = ["Yuxuan Shui <yshuiv7@gmail.com>", "Kayla Firestack <dev@kaylafire.me>", "Kent Overstreet <kent.overstreet@linux.dev>" ]
+edition = "2021"
+rust-version = "1.65"
+
+[[bin]]
+name = "bcachefs"
+path = "src/bcachefs.rs"
+
+[dependencies]
+atty = "0.2.14"
+log = { version = "0.4", features = ["std"] }
+colored = "2"
+clap = { version = "4.0.32", features = ["derive", "wrap_help"] }
+clap_complete = "4.3.2"
+anyhow = "1.0"
+libc = "0.2.69"
+udev = "0.7.0"
+uuid = "1.2.2"
+gag = "1.0.0"
+errno = "0.2"
+either = "1.5"
+rpassword = "4"
+bch_bindgen = { path = "bch_bindgen" }
+byteorder = "1.3"