]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - Cargo.toml
Disable pristine-tar option in gbp.conf, since there is no pristine-tar branch.
[bcachefs-tools-debian] / Cargo.toml
index 66d7bc6a5bf8f2f0a0af7f44f2acb295f23d6fd3..853123eea913c5ad331eb526f0143a005f4285ab 100644 (file)
@@ -3,14 +3,13 @@ name = "bcachefs-tools"
 version = "0.3.1"
 authors = ["Yuxuan Shui <yshuiv7@gmail.com>", "Kayla Firestack <dev@kaylafire.me>", "Kent Overstreet <kent.overstreet@linux.dev>" ]
 edition = "2021"
-rust-version = "1.65"
+rust-version = "1.70"
 
 [[bin]]
 name = "bcachefs"
 path = "src/bcachefs.rs"
 
 [dependencies]
-atty = "0.2.14"
 log = { version = "0.4", features = ["std"] }
 colored = "2"
 clap = { version = "4.0.32", features = ["derive", "wrap_help"] }
@@ -19,9 +18,8 @@ anyhow = "1.0"
 libc = "0.2.69"
 udev = "0.7.0"
 uuid = "1.2.2"
-gag = "1.0.0"
 errno = "0.2"
 either = "1.5"
-rpassword = "4"
+rpassword = "7"
 bch_bindgen = { path = "bch_bindgen" }
 byteorder = "1.3"