]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - Makefile
bcache-tools are GPL
[bcachefs-tools-debian] / Makefile
index d15525b5396f818e730a9bd00440aae7a5d0d0c6..10ec79c64e8740bb2ef2154881619ece099c5d2a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,21 +2,23 @@
 PREFIX=/usr
 CFLAGS+=-O2 -Wall -g
 
-all: make-bcache probe-bcache
+all: make-bcache probe-bcache bcache-super-show
 
-install: make-bcache probe-bcache
-       install -m0755 make-bcache      $(DESTDIR)${PREFIX}/sbin/
+install: make-bcache probe-bcache bcache-super-show
+       install -m0755 make-bcache bcache-super-show    $(DESTDIR)${PREFIX}/sbin/
        install -m0755 probe-bcache     $(DESTDIR)/sbin/
        install -m0644 61-bcache.rules  $(DESTDIR)/lib/udev/rules.d/
-       -install -m0755 initramfs/script $(DESTDIR)/etc/initramfs-tools/scripts/init-premount/bcache
+       install -m0755 bcache-register  $(DESTDIR)/lib/udev/
        -install -m0755 initramfs/hook  $(DESTDIR)/etc/initramfs-tools/hooks/bcache
-       install -m0644 *.8 $(DESTDIR)${PREFIX}/share/man/man8
+       install -m0644 -- *.8 $(DESTDIR)${PREFIX}/share/man/man8
 #      install -m0755 bcache-test $(DESTDIR)${PREFIX}/sbin/
 
 clean:
-       $(RM) -f make-bcache probe-bcache bcache-test *.o
+       $(RM) -f make-bcache probe-bcache bcache-super-show bcache-test *.o
 
 bcache-test: LDLIBS += -lm -lssl -lcrypto
 make-bcache: LDLIBS += -luuid
 make-bcache: bcache.o
 probe-bcache: LDLIBS += -luuid
+bcache-super-show: LDLIBS += -luuid
+bcache-super-show: bcache.o