]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - Makefile
Bring back debug makefile target
[bcachefs-tools-debian] / Makefile
index c448bbb8b7b5d0fbba97ea23be391d97d88fa007..6dcbc0682f5fb4725df9fbdcf541aabf418dbde8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -106,6 +106,10 @@ bcachefs: $(filter-out ./tests/%.o, $(OBJS))
 
 MOUNT_SRCS=$(shell find mount/src -type f -iname '*.rs') \
     mount/Cargo.toml mount/Cargo.lock mount/build.rs
+
+debug: CFLAGS+=-Werror -DCONFIG_BCACHEFS_DEBUG=y -DCONFIG_VALGRIND=y
+debug: bcachefs
+
 libbcachefs_mount.a: $(MOUNT_SRCS)
        LIBBCACHEFS_INCLUDE=$(CURDIR) cargo build --manifest-path mount/Cargo.toml --release
        cp mount/target/release/libbcachefs_mount.a $@