]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - Makefile
Disable pristine-tar option in gbp.conf, since there is no pristine-tar branch.
[bcachefs-tools-debian] / Makefile
index dce6c535bb1e3bb438392892b0c8cc9d943e5bce..6e5d0e56aa7fbc52bac355cfd794cbeba3741907 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
-VERSION=1.4.0
+VERSION=1.6.3
 
 PREFIX?=/usr/local
+LIBEXECDIR?=$(PREFIX)/libexec
 PKG_CONFIG?=pkg-config
 INSTALL=install
 LN=ln
@@ -105,7 +106,6 @@ else
        ROOT_SBINDIR?=$(PREFIX)/sbin
        INITRAMFS_DIR=/etc/initramfs-tools
 endif
-LIBEXECDIR=$(PREFIX)/libexec
 
 PKGCONFIG_SERVICEDIR:=$(shell $(PKG_CONFIG) --variable=systemdsystemunitdir systemd)
 ifeq (,$(PKGCONFIG_SERVICEDIR))
@@ -214,6 +214,7 @@ install: bcachefs $(optional_install)
 
        sed -i '/^# Note: make install replaces/,$$d' $(DESTDIR)$(INITRAMFS_HOOK)
        echo "copy_exec $(ROOT_SBINDIR)/bcachefs /sbin/bcachefs" >> $(DESTDIR)$(INITRAMFS_HOOK)
+       echo "copy_exec $(ROOT_SBINDIR)/mount.bcachefs /sbin/mount.bcachefs" >> $(DESTDIR)$(INITRAMFS_HOOK)
 
 .PHONY: install_systemd
 install_systemd: $(systemd_services) $(systemd_libexecfiles)
@@ -223,7 +224,7 @@ install_systemd: $(systemd_services) $(systemd_libexecfiles)
 .PHONY: clean
 clean:
        @echo "Cleaning all"
-       $(Q)$(RM) c_src/libbcachefs.a tests/test_helper .version *.tar.xz $(OBJS) $(DEPS) $(DOCGENERATED)
+       $(Q)$(RM) libbcachefs.a c_src/libbcachefs.a tests/test_helper .version *.tar.xz $(OBJS) $(DEPS) $(DOCGENERATED)
        $(Q)$(CARGO_CLEAN)
        $(Q)$(RM) -f $(built_scripts)
 
@@ -272,11 +273,20 @@ update-bcachefs-sources:
        git add include/linux/kmemleak.h
        cp $(LINUX_DIR)/lib/math/int_sqrt.c linux/
        git add linux/int_sqrt.c
-       git rm -f libbcachefs/mean_and_variance_test.c
-#      cp $(LINUX_DIR)/lib/math/mean_and_variance.c linux/
-#      git add linux/mean_and_variance.c
-#      cp $(LINUX_DIR)/include/linux/mean_and_variance.h include/linux/
-#      git add include/linux/mean_and_variance.h
+       cp $(LINUX_DIR)/lib/math/mean_and_variance.c linux/
+       git add linux/mean_and_variance.c
+       cp $(LINUX_DIR)/include/linux/mean_and_variance.h include/linux/
+       git add include/linux/mean_and_variance.h
+       cp $(LINUX_DIR)/lib/time_stats.c linux/
+       git add linux/time_stats.c
+       cp $(LINUX_DIR)/include/linux/time_stats.h include/linux/
+       git add include/linux/time_stats.h
+       cp $(LINUX_DIR)/include/linux/darray.h include/linux/
+       git add include/linux/darray.h
+       cp $(LINUX_DIR)/include/linux/darray_types.h include/linux/
+       git add include/linux/darray_types.h
+       cp $(LINUX_DIR)/include/linux/eytzinger.h include/linux/
+       git add include/linux/eytzinger.h
        cp $(LINUX_DIR)/scripts/Makefile.compiler ./
        git add Makefile.compiler
        $(RM) libbcachefs/*.mod.c