]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - Makefile
downgrade rust deps to compile for MSRV
[bcachefs-tools-debian] / Makefile
index cbed599110f92ecea151f686ebbe9c3d071d1afe..73621e0bc1a6df52d76e337a5c4e510680e521f7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -186,6 +186,11 @@ bcachefs-principles-of-operation.pdf: doc/bcachefs-principles-of-operation.tex
 
 doc: bcachefs-principles-of-operation.pdf
 
+.PHONY: cargo-update-msrv
+cargo-update-msrv:
+       cargo +nightly generate-lockfile --manifest-path rust-src/Cargo.toml -Zmsrv-policy
+       cargo +nightly generate-lockfile --manifest-path rust-src/bch_bindgen/Cargo.toml -Zmsrv-policy
+
 .PHONY: update-bcachefs-sources
 update-bcachefs-sources:
        git rm -rf --ignore-unmatch libbcachefs