]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - Makefile
Update bcachefs sources to d82da7126f fixup! bcachefs: for_each_btree_key2()
[bcachefs-tools-debian] / Makefile
index 266f98a1ac1cbfe3c2741faf717037d6e182b787..bed43bdab229ce15a94b53c0dbc4b0f1235bad16 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -189,6 +189,12 @@ update-bcachefs-sources:
        git add include/linux/list_nulls.h
        cp $(LINUX_DIR)/include/linux/poison.h include/linux/
        git add include/linux/poison.h
+       cp $(LINUX_DIR)/include/linux/generic-radix-tree.h include/linux/
+       git add include/linux/generic-radix-tree.h
+       cp $(LINUX_DIR)/lib/generic-radix-tree.c linux/
+       git add linux/generic-radix-tree.c
+       cp $(LINUX_DIR)/include/linux/kmemleak.h include/linux/
+       git add include/linux/kmemleak.h
        cp $(LINUX_DIR)/scripts/Makefile.compiler ./
        git add Makefile.compiler
        $(RM) libbcachefs/*.mod.c