]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - Makefile
Update bcachefs sources to bca25b802d fixup! bcachefs: Fix bch2_check_discard_freespa...
[bcachefs-tools-debian] / Makefile
index 31fb9ac07eaf605aaed6373233d5f83e9d952dcc..c77c0c51c2a0c1be872b5011ffedaca274455aff 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -98,7 +98,7 @@ TAGS:
 tags:
        ctags -R .
 
-SRCS=$(shell find . -type f ! -path '*/.*/*' -iname '*.c')
+SRCS=$(sort $(shell find . -type f ! -path '*/.*/*' -iname '*.c'))
 DEPS=$(SRCS:.c=.d)
 -include $(DEPS)
 
@@ -184,8 +184,6 @@ update-bcachefs-sources:
        test -d libbcachefs || mkdir libbcachefs
        cp $(LINUX_DIR)/fs/bcachefs/*.[ch] libbcachefs/
        git add libbcachefs/*.[ch]
-       cp $(LINUX_DIR)/include/trace/events/bcachefs.h include/trace/events/
-       git add include/trace/events/bcachefs.h
        cp $(LINUX_DIR)/include/linux/closure.h include/linux/
        git add include/linux/closure.h
        cp $(LINUX_DIR)/lib/closure.c linux/
@@ -210,6 +208,10 @@ update-bcachefs-sources:
        git add include/linux/kmemleak.h
        cp $(LINUX_DIR)/lib/math/int_sqrt.c linux/
        git add linux/int_sqrt.c
+       cp $(LINUX_DIR)/lib/math/mean_and_variance.c linux/
+       git add linux/mean_and_variance.c
+       cp $(LINUX_DIR)/include/linux/mean_and_variance.h include/linux/
+       git add include/linux/mean_and_variance.h
        cp $(LINUX_DIR)/scripts/Makefile.compiler ./
        git add Makefile.compiler
        $(RM) libbcachefs/*.mod.c