]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - build.nix
nix: replace deprecated cargo/rustc aliases with new version
[bcachefs-tools-debian] / build.nix
index a757fefeab497f684ec32a7fe2688f793f730a0d..efb5d7359040d5a88fd0701ff0ebf06bee84d054 100644 (file)
--- a/build.nix
+++ b/build.nix
@@ -13,6 +13,8 @@
 , lz4
 , nix-gitignore
 , rustPlatform
+, rustc
+, cargo
  }:
 
 let
@@ -28,9 +30,9 @@ in stdenv.mkDerivation {
 
   nativeBuildInputs = [
     pkg-config
+    cargo
+    rustc
     rustPlatform.cargoSetupHook
-    rustPlatform.rust.cargo
-    rustPlatform.rust.rustc
     rustPlatform.bindgenHook
   ];