]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - build.nix
Disable pristine-tar option in gbp.conf, since there is no pristine-tar branch.
[bcachefs-tools-debian] / build.nix
index 831c7e9f1e4d2f9db6818d272888f6589b384721..4a4b7b069c8b6e1aacb27aae6d29d9aaaf3a1b7d 100644 (file)
--- a/build.nix
+++ b/build.nix
@@ -33,23 +33,20 @@ in stdenv.mkDerivation {
     udev
   ] ++ lib.optional fuseSupport fuse3;
 
-  BCACHEFS_FUSE = if fuseSupport then "1" else "";
+  ${if fuseSupport then "BCACHEFS_FUSE" else null} = "1";
 
-  cargoRoot = "rust-src";
+  cargoRoot = ".";
   # when git-based crates are updated, run:
   # nix run github:Mic92/nix-update -- --version=skip --flake default
   # to update the hashes
   cargoDeps = rustPlatform.importCargoLock {
-    lockFile = "${src}/rust-src/Cargo.lock";
-    outputHashes = {
-      "bindgen-0.64.0" = "sha256-GNG8as33HLRYJGYe0nw6qBzq86aHiGonyynEM7gaEE4=";
-    };
+    lockFile = "${src}/Cargo.lock";
   };
 
   makeFlags = [ "DESTDIR=${placeholder "out"}" "PREFIX=" "VERSION=${commit}" ];
 
   dontStrip = true;
-  checkPhase = "./bcachefs version";
+  checkPhase = "./target/release/bcachefs version";
   doCheck = true;
 
   meta = {