]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - build.nix
build.nix: add instruction to keep cargoDeps hashes up-to-date
[bcachefs-tools-debian] / build.nix
index efb5d7359040d5a88fd0701ff0ebf06bee84d054..5cf07de25e2e32906e4da09f02e94f8b63d07054 100644 (file)
--- a/build.nix
+++ b/build.nix
@@ -51,6 +51,9 @@ in stdenv.mkDerivation {
   ];
 
   cargoRoot = "rust-src";
+  # when git-based crates are updated, run:
+  # nix run github:Mic92/nix-update -- --version=skip --flake default
+  # to update the hashes
   cargoDeps = rustPlatform.importCargoLock {
     lockFile = "${src}/rust-src/Cargo.lock";
     outputHashes = {