]> git.sesse.net Git - bcachefs-tools-debian/blobdiff - debian/rules
Prepare for upload
[bcachefs-tools-debian] / debian / rules
index 748186e32beb73482f2334fc2719b5f3e9e9c0c7..a202318e1731d696b77368b13e704b211253e60b 100755 (executable)
@@ -1,10 +1,14 @@
 #!/usr/bin/make -f
 
 export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+# Do not build rust code (dependencies currently unmet)
+export NO_RUST=-true
+
 PREFIX := /usr
 
 DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 
+
 ifeq ($(DEB_BUILD_ARCH),amd64)
     DEB_BUILD_MAINT_OPTIONS += optimize=-lto
 endif
@@ -15,6 +19,4 @@ endif
 override_dh_auto_install:
        dh_auto_install -- "PREFIX=$(PREFIX)"
 
-override_dh_auto_clean:
-
 override_dh_auto_test: