]> git.sesse.net Git - vlc/blobdiff - debian/rules
* debian/control:
[vlc] / debian / rules
index ed0ae6862cc68689e3381ad4f1fdfbe6127620dc..4a27d26251f0ea279aac848950a5a37cb3f0aa5e 100755 (executable)
@@ -1,13 +1,11 @@
 #!/usr/bin/make -f
 # debian/rules for the VideoLAN Client - uses debhelper.
+# $Id: rules,v 1.109 2004/01/04 04:53:07 sam Exp $
 # based on Joey Hess's one.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatability version to use.
-export DH_COMPAT=3
-
 #
 # Compilation options
 #
@@ -16,8 +14,8 @@ CONFIG_FLAGS = --enable-release --prefix=/usr
 CONFIG_FLAGS += \
        --enable-gnome \
        --enable-gtk \
-       --enable-familiar \
-       --enable-fb \
+       --disable-familiar \
+       --disable-fb \
        --enable-ggi \
        --enable-sdl \
        --enable-esd \
@@ -35,7 +33,7 @@ CONFIG_FLAGS += \
        --enable-mp4 \
        --enable-dvb \
        --enable-dv \
-       --enable-satellite \
+       --disable-satellite \
        --enable-ogg \
        --enable-vorbis \
        --enable-wxwindows \
@@ -43,17 +41,20 @@ CONFIG_FLAGS += \
        --enable-flac \
        --enable-skins \
        --disable-basic-skins \
-       --disable-freetype \
+       --enable-freetype \
        --enable-mkv \
        --enable-v4l \
+       --enable-pvr \
+       --enable-speex \
+       --enable-caca \
        $(NULL)
 
 # These ones are currently shipped with VLC
 CONFIG_FLAGS += --enable-ffmpeg --with-ffmpeg-tree=extras/ffmpeg
-CONFIG_FLAGS += --enable-faad --with-faad-tree=extras/faad
+CONFIG_FLAGS += --enable-faad --with-faad-tree=extras/faad2
 CONFIG_FLAGS += --enable-libmpeg2 --with-libmpeg2-tree=extras/mpeg2dec
 
-# Glide is only for x86
+# Glide and svgalib are only for x86
 ifeq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
 CONFIG_FLAGS += --enable-glide
 CONFIG_FLAGS += --enable-svgalib
@@ -86,15 +87,15 @@ configure-stamp:
        test -d extras/ffmpeg
        if test ! -d CVS; then \
          cd extras/ffmpeg \
-         && ./configure \
+         && ./configure --enable-pp \
          && cd libavcodec \
          && $(MAKE); \
        fi
 
-       # Check that we have an faad tree in here (can be a symlink)
-       test -d extras/faad
+       # Check that we have an faad2 tree in here (can be a symlink)
+       test -d extras/faad2
        if test ! -d CVS; then \
-         cd extras/faad \
+         cd extras/faad2 \
          && touch `find . -name configure.in` \
          && touch `find . -name aclocal.m4` \
          && touch `find . -name configure` \
@@ -148,7 +149,7 @@ ifneq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
 
        # HACKETY HACKETY HACK
        if test ! -d CVS; then \
-         cd extras/faad/libfaad \
+         cd extras/faad2/libfaad \
          && $(MAKE) clean \
          && $(MAKE) AM_CFLAGS=-fPIC; \
        fi
@@ -174,13 +175,18 @@ clean:
        # Check that we have an ffmpeg tree in here (can be a symlink)
        test -d extras/ffmpeg
        -if test ! -d CVS; then cd extras/ffmpeg && $(MAKE) distclean; fi
-       # Check that we have an faad tree in here (can be a symlink)
-       test -d extras/faad
-       -if test ! -d CVS; then cd extras/faad && $(MAKE) distclean; fi
+       # Check that we have an faad2 tree in here (can be a symlink)
+       test -d extras/faad2
+       -if test ! -d CVS; then cd extras/faad2 && $(MAKE) distclean; fi
        # Check that we have an mpeg2dec tree in here (can be a symlink)
        test -d extras/mpeg2dec
        -if test ! -d CVS; then cd extras/mpeg2dec && $(MAKE) distclean; fi
 
+       # Removed ugly cruft
+       rm -f extras/mpeg2dec/include/mpeg2dec
+       rm -f src/misc/modules_builtin.h
+       rm -f mozilla/vlcintf.xpt mozilla/vlcintf.h
+
        # Remove spurious autotools stuff
        rm -f config.log confdefs.h
 
@@ -202,8 +208,8 @@ install: build
        cp debian/gvlc.desktop debian/gvlc/$(GNOMEDIR)
        cp debian/gnome-vlc.desktop debian/gnome-vlc/$(GNOMEDIR)
 
-       cp doc/fortunes.txt debian/vlc/usr/share/games/fortunes/vlc
-       strfile doc/fortunes.txt debian/vlc/usr/share/games/fortunes/vlc.dat
+       #cp doc/fortunes.txt debian/vlc/usr/share/games/fortunes/vlc
+       #strfile doc/fortunes.txt debian/vlc/usr/share/games/fortunes/vlc.dat
 
        # Package: libvlc0-dev
        mv debian/vlc/usr/bin/vlc-config debian/libvlc0-dev/usr/bin/
@@ -235,8 +241,8 @@ install: build
          debian/gvlc/usr/lib/vlc/gui/
        mv debian/vlc/usr/lib/vlc/gui/libgtk_plugin.so \
          debian/gvlc/usr/lib/vlc/gui/
-       mv debian/vlc/usr/lib/vlc/gui/libfamiliar_plugin.so \
-         debian/gvlc/usr/lib/vlc/gui/
+       #mv debian/vlc/usr/lib/vlc/gui/libfamiliar_plugin.so \
+       #  debian/gvlc/usr/lib/vlc/gui/
        ln -s vlc.1.gz debian/gvlc/usr/share/man/man1/gvlc.1.gz
        mv debian/vlc/$(VIDDIR)/gvlc32x32.xpm debian/gvlc/$(VIDDIR)/gvlc.xpm
        mv debian/vlc/$(VIDDIR)/gvlc48x48.png debian/gvlc/$(PIXDIR)/gvlc.png
@@ -336,6 +342,7 @@ endif
 
        # Package: wxvlc
        mv debian/vlc/usr/bin/wxvlc debian/wxvlc/usr/bin/
+       mv debian/vlc/usr/bin/svlc debian/wxvlc/usr/bin/
        ln -s vlc debian/wxvlc/usr/share/doc/wxvlc
        mv debian/vlc/usr/lib/vlc/gui/libwxwindows_plugin.so \
          debian/wxvlc/usr/lib/vlc/gui/
@@ -344,6 +351,7 @@ endif
        mv debian/vlc/usr/share/vlc/skins \
          debian/wxvlc/usr/share/vlc/
        ln -s vlc.1.gz debian/wxvlc/usr/share/man/man1/wxvlc.1.gz
+       ln -s vlc.1.gz debian/wxvlc/usr/share/man/man1/svlc.1.gz
 
        # Clean up
        rm -f debian/vlc/$(VIDDIR)/*.png