]> git.sesse.net Git - vlc/blobdiff - debian/rules
* modules/video_filter/logo.c: compilation fixes.
[vlc] / debian / rules
index 179c98a6351aaa504787862deb0b3d5d899e60ad..a6d6e7cb8b2e07025be2c12f161286b9aab8de97 100755 (executable)
@@ -1,6 +1,6 @@
 #!/usr/bin/make -f
 # debian/rules for the VideoLAN Client - uses debhelper.
-# $Id: rules,v 1.106 2003/10/24 14:45:24 sam Exp $
+# $Id: rules,v 1.110 2004/01/20 17:45:19 sam Exp $
 # based on Joey Hess's one.
 
 # Uncomment this to turn on verbose mode.
@@ -15,7 +15,7 @@ CONFIG_FLAGS += \
        --enable-gnome \
        --enable-gtk \
        --disable-familiar \
-       --enable-fb \
+       --disable-fb \
        --enable-ggi \
        --enable-sdl \
        --enable-esd \
@@ -46,11 +46,12 @@ CONFIG_FLAGS += \
        --enable-v4l \
        --enable-pvr \
        --enable-speex \
+       --enable-caca \
        $(NULL)
 
 # These ones are currently shipped with VLC
 CONFIG_FLAGS += --enable-ffmpeg --with-ffmpeg-tree=extras/ffmpeg
-CONFIG_FLAGS += --enable-faad --with-faad-tree=extras/faad
+CONFIG_FLAGS += --enable-faad --with-faad-tree=extras/faad2
 CONFIG_FLAGS += --enable-libmpeg2 --with-libmpeg2-tree=extras/mpeg2dec
 
 # Glide and svgalib are only for x86
@@ -76,25 +77,25 @@ configure-stamp:
        dh_testdir
 
        # Touch stuff
-       touch configure.ac \
-       && touch aclocal.m4 \
-       && touch configure \
-       && touch config.h.in \
-       && touch `find . -name Makefile.in`
+       touch configure.ac
+       touch aclocal.m4
+       touch configure
+       touch config.h.in
+       touch `find . -name Makefile.in`
 
        # Check that we have an ffmpeg tree in here (can be a symlink)
        test -d extras/ffmpeg
        if test ! -d CVS; then \
          cd extras/ffmpeg \
-         && ./configure \
+         && CC=$(CC) ./configure --enable-pp --disable-debug \
          && cd libavcodec \
          && $(MAKE); \
        fi
 
-       # Check that we have an faad tree in here (can be a symlink)
-       test -d extras/faad
+       # Check that we have an faad2 tree in here (can be a symlink)
+       test -d extras/faad2
        if test ! -d CVS; then \
-         cd extras/faad \
+         cd extras/faad2 \
          && touch `find . -name configure.in` \
          && touch `find . -name aclocal.m4` \
          && touch `find . -name configure` \
@@ -148,7 +149,7 @@ ifneq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
 
        # HACKETY HACKETY HACK
        if test ! -d CVS; then \
-         cd extras/faad/libfaad \
+         cd extras/faad2/libfaad \
          && $(MAKE) clean \
          && $(MAKE) AM_CFLAGS=-fPIC; \
        fi
@@ -174,13 +175,18 @@ clean:
        # Check that we have an ffmpeg tree in here (can be a symlink)
        test -d extras/ffmpeg
        -if test ! -d CVS; then cd extras/ffmpeg && $(MAKE) distclean; fi
-       # Check that we have an faad tree in here (can be a symlink)
-       test -d extras/faad
-       -if test ! -d CVS; then cd extras/faad && $(MAKE) distclean; fi
+       # Check that we have an faad2 tree in here (can be a symlink)
+       test -d extras/faad2
+       -if test ! -d CVS; then cd extras/faad2 && $(MAKE) distclean; fi
        # Check that we have an mpeg2dec tree in here (can be a symlink)
        test -d extras/mpeg2dec
        -if test ! -d CVS; then cd extras/mpeg2dec && $(MAKE) distclean; fi
 
+       # Removed ugly cruft
+       rm -f extras/mpeg2dec/include/mpeg2dec
+       rm -f src/misc/modules_builtin.h
+       rm -f mozilla/vlcintf.xpt mozilla/vlcintf.h
+
        # Remove spurious autotools stuff
        rm -f config.log confdefs.h
 
@@ -336,6 +342,7 @@ endif
 
        # Package: wxvlc
        mv debian/vlc/usr/bin/wxvlc debian/wxvlc/usr/bin/
+       mv debian/vlc/usr/bin/svlc debian/wxvlc/usr/bin/
        ln -s vlc debian/wxvlc/usr/share/doc/wxvlc
        mv debian/vlc/usr/lib/vlc/gui/libwxwindows_plugin.so \
          debian/wxvlc/usr/lib/vlc/gui/
@@ -344,6 +351,7 @@ endif
        mv debian/vlc/usr/share/vlc/skins \
          debian/wxvlc/usr/share/vlc/
        ln -s vlc.1.gz debian/wxvlc/usr/share/man/man1/wxvlc.1.gz
+       ln -s vlc.1.gz debian/wxvlc/usr/share/man/man1/svlc.1.gz
 
        # Clean up
        rm -f debian/vlc/$(VIDDIR)/*.png