]> git.sesse.net Git - vlc/blobdiff - debian/rules
* : svn:keywords
[vlc] / debian / rules
index 38640a3d2eeac41468a2dd501c7366765b220ee8..ec6b83276a72ddc8602c3199b7eb23d0318d9d76 100755 (executable)
@@ -33,7 +33,6 @@ vlc_confflags += \
        --enable-a52 \
        --enable-aa \
        --enable-dvbpsi \
-       --enable-xosd \
        --enable-mozilla \
        --disable-kde \
        --enable-mp4 \
@@ -68,8 +67,15 @@ vlc_confflags += \
        --enable-ffmpeg \
        --enable-ncurses \
        --enable-smb \
+       --disable-gnomevfs \
+       --enable-bonjour \
+       --enable-mpc \
+       --enable-vcd \
+       --enable-vcdx \
+       --enable-xosd \
        $(NULL)
 
+
 # These ones are currently shipped with VLC
 vlc_confflags += --enable-faad --with-faad-tree=extras/faad2
 vlc_confflags += --enable-x264 --with-x264-tree=extras/x264
@@ -80,16 +86,6 @@ vlc_confflags += --enable-glide
 vlc_confflags += --enable-svgalib
 endif
 
-# We need this hack for i386 and amd64
-ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU),i386)
-CC = $(shell pwd)/debian/gcc-snapshot
-export CC
-endif
-ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU),amd64)
-CC = $(shell pwd)/debian/gcc-snapshot
-export CC
-endif
-
 # Remove --without-dvdcss in non-totalitarian countries
 vlc_confflags += --enable-dvd --without-dvdcss
 
@@ -149,7 +145,7 @@ build-stamp: patch configure-stamp
        $(MAKE) vlc
 
        # Hackety hackety hack
-       cd extras/x264 && $(MAKE) clean && $(MAKE) ECFLAGS=-fPIC EASFLAGS=__PIC__
+       cd extras/x264 && $(MAKE) clean && $(MAKE) ECFLAGS=-fPIC EASFLAGS=-D__PIC__
 
        # HACKETY HACKETY HACK
        cd extras/faad2/libfaad && $(MAKE) clean && $(MAKE) AM_CFLAGS=-fPIC
@@ -157,6 +153,12 @@ build-stamp: patch configure-stamp
        # Build all the rest, with the PIC libs
        AM_MAKEFLAGS='builtin=no' $(MAKE)
 
+       # Minor test, to see which plugins were built and whether they load
+       # properly.
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+       ./vlc --reset-plugins-cache -l -I rc vlc:quit
+endif
+
        touch build-stamp
 
 clean: unpatch
@@ -331,6 +333,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs -p vlc
+       dh_buildinfo -p vlc
 #      dh_installexamples
        dh_installmenu -s
        dh_installmime -s