]> git.sesse.net Git - vlc/blobdiff - debian/rules
* : svn:keywords
[vlc] / debian / rules
index 4121831c222fe581059be70ea2517b10b68f820b..ec6b83276a72ddc8602c3199b7eb23d0318d9d76 100755 (executable)
@@ -1,25 +1,31 @@
 #!/usr/bin/make -f
-# debian/rules for the VideoLAN Client - uses debhelper.
-# $Id: rules,v 1.104 2003/09/02 13:44:23 sam Exp $
+# debian/rules for the VLC media player - uses debhelper.
+# $Id$
 # based on Joey Hess's one.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
+include /usr/share/dpatch/dpatch.make
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+confflags = --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) 
 
 #
 # Compilation options
 #
-
-CONFIG_FLAGS = --enable-release --prefix=/usr
-CONFIG_FLAGS += \
-       --enable-gnome \
-       --enable-gtk \
+vlc_confflags = --enable-release --prefix=/usr
+vlc_confflags += \
+       --disable-gnome \
+       --disable-gtk \
        --disable-familiar \
-       --enable-fb \
+       --disable-fb \
        --enable-ggi \
        --enable-sdl \
        --enable-esd \
-       --enable-qt \
+       --disable-qt \
        --enable-mad \
        --enable-arts \
        --enable-alsa \
@@ -27,43 +33,67 @@ CONFIG_FLAGS += \
        --enable-a52 \
        --enable-aa \
        --enable-dvbpsi \
-       --enable-xosd \
        --enable-mozilla \
-       --enable-kde \
+       --disable-kde \
        --enable-mp4 \
        --enable-dvb \
        --enable-dv \
-       --enable-satellite \
+       --disable-satellite \
        --enable-ogg \
        --enable-vorbis \
-       --enable-wxwindows \
-       --enable-slp \
+       --enable-wxwidgets \
+       --with-wx-config=wx-config \
+       --disable-slp \
        --enable-flac \
-       --enable-skins \
+       --disable-skins \
        --disable-basic-skins \
+       --enable-skins2 \
        --enable-freetype \
        --enable-mkv \
        --enable-v4l \
+       --enable-pvr \
+       --disable-speex \
+       --enable-caca \
+       --enable-livedotcom \
+       --enable-libmpeg2 \
+       --enable-dts \
+       --enable-fribidi \
+       --enable-cdio \
+       --enable-mod \
+       --enable-theora \
+       --enable-modplug \
+       --enable-dvdnav \
+       --enable-gnutls \
+       --enable-ffmpeg \
+       --enable-ncurses \
+       --enable-smb \
+       --disable-gnomevfs \
+       --enable-bonjour \
+       --enable-mpc \
+       --enable-vcd \
+       --enable-vcdx \
+       --enable-xosd \
        $(NULL)
 
+
 # These ones are currently shipped with VLC
-CONFIG_FLAGS += --enable-ffmpeg --with-ffmpeg-tree=extras/ffmpeg
-CONFIG_FLAGS += --enable-faad --with-faad-tree=extras/faad
-CONFIG_FLAGS += --enable-libmpeg2 --with-libmpeg2-tree=extras/mpeg2dec
+vlc_confflags += --enable-faad --with-faad-tree=extras/faad2
+vlc_confflags += --enable-x264 --with-x264-tree=extras/x264
 
 # Glide and svgalib are only for x86
-ifeq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
-CONFIG_FLAGS += --enable-glide
-CONFIG_FLAGS += --enable-svgalib
+ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU),i386)
+vlc_confflags += --enable-glide
+vlc_confflags += --enable-svgalib
 endif
 
 # Remove --without-dvdcss in non-totalitarian countries
-CONFIG_FLAGS += --enable-dvd --without-dvdcss
+vlc_confflags += --enable-dvd --without-dvdcss
 
 # A few shortcuts
 VIDDIR = usr/share/vlc
 PIXDIR = usr/share/pixmaps
-GNOMEDIR = usr/share/gnome/apps/Multimedia
+APPDIR = usr/share/applications
+
 
 #
 # Build rules
@@ -74,58 +104,39 @@ configure-stamp:
        dh_testdir
 
        # Touch stuff
-       touch configure.ac \
-       && touch aclocal.m4 \
-       && touch configure \
-       && touch config.h.in \
-       && touch `find . -name Makefile.in`
-
-       # Check that we have an ffmpeg tree in here (can be a symlink)
-       test -d extras/ffmpeg
-       if test ! -d CVS; then \
-         cd extras/ffmpeg \
-         && ./configure \
-         && cd libavcodec \
-         && $(MAKE); \
-       fi
-
-       # Check that we have an faad tree in here (can be a symlink)
-       test -d extras/faad
-       if test ! -d CVS; then \
-         cd extras/faad \
-         && touch `find . -name configure.in` \
-         && touch `find . -name aclocal.m4` \
-         && touch `find . -name configure` \
-         && touch `find . -name config.h.in` \
-         && touch `find . -name Makefile.in` \
-         && ./configure --disable-shared \
-         && cd libfaad \
-         && $(MAKE); \
-       fi
-
-       # Check that we have an mpeg2dec tree in here (can be a symlink)
-       test -d extras/mpeg2dec
-       if test ! -d CVS; then \
-         cd extras/mpeg2dec \
-         && touch configure.in \
-         && touch aclocal.m4 \
-         && touch acinclude.m4 \
-         && touch configure \
-         && touch `find . -name config.h.in` \
-         && touch `find . -name Makefile.in` \
-         && ./configure --disable-shared \
-         && cd libmpeg2 \
-         && $(MAKE); \
-       fi
+       touch configure.ac
+       touch aclocal.m4
+       touch configure
+       touch config.h.in
+       touch `find . -name Makefile.in`
+
+       # Check that we have an x264 tree in here (can be a symlink)
+       test -d extras/x264
+       cd extras/x264 \
+        && ./configure $(confflags) --extra-cflags='$$(ECFLAGS)' \
+                                    --extra-asflags='$$(EASFLAGS)' \
+        && $(MAKE)
+
+       # Check that we have an faad2 tree in here (can be a symlink)
+       test -d extras/faad2
+       cd extras/faad2 \
+        && touch `find . -name configure.in` \
+        && touch `find . -name aclocal.m4` \
+        && touch `find . -name configure` \
+        && touch `find . -name config.h.in` \
+        && touch `find . -name Makefile.in` \
+        && ./configure $(confflags) --disable-shared \
+        && cd libfaad \
+        && $(MAKE)
 
        # Configure VLC
        ./configure --mandir=$${prefix}/share/man \
-         --infodir=$${prefix}/share/info $(CONFIG_FLAGS)
+         --infodir=$${prefix}/share/info $(confflags) $(vlc_confflags)
 
        touch configure-stamp
 
-build: configure-stamp build-stamp
-build-stamp:
+build: build-stamp
+build-stamp: patch configure-stamp
        dh_testdir
 
        # Build only VLC, with the non-PIC libs
@@ -133,51 +144,41 @@ build-stamp:
        cd modules && AM_MAKEFLAGS='plugin=no pic=no' $(MAKE)
        $(MAKE) vlc
 
-ifneq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
        # Hackety hackety hack
-       if test ! -d CVS; then \
-         cd extras/ffmpeg/libavcodec \
-         && $(MAKE) clean \
-         && rm -f Makefile.pic \
-         && sed 's/^CFLAGS *=/&-fPIC -DPIC /' <Makefile >Makefile.pic \
-         && $(MAKE) -f Makefile.pic \
-         && rm -f Makefile.pic; \
-       fi
+       cd extras/x264 && $(MAKE) clean && $(MAKE) ECFLAGS=-fPIC EASFLAGS=-D__PIC__
 
        # HACKETY HACKETY HACK
-       if test ! -d CVS; then \
-         cd extras/faad/libfaad \
-         && $(MAKE) clean \
-         && $(MAKE) AM_CFLAGS=-fPIC; \
-       fi
-
-       # HACK ME PLENTY MORE!!!
-       if test ! -d CVS; then \
-         cd extras/mpeg2dec/libmpeg2 \
-         && $(MAKE) clean \
-         && $(MAKE) LIBMPEG2_CFLAGS=-fPIC; \
-       fi
-endif
+       cd extras/faad2/libfaad && $(MAKE) clean && $(MAKE) AM_CFLAGS=-fPIC
 
        # Build all the rest, with the PIC libs
        AM_MAKEFLAGS='builtin=no' $(MAKE)
 
+       # Minor test, to see which plugins were built and whether they load
+       # properly.
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+       ./vlc --reset-plugins-cache -l -I rc vlc:quit
+endif
+
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f configure-stamp build-stamp
 
-       # Check that we have an ffmpeg tree in here (can be a symlink)
-       test -d extras/ffmpeg
-       -if test ! -d CVS; then cd extras/ffmpeg && $(MAKE) distclean; fi
-       # Check that we have an faad tree in here (can be a symlink)
-       test -d extras/faad
-       -if test ! -d CVS; then cd extras/faad && $(MAKE) distclean; fi
-       # Check that we have an mpeg2dec tree in here (can be a symlink)
-       test -d extras/mpeg2dec
-       -if test ! -d CVS; then cd extras/mpeg2dec && $(MAKE) distclean; fi
+       # Check that we have an x264 tree in here (can be a symlink)
+       test -d extras/x264
+       -cd extras/x264 && $(MAKE) distclean
+       # Check that we have an faad2 tree in here (can be a symlink)
+       test -d extras/faad2
+       -cd extras/faad2 && $(MAKE) distclean
+
+       # Clean zsh completion stuff
+       rm -f extras/zsh
+
+       # Removed ugly cruft
+       rm -f src/misc/modules_builtin.h
+       rm -f mozilla/vlcintf.xpt mozilla/vlcintf.h
 
        # Remove spurious autotools stuff
        rm -f config.log confdefs.h
@@ -197,11 +198,14 @@ install: build
        # Package: vlc
        mv debian/vlc/$(VIDDIR)/vlc48x48.png debian/vlc/$(PIXDIR)/vlc.png
        mv debian/vlc/$(VIDDIR)/vlc32x32.xpm debian/vlc/$(VIDDIR)/vlc.xpm
-       cp debian/gvlc.desktop debian/gvlc/$(GNOMEDIR)
-       cp debian/gnome-vlc.desktop debian/gnome-vlc/$(GNOMEDIR)
+       cp debian/gvlc.desktop debian/gvlc/$(APPDIR)
+       cp debian/gnome-vlc.desktop debian/gnome-vlc/$(APPDIR)
 
-       cp doc/fortunes.txt debian/vlc/usr/share/games/fortunes/vlc
-       strfile doc/fortunes.txt debian/vlc/usr/share/games/fortunes/vlc.dat
+       #cp doc/fortunes.txt debian/vlc/usr/share/games/fortunes/vlc
+       #strfile doc/fortunes.txt debian/vlc/usr/share/games/fortunes/vlc.dat
+
+       rm -Rf debian/vlc/$(VIDDIR)/skins
+       ln -s vlc.1.gz debian/vlc/usr/share/man/man1/svlc.1.gz
 
        # Package: libvlc0-dev
        mv debian/vlc/usr/bin/vlc-config debian/libvlc0-dev/usr/bin/
@@ -212,55 +216,39 @@ install: build
        ln -s vlc debian/libvlc0-dev/usr/share/doc/libvlc0-dev
 
        # Package: gnome-vlc
-       mv debian/vlc/usr/bin/gnome-vlc debian/gnome-vlc/usr/bin/
+       #mv debian/vlc/usr/bin/gnome-vlc debian/gnome-vlc/usr/bin/
        ln -s vlc debian/gnome-vlc/usr/share/doc/gnome-vlc
-       mv debian/vlc/usr/lib/vlc/misc/libgnome_main_plugin.so \
-         debian/gnome-vlc/usr/lib/vlc/gui/
-       mv debian/vlc/usr/lib/vlc/gui/libgnome_plugin.so \
-         debian/gnome-vlc/usr/lib/vlc/gui/
-       ln -s vlc.1.gz debian/gnome-vlc/usr/share/man/man1/gnome-vlc.1.gz
-       mv debian/vlc/$(VIDDIR)/gnome-vlc32x32.xpm debian/gnome-vlc/$(VIDDIR)/gnome-vlc.xpm
-       mv debian/vlc/$(VIDDIR)/gnome-vlc48x48.png debian/gnome-vlc/$(PIXDIR)/gnome-vlc.png
-
-       # Package: vlc-gnome
-       mkdir -p debian/vlc-gnome/usr/share/doc/
-       ln -s vlc debian/vlc-gnome/usr/share/doc/vlc-gnome
+       #mv debian/vlc/usr/lib/vlc/misc/libgnome_main_plugin.so \
+       #  debian/gnome-vlc/usr/lib/vlc/gui/
+       #mv debian/vlc/usr/lib/vlc/gui/libgnome_plugin.so \
+       #  debian/gnome-vlc/usr/lib/vlc/gui/
+       #ln -s vlc.1.gz debian/gnome-vlc/usr/share/man/man1/gnome-vlc.1.gz
+       #mv debian/vlc/$(VIDDIR)/gnome-vlc32x32.xpm debian/gnome-vlc/$(VIDDIR)/gnome-vlc.xpm
+       #mv debian/vlc/$(VIDDIR)/gnome-vlc48x48.png debian/gnome-vlc/$(PIXDIR)/gnome-vlc.png
 
        # Package: gvlc
-       mv debian/vlc/usr/bin/gvlc debian/gvlc/usr/bin/
+       #mv debian/vlc/usr/bin/gvlc debian/gvlc/usr/bin/
        ln -s vlc debian/gvlc/usr/share/doc/gvlc
-       mv debian/vlc/usr/lib/vlc/misc/libgtk_main_plugin.so \
-         debian/gvlc/usr/lib/vlc/gui/
-       mv debian/vlc/usr/lib/vlc/gui/libgtk_plugin.so \
-         debian/gvlc/usr/lib/vlc/gui/
+       #mv debian/vlc/usr/lib/vlc/misc/libgtk_main_plugin.so \
+       #  debian/gvlc/usr/lib/vlc/gui/
+       #mv debian/vlc/usr/lib/vlc/gui/libgtk_plugin.so \
+       #  debian/gvlc/usr/lib/vlc/gui/
        #mv debian/vlc/usr/lib/vlc/gui/libfamiliar_plugin.so \
        #  debian/gvlc/usr/lib/vlc/gui/
-       ln -s vlc.1.gz debian/gvlc/usr/share/man/man1/gvlc.1.gz
-       mv debian/vlc/$(VIDDIR)/gvlc32x32.xpm debian/gvlc/$(VIDDIR)/gvlc.xpm
-       mv debian/vlc/$(VIDDIR)/gvlc48x48.png debian/gvlc/$(PIXDIR)/gvlc.png
-
-       # Package: vlc-gtk
-       mkdir -p debian/vlc-gtk/usr/share/doc/
-       ln -s vlc debian/vlc-gtk/usr/share/doc/vlc-gtk
+       #ln -s vlc.1.gz debian/gvlc/usr/share/man/man1/gvlc.1.gz
+       #mv debian/vlc/$(VIDDIR)/gvlc32x32.xpm debian/gvlc/$(VIDDIR)/gvlc.xpm
+       #mv debian/vlc/$(VIDDIR)/gvlc48x48.png debian/gvlc/$(PIXDIR)/gvlc.png
 
        # Package: vlc-plugin-esd
        ln -s vlc debian/vlc-plugin-esd/usr/share/doc/vlc-plugin-esd
        mv debian/vlc/usr/lib/vlc/audio_output/libesd_plugin.so \
          debian/vlc-plugin-esd/usr/lib/vlc/audio_output/
 
-       # Package: vlc-esd
-       mkdir -p debian/vlc-esd/usr/share/doc/
-       ln -s vlc debian/vlc-esd/usr/share/doc/vlc-esd
-
        # Package: vlc-plugin-alsa
        ln -s vlc debian/vlc-plugin-alsa/usr/share/doc/vlc-plugin-alsa
        mv debian/vlc/usr/lib/vlc/audio_output/libalsa_plugin.so \
          debian/vlc-plugin-alsa/usr/lib/vlc/audio_output/
 
-       # Package: vlc-alsa
-       mkdir -p debian/vlc-alsa/usr/share/doc/
-       ln -s vlc debian/vlc-alsa/usr/share/doc/vlc-alsa
-
        # Package: vlc-plugin-sdl
        ln -s vlc debian/vlc-plugin-sdl/usr/share/doc/vlc-plugin-sdl
        mv debian/vlc/usr/lib/vlc/audio_output/libaout_sdl_plugin.so \
@@ -268,42 +256,26 @@ install: build
        mv debian/vlc/usr/lib/vlc/video_output/libvout_sdl_plugin.so \
          debian/vlc-plugin-sdl/usr/lib/vlc/video_output/
 
-       # Package: vlc-sdl
-       mkdir -p debian/vlc-sdl/usr/share/doc/
-       ln -s vlc debian/vlc-sdl/usr/share/doc/vlc-sdl
-
        # Package: vlc-plugin-ggi
        ln -s vlc debian/vlc-plugin-ggi/usr/share/doc/vlc-plugin-ggi
        mv debian/vlc/usr/lib/vlc/video_output/libggi_plugin.so \
          debian/vlc-plugin-ggi/usr/lib/vlc/video_output/
 
-       # Package: vlc-ggi
-       mkdir -p debian/vlc-ggi/usr/share/doc/
-       ln -s vlc debian/vlc-ggi/usr/share/doc/vlc-ggi
-
        # Package: vlc-plugin-glide
-ifeq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
+ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU),i386)
        ln -s vlc debian/vlc-plugin-glide/usr/share/doc/vlc-plugin-glide
        mv debian/vlc/usr/lib/vlc/video_output/libglide_plugin.so \
          debian/vlc-plugin-glide/usr/lib/vlc/video_output/
-
-       # Package: vlc-glide
-       mkdir -p debian/vlc-glide/usr/share/doc/
-       ln -s vlc debian/vlc-glide/usr/share/doc/vlc-glide
 endif
 
        # Package: qvlc
-       mv debian/vlc/usr/bin/qvlc debian/qvlc/usr/bin/
+       #mv debian/vlc/usr/bin/qvlc debian/qvlc/usr/bin/
        ln -s vlc debian/qvlc/usr/share/doc/qvlc
-       mv debian/vlc/usr/lib/vlc/gui/libqt_plugin.so \
-         debian/qvlc/usr/lib/vlc/gui/
-       ln -s vlc.1.gz debian/qvlc/usr/share/man/man1/qvlc.1.gz
-       mv debian/vlc/$(VIDDIR)/qvlc32x32.xpm debian/qvlc/$(VIDDIR)/qvlc.xpm
-       mv debian/vlc/$(VIDDIR)/qvlc48x48.png debian/qvlc/$(PIXDIR)/qvlc.png
-
-       # Package: vlc-qt
-       mkdir -p debian/vlc-qt/usr/share/doc/
-       ln -s vlc debian/vlc-qt/usr/share/doc/vlc-qt
+       #mv debian/vlc/usr/lib/vlc/gui/libqt_plugin.so \
+       #  debian/qvlc/usr/lib/vlc/gui/
+       #ln -s vlc.1.gz debian/qvlc/usr/share/man/man1/qvlc.1.gz
+       #mv debian/vlc/$(VIDDIR)/qvlc32x32.xpm debian/qvlc/$(VIDDIR)/qvlc.xpm
+       #mv debian/vlc/$(VIDDIR)/qvlc48x48.png debian/qvlc/$(PIXDIR)/qvlc.png
 
        # Package: vlc-plugin-arts
        ln -s vlc debian/vlc-plugin-arts/usr/share/doc/vlc-plugin-arts
@@ -313,20 +285,24 @@ endif
        # Package: mozilla-plugin-vlc
        ln -s vlc debian/mozilla-plugin-vlc/usr/share/doc/mozilla-plugin-vlc
        mv debian/vlc/usr/lib/mozilla debian/mozilla-plugin-vlc/usr/lib
+       # links for firefox
+       mkdir -p debian/mozilla-plugin-vlc/usr/lib/mozilla-firefox/plugins/
+       ln -s ../../mozilla/plugins/libvlcplugin.so debian/mozilla-plugin-vlc/usr/lib/mozilla-firefox/plugins/
+       mkdir -p debian/mozilla-plugin-vlc/usr/lib/mozilla-firefox/components/
+       ln -s ../../mozilla/components/vlcintf.xpt debian/mozilla-plugin-vlc/usr/lib/mozilla-firefox/components/
 
        # Package: kvlc
-       mv debian/vlc/usr/bin/kvlc debian/kvlc/usr/bin/
+       #mv debian/vlc/usr/bin/kvlc debian/kvlc/usr/bin/
        ln -s vlc debian/kvlc/usr/share/doc/kvlc
-       mv debian/vlc/usr/lib/vlc/gui/libkde_plugin.so \
-         debian/kvlc/usr/lib/vlc/gui/
-       mv debian/vlc/usr/share/vlc/ui.rc \
-         debian/kvlc/usr/share/vlc
-       ln -s vlc.1.gz debian/kvlc/usr/share/man/man1/kvlc.1.gz
-       mv debian/vlc/$(VIDDIR)/kvlc32x32.xpm debian/kvlc/$(VIDDIR)/kvlc.xpm
-       mv debian/vlc/$(VIDDIR)/kvlc48x48.png debian/kvlc/$(PIXDIR)/kvlc.png
+       #mv debian/vlc/usr/lib/vlc/gui/libkde_plugin.so \
+       #  debian/kvlc/usr/lib/vlc/gui/
+       #mv debian/vlc/$(VIDDIR)/ui.rc debian/kvlc/$(VIDDIR)
+       #ln -s vlc.1.gz debian/kvlc/usr/share/man/man1/kvlc.1.gz
+       #mv debian/vlc/$(VIDDIR)/kvlc32x32.xpm debian/kvlc/$(VIDDIR)/kvlc.xpm
+       #mv debian/vlc/$(VIDDIR)/kvlc48x48.png debian/kvlc/$(PIXDIR)/kvlc.png
 
        # Package: vlc-plugin-svgalib
-ifeq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
+ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU),i386)
        ln -s vlc debian/vlc-plugin-svgalib/usr/share/doc/vlc-plugin-svgalib
        mv debian/vlc/usr/lib/vlc/video_output/libsvgalib_plugin.so \
          debian/vlc-plugin-svgalib/usr/lib/vlc/video_output
@@ -335,12 +311,10 @@ endif
        # Package: wxvlc
        mv debian/vlc/usr/bin/wxvlc debian/wxvlc/usr/bin/
        ln -s vlc debian/wxvlc/usr/share/doc/wxvlc
-       mv debian/vlc/usr/lib/vlc/gui/libwxwindows_plugin.so \
-         debian/wxvlc/usr/lib/vlc/gui/
-       mv debian/vlc/usr/lib/vlc/gui/libskins_plugin.so \
+       cp debian/vlc/$(VIDDIR)/vlc.xpm debian/wxvlc/$(VIDDIR)/wxvlc.xpm
+       cp debian/vlc.desktop debian/wxvlc/$(APPDIR)
+       mv debian/vlc/usr/lib/vlc/gui/libwxwidgets_plugin.so \
          debian/wxvlc/usr/lib/vlc/gui/
-       mv debian/vlc/usr/share/vlc/skins \
-         debian/wxvlc/usr/share/vlc/
        ln -s vlc.1.gz debian/wxvlc/usr/share/man/man1/wxvlc.1.gz
 
        # Clean up
@@ -359,6 +333,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs -p vlc
+       dh_buildinfo -p vlc
 #      dh_installexamples
        dh_installmenu -s
        dh_installmime -s