]> git.sesse.net Git - vlc/blobdiff - debian/rules
* : svn:keywords
[vlc] / debian / rules
index 6faf45f395610d3a96fa55ff9b53a0ea92a36e00..ec6b83276a72ddc8602c3199b7eb23d0318d9d76 100755 (executable)
@@ -33,7 +33,6 @@ vlc_confflags += \
        --enable-a52 \
        --enable-aa \
        --enable-dvbpsi \
-       --enable-xosd \
        --enable-mozilla \
        --disable-kde \
        --enable-mp4 \
@@ -73,8 +72,10 @@ vlc_confflags += \
        --enable-mpc \
        --enable-vcd \
        --enable-vcdx \
+       --enable-xosd \
        $(NULL)
 
+
 # These ones are currently shipped with VLC
 vlc_confflags += --enable-faad --with-faad-tree=extras/faad2
 vlc_confflags += --enable-x264 --with-x264-tree=extras/x264
@@ -85,16 +86,6 @@ vlc_confflags += --enable-glide
 vlc_confflags += --enable-svgalib
 endif
 
-# We need this hack for i386 and amd64
-ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU),i386)
-CC = $(shell pwd)/debian/gcc-snapshot
-export CC
-endif
-ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU),amd64)
-CC = $(shell pwd)/debian/gcc-snapshot
-export CC
-endif
-
 # Remove --without-dvdcss in non-totalitarian countries
 vlc_confflags += --enable-dvd --without-dvdcss